
Sage 

Budgeting and Planning 
2016 

System Management Guide 

Version 7.60 

http://www.acutedata.com


 

 

Copyright Program copyright © 2016 Sage Software, Inc. This work and the computer 
programs to which it relates are the property of, and embody trade secrets 
and confidential information proprietary to, Sage Software, Inc., and may 
not be reproduced, copied, disclosed, transferred, adapted or modified 
without the express written approval of Sage Software, Inc. Manual 
copyright © Sage Software, Inc. Printed in U.S.A. All rights reserved. This 
document may not, in whole or in any part, be copied, photocopied, 
reproduced, translated, transmitted or reduced to any electronic medium or 
machine-readable form without prior consent, in writing, from Sage 
Software, Inc. 

Trademarks Sage Budgeting and Planning is a trademark of Sage Software, Inc. 

Windows, Internet Explorer, and Excel are registered trademarks of 
Microsoft Corporation. 

Other company or product names mentioned may be trademarks or 
registered trademarks of their respective holders. 

Warranty Sage Software, Inc. makes no representations or warranties with respect to 
the contents of this manual and specifically disclaims any implied 
warranties of merchantability or fitness for a particular purpose. Any 
statements made by a dealer or any party other than Sage Software, Inc. 
are not warranties and you cannot rely on them in deciding to license the 
software. We welcome user comments and reserve the right to revise this 
publication and/or make improvements or changes to the products or 
programs described in this publication at any time, without notice. 

Limitation of Liability Neither Sage Software, Inc. nor anyone else who has been involved in the 
creation, production, or delivery of this software or its accompanying 
documentation shall be liable for any indirect, incidental, special exemplary 
or consequential damages, including, but not limited to any loss of 
anticipated profit or benefits, resulting from the use of the software or its 
documentation or arising out of any breach of warranty. Sage Software, 
Inc.'s cumulative liability to you or any other party for damages for any 
cause whatsoever will be limited to the price you paid for the product that 
caused the damages. 

 

 



 

iii 

Table Of Contents 
Active Planner System Management Guide ............................................................................................................... 1 

Chapter 1 - Introduction ............................................................................................................................................ 1 

Welcome .................................................................................................................................................................. 1 

Prerequisite Knowledge ........................................................................................................................................ 1 

Getting Started ........................................................................................................................................................ 1 

Conventions Used in this Guide .......................................................................................................................... 2 

Conventions Used in this Guide ...................................................................................................................... 2 

Using this Guide ................................................................................................................................................. 2 

Chapter 2 - System Requirements and Installation ............................................................................................... 4 

Minimum System Requirements for Sage Budgeting and Planning ............................................................... 4 

Database Server .................................................................................................................................................. 4 

Network File Server ........................................................................................................................................... 4 

Client Workstation ............................................................................................................................................. 4 

General Ledger Environment ........................................................................................................................... 5 

Existing Active Planner now known as Sage Budgeting and PlanningActive Planner Version (if 
upgrading) .......................................................................................................................................................... 5 

File Share Location ............................................................................................................................................. 5 

Installation and Upgrade Overview .................................................................................................................... 6 

Installation and Upgrade Overview ................................................................................................................ 6 

Sage Budgeting and PlanningNetwork File Server Installation................................................................... 9 

Initial Setup ....................................................................................................................................................... 16 

Sage Budgeting and Planning Client Workstation Installation.................................................................. 20 

Minimum System Requirements for WebView ............................................................................................... 26 

Internet Information Services (IIS) ................................................................................................................. 26 

WebView Client Workstation ......................................................................................................................... 26 

Pre-Installation Requirements for WebView ................................................................................................ 27 

Other Installation Options .................................................................................................................................. 28 

Portable Document Format (PDF) User Guides ........................................................................................... 28 

Installing Program Components Separately ................................................................................................. 28 

Client Workstation Autoupdate ..................................................................................................................... 28 

Chapter 3 - System Configuration ......................................................................................................................... 29 



Sage Budgeting and Planning System Management Guide 

iv 

Creating a New System Configuration ............................................................................................................. 29 

Chapter 4 - Upgrading from Previous Versions .................................................................................................. 36 

Upgrading Older Active Planner now known as Sage Budgeting and Planning Versions ....................... 36 

Upgrading Sage Budgeting and Planning Databases ...................................................................................... 36 

Upgrading Analysis Server 2005 Cubes ............................................................................................................ 38 

Upgrading OLAP Dimensions ........................................................................................................................... 39 

Chapter 5 - System Maintenance............................................................................................................................ 41 

Maintaining the System Configuration ............................................................................................................. 41 

Overview ........................................................................................................................................................... 41 

System Configuration, SDA and DQA Maintenance .................................................................................. 42 

Remove System Configuration ....................................................................................................................... 44 

System Database Maintenance ........................................................................................................................... 47 

Refresh Procedures System Database ............................................................................................................ 47 

Remove System Database ............................................................................................................................... 48 

Publication Database Maintenance .................................................................................................................... 49 

Reinitialize Publication Database ................................................................................................................... 49 

Refresh Procedures Publication Database .................................................................................................... 49 

Company Database Maintenance ...................................................................................................................... 51 

Add Company .................................................................................................................................................. 51 

Remove Company ............................................................................................................................................ 52 

Refresh Procedures Company Database ....................................................................................................... 53 

Refresh Stored Procedures for Configuration .................................................................................................. 55 

Refresh Procedures All Databases for the Configuration ........................................................................... 55 

Linked Server Configuration .............................................................................................................................. 57 

Creating New Linked Server Configurations ............................................................................................... 57 

Access Database ............................................................................................................................................... 57 

Excel Spreadsheet ............................................................................................................................................. 59 

Linked Servers on 64-bit SQL Servers ........................................................................................................... 62 

Maintaining Linked Server Configurations .................................................................................................. 62 

Deleting Linked Server Configurations ........................................................................................................ 64 

Registration ........................................................................................................................................................... 66 

Registering from the Admin Tool .................................................................................................................. 66 



Table Of Contents 

v 

Registering from within the Application ...................................................................................................... 67 

Admin Tool Login Maintenance ........................................................................................................................ 70 

Database Mail ....................................................................................................................................................... 71 

Chapter 6 - User Maintenance ................................................................................................................................ 73 

System Administrator.......................................................................................................................................... 73 

Admin User ........................................................................................................................................................... 73 

User Login ............................................................................................................................................................. 74 

Initial Login ....................................................................................................................................................... 74 

User Login ......................................................................................................................................................... 74 

User Maintenance ................................................................................................................................................ 76 

Adding a User................................................................................................................................................... 76 

Modifying a User ............................................................................................................................................. 78 

Deleting a User ................................................................................................................................................. 80 

Windows Authentication .................................................................................................................................... 81 

Windows Authentication Overview .............................................................................................................. 81 

Add Sage Budgeting and Planning Users ..................................................................................................... 81 

Chapter 7 - Installing Demonstration Data ........................................................................................................... 84 

Create the Demonstration Company Databases .......................................................................................... 84 

Installing the Sample Plan Sheets .................................................................................................................. 84 

Create Demonstration OLAP Cube ................................................................................................................... 89 

Republish Plan Sheets ...................................................................................................................................... 89 

Demonstration OLAP Cube ............................................................................................................................ 92 

Chapter 8 - WebView Installation .......................................................................................................................... 94 

Overview ............................................................................................................................................................... 94 

WebView Pre-Installation ................................................................................................................................... 94 

WebView IIS Installation..................................................................................................................................... 95 

WebView IIS Upgrade ......................................................................................................................................... 99 

WebView Registration ....................................................................................................................................... 101 

WebView Registration ................................................................................................................................... 101 

WebView User Maintenance ........................................................................................................................ 101 

WebView Configuration Tool .......................................................................................................................... 102 

WebView Client Installation ............................................................................................................................. 103 



Sage Budgeting and Planning System Management Guide 

vi 

Chapter 9 - Integration Maintenance . ................................................................................................................... 105 

Overview ............................................................................................................................................................... 105 

Fiscal Period Maintenance . ................................................................................................................................ 106 

Initial Setup Using Quick Start Assistant . .................................................................................................... 106 

Adding a Fiscal Period . .................................................................................................................................. 109 

Modifying Fiscal Periods. ............................................................................................................................... 112 

Deleting Fiscal Years . ...................................................................................................................................... 113 

Reviewing Fiscal Periods . .............................................................................................................................. 114 

Selecting Current Processing Period. ............................................................................................................ 115 

Configuration Options . ...................................................................................................................................... 116 

Account Numbers . .......................................................................................................................................... 116 

Account Dimensions . ...................................................................................................................................... 117 

Balance Codes . ................................................................................................................................................. 118 

Transaction Information . ................................................................................................................................ 118 

Table Maintenance . ............................................................................................................................................. 119 

Accounts ............................................................................................................................................................ 119 

Balance Codes . ................................................................................................................................................. 122 

Transactions ...................................................................................................................................................... 123 

Balances ............................................................................................................................................................. 125 

Resulting Balances . ............................................................................................................................................. 126 

Integration Maintenance Utilities . .................................................................................................................... 129 

Importing .......................................................................................................................................................... 129 

Exporting ........................................................................................................................................................... 139 

Index . ............................................................................................................................................................................. 147 



1 

Active Planner System Management Guide 
Chapter 1 - Introduction 

Chapter 1 

Introduction 

Welcome 

Sage Budgeting and Planning is a powerful tool for collaborative enterprise-wide budgeting, planning, and 
analysis. While powerful, Sage Budgeting and Planning is intuitive and easy to use in its spreadsheet design 
and Windows interface. This manual explains how to install, set up and manage Sage Budgeting and 
Planning. 

Prerequisite Knowledge 

This guide assumes a basic understanding of personal computers, database management, graphical user 
interface environments such as Windows, and operating systems. 

Getting Started 

We have provided a number of tools to aid you in understanding Sage Budgeting and Planning. Your 
individual learning style and basic computer knowledge will dictate how extensively you need to use these 
aids. 

       This System Management Guide provides specific instructions for setting up Sage Budgeting and Planning 
on your Financial system. It also provides details on upgrading from previous versions of Sage 
Budgeting and Planning. 

       The Sage Budgeting and Planning User Guide discusses basic concepts and the procedures to design and 
use an integrated budgeting, planning, and analysis environment. In addition, the procedures to set up, 
administer, and control a distributed budget environment are reviewed. 

       The Online Help provides context-sensitive help to understand and apply Sage Budgeting and Planning 
to your organization. 

http://www.acutedata.com
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Conventions Used in this Guide 

Conventions Used in this Guide 

       Names of screen objects such as windows, tabs, fields, field selection options, and buttons are printed in 
bold type. 

       Names of individual keys to press are printed in bold type. 

       Information that displays exactly as it is stated, or that you are instructed to enter exactly, is printed in 
bold type. 

       Publication names and simple emphasis is printed in italic type. 

       Important terms are introduced in sans-serif type. 

       Keystroke combinations are separated by a (+) sign. For example, “Shift+F4” means to press the Shift 

key and hold it down while pressing the F4 key. 

       Menus and menu items are separated by a (>) sign. For example, “Select File > Open” means to select 
the Open command from the File menu. “Select File > New > Sheet” means to select Sheet from the 
File menu’s New submenu. 

       “Click” means to press and then immediately release your mouse button without moving the mouse. 

       Options are selected using a checkbox. "Check" means to click on the option and a checkmark or X will 
appear in the checkbox. "Uncheck" means to click the option again to remove the checkmark or X from 
the checkbox.  

Special visual aids are used throughout this guide such as Notes and Tips. These appear as text in the 
format displayed below: 

Note: This indicates additional information that may help you avoid problems or that should be considered in 
using the described features. 

 

Tip: This indicates additional information that may help you to do a specific task. 

Examples illustrate specific concepts: 

 
Example: 

This is example text. 
This is example details. 

 

 

Using this Guide 

This guide is intended to help you install and manage Sage Budgeting and Planning and its environment in 
the most efficient way. 

       Chapter 2 provides detailed instructions on system requirements and installation. 

       Chapter 3 provides the steps to set up the system configuration for a new installation. 

       Chapter 4 provides upgrade information from previous versions. 

       Chapter 5 provides the steps to maintain the system configuration. 

       Chapter 6 provides the steps to set up and maintain users. 

       Chapter 7 provides the steps to install the sample general ledger and plan sheet demonstration data. 

       Chapter 8 provides the steps to set up and maintain WebView. 

       Chapter 9 provides information about the integration between Sage Budgeting and Planning and the GL 
data. 
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Chapter 2 - System Requirements and Installation 

Chapter 2 

System Requirements and Installation 

Minimum System Requirements for Sage Budgeting and Planning 

The following are the minimum System Requirements for Sage Budgeting and Planning. The requirements 
for Sage Budgeting and Planning generally follow the same guidelines as the General Ledger requirements 
regarding minimum levels and scalability. As always, these are suggestions for entry level activity and your 
actual requirements will need to be scaled according to your specific environment. If your server does not 
meet the requirements shown below, you can still continue with the installation and upgrade the hardware 
later. 

Database Server 

8 GB RAM  

10 GB free disk space for processing  

    Microsoft® Windows® Server 2008 

    Microsoft® Windows® Server 2012 

    Microsoft® Windows® Server 2012 R2 

    Microsoft® Windows® Server 2016 

    Microsoft® SQL Server 2008 

    Microsoft® SQL Server 2008 R2 

    Microsoft® SQL Server 2012 

    Microsoft® SQL Server 2014 

    Microsoft® SQL Server 2016 

    The SQL Server Service account will need permission to the folder where Sage Budgeting and Planning 
is installed. 

    The SQL Server authentication mode must be set to mixed mode. 

    Microsoft Access Database Engine (Microsoft ACE Driver) available for download from Microsoft. 

Network File Server 

    75MB available disk space for the program and its client setup files 

    100 MB available disk space for the demonstration data environment 

Client Workstation 

    2 GB RAM  

    60 MB free disk space for the program setup 

   Certified Operating Systems: 

 Microsoft® Windows® Server 2008 

 Microsoft® Windows® Server 2008 R2 

 Microsoft® Windows® Server 2012 

 Microsoft® Windows® Server 2012 R2 

 Microsoft® Windows® Server 2016 

 Microsoft® Windows® 7 

 Microsoft® Windows® 8 

 Microsoft® Windows® 10 
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 Microsoft® Windows® 10.1 

 

    Microsoft® Office 2007 or later  

General Ledger Environment 

    Any General Ledger with ODBC connectivity to the Accounts and Balances 

  

Existing Active Planner now known as Sage Budgeting and PlanningActive Planner Version (if 
upgrading) 

    Active Planner now known as Sage Budgeting and Planning 7.5, 7.51 or 7.52 

  

File Share Location 

To facilitate processing, a TmpShare folder is used as a central location to exchange files between the client 
and SQL server machines. This folder is located in the main Sage Budgeting and Planning folder. The 
Startup Service Account used for SQL Server and all Sage Budgeting and Planning users must have Full 
Control permission to the main Sage Budgeting and Planning folder and its subfolders. If you will be 
installing WebView, then the Startup Service Account used for the WebView service must have Full Control 
permission to the main Sage Budgeting and Planning folder and its subfolders. 
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Installation and Upgrade Overview 

Installation and Upgrade Overview 

This section provides an overview of the various installation and upgrade processes. Read this section to 
gain an understanding of the steps needed installing and upgrading Sage Budgeting and Planning. Then 
follow the detailed instructions on installing and upgrading in the appropriate sections found later in this 
guide. 

 

Note: Maintenance Releases and patches are periodically produced for Sage Budgeting and Planning to 
address issues found after the initial release of the new version. These issues might affect installation or 
upgrading. Before you install or upgrade, you should check with Sage Budgeting and Planning Technical 
Support to see if any Maintenance Releases or patches are available. Always backup your databases 
(including the company databases) before installing or upgrading Sage Budgeting and Planning. Ensure that 
no General Ledger or Sage Budgeting and Planning users are in the system while installing or upgrading 
Sage Budgeting and Planning. 

 
Sage Budgeting and Planning New Installation 

Step Machine Instructions 

1 Network File 
Server 

Install the application on the network file server. 

          Follow the detailed steps in the Sage Budgeting and Planning 

Network File Server Installation and in the Analytics SQL Server 
Install sections in Chapter 2. If you plan to install the demonstration 
data, accept the default to install Demonstration Data. 

2 Client 
Workstation 

Set up first Client Workstation. 

          Follow the detailed steps in the Sage Budgeting and Planning Client 
Workstation Installation section in Chapter 2. 

3 Client 
Workstation 

Create a new system configuration using the Admin Tool. 

          Follow the detailed steps in the Creating a New System Configuration 
section in Chapter 3. 

4 Client 
Workstation 

Register Sage Budgeting and Planning. 

          Follow the detailed steps in the Registration section in Chapter 5. 

5 Client 
Workstation 

Set up additional Client Workstations. 

          Follow the detailed steps in the Sage Budgeting and Planning Client 

Workstation Installation section for each Client Workstation. 

6 Client 
Workstation 

Set up each Sage Budgeting and Planning user. 

          Follow the detailed steps in the User Maintenance section in Chapter 6 
to add each user. 

 
Upgrading Sage Budgeting and Planning 

If you are running a version older than 7.45, then you must upgrade to Sage Budgeting and Planning7.45 or 
7.46 before installing this new version and running the upgrade procedure. Refer to the appropriate version 
System Management Guide for additional information on upgrading from prior versions. 

 

Step Machine Instructions 

1 Network File 
Server 

Install the application on the network file server. 

          Follow the detailed steps in the Sage Budgeting and Planning Network 
File Server Installation and be sure to install this new version in the folder 
which contains the prior version. 

2 Client 
Workstation 

Upgrade the client workstations. 

          Launch Sage Budgeting and Planning setup.exe on a client workstation 
that has the prior version installed. This will begin the automatic upgrade 
to the new version.  
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3 Client 
Workstation 

Upgrade the databases. 

          Launch the Admin Tool. Select your existing configuration then choose 
Upgrade Configuration. 

 

Installing Sage Budgeting and Planning Demonstration Companies 

Demonstration companies may be installed and may be used to become familiar with the functions of Sage 
Budgeting and Planning without affecting live production data. First, the demonstration companies are 
created and then the sample general ledger data and plan sheets may be loaded into the company databases. 
 
 

Step Machine Instruction 

1 Database Server Create databases. 

         Follow the detailed steps in the Create the Demonstration Company 

Databases section in Chapter 7. 

2 Client 
Workstation 

Create a system configuration using the Admin Tool. 

          Follow the detailed steps in the Installing the Sample Plan Sheets 

section in Chapter 7. 

 

WebView Installation Overview 

Note: The installation of WebView will require a reboot of the IIS server, so schedule the installation at a 
time when this can occur. 

Step Machine Instructions 

1  Install Sage Budgeting and Planning. 

          Sage Budgeting and Planning must be installed and configured prior to 
installing and using WebView.  Follow the detailed steps in the Sage 
Budgeting and Planning Network File Server Installation section, the 
Analytics SQL Server Install section and the Sage Budgeting and 

Planning Client Workstation Installation section in Chapter 2. 

2  WebView Pre-Installation. 

          Prior to installing the WebView application, several steps must be 
completed.  Follow the detailed steps in the WebView Pre-Installation 
section in Chapter 8. 

3 IIS Server WebView Installation on IIS Server. 

          Follow the detailed steps in the WebView IIS Installation section in 
Chapter 8. 

4 Sage Budgeting 
and Planning 
Client 
Workstation 

WebView Registration. 

          Follow the detailed steps in the Registration section in Chapter 6 to 
register WebView. 

5 Sage Budgeting 
and Planning 
Client 
Workstation 

Add WebView Users. 

          Follow the detailed steps in the User Maintenance section in Chapter 6 
to add each WebView user. 

6 WebView 
Client 
Workstation 

Set up WebView Client Workstations. 

          Follow the detailed steps in the WebView Client Installation section in 
Chapter 8 for each WebView Client Workstation. 
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Upgrading WebView 

 

Step Machine Instructions 

1  Upgrade Sage Budgeting and Planning. 

          Sage Budgeting and Planning must be upgraded prior to upgrading 
WebView.  Follow the detailed steps in the Sage Budgeting and 
Planning Network File Server Installation section, the Analytics SQL 

Server Install and the Sage Budgeting and Planning Client 
Workstation Installation section in Chapter 2. Follow the detailed steps 
in the Upgrading Sage Budgeting and Planning Databases section in 
Chapter 4. 

2 IIS Server Upgrade WebView. 

          Follow the detailed steps in the WebView IIS Upgrade section in 
Chapter 8. 
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Sage Budgeting and PlanningNetwork File Server Installation 

The Network File Server installation installs all files necessary to use the Sage Budgeting and Planning 
program on a shared file server on the network. It is not normal practice to use your local drives for the 
Network File Server installation. Normal practice is to share a folder on your Network File Server, then 
specify this shared folder during the Sage Budgeting and Planning Network File Server installation. 

The Network File Server installation will create the CLISETUP and TmpShare folders in the main Sage 
Budgeting and Planning folder. The CLISETUP folder contains the Client Workstation Installation. The 
TmpShare folder is used as a central location to exchange files between the clients and SQL server. The 
Startup Service Account used for SQL Server and all Sage Budgeting and Planning users must have Full 
Control permission to the main Sage Budgeting and Planning folder and its subfolders.   

If you will be installing WebView, then the Startup Service Account used for the WebView service must 
have Full Control permission to the main Sage Budgeting and Planning folder and its subfolders. Refer to 
Chapter 8 for further details on the WebView Installation 

Note: If you are in an Active Directory environment, then you should give permissions to the main Sage 
Budgeting and Planning folder through Active Directory, not by going through the permission button 
when exploring out to the main Sage Budgeting and Planning folder. 

 

1.        Place the Sage Budgeting and Planning CD-ROM into your drive and browse to the Program folder. 

2.        Double-click on SETUP.EXE, and the Welcome screen displays. 

 

3.        Click Next, to proceed to the Software License Agreement screen. Please read the agreement carefully. 
If you agree with the terms and conditions, click Yes to proceed with the installation. If you click 
Cancel, the Setup program closes. 
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4.        The Customer Information screen displays. Complete the User, Company and User Title fields. This 
information is used in the registration process. Once the installation is complete, you cannot change the 
entry. Click Next to continue. 

 

5.        The Readme file displays next. Read this file for release notes and other late-breaking information. 
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6.        Select from the following installation options illustrated below: 

          Network Application Files installs the program. 

          Application Help Files installs the Help files. 

          Demonstration Data installs the sample data environment. 

 

Note: If the Demonstration Data option is not checked, then the components necessary to install 

sample plan sheets will not be installed into the application directory. These components may be 
installed later by running through the Network File Server installation again. If you choose to install the 
Demonstration Data at another time, launch this Network Installation CD, select the Demonstration Data 
option only and be sure to choose the same Destination Folder that you used during the initial 
installation. 

7.        Select the location to install Sage Budgeting and Planning. Accept the default directory, or click Browse 

to choose a different directory. Normal practice is to browse to a share on your Network File Server 
where Sage Budgeting and Planning users have full permissions (eg. \\FileServer\APshare\Sage 
Budgeting and Planning ). Click Next. 

 

Note: If you are upgrading from a prior version and want to replace it, specify the destination folder path 
as the same path where the prior version was installed. If you want to rename the folder containing the 
prior version, then you should rename it before taking this step. Some customers will need to keep the 
prior version working in a production environment while creating a test environment for the new version. 
This is easily accomplished by first copying the prior version from the production environment to a new 

folder in the test environment, then specify this new folder as the destination folder in this step. 

8.        The installation program now has enough information to perform the installation. Click Next to copy 
the files to your hard disk or network drive. 
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9.        A screen will display once the installation program is complete. Click Finish to complete the network 
file server installation. 

  

10.     If you have not already done so, then give the Sage Budgeting and Planning users and the SQL Server 
Service Account Permission to the share specified in Step 7. 

11.     A sub-directory called CLISETUP is created under the Sage Budgeting and Planning installation 
directory. It contains a Setup program that you must run for each Client Workstation that will be 
running Sage Budgeting and Planning. See the Client Workstation Installation described later in this 
chapter. 

 

Analytics SQL Server Install 

Follow the steps below to install the SQL Server components needed by Sage Budgeting and Planning. 
These steps will install both the Publication Service and the DLL used for NT Authentication. You must 
install the SQL Server components in order for Sage Budgeting and Planning to work correctly. 

1.        Place the Sage Budgeting and Planning CD-ROM into the drive on the SQL Server and browse to the 
SQLServer folder. 

2.        Double-click on SETUP.EXE, and the Welcome screen displays. Click Next to install the Server 
Authentication and Publication Service or click Cancel to exit the installation. 
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3.        Select the location to install Analytics Server Components. Accept the default directory, or click 
Browse to choose a different directory. Click Next to continue. 

 

4.        The Service Log On screen displays. Specify the User account which will be used for the Publication 
service. Also specify the Domain and Password for this account. Click Next to continue. 
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5.        The installation program now has enough information to perform the installation. Click Next to start 
copying the needed files. 

6.        A screen will display once the installation program is complete. Click Finish to complete the 
installation. 

This Install will also create a task that can be modified for your needs. 

On the SQL server where the install was performed enter Server Manager, and in the configurations area 
you will see a item labeled Task Scheduler. 

In the Task Scheduler Library a new task will be created. 

In this folder is a Task called Analytics Publication Service Process. 

http://www.acutedata.com
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This Task can be modified to run at any time desired, on a schedule of Daily, Weekly, Monthly. This task can 
be scheduled to run at off hours to minimize impact on the server during crucial processing times. 

When this task is created by the install the default settings will be running Saturdays at 1:00 am. 

Changed to the schedule are handled by modifying the Trigger settings of the task. Below is a sample of the 
available options. 

 

Note: On a Windows 2003 server the Task Scheduler is located in the control panel area 

 

Note: For NT authentication to work with Sage Budgeting and Planning, the Analytics role needs to be 
part of the sysadmin group in SQL Server. 
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Initial Setup 

The Microsoft Analysis Server is a separate server from the SQL Server and has its own security 
requirements in addition to SQL Server and Active Planner. The Analysis Server uses Domain 
Authentication for its security. Active Planner uses either its own authentication or Domain Authentication. 
SQL Server uses either its own authentication or Domain Authentication. Depending on your specific 
environment, this could represent three distinct security setups. This means that if your Active Planner User 
(the User ID you use to log into Active Planner) has Administrative rights, then you have full access to 
cubes in terms of definition. However, as soon as you begin communicating with the Analysis Server, the 
Analysis Server will pay attention to your Domain User (the account you use to log into your PC) security 
settings. So, you will be restricted on what you can do or view with the cubes based on the Domain User. 
While these additional security requirements may seem challenging, you should be able to accomplish them 
by following the details in this chapter. 

Prior to creating and processing cubes in Active Planner, it is important to verify that preliminary settings 
and configurations have been established. 

          Make sure Microsoft Analysis Server is installed and current service packs are applied 

          Create an Analysis database on the Analysis Server for Active Planner to use when creating cubes 

          On the Analysis database, set the impersonation property's security setting to "Use the service 
account" 

          Define Active Planner User permissions for each user (Edit Cubes, Edit OLAP Dimensions, View 
Cubes) 

          Give the Active Planner user security to access the Plans (Administrator, Plan Administrator, Plan 
Controller) 

          Define the Domain User security settings 

       To create, process and view cubes: the Domain User must a member of the local 
Administrator group on the Analysis server 

       To only view cubes: Create a Read-Only OLAP Security Role (in Active Planner) and 
assign the Domain User to this role 

       To manage Cubes in Analysis Services: Install Analysis Services on the client PC 

 

Steps to connect to OLAP server 

          Ensure domain user is a member of the Local Administrator group on the Analysis server. 

          Log into the machine as this domain user. 

          Run our client setup. 

          Log into Active Planner with appropriate cube rights (see Active Planner Security chart). 

          User can now launch the Analyzer on an existing cube. 

          User can create a new cube and process an existing cube. 

 

          Install Microsoft Office Excel on machine 

          Enable trust access to VB in Excel 

          User can now launch the Excel Pivot Table on an existing cube. 

 

          Install Analysis Services (client only or server install) 

          User can now manage cubes in the Analysis server. 
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If you do not want to assign user as an OLAP Administrator, but want to give them cube rights 

          Log into the machine as a user who is a member of the Local Administrator group on the Analysis 
server. 

          Log into Active Planner with appropriate cube rights (see Active Planner Security chart). 

          In the Cubes folder, launch Cube Security. 

          Create a role (or use existing role) and assign domain user to this role which has appropriate 
rights to the cube. 

          Log in to the machine as the user assigned to this role.  

          User can now see the cube and will be limited based on the roles restrictions.  

 

OLAP Cube Roles 

Basically, if you are a cube viewer, or cube editor, you can get into the analyzer and pivot table. From that 
point on, the security is handled by the Analysis server cube security roles. So, you would probably want at 
a minimum a read role, and a read/write role to place people into. As part of the cube role security, you can 
setup roles which would obtain limited information from the cube. For example, you could limit a set of 
users to a certain department range, etc. 

There are basically two types of roles; those created in Active Planner and those created independently. 
Active Planner manages roles created within Active Planner, not those created elsewhere. The roles created 
directly from the Analysis Manager are independent of Active Planners roles. 

The roles created within Active Planner are stored both in Active Planner and placed into the OLAP 
database. Since Active Planner maintains its own copy, you can delete, re-create, and change these roles 
independently of the Analysis Manager. Those with access to the Analysis Server can delete/modify roles 
created within both the Analysis Manager and Active Planner. 

The Roles Screen in Active Planner reflects the roles from Active Planners perspective, not any other roles 
which may exist from other sources. 

  
Additional Notes and Steps 

There are two sides to OLAP Security. There is the Active Planner perspective based on the Active Planner 
User and the Analysis server's perspective based on the Domain User. So, for any action taken in Active 
Planner, both sides exist; each with its own security and considerations. The two sides do not really know 
about the other's security setup. In other words, when you set up a user in Active Planner (with Edit Cubes 
rights, for example) that is not mapped logically to a domain user, an Administrator, for example, has to 
make sure the domain user and Active Planner user are setup so it makes sense. 

 

Action: Cube creation 

Active Planner Perspective: 

          User has appropriate rights (create cubes, plan admin, etc.) 

Analysis Server Perspective: 

          Domain user is an Analysis Server Administrator, member of Local Administrator group on 
Analysis server 

Action: Cube processing 

ctive Planner Perspective: 

          User has rights to process cube (cube manager, plan manager, etc.) 

nalysis Server Perspective: 



Sage Budgeting and Planning System Management Guide 

18 

          Domain user is an OLAP Administrator, member of Local Administrator group on Analysis 
server. (They need rights to pull data from Active Planner fact tables for the cube.) 

Action: Cube deletion 

ctive Planner Perspective: 

          To delete Active Planners side of the cube, user has rights to delete the cube (cube manager, edit 
cubes, etc.) 

nalysis Server Perspective: 

          To delete the Analysis server's side of the cube, domain user is an Analysis Server Administrator 
and member of Local Administrator group on Analysis server 

Action: View cube through Excel pivot table or Analyzer 

ctive Planner Perspective: 

          User has rights to edit or view cube. 

nalysis Server Perspective: 

          Domain user is a member of a read or read/write role for the cube, or is an Analysis Server 
Administrator. 

Action: "Modeling" cube through Analyzer 

ctive Planner Perspective: 

          User has rights to edit cube and high level plan type user. 

nalysis Server Perspective: 

          Domain user is a member of a read/write role for the cube, or is an Analysis Server Administrator 
, and has rights to the fact table's _WB table in SQL server through a SQL login/role. 

 

Active Planner Security: (Active Planner Perspective) 

Active 
Planner 
Permissions 

Create 
Cube 

Cube 
Maint. 

Delete Cube 
Security 

Process 
Cube 

Analyzer Excel 
Pivot 
Table 

Edit 
EPT 

Write 
Back 

View Cubes      X X   

Edit Cubes      X X X  

View Cubes + 
Cube 
Manager 

     X X   

Edit Cubes + 
Cube 
Manager 

X X X X X X X X X 

Edit Cubes + 
Plan 
Controller 

X X X X X X X X X 

View Cubes + 
Plan 
Controller 

     X X   

View Cubes + 
Plan Admin 

     X X   

Edit Cubes + 
Plan Admin 

X X X X X X X X X 
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Administrator X X X X X X X X X 

 



Sage Budgeting and Planning System Management Guide 

20 

Sage Budgeting and Planning Client Workstation Installation 

The Client Workstation Installation installs all the system files necessary to use the Sage Budgeting and 
Planning program on a Client Workstation. 

Note: If you are upgrading from a prior version, then you may not need to run the Client Workstation 
Installation for every workstation. In step 7 of the Network File Server Installation , you had the option 

to specify the destination folder path as the same path where the prior version was installed. If you did 
this, then any workstation that already has Sage Budgeting and Planning installed will update 
automatically when you launch Sage Budgeting and Planning on the Client Workstation. Refer to the 
Client Workstation Autoupdate section later in this chapter. 

 

1.        Browse to the main Sage Budgeting and Planning directory which was created during the network file 
server installation.  Run the Client Installation program by double-clicking on SETUP.EXE, located in 
the CLISETUP directory. 

 

 

Note: If you are installing the client on a machine that is 64 bit the folder you should use is CLISETUP64 
instead of the CLISETUP folder which  contains the 32 bit installation. 

Tip: Be sure to use a UNC path, not a mapped network drive. A UNC path is a path that has the form: 
\\Computername\FileShare and an example of this is \\OH307\ActivePlanner. 

 

2.        Depending on what is loaded on your machine, a screen may appear indicating prerequisites necessary 
to continue with the client install.  Highlight the requirement's Status and press Install. Once all 
prerequisites are installed on your machine, the client setup will continue. 

Note: You may have to reboot your machine after installing the prerequisites. If a reboot is required, log 
back into your machine and the client install will continue.  
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3.        The Welcome screen displays.  Click Next to continue or click Cancel to cancel the installation process. 

 

 

4.        Next, read the Software License Agreement carefully. If you agree with the terms and conditions, click 
Yes to proceed. If you click No, the setup program will close. 
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5.        The Customer Information screen displays. Complete the User Name and Company Name fields. 
Click Next to continue. 

 

 

6.        Next, choose the Setup Type that best suits your needs for this workstation. Normally you should use 
the Network option where the executable and other supporting files reside on the network file 
server. Remote workstations (eg. connected via WAN) would use the Local option to copy the 
executable file to the workstation. The other supporting files remain on the network file server so the 
workstation will need to maintain connectivity to the network file server while running Sage Budgeting 
and Planning. After choosing the setup type, click Next to continue. 
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7.        You are then prompted for the program group the Sage Budgeting and Planning shortcuts should be 
created in, as shown below. You can either select an existing group or create a new group. After 
identifying the program folder, click Next to continue. 

 

8.        At this point, the setup program has enough information to copy needed files to the workstation. If you 
want to change or review any settings, click Back. Click Next to begin copying files. 
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9.        A window will display once the appropriate settings have been selected. Click Finish to complete the 
Client Workstation installation. 

10.      Depending on the specific components that were copied to the workstation, it may be necessary for 
you to restart windows to complete the installation. If needed, the Restart Windows screen will 
display. Select Yes, I want to restart my computer now then click Finish. Your system will restart. 
Other wise, click Finish to complete the Client Workstation installation. 

11.     The Client Workstation installation is now complete. 

Client Installations of Sage Budgeting and Planning on a Vista Machine, Windows 7 or 
a Windows 8 Machine  

If Sage Budgeting and Planning was installed locally by another user with different credentials than your 
own, when you launch Sage Budgeting and Planning, it will not recognize entries in the configuration.mdb. 
This problem occurs because of the Vista Operating System. Vista will virtualize files underneath the 
Program Files folder, so your changes are in a virtual folder. As a result, those changes cannot be seen by 
anyone else. To work around this issue, follow these steps: 

1. Launch Sage Budgeting and Planning as an Administrator  

2. Click Start, point to All Programs, point to Sage Budgeting and Planning, right click  and choose 
Run as Administrator 

3. Sage Budgeting and Planning will launch; Log into Sage Budgeting and Planning 

4. Log off the client machine and log back in as a different user 

5. You should now be able to run Sage Budgeting and Planning 

Client Installations of Sage Budgeting and Planning on a Windows 8 or Windows 
Server 2012 Machine  

Microsoft .Net Framework 3.5 is required for Sage Budgeting and Planning client application; however .Net 
Framework 3.5 can only be enabled on Windows 8 and Windows Server 2012 and cannot be installed. 

User can enable the .NET Framework 3.5 yourself through Control Panel. In Control Panel, choose Programs 
and Features, choose Turn Windows features on or off, and then select the Microsoft .NET Framework 3.5.1 
check box. This option requires an Internet connection. 

Enabling .Net framework 3.5 in Control panel for Windows 8 

Turning Windows features on or off in Control Panel   

http://www.acutedata.com
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If enabling the .NET Framework 3.5 in Control Panel fails, user may get error message 0x800f0906: 
“Windows couldn't connect to the Internet to download necessary files. Make sure that you're connected to 
the Internet, and click Retry to try again.” This message may be displayed for the following reasons: 

• Your computer is not connected to the Internet. Please connect, and then retry the operation. 

• Your administrator has configured your computer to use Windows Server Update Services 
(WSUS) instead of Windows Update for servicing. Please ask your administrator to enable the policy 
to use Windows Update instead of WSUS. 

 

Enabling .NET Framework 3.5 on Windows Server 2012 through Add Roles and Features Wizard 

• Open Add Roles and Features Wizard 

• Select .NET Framework 3.5 Features and then click next, 

• Select specify an alternate source path link in the Confirm installation selections screen. 

• Path: D:\Sources\SxS (where D drive is installation media) and then click OK. 

• Finally click Install button 
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Minimum System Requirements for WebView 

The following are the minimum System Requirements for WebView. As always, these are suggestions for 
entry level activity and your actual requirements will need to be scaled according to your specific 
environment. If your server does not meet the requirements shown below, you can still continue with the 
installation and upgrade the hardware later. If you are running other applications in addition to IIS, then 
scale your hardware accordingly. 

Internet Information Services (IIS) 

Processor - See Requirements for Operating System being used. 

    Memory (RAM) - See Requirements for Operating System being used. 

    Microsoft® Windows® Server 2003 

    Microsoft® Windows® Server 2003 R2 

    Microsoft® Windows® Server 2008 

    Microsoft® Windows® Server 2008 R2 

    Microsoft® Windows® Server 2012 

    Microsoft® Internet Information Services (IIS) Server 6.0 or 7.0 

    Microsoft® Excel® 2003 or later (needed for consolidating Excel spreadsheets) 

    30-100 MB free disk space for installation and processing 

    High speed internet access is recommended for external connections 

WebView Client Workstation 

   Processor - See Requirements for Operating System being used. 

   Memory (RAM) - See Requirements for Operating System being used. 

   High speed internet connection (100 Mbps or higher recommended) 

    Certified Operating Systems: 

     Microsoft® Windows® XP Professional, Service Pack 2 

     Microsoft® Windows® Server 2003 

     Microsoft® Windows® Server 2003 R2 

     Microsoft® Windows® Server 2008 

     Microsoft® Windows® Server 2008 R2 

     Microsoft® Windows® Server 2012 

     Microsoft® Windows® Vista 

     Microsoft® Windows® 7 

     Microsoft® Windows® 8 

    Microsoft® Internet Explorer 7, 8 or 9 

     Cookies must be enabled 
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Pre-Installation Requirements for WebView 

Prior to installing the WebView application, several steps must be completed.  

    Sage Budgeting and Planning must be installed and configured prior to installing and using WebView. 

    450-MHz Pentium III processor 

    Internet Information Server (IIS) version IIS 6 or IIS 7 must be installed and configured. 

    A network user will need to be created that will allow WebView services and the Web Site to access 
other resources on the network. 

1)       Create a network user with a password that never expires. For security reasons, you should restrict 
this user to only allow logins from your IIS machine. 

2)       Grant this user access, with full rights, to the main Sage Budgeting and Planning directory which 
was created during the network file server installation. This user will need to access the registration 
information and configuration.mdb located in this directory. 

3)       Make this user a local Administrator on the IIS server. Grant this user access, with full rights, to 
the Microsoft.net\Framework directory on the IIS machine. This should be located in the windows 
directory (e.g. c:\windows\Microsoft.net\Framework). 

4)       Assign this user to the IIS_WPG user group on this machine. 
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Other Installation Options 

Portable Document Format (PDF) User Guides 

The User Guide and System Management Guide are also provided in Portable Document Format (PDF 
files). These documents can be found in the Adobe PDF subdirectory. You can also copy the files from the 
CD to your Client Workstation. You must use Adobe Acrobat Reader to view this documentation. 

Installing Program Components Separately 

If you did not select the option to install the demonstration data during the initial program installation, you 
may install it later. 

1.        Run the program setup, check the Demonstration Data box, and specify the program data path. The 
same data path used during program installation should be used. 

2.        After step 1 is complete, the Demonstration Data is ready for installation, but is not yet installed. 
Follow the steps in Chapter 7 to install the demonstration data. 

Client Workstation Autoupdate 

When the Network File Server installation is updated with a new Maintenance Release or a new version, the 
client workstations will recognize the new version and automatically run the Client Setup.   

When you launch Sage Budgeting and Planning on the client workstation, it checks its version against the 
Network File Server version. If an update is needed, a window will display asking if you want to update. 
Click Yes to continue. 

 

The Client Workstation setup will run, updating needed components. 
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Chapter 3 - System Configuration 

Chapter 3 

System Configuration for a New Program 
Installation 

Prior to logging into Sage Budgeting and Planning, system configuration settings must be defined, including 
assigning companies to a centralized system database, defining a primary Microsoft SQL user, and defining 
a publication database. This process is simplified through the use of the Configuration Setup Wizard. 

Defining configuration settings, as well as the execution of other system administrative tasks, are performed 
from within the Admin Tool. The Admin Tool is accessed from the main application directory or from the 
Programs listing off of the Start menu. 

Note: This section assumes the GL environment is already set up and company databases exist.  

Note: Microsoft SQL Client Network Utilities MUST be installed on the Client Workstation before you can run 
the Admin Tool. 

Note: If you are upgrading from a previous version, skip this section and follow the procedures outlined in 

Chapter 4. 

Creating a New System Configuration 

During the configuration setup process, databases may be created, SQL users may be defined and objects, 
stored procedures and tables will be added to databases. For this reason, you must log into the designated 
SQL Server as sa or another administrative user. 

1.        Launch the Admin Tool by selecting it from the Start > Programs menu or by double-clicking ADMIN 

TOOL.EXE from the main application root folder. 

2.        The Admin Tool Login screen displays. 

http://www.acutedata.com
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3.        Next, type the Admin Tool password. 

Note: The first time you launch the Admin Tool, you will be prompted to create a new password. Since a 
SQL administrative account is required to perform the steps in the Admin Tool, it is often the DBA or 
someone else in the IT staff who uses the Admin Tool. This password prevents other Budgeting and 
Planning users from accidentally running the Admin Tool. Please be sure to save this password. 

4.        Click Ok to enter the Admin Tool application. 

5.        Select Action > New Configuration from the menu to launch the Configuration Setup Wizard. A 
message will appear reminding you to stop the Analytics Publication Service before proceeding. The 
Publication Service runs in the background and assists with publishing plan sheet data which reduces 
the time to save a sheet. Continue after stopping this service.  

6.        The Welcome screen displays. Select the option to Create a new configuration and click Next to 
continue. 

 

7.        Type or select from the drop-down the SQL Server where the application data will be stored. You 
cannot choose ‘(local)’ from the drop-down. To use the local machine, type the actual name of the 
machine. During the initial setup, information is written to application specific databases on the SQL 
Server. To execute these actions, the wizard must connect to the data server as a SQL administrative 
account.   
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Click Next to bring up the SQL Server Admin Connection window.   

 

Enter the username and password for a SQL administrative account and click Ok.  The wizard will 
attempt to connect to the specified server. 

 

  

Note: The SQL Server authentication mode must be set to mixed mode. 

8.        The next step is to define a configuration definition. Creating this configuration centralizes the settings 
necessary to run the application. Each configuration identifies the SQL server that contains the 
Budgeting and Planning system database, the Budgeting and Planning publication database, the 
Budgeting and Planning Company database, a system database administrator user, and a database 
query authority user. This definition name is the only information that the user will select when logging 
into the application. Type a name for the configuration definition of up to 16 alphanumeric characters. 
Be sure to use standard characters only (letters, numbers, underscore) and avoid spaces or other special 
characters (e.g. /, !, &, etc. ). 

Next, either select an existing database to store the Budgeting and Planning system objects or create a 
new system database by selecting <New> from the drop-down list. 
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If you choose to create a new system database from the wizard, the Microsoft SQL Server Database 

Properties form displays so that the appropriate information may be defined and the new database can 
be created. 

 

Once the system database has been identified, you must identify a publication database to store any 
published data. Select an existing database or select <New> from the drop-down list. If you choose to 
create a new publication from the wizard, the Microsoft SQL Server Database Properties form displays 
so that the appropriate information may be defined and the new database can be created. 

 

9.        Click Next and the Wizard will open the selected system database. If Budgeting and Planning system 
objects already exist in the system database, a message displays asking if you would like to overwrite 
the existing objects or if you would like to use the existing objects. 
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The same process occurs on the publication database. If Budgeting and Planning publication objects 
already exist in the publication database, a message displays asking if you would like to overwrite the 
existing objects or if you would like to use the existing objects. 

10.     The next step is to define a system database administrator and a database query authority. 

The System Database Administrator (SDA) is the only true SQL server user that will have access to the 
application databases. When the SDA is defined, it creates an Analytics role and assigns the SDA to this 
role. Thus it has full administrative access to all of the Budgeting and Planning databases.  It is not a 
good idea to use the sa account for the SDA, so typically you would create a new user for the SDA. 

Consequently, since there is only one SQL user that accesses all of the application databases, the ability 
to query, update, and change data is potentially available to all users defined in the application. 
Therefore, to reinforce security, an additional user with specific database query access known as the 
Database Query Authority (DQA) needs to be defined. 

The DQA login ID created and identified here will be assigned to the Public database role for the 
control database, the company databases, the publication database and the Budgeting and Planning 
System database. The DQA will be used as the default user for all database queries within the 
application.  

Note: If any additional permissions are needed, then the database or system administrator must assign 
the them for the DQA user. 

 

In the designated fields, select <New> to create new users or select an existing user to be assigned as 
the System Database Administrator and the Database Query Authority. For each login ID, type the 
associated passwords. 

 

If you choose to create a new user from the wizard, an additional window displays, allowing you to 
define the new user ID and password. 
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11.     In addition to adding application-specific objects to the system and publication databases, Budgeting 
and Planning specific tables, views, and scripts are inserted into specified company databases. 

Complete the Company Setup screen, by typing the appropriate Company Code and Description. 

 

Note: Only one company may be initially assigned to a configuration. Additional companies may be 
assigned to the configuration using the Add Company option in Database Maintenance. 

 

12.     Click Next to continue. If Budgeting and Planning company objects already exist in the database a 
message displays asking if you would like to overwrite the existing objects or if you would like to use 
the existing objects. 

 

13.     The final step of the configuration setup process is the Setup Verification. This allows you to review the 
information listed and make modifications before the any changes are made to your databases. Click 
Previous to correct any information. Click Run to save the configuration options defined and to invoke 
actions listed for the system, publication and company databases.  
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14.     The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s). Any errors encountered will be displayed in red. Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file. This log file is created in the folder that you specified during the Budgeting and 
Planning Network File Server Installation. The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created, e.g.: “Processing Log 2009-10-03 10.53.38.rtf”. You should review 
it for any errors that might have occurred during the processing. 

 

15.     Click Finish to save the configuration options defined. 

 

 

Note: Before you can begin creating plan sheets in Budgeting and Planning, some configuration 
information and data must be established in the company database. This would include Chart of 
Accounts format, Fiscal periods, Accounts and Balance codes. Please refer to Chapter 9, Integration 
Maintenance, for details on how to accomplish this. 
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Chapter 4 - Upgrading from Previous Versions 

Chapter 4 

Upgrading from Previous Versions 

This section provides details of the upgrade processes.   

Note: Maintenance Releases and patches are periodically produced for Sage Budgeting and Planning to fix 
issues found after the initial release of the new version. These issues might affect installation or 
upgrading. Before you install or upgrade, you should check with Sage Budgeting and Planning Technical 
Support to see if any Maintenance Releases and patches are available. 

Note: Prior to upgrading, you should backup your Sage Budgeting and Planning System, Publication and 
company databases. Schedule the installation for a time when you have exclusive access to these 
databases and no one is entering data in Sage Budgeting and Planning. 

Upgrading Older Active Planner now known as Sage Budgeting and Planning Versions 

If you are running an older version, then you must upgrade to Sage Budgeting and Planning7.45 before 
installing this new version and running the upgrade procedure. Refer to the appropriate version System 
Management Guide for additional information on upgrading from prior versions. 

Upgrading Sage Budgeting and Planning Databases 

Once you have installed Sage Budgeting and Planning, you can follow these detailed steps for upgrading 
the databases from Versions 7.45, 7.46, 7.50  or 7.51.  

During the configuration setup process, databases may be created, users may be defined and objects, stored 
procedures and tables will be added to databases. When prompted, you must log into the designated SQL 
Server as sa or another administrative user. 

Note: Prior to following the steps in this section, you need to complete the Sage Budgeting and Planning 
installation. If you have not already done so, complete the steps in the Sage Budgeting and Planning 
Network File Server Installation section in Chapter 2. When prompted for the installation location in Step 

8, specify the location of the existing Sage Budgeting and Planning directory. Then, complete the steps in 
the Sage Budgeting and Planning Client Workstation Installation section.   

1.        Launch the Admin Tool by selecting it from the Start > Programs menu. 

2.        The Admin Tool Login screen displays. 

http://www.acutedata.com
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3.        Next, type the Admin Tool password. 

Note: The first time you launch the Admin Tool, you will be prompted to create a new password and a 
password hint. Since a SQL administrative account is required to perform the steps in the Admin Tool, it 
is often the DBA or someone else in the IT staff who uses the Admin Tool. This password prevents 
other Sage Budgeting and Planning users from accidentally running the Admin Tool. Please be sure to 
save this password. The text entered in the password hint area will be displayed on the login screen 
after a failed login. 

4.        Click Ok to enter the Admin Tool application. 

From the Admin Tool tree, choose the existing system configuration you want to upgrade. If you do not 
have any System Configurations listed, then you are not using the correct configuration.mdb. 

 

Right-click on it and choose Upgrade Configuration. This will bring up a message confirming that you 
want to upgrade followed by the SQL Server Admin Connection window.  
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Enter the username and password for a SQL administrative account and click Ok. The wizard will 
attempt to connect to the specified server then begin the upgrade process. 

 

Note: The SQL Server authentication mode must be set to mixed mode. 

5.        The SQL Query Output screen will display temporarily as the upgrade progresses. A conversion report 
will automatically be created and is saved in a log file. This log file is created in the folder that you 
specified during the Sage Budgeting and Planning Network File Server Installation. The file is named 
"Processing Log xxx.rtf" where xxx is the date and time the log was created, e.g.: "Processing Log 2009-
10-03 10.53.38.rtf". You should review it for any errors that may have occurred during the processing. 

 

6.        When the upgrade has completed, a screen will display indicating this. Click OK. 

 

 

7.        The final step in upgrading Sage Budgeting and Planning is to update the client workstations. The 
method used depends on how you performed the Network File Server Installation. In step 7 of the 
Network File Server Installation , you had the option to specify the destination folder path as the same 
path where the prior version was installed. If you did this, then any workstation that already has Sage 
Budgeting and Planning installed will update automatically when you launch Sage Budgeting and 
Planning on the Client Workstation. Refer to the Client Workstation Autoupdate section in Chapter 2. 
If you did not specify the same path as the prior version, then you will need to use the following 
method at each client workstation: Uninstall Sage Budgeting and Planning and then run setup.exe in 
the CLISETUP folder. Refer to Sage Budgeting and Planning Client Workstation Installation in 
Chapter 2. 

 

Upgrading Analysis Server 2005 Cubes 

In earlier Sage Budgeting and Planning versions (7.46 and prior), when a cube was created and processed on 
a SQL2005 Analysis Server, Sage Budgeting and Planning created the cube using SQL2000 emulated mode; 
Sage Budgeting and Planning was not running in Native SQL2005 mode. Therefore, cubes that were created 
in prior releases will need to be saved and processed in the new, Native SQL2005 environment of Sage 
Budgeting and Planning.  

Here is a list of steps that should be completed as you upgrade: 
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1.     Create a new OLAP 2005 database on your SQL2005 Analysis Server 

 Launch SQL Server Management Studio and connect to your Analysis Server 

 Highlight your Analysis Server and expand the Databases folder 

 Right-click Databases and select New Database 

 Enter an Analysis Server Database name 

 Set the impersonation property to “Use the service account:" 
2.     Log in to Sage Budgeting and Planning as a user with Edit Cube permissions 

3.     Open each cube definition and point to the new Analysis database created in step one 

4.     Save and process each cube 

Note: If you used Analyzer and saved your views as Analyzer Books, then you will need to recreate these 
views after upgrading and save them as Briefing Books. 

 

Upgrading OLAP Dimensions 

Using Analysis Server 2005/2008 requires an update to existing OLAP dimensions so they can be used in 
2005+ cubes. Updates will occur on each cube definition's Advanced Level Properties screen which requires 
the "OLAP 2005+ Level Selection" fields (located on the bottom half of the screen, shown below) to be 
completed.  

 

Updating the cube definition's Advanced Level Properties screen can be accomplished in one of two ways: 

1. Have ready either print screens or notes on your dimension's setup. Then, delete the existing OLAP 
dimension and recreate a new OLAP dimension using the wizard and attach it to your cube(s). The 
wizard will fill in the extra fields for you. 

2. Have ready either print screens or notes on your dimension's setup. Then, open the existing OLAP 
dimension and go to the Advanced Level Properties screen and manually complete the fields 
appropriately for each level you have defined. 
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Note: It is recommended that you open your existing OLAP dimensions and do print screens of all the 
pages, including the advanced detail for each level, so you can duplicate or adjust later if necessary. You 
can also save an existing OLAP dimension with a new name to create a copy of it for later reference.   

In most cases,  the original OLAP dimension was created with the wizard and left unchanged. For these 
cases, use method #1 as this does the work for you. 

For the small amount of cases where the advanced detail was customized, you can enter the OLAP 2005+ 
field values manually based on what was in the OLAP 2000 field values. There are a few differences 
between how OLAP 2000 and OLAP 2005+ access the table fields. These differences may be helpful to 
review as you manually create your OLAP Dimension:  

 OLAP 2005+ requires that the table name or && table replacement variables be put in separate 
table fields on the screen.  

 OLAP 2005+ also requires that any table references be removed from the select fields on the screen. 

 OLAP 2005+ does not surround field names with quotes. You can surround field names with 
square brackets [] instead. 

 The OLAP 2005+ member name select field must return a SQL string, not an integer. 

Note: If you update an OLAP dimension used in these cubes and choose to refresh cubes, the changes will 
not take effect until you process the cubes listed on the refresh report.  
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Chapter 5 - System Maintenance 

Chapter 5 

System Maintenance 

Maintaining the System Configuration 

Overview 

The Admin Tool is the utility used to define and maintain System Configurations. Maintaining your SDA, 
DQA, Linked Servers, Publication databases as well as the execution of other system administrative tasks is 
performed from within the Admin Tool. It has been modeled after SQL Server Enterprise Manager’s look 
and feel, giving it a familiar interface for administering your Sage Budgeting and Planning system.   

Since a SQL administrative account is required to perform the steps in the Admin Tool, it is often the DBA 
or some one else in the IT staff who uses the Admin Tool. This utility is password protected preventing 
other Sage Budgeting and Planning users from accidentally running the Admin Tool.   

In an effort to ensure database security, only one true SQL server user is permitted to access the application 
databases. This login, known as the System Database Administrator (SDA), will allow users defined within 
the application to connect to the SQL server under one account. As a member of the Analytics role, the SDA 
has full administrative access to all of the Sage Budgeting and Planning databases. One SDA is assigned to a 
system configuration definition and may be changed at any time. 

Since Sage Budgeting and Planning accesses the application databases through only one system 
administrator (SDA), the ability to query, update and change data is potentially available to all users 
defined in the application. Therefore, to reinforce security, an additional user with specific database query 
access known as the Database Query Authority (DQA) needs to be defined. The DQA login ID will be 
assigned to the Public database role for the control database, the company databases, the publication 
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database and the Sage Budgeting and Planning System database. The DQA will be used as the default user 
for all database queries within the application. 

Note: If any additional permissions are needed, then the database or system administrator must assign the 
additional permissions for this user. 

 

Launch the Admin Tool by selecting it from the Start > Programs menu or by double-clicking ADMIN 
TOOL.EXE from the main application root folder. Enter the Admin Tool password.  

 

 

System Configuration, SDA and DQA Maintenance 

1.        Existing configurations may be maintained at any time by right-clicking on the desired System 
Configuration and choosing Properties from the pop-up menu. 
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2.        To invoke any changes, you must connect to the SQL Server as sa or another administrative user. Enter 
the username and password for a SQL administrative account and click Ok. 

 

3.        Once you are connected, the existing configuration information such as the Description, SQL Server 
name, System database, SDA and DQA IDs, the Publication database, the control database, and the 
associated company databases are listed. 

On the Database Information tab, you may modify the configuration description or maintain the SDA 
and DQA.  

 

To maintain the SDA, select a new login ID from the drop-down or select <New> to create a new login ID.  
Type the associated password for the selected login ID. 

To maintain the DQA, select a new login ID from the drop-down or select <New> to create a new login ID.  
Type the associated password for the selected login ID. 

4.        Click the Companies tab to view the Publication database, the control database, and the information 
about the associated company databases. 
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5.        Click Ok to save any modifications. 

Remove System Configuration 

Removing a System Configuration deletes the configuration information from the configuration 
database. Optionally, it also deletes all Sage Budgeting and Planning objects from the system database, the 
publication database and all company databases. Only Sage Budgeting and Planning objects are deleted 
from the company databases and the GL data is untouched. 

1.        From the Admin Tool tree, choose the system configuration you want to remove. Right-click and 
choose Remove. 
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2.        The Remove System Configuration screen displays. Put a checkmark next to the Remove System 

Database Objects if you wish to delete the Sage Budgeting and Planning objects from the system 
database. Put a checkmark next to the Remove All Company and Publication Database Objects if you 
wish to delete the Sage Budgeting and Planning objects from the company and publication databases. 

 

3.        A confirmation screen will display. Click Yes to delete the Sage Budgeting and Planning objects from 
the databases and remove the system configuration from the configuration database.   

 

4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s). Any errors encountered will be displayed in red. Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file. This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation. The file is named “Processing Log xxx.rtf” where xxx is the 



Sage Budgeting and Planning System Management Guide 

46 

date and time that the log was created, e.g.: “Processing Log 2009-10-03 10.53.38.rtf”. You should review 
it for any errors that might have occurred during the processing. 
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System Database Maintenance 

Refresh Procedures System Database 

Occasionally, it is necessary to update the stored procedures for the system database. This action should 
only be executed under the advisement of a customer support representative. 

1.        From the Admin Tool tree, choose the system configuration where you want to refresh procedures. 
Right-click on the system configuration and choose Refresh Stored Procedures. 

 

2.        A message will display to confirm that you want to refresh procedures. Click Yes. 

 

3.        A message will display asking if you would like to also refresh procedures in the Company and 
Publication databases. Click Yes to refresh procedures in these databases. If you want to update stored 
procedures in the System Database only, then Click No. Sage Budgeting and Planning stored 
procedures, triggers, and views are dropped and then recreated. 

 

4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s). Any errors encountered will be displayed in red. Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file. This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation. The file is named “Processing Log xxx.rtf” where xxx is the 
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date and time that the log was created, e.g.: “Processing Log 2012-10-03 10.53.38.rtf”. You should review 
it for any errors that might have occurred during the processing. 

 

Remove System Database 

Follow the steps in the Remove System Configuration section above to remove Sage Budgeting and 
Planning objects from the system database. If you remove Sage Budgeting and Planning objects from the 
system database, you will lose all system and company data, therefore it is recommended that you perform 
this action under the advisement of a customer service representative. 
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Publication Database Maintenance 

Reinitialize Publication Database 

The Reinitialize Database option drops Sage Budgeting and Planning objects from the publication database 
and then recreates them. If you initialize an existing publication database, you will lose all published data, 
therefore it is recommended that you perform this action on the advisement of a customer service 
representative. 

Note: If you are removing publication databases, you must stop the publication service first. 

1.        From the Admin Tool tree, choose the system configuration where you want to reinitialize a 
publication database and expand the node for it. Then expand the Publication Databases node, Right-
click on the publication database and choose Reinitialize Database. 

 

2.        A warning displays confirming that you wish to initialize the publication database. 

 

3.        Click Yes to continue with the initialization process. 

4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file.  This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should 
review it for any errors that might have occurred during the processing. 

Refresh Procedures Publication Database 

Occasionally, it is necessary to update the stored procedures for a publication database. This action should 
only be executed under the advisement of a customer support representative. 



Sage Budgeting and Planning System Management Guide 

50 

1.        From the Admin Tool tree, choose the system configuration where you want to refresh procedures and 
expand the node for it. Then expand the Publication Databases node, Right-click on the publication 
database and choose Refresh Stored Procedures. 

 

2.        A message will display to confirm that you want to refresh procedures. 

 

3.        Click Yes to initiate the refresh process. Sage Budgeting and Planning stored procedures, triggers, and 
views are dropped from the publication database and then recreated. 

4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file.  This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should 
review it for any errors that might have occurred during the processing. 
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Company Database Maintenance 

Add Company 

The Add Company option provides the ability to add companies to an existing system configuration 
definition. The companies that display in the list are only those companies that have been previously 
defined in the general ledger. Tables, views, triggers, stored procedures, and other Sage Budgeting and 
Planning objects are added to the selected companies during the initialization process. 

1.        From the Admin Tool tree, choose the system configuration you want to add a company to and expand 
the node for it. Right-click on Companies and choose New Company. 

2.        Enter a new Company Code and Description. From the drop-down, select the company database to be 
initialized with Sage Budgeting and Planning information and added to the System Configuration. 

3.        From the Publication Database drop-down, select the publication database to be used with this 
company database.   Click Ok to initiate the initialization process. If Sage Budgeting and Planning 
company objects already exist in the database a message displays asking if you would like to overwrite 
the existing objects or if you would like to use the existing objects. 
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4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file.  This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should 
review it for any errors that might have occurred during the processing. 

Remove Company 

Removing companies from a configuration deletes Sage Budgeting and Planning objects from the selected 
company databases. Use the following steps to remove a single company from a configuration.  If you wish 
to remove all companies in a configuration, then use the steps in the Remove System Configuration section 
above. 

1.        From the Admin Tool tree, choose the system configuration you want to delete a company from and 
expand the node for it. Then expand the Companies node, Right-click on the company database and 
choose Delete. 

 

2.        A warning message displays prompting you to confirm the deletion. 
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3.        Click Yes to delete the company database from the system configuration.  Another warning message 
displays asking if you wish to permanently remove Sage Budgeting and Planning data.   

 

4.        Clicking Yes will delete all from the Sage Budgeting and Planning objects from the company database.  
Clicking No will delete the company database from the system configuration but leave the Sage 
Budgeting and Planning objects in the company database. 

5.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file.  This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should 
review it for any errors that might have occurred during the processing. 

Refresh Procedures Company Database 

Occasionally, it is necessary to update the stored procedures for a company database. This action should 
only be executed when the application instructs you to do so or under the advisement of a customer support 
representative.  Optionally, you can update the stored procedures for all databases in the configuration.  See 
the Refresh Procedures – All Databases for the Configuration section below. 

1.        From the Admin Tool tree, choose the system configuration where you want to refresh procedures and 
expand the node for it. Right-click on the company database and choose Refresh Stored Procedures. 

 

2.        A message will display to confirm that you want to refresh procedures. 



Sage Budgeting and Planning System Management Guide 

54 

 

3.        Click Yes to initiate the refresh process. Sage Budgeting and Planning stored procedures, triggers, and 
views are dropped from the company databases and then recreated. 

The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, you 
may have an option to save or print the contents of the Output screen but it is always automatically saved in 
a log file.  This log file is created in the folder that you specified during the Sage Budgeting and Planning 
Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the date and time 
that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should review it for any errors 
that might have occurred during the processing. 
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Refresh Stored Procedures for Configuration 

Refresh Procedures All Databases for the Configuration 

You can update the stored procedures for all databases in the configuration. This action should only be 
executed when the application instructs you to do so or under the advisement of a customer support 
representative. 

1.        From the Admin Tool tree, choose the system configuration where you want to refresh procedures, 
Right-click on the configuration and choose Refresh Stored Procedures. 

 

2.        A message will display to confirm that you want to refresh procedures. Click Yes. 

 

3.        A message will display asking if you would like to also refresh procedures in the Company and 
Publication databases. Click Yes to initiate the refresh process. Sage Budgeting and Planning stored 
procedures, triggers, and views are dropped and then recreated. 

 

4.        The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s).  Any errors encountered will be displayed in red.  Depending on the specific actions taken, 
you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file.  This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation.  The file is named “Processing Log xxx.rtf” where xxx is the 
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date and time that the log was created.  Eg.: “Processing Log 2005-10-03 10.53.38.rtf”  You should 
review it for any errors that might have occurred during the processing. 
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Linked Server Configuration 

Linked server configurations provide centralized access to data sources. Basically, linked server 
configurations allow the designated SQL Server to connect to other data sources through the OLE-DB 
provider. In essence, this configuration regards the other data sources as databases on the SQL Server. 

Access to data sources outside the defined company databases requires that linked server configurations be 
defined.  Linked server configurations are required for dimension definitions but may be needed for 
database queries too.   

Note: Additional security for the linked server definition may be defined through SQL Server Enterprise 
Manager. 

 

Note: SQL Server Service must run as a domain user if a network file share is to be accessed. 

Creating New Linked Server Configurations 

Access Database 

Linked server configurations may be created for many data sources including Access databases. 

Note: Microsoft Distributed Transaction Coordinator (MS DTC) must be running to connect to Access 
databases. 

1.        From the Admin Tool tree, choose the SQL Server where you want to add a Linked Server and expand 
the node for it. Then Right-click on Linked Servers and choose New Linked Server. 

 

2.        The Linked Sever Property Dialog will come up. 

3.        Select the Provider Name. (Microsoft Office Access Database Engine OLEDB Provider is 
recommended) 

Note: If The Microsoft Office Access Database Engine OLEDB Provider is not in the drop down list then that 
means it is not currently installed on the SQL Sever. This provider is available for download from 
Microsoft. 

4.        Fill in the rest of the information for the Linked Server. 
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Access Linked Server Definition 

Linked Server Name Type a descriptive name for the linked server definition of up to 40 
alphanumeric characters. This name will display in the table lookups. 

Data source Type or browse to the path that contains the source file. 

Note: This file must be accessible to the SQL Server. Use a UNC path 
unless the file is located on the same machine as the SQL Server. 

Product Name Enter the word Access Here 

4.        Click on the Security Tab. 
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Remote login Enter Admin for the login name. 

With password Leave the password blank. 

Note: When you view the properties of this linked server this field will 
have **** instead of being blank even though the actual value is empty, 
this is normal. 

 

Excel Spreadsheet 

Linked server configurations may be also be created to link to Excel files. 

Note: Microsoft Distributed Transaction Coordinator (MS DTC) must be running to connect to Excel files. 

1.        From the Admin Tool tree, choose the SQL Server where you want to add a Linked Server and expand 
the node for it. Then Right-click on Linked Servers and choose New Linked Server. 
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2.        The Linked Sever Property Dialog will come up. 

3.        Select the Provider Name. (Microsoft Office Access Database Engine OLEDB Provider is 
recommended) 

Note: If The Microsoft Office Access Database Engine OLEDB Provider is not in the drop down list then that 
means it is not currently installed on the SQL Sever. This provider is available for download from 
Microsoft. 

4.        Fill in the rest of the information for the Linked Server. 
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Excel Linked Server Definition 

Linked Server Name Type a descriptive name for the linked server definition of up to 40 
alphanumeric characters. This name will display in the table lookups. 

Source File Type or browse to the path that contains the source file. 

Note: This file must be accessible to the SQL Server. Use a UNC path 
unless the file is located on the same machine as the SQL Server. 

Product Name Enter Excel here. 

Provider String Enter Excel 12.0 here. 
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Remote Login For secure Excel files, type the correct login name. To access unsecured 
Excel files, you MUST use the login name Admin. 

With Password For secure Excel files, type the password associated with the designated 
User Name; otherwise leave the field blank. 

 

4.        Click Ok to save the linked server configuration definition. 

Linked Servers on 64-bit SQL Servers 

On 64-bit SQL 2005 or SQL 2008 servers, use the Microsoft.ACE.OLEDB drivers for creating linked servers 
to Excel,  Access, dBase, etc. Microsoft has replace the Jet Driver with the new ACE drivers mentioned above 
and is the recommended  method used to connect a 64-bit SQL server to an OLEDB data sources. The Ace 
driver may not be available by default with the SQL server installation and can be downloaded from 
Microsoft. 

Additional types of Linked servers can be created to other data sources. For specifics about connecting to 
other external data sources see SQL Server Books online/SQL Server Help about what is needed to do this. 

 For details on this process, contact Sage Budgeting and Planning Technical Support. 

 

Maintaining Linked Server Configurations 

Due to the complexity of linked server definitions, the Admin Tool will not allow you to modify an existing 
Linked Server.  You must delete the linked server and recreate it. Using the Admin Tool you can view the 
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properties of an existing Linked Serer but you cannot change them.  If you would like to maintain an 
existing Linked Server, you can do this in the SQL Server in SQL Management Studio. 

1.        From the Admin Tool tree, choose the SQL Server where you want to view the defined Linked Servers, 
expand the node for it, then expand the Linked Servers node. Right-click on the desired linked server 
and choose Properties. 

 

2.        This will display the Linked Server Properties screen. 
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3.        You can click the Security tab to view the security options.  Click the Server Options tab to view the 
Linked Server options 

4.        Click OK when complete. 

 

Deleting Linked Server Configurations 

To delete an existing Linked Server follow these steps: 

1.        From the Admin Tool tree, choose the appropriate SQL Server, expand the node, then expand the 
Linked Servers node. Right-click on the desired linked server and choose Delete. 
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2.        Click Yes to confirm that you want to delete the linked server. 
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Registration 

Once you have installed the software, it needs to be registered. The registration process starts by contacting 
customer service at 800-368-2405. Once you receive an unlock code, you can complete the registration 
window. Registering Sage Budgeting and Planning can be done from the Admin Tool or from within the 
main application. 

Registration is based upon the number of user connections, an installation code and a serial number. With 
the exception of updates to the general ledger, all functions are available in the program prior to registration 
for a period of 90 days.  

Registering from the Admin Tool 

1.        From the Admin Tool, choose Tools > Product Registration. The Registration form displays. 

 

Registration 

Registered to Name of company, person and title specified during program 
installation. These fields cannot be updated. 

Installation Code Identification created during program installation. This field cannot be 
updated. 

Sage Budgeting 
and Planning 

Sage Budgeting and Planning Serial number supplied with program 
contents or by customer service. 

WebView Optional WebView Serial number. 

Analyzer Optional Analyzer Serial number. 

Unlock Code Identification provided by Sage Registration department based upon 
the serial numbers and installation code. 

Connections Maximum number of users allowed in Sage Budgeting and Planning 
based on the number of licenses purchased. And, optionally, the 
maximum number of users allowed in Sage Budgeting and Planning as 
calculated by the system. 

2.        Click the Sage Budgeting and Planning option. Enter the serial number supplied. 



Active Planner System Management Guide 

67 

3.        Optionally, click on the WebView product. Enter the serial number. 

4.        Optionally, click on the Analyzer product. Enter the serial number. 

5.        Enter the unlock code and connections as provided by Customer Service. 

6.        Click Ok to complete the registration process. The system will indicate a successful registration if all 
information was entered correctly. 

 

 

 

Registering from within the Application 

1.        Until registered, the Demonstration Version Notice window will display each time the program is 
launched. Click the Registration button to display the registration form. 

 

2.        To access the Registration window from within Sage Budgeting and Planning, select Setup > 

Registration from the main window after logging in. Complete the registration form to unlock Sage 
Budgeting and Planning. 
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Registration 

Registered to Name of company, person and title specified during program 
installation. These fields cannot be updated. 

Installation Code Identification created during program installation. This field cannot be 
updated. 

Sage Budgeting 
and Planning 

Sage Budgeting and Planning Serial number provided with program 
contents. 

WebView Optional WebView Serial number. 

Analyzer Optional Analyzer Serial number. 

Unlock Code Identification provided by Sage Registration department based upon 
the serial numbers and installation code. 

Connections Maximum number of users allowed in Sage Budgeting and Planning as 
calculated by the system.  And optionally the maximum number of users 
allowed in Sage Budgeting and Planning as calculated by the system. 

3.        Click the Sage Budgeting and Planning option. Enter the supplied serial number. 

4.        Optionally, click the WebView product. Enter the serial number. 

5.        Optionally, click the Analyzer product. Enter the serial number. 

6.        Enter the unlock code and connections as provided by Customer Service. 

7.        Click Ok to complete the registration process. The system will indicate a successful registration if all 
information was entered correctly. 
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Admin Tool Login Maintenance 

1.        From the Admin Tool, choose Tools > Change Password. The Admin Tool Login Maintenance form 
displays. 

2.        Type a new password of up to 16 alphanumeric characters in the New Password field. 

3.        Retype the new password in the Confirm New Password field. 

4.        Fill in a Password hint on the line labeled Password Hint. This will be displayed on the log in screen 
when a bad password has been entered. 

5.        Click Ok to save the changes. 
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Database Mail 

Sage Budgeting and Planning provides the ability to use either SQL Mail or Database Mail for sending e-
mail messages to users. If you are running a SQL Server version prior to 2005, Sage Budgeting and Planning 
will use SQL Mail exclusively. If you are using SQL Server 2005 or a higher version and have Database Mail 
enabled, Sage Budgeting and Planning will use Database Mail.  

While SQL Server Books Online will provide all the details necessary for Database Mail setup, here are four 
basic steps: 

1. Enable SQL Database Mail 

Launch SQL Server Management Studio and connect to your server. Expand the Management folder, 
highlight Database Mail and follow these steps:  

 Right click Database Mail and select Configure Database Mail. Click Next.  

 Select Set up Database Mail by performing the following tasks: Click Next. 

 Profile Name: Type in a user defined profile name 

 Description:  Type in a user defined description 

 SMTP accounts: Click Add. Click New Account. 

 Account Name: Type in a user defined account name 

 Description : Type in a user defined description 

 E-mail address: Type in a valid e-mail address to your SMTP Server 

 Display name: Type in a user defined display name 

 Reply e-mail: Type in a valid e-mail address to your SMTP Server  

 Server name: Type in a valid running SMTP Server (refer to Microsoft help) 

 Port number: 25 (refer to Microsoft help) 

 This server requires a secure connection (SSL): Check this option as necessary, depending on your 
SMTP server requirements (refer to Microsoft help) 

 SMTP Authentication: Choose your SMTP Authentication Method (refer to Microsoft help). Click 
OK. 

 Press Next on the New Profile screen once you have finished adding SMTP accounts. 

 On the Manage Profile Security screen, check the Public or Private Profiles as appropriate. Click 
Next. 

 On the Configure System Parameters screen, set the system parameters as needed. Click Next. 

 Click Finish on the last screen if the actions are correct.  

 

2. Test Database Mail  

It is very important to test Database Mail once setup it is complete.  

Inside the Microsoft SQL Server Management Studio, under your server’s Management folder, highlight 
Database Mail, right-click and select Send Test E-Mail. Verify the test e-mail was sent correctly. This must be 
fully functional and sending e-mails in order for Sage Budgeting and Planning to function with this mail 
solution.  

3. Configure User to be in msdb DatabaseMailUserRole  

The SDA User needs to be added to the msdb DatabaseMailUserRole. To do this manually, in the SQL 
Server Management Studio, under your server name, expand Security and highlight Logins. Find your SDA 
login name, right-click and select Properties. Select the page User Mapping. In the Users mapped to this 
login: section, locate the msdb database and check it on. Then, in the Database role membership for: msdb, 
check on the option for DatabaseMailUserRole. Click OK. 

4. Configure Private Profile for your Sage Budgeting and Planning SDA User  

In the SQL Server Management Studio, under your server name, expand Management and highlight 
Database Mail. Right-click and select Configure Database Mail. On the Select Configuration Task screen, 
choose Manage profile security and click Next. On the Manage Profile Security screen, select the Private 
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Profiles tab. Choose your Sage Budgeting and Planning SDA as the User name, check on Access and set the 
Default Profile as Yes. 

Review SQL Server Books Online for complete details in configuring Database Mail. 
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Chapter 6 - User Maintenance 

Chapter 6 

User Maintenance 

System Administrator 

A user designated as a system administrator has permission to create and maintain users in the Sage 
Budgeting and Planning application. In addition, this user has complete access to all functions within the 
application. Any user may be designated as a system administrator through User Maintenance. 

Admin User 

One default user, Admin, with the default password of password, is created automatically when Sage 
Budgeting and Planning is installed. This user has full system administrative rights and cannot be deleted or 
altered, other than to change the password. 

Initially, you will be required to log into the system under this user account to create new users and set 
system parameters. 

Note: It is recommended that you change the Admin user password upon initial login. The password can be 
changed through User Maintenance. Make sure that you remember this password as you will need it to 

login as the Admin later. 

http://www.acutedata.com


Sage Budgeting and Planning System Management Guide 

74 

User Login 

Initial Login 

1.        When Sage Budgeting and Planning is first launched, the login screen displays. 

 

2.        In the User field, type the user ID Admin. 

Note: The Admin user ID MUST be typed exactly as indicated otherwise you will not be granted access 

to the system. 

3.        Next, in the Password field, type password. 

Note: It is recommended that you change the Admin user password upon initial login through User 
Maintenance. 

4.        In the Configuration field, select the system configuration that was created using the Admin Tool. 

Note: If only one configuration exists, the system will default to that configuration. 

 

5.        On the main login screen, click Ok to log into the application. 

Note: For subsequent logins, all fields on the login screen will default to the settings used in the 
previous session. 

User Login 

1.        When Sage Budgeting and Planning is launched, the login screen displays. 
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2.        In the User field, type the user ID. 

3.        Next, in the Password field, type the corresponding user password. 

4.        In the Configuration field, select the system configuration that was created using the Admin Tool. 

Note: If only one configuration exists, the system will default to that configuration. 

5.        On the main login screen, click Ok to log into the application. 

Note: For subsequent logins, all fields on the login screen will default to the settings used in the 

previous session. 
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User Maintenance 

You must be logged into Sage Budgeting and Planning as an administrator to access User Maintenance. If 
you have not created users or have not set one of them to be an administrator, then you will need to use the 
default Admin user to create new users. 

Adding a User 

1.        Expand the System Setup node and highlight the User Maintenance node. 

 

2.        Select File > New (Ctrl + N) or click the new user  icon. 

3.        Complete the Maintain User screen. 

 

 

 

Maintain User Options – User Tab 

User ID Type a user ID of up to 30 alphanumeric characters. 

Note: Once you save the User ID, you cannot modify it. 

Description Type a description for the User ID, such as a user name or a role. 
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Email Address Type the user’s e-mail address. This e-mail address is used if the 
e-mail notification feature is defined for status codes. 

Enabled Check this box to allow the user access to Sage Budgeting and 
Planning. 

Administrator Check this box to designate the user as a system administrator. 

Authentication Method Choose the authentication method: 

    Application – the system verifies the user and password 
combination based on the user ID and password created 
within Sage Budgeting and Planning. 

    Domain – the user password is verified using Windows 
Authentication. 

Query Login Choose the login to use for formula database queries: 

    Use Default – this is the Database Query Authority (DQA) 
login ID identified using the Admin Tool. 

    User Specific – a different user account other than the DQA 
may be used for database queries. If this option is selected, 
type the user ID and associated password. 

Note: This user must be a SQL Server user. 

4.        Click the Sage Budgeting and Planning tab. 

 

 

 

Maintain User Options – Sage Budgeting and Planning Tab 
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Sage Budgeting and 
Planning User 

This option allows the user to access Sage Budgeting and 
Planning. If this option is unchecked, the user will be added to the 
Sage Budgeting and Planning system; however, the user will be 
denied access until this option is enabled. 

WebView User Optional: Select this option to designate this user as a WebView 
user.  

Analyzer User Optional: Select this option to designate this user as an Analyzer 
user.  

Create Plans and Sheets Check this box to allow the user to create plans and subsheets in 
Sage Budgeting and Planning. If this option is checked, it is not 
necessary to check the Create Sheets Only option. 

Create Sheets Only Check this box to allow the user to create only plan sheets in 
Sage Budgeting and Planning. 

Edit Cubes Check this box to allow the user full access to Cube 

Maintenance. If this option is left unchecked, the user will not 
see the Cubes node in the tree-view on the desktop interface. 
Also, if this option is checked, it is not necessary to check the 
View Cubes option. 

Edit Dimensions Check this box to allow the user full access to Dimension 

Maintenance. If this box is not checked, the user can open 
Dimension Maintenance, but with read-only access. 

Edit ERP Configurations Check this box to allow the user full access to ERP 

Configurations. See the User Guide for more information on 
creating and editing ERP Configurations. 

Edit Formulas Check this box to allow the user full access to Global Formula 

Maintenance. If this option is left unchecked, the user will not 
see the Global Formulas or Local Formulas nodes in the tree-
view on the desktop interface. 

Edit OLAP Dimensions Check this box to allow the user full access to OLAP Dimensions 

Maintenance. See the User Guide for more information on 
creating and editing OLAP Dimensions. If this option is left 
unchecked, the user will not see the OLAP Dimensions node in 
the tree-view of the desktop interface. 

Edit Status Codes Check this box to allow the user full access to Status Code 

Maintenance. If this option is left unchecked, the user can open 
Status Code Maintenance, but with read-only access. 

Secure Sheet Lookups Selecting this option allows users to only view plan sheets for 
which they have access. 

View Cubes Check this box to allow users to view published cubes, but not 
allow them to update the cube definition. If this option is left 
unchecked, the user will not see the Cubes node in the tree-view 
on the desktop interface. 

5.        Click Ok to accept the changes, or Cancel to exit the window without saving any changes. If the 
Application Authentication option has been selected, the Change Password screen displays so that a 
password can be applied to the user ID. 

Modifying a User 

Once a user has been created, any of the options may be modified. 
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1.        Expand the System Setup node and highlight the User Maintenance node. 

 

 

2.        Highlight the user to be modified. 

3.        Select File > Open (Ctrl + O) or click the open  icon. 

 

4.        Modify the necessary options, as described in the Adding a User section. 

5.        To change the user's password, click the Change Password button. 
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6.        Type the user’s New Password and retype it in the Retype New Password field for verification. 

7.        Click Ok to save the password changes. A confirmation message displays when the password has been 
changed. 

8.        On the Maintain User screen, click Ok to save the user changes. 

Deleting a User 

1.        Expand the System Setup node and highlight the User Maintenance node. 

 

2.        Highlight the user to be deleted. 

3.        Select File > Delete or click the delete  icon. 

4.        Click Yes to delete the user, or click No to exit the window without deleting the user. 
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Windows Authentication 

Windows Authentication Overview 

Users may log into the Sage Budgeting and Planning application using their Windows Domain account. To 
utilize this functionality: 

         You must have installed the SQL Server components needed by Sage Budgeting and 
Planning. Refer to the Analytics SQL Server Install section in Chapter 2. 

         The SQL Server and the Sage Budgeting and Planning users must be in the same domain. 

         Add Sage Budgeting and Planning users and enter their Windows Domain account  as 
the Sage Budgeting and Planning User ID. Do not enter the name of the Domain (eg: 
“Domain1\User1”). Select Domain for the Authentication Method and assign the 
appropriate Sage Budgeting and Planning User Permissions. 

Note: If an existing Sage Budgeting and Planning User ID (eg: “TomSmith”) does not match their 
Windows Domain account (eg: SmithT”) then you will have to delete this User ID in Sage Budgeting and 
Planning and recreate it using their Windows Domain account. 

Add Sage Budgeting and Planning Users 

1.        Log into Sage Budgeting and Planning as an administrator. 

2.        Expand the System Setup node and highlight the User Maintenance node. 

3.        Select File > New (Ctrl + N) or click the new user  icon. 

4.        Complete the Maintain User screen. Select Domain as the Authentication Method. 
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5.        Click the Sage Budgeting and Planning tab and assign the appropriate Permissions. 
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6.        Click Ok to accept the changes, or Cancel to exit the window without saving any changes. 
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Chapter 7 - Installing Demonstration Data 

Chapter 7 

Installing Demonstration Data 

Create the Demonstration Company Databases 

Prior to installing the general ledger demonstration data, you must create the following databases in SQL 
Server. The names of these databases can be anything you want but for consistency in the documentation 
they will be referred to with the following names: 

System Database: Analytics_DemoSystem  

Publication Database: Analytics_DemoPublication  

Demonstration Company Database: Analytics_DemoComp  

Installing the Sample Plan Sheets 

Sage Budgeting and Planning ships with a complete set of demonstration data for one sample company. 
This company contains sample plan sheet data as well as accounts, transactions, balances, and other 
supporting data. 

Prior to following the steps in this section, you need to complete the Sage Budgeting and Planning 
installation, then complete the steps in the Sage Budgeting and Planning Network File Server Installation 
section.  If you have not already done so, also complete the steps in the Sage Budgeting and Planning Client 
Workstation Installation section.   

During the configuration setup process, databases may be created, SQL users may be defined and objects, 
stored procedures and tables will be added to databases. For this reason, you must log into the designated 
SQL Server as sa or another administrative user. 

1.        Launch the Admin Tool by selecting it from the Start > Programs menu or by double-clicking ADMIN 

TOOL.EXE from the main application root folder. 

2.        The Admin Tool Login screen displays. 
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3.        Next, type the Admin Tool password. 

Note: The first time you launch the Admin Tool, you will be prompted to create a new password.  Since 
a SQL administrative account is required to perform the steps in the Admin Tool, it is often the DBA or 
some one else in the IT staff who uses the Admin Tool.  This password prevents other Sage Budgeting 
and Planning users from accidentally running the Admin Tool. 

4.        Click Ok to enter the Admin Tool application. 

5.        Select Action > New Configuration from the menu to launch the Configuration Setup Wizard.  

6.        The Welcome screen displays.  Select the option to Create a new configuration with Demonstration 

Data and click Next to continue. 

 

7.        Type or select from the drop-down the SQL Server where the application data will be stored. You 
cannot choose ‘(local)’ from the drop-down.  To use the local machine, type the actual name of the 
machine. During the initial setup, information is written to application specific databases on the SQL 
Server. To execute these actions, the wizard must connect to the data server as a SQL administrative 
account.  
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Click Next to bring up the SQL Server Admin Connection window.   

 

Enter the username and password for a SQL administrative account and click Ok. The wizard will 
attempt to connect to the specified server. 

 

Note: The SQL Server authentication mode must be set to mixed mode. 

8.        The next step is to define a configuration definition. Creating this configuration centralizes the settings 
necessary to run the application. Each configuration identifies the SQL server that contains the Sage 
Budgeting and Planning system database, the Sage Budgeting and Planning publication database, a 
system database administrator user, and a database query authority user. This definition name is the 
only information that the user will select when logging into the application.  

Type a name for the configuration definition of up to 16 alphanumeric characters (eg. DemoConfig). Be 
sure to use standard characters only (letters, numbers, underscore) and avoid spaces or other special 
characters (/, !, &, etc. ). 

From the drop-down, select the Analytics_DemoSystem database to use as the Sage Budgeting and 
Planning system database, then select the Analytics_DemoPublication database to use as the Sage 
Budgeting and Planning publication database. Also select the Analytics_DemoComp database to use as 
the Sage Budgeting and Planning company database.  Click Next. 
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9.        The next step is to define a system database administrator and a database query authority. 

The System Database Administrator (SDA) is the only true SQL server user that will have access to the 
application databases. When the SDA is defined, it creates an Analytics role and assigns the SDA to this 
role. Thus it has full administrative access to all of the Sage Budgeting and Planning databases. It is not 
a good idea to use the sa account for the SDA, so typically you would create a new user for the SDA. 

Consequently, since there is only one SQL user that accesses all of the application databases, the ability 
to query, update, and change data is potentially available to all users defined in the application. 
Therefore, to reinforce security, an additional user with specific database query access known as the 
Database Query Authority (DQA) needs to be defined. 

The DQA login ID created and identified here will be assigned to the Public database role for the 
control database, the company databases, the publication database and the Sage Budgeting and 
Planning System database. The DQA will be used as the default user for all database queries within the 
application.  

Note: If any additional permissions are needed, then the database or system administrator must assign 
the additional permissions for the DQA user. 

 

In the designated fields, select <New> to create new users or select an existing user to be assigned as 
the System Database Administrator and the Database Query Authority. For each login ID, type the 
associated passwords. 

 

If you choose to create a new user from the wizard, an additional window displays, allowing you to 
define the new user ID and password. 
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10.     In addition to adding application-specific objects to the system and publication databases, Sage 
Budgeting and Planning specific tables, views, and scripts are inserted into specified company 
databases. The Company Setup screen will be populated with DEMO in the Company Code field and 
Demonstration Company in the Description field.  

Note: You MUST use DEMO with all capital letters in the Company Code field. 

 

 

11.     Click Next and the Wizard will take you to the Setup Verification. This allows you to review the 
information listed and make modifications before the any changes are made to your databases. Click 
Previous to correct any information. Click Run to save the configuration options defined and to invoke 
actions listed for the system, publication and company databases and to install the sample plan sheets .    

 

12.     The SQL Query Output screen will display a record of the progress of all the actions taken on the 
database(s). Any errors encountered will be displayed in red. Depending on the specific actions taken, 
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you may have an option to save or print the contents of the Output screen but it is always automatically 
saved in a log file. This log file is created in the folder that you specified during the Sage Budgeting and 
Planning Network File Server Installation. The file is named “Processing Log xxx.rtf” where xxx is the 
date and time that the log was created, e.g.: “Processing Log 2012-10-03 10.53.38.rtf”. You should review 
it for any errors that might have occurred during the processing. 

 

13.     Click Finish to save the configuration options defined. 

 

Note: Plan sheets must be republished before cubes can be created. 

 

Create Demonstration OLAP Cube 

You must be logged into Sage Budgeting and Planning as an administrator to access Cube Maintenance. If 
you have not created users or have not set one of them to be an administrator, then you will need to use the 
default Admin user to create the OLAP cube. An Analysis Server must be installed, the latest Analysis 
Server Service Pack must be applied, and an OLAP database must be created prior to creating OLAP cubes. 
Follow these steps to create the demonstration OLAP cube. 

Note: The OLAP database you will create has a security setting impersonation property which must be 
set to "Use the service account". 

 

Republish Plan Sheets 

1.        Expand the Plans folder in the Tasks pane and highlight the Department_Expense Plan. 

 

2.        Select Plan > Properties to display the Plan Properties screen. 
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3.        Click the Advanced tab and place a checkmark next to the Republish Plan option. Click the Ok button 
to begin the republish process. 

 

4.        A warning message will appear. Click Yes to continue. 
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5.        The process will make sure that all plan sheets have been checked in. Click Close to continue. 

 

6.        If any plan sheets were checked out, then you will see this screen. Choose the Undo All Check Outs 
option and click Ok. 

 

7.        The process will check in all plan sheets. Click Close to continue. 

 

8.        The process will republish all plan sheets. Click Close to continue. 
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Demonstration OLAP Cube 

1.        Click the Cubes folder in the Tasks pane. Highlight the Sales_Analysis cube. 

 

2.        Select File > Open to display the Cube Maintenance screen. 
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3.        Complete Server: and Database: under the OLAP Settings portion of the screen. Enter your Analysis 
server and the name of your OLAP database. Select File > Save to save the cube definition. 

 

 

4.        Select Cube > Process to process the cube. An output log displays detailing the processing routine. 
When the cube has finished processing, click the Close button.  
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Chapter 8 - WebView Installation 

Chapter 8 

WebView Installation 

Overview 

Sage Budgeting and Planning provides users remote access to the planning environment through controlled 
access to plan sheets using WebView. Since WebView provides the means for users to access existing plan 
sheets, view and edit data, and save the changes, there is no need to have Sage Budgeting and Planning 
installed on the Client Workstation. You will need to install WebView on an existing IIS server. The 
installation will create a new Virtual Directory in the default Web Site on the IIS server.  Client Workstations 
will access this Web Site using Microsoft Internet Explorer. All client components are automatically 
downloaded from the Web Site the first time WebView is accessed from a workstation. 

Note: The installation of WebView will require a reboot of the IIS server, so schedule the installation at a 
time when this can occur. 

WebView Pre-Installation 

Prior to installing the WebView application, several steps must be completed.  

       Sage Budgeting and Planning must be installed and configured prior to installing and using WebView. 

       Internet Information Services (IIS) server must be installed and configured. 

       Microsoft® Excel® 2003 or later must be installed and configured if you plan to consolidate Excel 
spreadsheets. 

       A network user will need to be created that will allow WebView service to access other resources on 
the network. 

1)       Create a network user with a password that never expires. For security reasons, you should restrict 
this user to only allow logins from your IIS machine. 

2)       Grant the Full Control permission for this user to the main Sage Budgeting and Planning folder 
which was created during the network file server installation. This is necessary because this user 
will need to access the registration information, the configuration.mdb and the TMPSHARE folder 
located in the main Sage Budgeting and Planning folder. 

3)       Assign this user to the IIS_WPG user group. 

Note: These steps are critical to the successful installation of WebView. Customer issues mainly 

occur because these setup steps are not correctly followed. 

Once these procedures are complete, WebView may be installed on the IIS server. 
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WebView IIS Installation 

Once the pre-installation requirements have been met, the installation of WebView may continue. The 
WebView installation will install Microsoft .NET Framework 2.0 if it is not already installed on the IIS 
server. 

Note: The WebView application must be installed on the same server that contains IIS and the ASP.Net role 
must be installed on the IIS machine. You will need to log into the machine as an Administrative user to do 
this installation.   

1.        Place the WebView CD-ROM into the drive on your IIS server and browse to the WebView folder. 

2.        Double-click on SETUP.EXE, and the Welcome screen displays. 

 

3.        Click Next, to proceed to the Software License Agreement screen. Please read the agreement carefully. 
If you agree with the terms and conditions, click Yes to proceed with the installation. If you click No, 
the Setup program closes. 

 

4.        Select the location to install WebView. Accept the default directory, or click Browse to choose a 
different directory. Click Next to continue. 
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5.        Select the network directory where Sage Budgeting and Planning is installed. Click Browse to choose 
the directory. This directory contains the configuration database which WebView will use to determine 
the SQL Server name and SDA account, so these will not be specified as part of the installation. Click 
Next to continue. 

 

6.        The Service Log On screen displays. Specify the User account which the WebView service will run 
as. This is the Network Account that you created during the Pre-Installation steps. Also specify the 
Domain and Password for this account. Click Next to continue. 
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7.        The installation program now has enough information to perform the installation. Click Next to copy 
the files to your hard disk. 

 

8.        A screen will display once the installation program is complete. Choose the option, Yes, I want to 

restart my computer now, and then click Finish to complete the WebView installation. 
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Note: WebView will not work properly until you reboot the IIS server. 

Installing WebView on a 64-bit Machine 

Windows 2003 64-bit Machine  
To allow WebView to properly run on a Windows 2003 64-bit machine, complete the following steps: 

1.     Click Start and choose Run 

2.     Type cmd and then click OK 

3.     At the prompt, type this command: " cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs 
SET W3SVC/AppPools/Enable32bitAppOnWin64 1" 

4.     Make sure web extensions allow ASP.NET 2.0.50727 

5.     Restart WebView and your IIS service 

Windows 2008 64-bit Machine (this setting is set during the install but can be verified if 
needed) 
To allow WebView to properly run on a Windows 2008 64-bit machine, complete the following steps: 

1.     In the Server Manager, expand Web Server, launch the ISS Manager and click on Application Pools 

2.     From the list, select the WebView application pool; right click and choose Advanced Settings 

3.     Under the General section, set Enable 32-bit Applications to True 

4.     Restart WebView and your IIS service 
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WebView IIS Upgrade 

Upgrading WebView is a fairly simple process. You only need to install the new version of WebView on the 
IIS server where the previous version was running. Client Workstations will be automatically updated when 
they access the WebView Web Site.  

Note: The WebView application must be installed on the same server that contains IIS. You will need to log 
into the machine as an Administrative user to do this installation. 

Note: The screens may differ depending on upgrade path, and may appear as a normal install. 

1.        Place the WebView CD-ROM into the drive on your IIS server and browse to the WebView folder. 

2.        Double-click on SETUP.EXE, and the upgrade screen displays. Click Yes, to proceed to the installation 
wizard. 

 

3.        Click Next,  and the installation wizard will perform the upgrade. 

 

4.        A screen will display once the installation program is complete. Choose the option, Yes, I want to 

restart my computer now, and then click Finish to complete the WebView installation. 
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Note: WebView will not work properly until you reboot the IIS server. 
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WebView Registration 

WebView Registration 

You will need to register WebView before adding WebView users.  This is accomplished using the Sage 

Budgeting and Planning Admin Tool.  Follow the steps in the Registration section in Chapter 5 to register 
WebView. 

  

WebView User Maintenance 

You will need to create WebView users before doing the Client Installation.  This is accomplished using 
Sage Budgeting and Planning.  Follow the steps in the User Maintenance section in Chapter 6 to add and 
maintain WebView users. 
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WebView Configuration Tool 

Once WebView has been installed, the configuration information may be reviewed or edited. 

1.        From the Start Menu on the IIS server, open the WebView ConfigTool to review WebView 
configuration parameters.  Generally you should only modify the File Share and User Timeout 
options. The options listed on the Service and Task Control tabs, as well as the Diagnostic Switches, 
should only be modified under the advisement of a customer support representative. 

WebView Configuration Tool Options 

Virtual Directory The Virtual Directory name that has been created on IIS for WebView. 
This cannot be modified. 

File Share Type or browse to the path that contains the main Sage Budgeting and 
Planning folder. This is the same path that you specified in the Sage 
Budgeting and Planning Network File Server Installation in Chapter 2. 

Note: This folder must be accessible to the IIS Server. This must be a 
UNC path. 

User Timeout The time in minutes before an inactive WebView user is automatically 
logged out. 

2.        Once the changes are completed, click Ok.  

3.        Restart the SageActivePlannerWebView752 service which you’ll find using Control Panel > Services. 

4.        Restart Internet Information Service. Under Control Panel > Administrative Tools > Computer 

Management > Services and Applications, right click on Internet Information Services and select All 

Tasks > Restart IIS. 
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WebView Client Installation 

WebView is accessed using Microsoft Internet Explorer. All client components are automatically 
downloaded from the Web Site the first time WebView is accessed by the user.  

Note: For the download of client components to work correctly, you must be logged into the workstation 
as a user with permission to install ActiveX controls. Any user that is a member of the local 
Administrator group, or Power User group would have sufficient permissions. If another user logs in to 
the same workstation, then the client components will not need to be downloaded for this user. 
However, they will need to set the Internet Options in step 2 before they connect to the WebView Web 
Site. 

Versions 7.52 and later of WebView have had some changes for the Internet security settings. 

1.        Make sure Microsoft Internet Explorer version 7 or later is installed on the workstation. 

2.       When Launching Internet Explorer to run WebView for the first time: Right Click the Internet Explorer 
Icon and choose "Run as Administrator". (This is just needed to be run one time to allow all controls 
needed to be installed correctly.) 

3.       When Running WebView 7.52 and later in most environments the site will be part of the Local Intranet 

Security Zone by default. (Use The Default settings for the Local Intranet Zone.) 

Note: If you would like to run WebView using the Trusted Sites see Using WebView With Internet 

Trusted Sites Zone at the end of this section.. 

4.        Obtain the URL from the IIS system administrator that you will use to access WebView. 

5.        Launch Microsoft Internet Explorer and type the WebView URL. 

 

6.        The first time WebView is accessed from a workstation, all client components are automatically 
downloaded from the Web Site.  If the client PC is setup as described above, then the components will 
automatically install without further prompting. While the components are being installed, you will see 
a message saying Please wait. Once the components have downloaded, the Please Wait message will 
disappear and you can proceed to log in. 
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7.        The login window displays. Type a valid WebView user name and password. Click Ok to continue or 
Cancel to exit out of the WebView application.  

 

Note: Users must be established as valid users in Sage Budgeting and Planning in order to access 
WebView. The default Sage Budgeting and Planning user, Admin, cannot be used to log into WebView. 

Note: Sage Budgeting and Planning must be registered before any users can log into WebView 

 

 

Using WebView With Internet Trusted Sites Zone 

1.        Make sure Microsoft Internet Explorer version 7 or later is installed on the workstation. 

2.        Start Internet Explorer and configure the options as needed by WebView.  From the menu choose 
Tools > Internet Options, then go to Security Tab and click on Trusted Sites. 

a.        Click the Sites button and add your IIS Server as a trusted site. 

b.        Click on Custom Level and ensure you have the following minimum Security Options: 

IE Security Options 

Run Clients Not Signed with Authenticode Enabled 

Run Clients Signed with Authenticode Enabled 

Download Signed ActiveX Controls Enabled 

Run ActiveX Controls and Plug-Ins Enabled 

Allow script-initiated windows without size or position constraints Enabled 

Java Permissions Low Safety 

 

Note: Depending on the version of IE, the permissions above may vary.  If a permission is listed, ensure 
it is set as shown above. 
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Chapter 9 - Integration Maintenance 

Chapter 9 

Integration Maintenance 

Overview 

In order to use Sage Budgeting and Planning with Open Integration, configuration information and data 
must be established in the company database. 

Configuration information includes: 

          Chart of accounts format 

          Availability of separate accounts for budget or statistical information 

          Standard number of decimal places 

          Length of budget and statistical balance codes 

          Availability of transaction data 

Available data includes: 

          Fiscal periods 

          Accounts 

          Balance codes 

          Balance amounts 

          Transaction amounts 

For a new company, only a minimal amount of data must be created. The first time you launch Sage 
Budgeting and Planning after creating the new company, you will automatically be prompted for the 
required data. This includes defining fiscal periods, selecting Average Daily Balance calculation options and 
the Configuration Options.  See the Fiscal Period Maintenance section and Configuration Options section 
below for help setting up this configuration information. 

Once this is complete, you will need to set the current fiscal period and establish account numbers. 
Optionally, balance and transaction information can be established as well. The chart of accounts, balances 
and transactions can be imported from a production system or the data can be defined and maintained 
manually. 

For balances and transactions, there are two data sets. One set of data is used in Sage Budgeting and 
Planning to calculate values. This includes balance amounts and transaction amounts. Transactions are used 
in the calculation of the average daily balance of accounts. The second set of data is generated through the 
updating of plan sheet balances. This data, stored in the resulting balances table, can be exported to a 
production system. This chapter explains how to configure information for a company and how to set up 
and maintain data. 

Each new company created using Company Maintenance from the Setup menu requires that configuration 
options must be defined. For more information on creating a company, see Chapter 3. For each company, the 
configuration options defined are used to create the data structure and to process plan sheets. 
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Fiscal Period Maintenance 

At least one fiscal period must be set up for each company defined. Fiscal periods must be established for 
any historical periods for which data will be maintained as well as for future periods to be used in plan 
sheets. The first time you set up a company, the Fiscal Period Maintenance window displays. 

The first step is to define the beginning and ending dates of the fiscal year. The second step is to define the 
fiscal periods within that year. Periods can be created automatically or manually. When creating periods 
automatically, there are a number of options from which to select and the periods generated can be edited 
until saved. 

 

Initial Setup Using Quick Start Assistant 

The Quick Start Assistant is a tool that to help in the initial setup of a company where the data is in a 
Sage 100 or Sage 300 Business Management Solutions. This Tool will import the data that is needed for 
Budgeting and planning as well as define the import queries that could be used later if needed. The result 
of using the tool would be to have the initial data for a company set up with minimal effort for the Sage 
100 and 300 environments. 

1.     If you have selected a company that has not been accessed previously, you will be prompted with the 
option to use the Quick Start Assistant to assist with the setup of the company when using some of the 
Sage General Ledger Systems. This tool is currently available for Sage 100 and Sage 300. Choose the 
Appropriate General Ledger for your setup or choose "Other" to manually complete your company 
setup. 

 

2.     If you select one of the available general ledgers you will be provided with an interface to connect to the 
system. 

This image is a sample of what the connection area for Sage 300 or Sage 100 Premium would look like. 

 

This image is a sample of what the connection area for Sage 100 Standard/Advanced. 
**Note:  The use of the Quick Start Assistant with Sage 100 Standard and Advanced requires the General Ledger 

client to be installed on the same machine so that the DSN is available. 
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3.     After connecting you will be shown the information that is available about the Company's setup in the 
system.  

This information will include: 
Account Structure, and Segment Definitions 

 
Fiscal Periods 

 
Balance Codes 

 
Accounts 
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Balances 

 

4.     You can also set some of the options for the Company to be used in Budgeting and Planning, these 
values can be changes later if desired in the Utilities->Configuration Menu option. 

Company code and Name are read only and displayed for reference. 
Decimal Places is the number of decimal places you will use in the system default is 2. 
Budget Balance code and Statistical Balance code Length represents the maximum length of codes 
you will use for this data 16 is the largest value you can use here and is the default, this does not 
mean you codes must be 16 long just that they cannot be longer. 
The items in the Transaction information area are flags representing weather the data for the 
different types of transactions are available. 
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5.     When you are satisfied with the information displayed, click the apply button the progress of the 
imports will be displayed. 

 

 

 

Adding a Fiscal Period 

1.        If no fiscal periods are established in the company, the Fiscal Period Maintenance window will 
display when a company is selected from the Change Company window. If additional periods are to be 
added after the initial configuration, highlight the Open Integration folder, then from the menu bar 
select Utilities > Fiscal Period Setup. 

 

2.        Click New. This window displays: 
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Fiscal Year Maintenance Options 

Beginning Date Type the beginning date for the fiscal year to be established, 

or click the lookup button , to select the date from a 
calendar. 

Ending Date Type the ending date for the fiscal year to be established, or 

click the lookup button , to select the date from a 
calendar. 

Create Periods 
Automatically 

Check this box to generate fiscal periods with standardized 
beginning and ending dates based on the fiscal year. 
Options include: 

          Daily 

          Weekly 

          Monthly 

          Quarterly 

          Semi-Annually 

          Yearly 

          13 4 Week Periods 

Tip: This method is much faster than creating fiscal periods 
manually. Even if you need customized fiscal periods, you 
may want to use this option and then modify the results. 

3.        When you click the Lookup button  for either the beginning or the ending date, this window 
displays: 
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Highlight the desired date and then click Ok to return to the Fiscal Year Maintenance window. 

4.        Click Ok in the Fiscal Year Maintenance window to continue. 

5.        If you checked Create Periods Automatically, this window displays: 

 

This window allows you to select the basis for the generated fiscal periods. Sage Budgeting and Planning 
will automatically create the beginning and ending dates for each period. Select the desired increment 
and then click Ok. 

6.        The Period Maintenance window displays: 
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This illustration shows the results if Create Periods Automatically is selected and the fiscal year is 
divided into 12 monthly periods. 

7.        Modify the periods as desired. If Create Periods Automatically was selected, only the period end dates 
and the description can be edited. 

a.        To delete a period, highlight the row, then click  or select Edit > Delete Rows. 

b.       To add a new period, click  or select Edit > Append Rows. 

c.        To change an End Date or Period Description, type the new information in the 
appropriate cell. The Start Date for the next period will adjust appropriately based on the 
new End Date. There can be no days in the fiscal calendar that are skipped or duplicated. 

8.        Click Ok when finished to return to the Fiscal Periods Maintenance window. A warning will display. 

 

9.        Click Yes to add the new fiscal year and periods to the company. Click No to return to the Fiscal 

Periods Maintenance window. To exit the Fiscal Periods Maintenance window without saving 
changes, click No. 

Modifying Fiscal Periods 

Once a set of fiscal periods is created, you cannot change the beginning and ending dates of the year or 
individual periods and individual periods cannot be added or deleted. However, period descriptions can be 
changed. 

1.        Click on the Open Integration folder. From the menu bar select Utilities > Fiscal Period Setup. 
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2.        Highlight the fiscal year to modify then click Maintain. The Period Maintenance window displays. 

 

3.        Modify the Period Description as desired. 

4.        Click Ok when finished to save changes and return to the Fiscal Periods Maintenance window. To exit 
the Fiscal Periods Maintenance window without saving changes, click Cancel. 

  

Deleting Fiscal Years 

You can only delete an entire fiscal year if there are no associated balance or transaction records and if no 
period in the fiscal year is designated as the current processing period. Before proceeding, make sure that no 
records are attached to the fiscal periods to be deleted. 

1.        Click on the Open Integration folder. From the menu bar select Utilities > Fiscal Period Setup. 
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2.        Highlight the fiscal period to delete then click Delete. 

3.        This confirmation box displays: 

 

4.        Click Yes to delete the selected fiscal periods, or No to exit the window without deleting the periods. 

5.        If data exists for the periods, the following message displays: 

 

Reviewing Fiscal Periods 

1.        From the menu bar select Utilities > Fiscal Period Setup. 
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2.        Highlight the fiscal period to view then click Maintain. 

3.        The Fiscal Period information is displayed.  Click OK to close the screen. 

Selecting Current Processing Period 

When a company is initialized in Sage Budgeting and Planning, and fiscal periods are defined, the first fiscal 
period will be designated as the current processing period. A few features and cell functions in Sage 
Budgeting and Planning utilize the Current Processing Period. In order to use the option, the current 
processing period must be identified initially and then maintained each month. 

1.        From the menu bar select Utilities > Select Processing Period. 
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2.        Click on the fiscal period that is the current period and click Ok. To close the window without 
saving changes, click Cancel. 

Note: As the current process period changes, this procedure should be repeated to select a new period as 
the current processing period. 

 

Configuration Options 

Account Numbers 

The mask for the account number structure must be defined before accounts can be created or activity can 
be processed. 

 

 

 

 

Account Numbers Tab Fields 
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Account Number Mask The mask (up to 64 characters total) to be used for account 
numbers in the chart of accounts. An exclamation point (!) is 
used for the first digit or character of each segment and a 
pound sign (#) for other digits. Separator symbols, such as -, 
may be used to separate account segments. For example, an 
account mask of !###-!##-!##-!#, allows for accounts like 
8000-100-100-00 and A100-100-100-BB.  

Note: The account mask you create can be changed until 
account numbers have been entered or imported. After that, 
the mask can only be changed by deleting all of the account 
numbers. 

Decimal Places for 
Amounts 

The number of decimal places (up to 4) to be used in storing 
balances and transactions.  

Separate Budget 
Accounts 

This box is checked if a separate set of accounts will be used 
to track budget balances. These accounts must match the 
defined account number mask and they will be used for 
lookups and account inserts. If separate budget accounts are 
not defined, actual accounts will be used in lookups and 
account inserts. 

Separate Statistical 
Accounts 

This box is checked if a separate set of accounts will be used 
to track statistical values. These accounts must match the 
defined account number mask. These accounts are available 
in plan sheets but will not be included in lookups and 
account inserts. 

Segment Descriptions If the Account Number includes multiple segments, then 
you can enter a description for each segment. The 
description can be up to 20 characters in length. These 
segment descriptions will then be used for publishing 
purposes.  

Account Dimensions 

The Account Dimensions Tab will display the Code, Description and Mask for each Account Dimension. 

 

Account Dimensions Tab Fields 

Number of Account 
Dimensions 

Indicates the number of account dimensions that will be 
used for the company.  The valid options are zero through 
nine account dimensions. 

ACCTDIM Displays ACCTDIM1 through ACCTDIM9 to indicate the 
key for the Account Dimension. 
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Code An Alias name for ACCTDIM1 through ACCTDIM9.  This 
will allow the users to give each Account Dimension a 
meaningful code instead of the ACCTDIM(x) codes.  These 
can be used anywhere a Dimension code is used.  These 
codes cannot conflict with any other Account Dimension 
code or any of the System Dimension Codes. 

Description 20 Character Description for the Account Dimension. 

Mask The mask for the Account Dimension.  This will determine 
the length of the mask and any formatting characters to use 
when displaying the mask.  Segmenting markers can also be 
entered.  The program will not permit the mask to be altered 
once data exists in the system for the dimension. 

Balance Codes 

Use balance codes to categorize and identify groups of budget or statistical data. Once balance code lengths 
have been set, they cannot be shortened. However, they can be lengthened after initial setup. 

 

Balance Codes Tab Fields 

Budget Balance Code 
Length 

Use the arrow buttons to select a number of digits, up to a 
maximum of 16. If the value is set to zero, budget balances 
will still be available. However, there will be no identifying 
code to distinguish different budget balances.  The number 
of digits can be increased after the initial setup, but can not 
be decreased.  

Statistical Balance Code 
Length 

Use the arrow buttons to select a number of digits, up to a 
maximum of 16. If the value is set to zero, statistical 
balances will still be available. However, there will be no 
identifying code to distinguish different statistical balances . 

Transaction Information 

In order to import or create transaction records, the option to allow transaction records must be selected. 
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Transaction Information Tab Fields 

Actual Transaction 
Information Available  

This box will be checked if activity for actual transactions will be 
maintained in the transaction table. If this box is not checked, 
actual transactions cannot be created or imported. 

Budget Transaction 
Information Available 

This box will be checked if activity for budget transactions will 
be maintained in the transaction table. If this box is not checked, 
budget transactions cannot be created or imported. 

Statistical Transaction 
Information Available 

Check this box if activity for statistical transactions will be 
maintained in the transaction table. If this box is not checked, 
statistical transactions cannot be created or imported. 

 

Note: If no options have been selected in the Transaction Information Tab, you will be unable to open the 

transaction maintenance table. 

 

Table Maintenance 

Tables for accounts, account dimensions and balances are maintained in order to create and process plan 
sheets and create reports. Data can be created manually in all tables or data can be imported into the 
accounts, transactions and balance tables. 

Any type of data can be created or imported. Data tables can be used to define data sets such as projects, 
customers or products. Using this type of data, you can create transactions that allocate costs across 
customers or products, rather than across accounts. 

For example, customer data can be imported into accounts and quantities shipped by customer can be 
imported into the balance amounts table. The customer keys and customer names automatically populate 
the account number and description fields. With this information now imported, you can allocate freight 
costs to each customer based on the quantity shipped. 

Accounts 

Accounts can be created and maintained manually or accounts can be imported from an existing financial 
system. For more information on importing, see Open Integration Utilities later in this chapter. 

If designated in the Account Numbers tab of the Configuration Options, separate accounts can be created 
to record actual, budget or statistical balances and transactions. New accounts can be added individually 
and accounts can be deleted. However, only accounts with no associated balances or transactions can be 
deleted. 

 

1.        Click on the Open Integration folder, then click on the Accounts folder from the Sage Budgeting and 
Planning window. 
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Account Maintenance Fields 

Account Number The account number is typed and displayed here. The 
account number must conform to the format (mask) defined 
in the configuration options.  

Actual, Budget, Statistical Check this box to indicate the account number type of 
Actual, Budget or Statistical. The Budget and Statistical 
columns may not be present based on the setting in the 
 configuration options. 

Description Type a description of the account.  

Credit Check this box to indicate that the account normally has a 
credit balance. 

Account Dimensions 1-9 Designates that the selected Account Dimension can be used 
for the Account Number.  

2.        To edit a specific account number, double click on the account number or select File > Open.  Modify 
the account and click OK to save the changes or Cancel to exit with saving the changes. 
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3.        You may add or delete accounts as desired. 

a.        To delete an account, click on the account, then select File > Delete or click the delete  icon. You 
cannot delete an account that is in use. 

b.       To add a new account, select File > New or click the New  icon. The Account Number 

Maintenance screen appears. Complete the appropriate information then press OK to save this 
record, or press Save Add Another to save the record and add another record. After saving your 
work, the accounts are re-sorted and new accounts are inserted in the appropriate order. 

Change Account Settings 

Batch Changes can be made to Accounts in the Chart of Accounts by using the Change Account Settings 
option.  You will be able to select a From and Thru Account along with the changes you wish to make to 
each of these accounts.  Changes will be indicated by selecting options on the check boxes to indicate the 
changes to be made. 

1.        Click on the Open Integration folder, then click on the Accounts folder from the Sage Budgeting and 
Planning window. Select Utilities > Change Account Settings from the menu bar. Select a From and 
Thru Account range. Utilizing the 3 state check box, specify the desired changes to the accounts.  If the 
option is checked, then a check mark will be applied to that option for every account in the From and 
Thru Account range.  If the option is unchecked, then the check mark will be cleared for that option for 
every account in the From and Thru Account range.  When the check box is grayed out, no change will 
be made to that account option.   
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Change Account Settings Options 

From Account From Account to apply changes to.  Segment Ranging will be 
recognized. 

Thru  Account  Thru Account to apply changes to.  Segment Ranging will be 
recognized. 

Credit Balance  Three-State Checkbox indicating changes to the Credit Balance Flag. 

Actual  Three-State Checkbox indicating changes to the Actual Account Flag. 

Statistical Three-State Checkbox indicating changed to the Statistical Account 
Flag 

Account 
Dimension Flags 

Three-State Checkbox for each configured Account Dimension 
indicating changes to each of the Account Dimension Flags. 

2.        Click OK to apply the changes or Cancel to exit without making any changes. 

 

Balance Codes 

For each type of balance defined in the configuration options, appropriate balance codes must be created. 
Budget and statistical balances and transactions are then assigned to a corresponding balance code. This 
allows for multiple budget and statistical balances. 

With multiple budget and statistical codes available, an unlimited number of budget and statistical balances 
and transactions can be created. For example, there may be separate budget codes for best case and worst 
case budgets, while statistical codes may be defined for square feet and head count. These codes can be 
applied to formulas to retrieve balances or to plan sheets to retrieve information. 

1.        Click on the Open Integration folder, then click on the Accounts folder from the Sage Budgeting and 
Planning window. Select Utilities > Balance Code Setup from the menu bar. 
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2.        Select a balance type from the Balance Type menu. The options available depend on balance codes 
defined in Configuration Options and may include budget and statistical balance types. 

3.        In a row, type in the Balance Code and Description. The allowable length of the balance code is 
determined in Configuration Options. 

4.        An unlimited number of codes can be created. To add additional records, click  or select Edit > 

Append Rows. 

5.        Balance codes with no activity can be deleted. To delete a record, highlight the row and click  or 
select Edit > Delete Rows. 

6.        Select File > Save to save your changes. 

7.        Select File > Close to exit the Balance Codes maintenance window. 

Transactions 

Based on the configuration options selected, transactions for actual, budget and statistical values can be 
created. Transactions are used to calculate the average daily balance of an account and can also be used to 
generate balances. Each transaction can be input manually or imported. See Open Integration Utilities, later in 
this chapter, for more information on importing. 

Transactions are assigned to batches, with an unlimited number of transactions per batch. Each batch is 
grouped using the Batch Key and Balance Type. If budget or statistical balance types are used, balance code 
information is also assigned. The transactions within a batch can cross fiscal periods and the date of the 
individual transaction determines which fiscal period the transaction belongs to. Batches provide a way to 
limit the amount of information viewed at any one time. 

1.        Click on the Open Integration folder, then click on the Transactions folder from the Sage Budgeting 
and Planning window. The Transaction Information window displays. To retrieve existing balance 

groups click or select File > Open. Header information designates a batch key, a description and the 
balance type and balance code. 
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Header Information Tab 

Batch Key The batch key used to identify this transaction batch in the system. 

Description A descriptive name to identify this transaction batch. 

Balance Type The balance type as defined in the configuration options.  

2.        Select the Detail Information tab to enter transaction detail. 

 

Header Information Tab 

Date The date of the transaction. This date is compared to the fiscal 
calendar to determine which fiscal period the transaction belongs to. 

Account Number The account assigned to the transaction. 

Account 
Description 

The account description from the chart of accounts. This description 
cannot be changed. 

Description A 40 character user-defined description of the transaction. 

Amount The amount assigned to the transaction. The number of decimal 
places available is based on the setting in Configuration Options. 

 

Deleting Transactions 

1.        To delete a transaction batch, highlight the batch, right click and select Delete. A warning will display. 
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2.        Click Yes to delete the batch or No to cancel the delete process. 

Balances 

Balances of accounts can be defined for each account and each fiscal period. The balances are maintained by 
fiscal period and balance type, including balance code(s) for budget or statistical balances. Balances can be 
created and maintained manually or imported. See Open Integration Utilities later in this chapter for more 
information on importing. 

Balances are related to each fiscal period based on the ending date of the period. A header is attached to 
each combination of balance code and fiscal year. Balances are not required as database queries can always 
be used to retrieve and calculate values. However, by importing or creating balance amounts, calculations 
will process more efficiently. 

1.        Click on the Open Integration folder, then click on the Balances folder from the Sage Budgeting and 
Planning window. The Balance Information window displays. To retrieve existing balance groups click 

or select File > Open. Header information designates the balance type, the fiscal year and, if 
appropriate, the balance code. 

 

Header Information Tab 

Balance Type Select from a list of available balance types, actual, budget or 
statistical.  

Fiscal Year Select the fiscal year to view. Fiscal years available are based upon 
the fiscal periods created. 

Balance Code For Budget and Statistical type only. Select the balance code to view.  

2.        Click the Detail Information tab to enter account balance information. This tab shows every account in 
the chart of accounts and rows cannot be added or deleted. If a new account is required, it must be 
created in the Accounts table before entering an associated balance. Amounts can be modified as 
needed. 
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Balance amounts can also be created based on individual transactions in the transaction amounts table. 
See Open Integration Utilities later in this chapter for more information. 

 

Detail Information Tab 

Account Number The account number based upon the chart of accounts.  

Description A description of the account from the chart of accounts. 

Account 
Dimensions 

The account number dimensions based upon the chart of accounts. 

Beginning 
Balance 

The beginning balance for this account, for this fiscal year. 

Fiscal Period 
Balances 

Based on the fiscal year designated in the header information, a 
column is available for each fiscal period. The net change balance 
for the period is shown.  

3.        If there are account numbers in the Balance table that don't exist in the Account Numbers table, then 
you will get the following message. This condition often occurs when an account number has been 
made inactive, but balances exist for the account number. You may want to modify your import scripts 
to correctly hand this condition. 

 

4.        Select File > Save when finished to save your changes. 

 

Resulting Balances 

There are two tables available from the Open Integration folder selection. When the Update Balances 
option is processed in Sage Budgeting and Planning, the Resulting Balances table is updated. This table is 
read-only and the balances and transactions can be exported to a production system. See Open Integration 
Utilities later in this chapter for more information. 

1.        Select Open Integration > Resulting Balances from the Sage Budgeting and Planning window. 
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2.        Select a Balance Type, Fiscal Year combination from the list of Balances. Then select File > Open to 
view the details of the resulting balances. 

 

 

Generated Results: Balances 

Balance Type A value of 1 designates a budget balance and a value of 2 
designates a statistical balance. 

Balance Code The budget or statistical balance code assigned at the time 
Update Balances is processed.  

Account Number The account number assigned to the balance. 

Account Dimensions The account dimensions assigned to the balance. 

Date The fiscal period ending date associated with the balance. 

Net Change The activity for the associated balance type, balance code, 
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account number and date. 

Ending Balance The ending balance for the associated balance type, balance 
code, account number and date. The ending balance is the 
sum of the net change for all fiscal periods through the 
period end date. 
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Integration Maintenance Utilities 

Importing 

For accounts, balances, and transactions, data can be imported from an existing production system using 
basic SQL queries. Data can be imported from a variety of source database types including Microsoft SQL 
Server, Access, Excel, FoxPro and Dbase. Data can also be imported from any ODBC or OLE-DB compliant 
database. Balances and transactions can also be exported from the resulting balance tables. 

Both import and export configurations can be saved and reused. For example, at the end of each period, 
account balances for the current period can be imported to update the balance table for the new balances. 

1.        Click on the Open Integration folder. From the menu bar select Utilities > Import. The import 
configuration listing displays: 

 

2.        Import configuration parameters can be saved allowing you to reuse a configuration once it is set up. 

a.        To import data using an existing import configuration, highlight a configuration on the list then 
click Run. 

b.       To modify an existing import configuration highlight it, then click Maintain. 

c.        To create a new import configuration, click New. An Import Setup Wizard is available to import 
different data types. Click Yes to use the Import Setup Wizard or No to manually create the import 
configuration. 

 

d.    To delete an import configuration, highlight it then click Delete. 

e.     Click on Cancel to close the Import Listing window. 
3.        Click New or Maintain and the import configuration displays. Complete the Sort Key and Description 

and select the appropriate option in Tables. Optionally, select to use the Import Setup Wizard when 
prompted. 
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Main Tab Options 

Sort Key A sort key to identify the import configuration in the system. 

Description A description of the import configuration. 

Tables Balance Information - The configuration will import account 
balance information. 

Transaction Information - The configuration will import account 
transaction information. 

Chart of Accounts - The configuration will import accounts. 

Prompt for 
Parameters 

Check the box to have the Import Configuration window display 
when the import is run. This allows you to confirm or change field 
entries before the process is run. 

Note: If the table selection is changed from one type to another, a warning will display that all query detail 
will be lost. Click Yes to continue and No to return to the Main tab without changing the table type. 

4.        Define the source of the data to be imported. The information to be completed on the form differs 
depending on the database selected. For file type databases, this includes a minimum of the path 
location of the files. If you select SQL Server, the Data Source tab will display as follows. The default 
database is the current company database. However, you can change this to any other database. 
Connection and login information may be required for other databases. 
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Data Source Tab Options 

Data Source Type Select the type of database the source data is stored in.  

Test Connection Click the Test button to test the connection to the selected 
database. If the connection to the selected database is 
successful, the field displays the message "Success!" If the 
data source could not be found, an error message will 
display. 

5.        If you select ODBC as the Database Type, the Data Source tab displays as follows: 

 

6.        If you click Manage Data Sources, a series of windows will display allowing you to define a data 
source. See Defining an ODBC Data Source at the end of this section for more information. If you have 
already set up your ODBC database sources, you can click on the Learn Connection button. 

7.        A lookup window with a list of the ODBC database sources configured displays. Select the appropriate 
data source. Sage Budgeting and Planning will attempt to create an ODBC connection. If the connection 
is successful, the balance of the information on the form will be completed automatically. Optionally, 
you can also type in the appropriate data source name and the related fields. 

ODBC Database Fields 

Data Source Name The descriptive name assigned to the ODBC source created. 

User ID Complete if the database requires a user ID. You can 
optionally complete this at the time of processing the plan 
sheet calculation. 

Password Complete if the database requires a password. You can 
optionally complete this at the time of processing the plan 
sheet calculation. 

Other Parameters Any extra driver-specific connection information entered in 
key=value format. The key parameter and valid values vary 
with the driver. See your ODBC driver documentation for 
more information. 

Send SQL directly 
to ODBC 

Check the box if you want to pass the SQL query directly to 
the ODBC driver without interpreting it as a Microsoft Jet 
SQL query. You should check this box if you want to take 
advantage of any ODBC driver specific SQL syntax. Consult 
your ODBC driver manual for the SQL syntax supported. 

8.        If you select OLE-DB as the Database Type, the Data Source tab displays as follows: 
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9.        Any data providers already existing will be listed when you select the drop down list box. If you click 
on the Learn Data Link button, Sage Budgeting and Planning will list any Universal Data Link (udl) 
files that define OLE-DB connectivity. If you select one, Sage Budgeting and Planning will attempt to 
connect to the database. If the connection is successful, the connection information will be completed. If 
the connection is unsuccessful, you will need to launch the Data Link Provider program or choose 
Manage Data Links and complete the data source information. Optionally, you can complete the 
connection information manually. 

OLE-DB Connection Information 

Provider Select from the list of available OLE-DB providers. 

Server Enter the name of the server that you wish to connect to. 

Login ID Complete if the database requires a user ID. You can 
optionally complete this the first time that you connect to 
the database. 

Password Complete if the database requires a password. You can 
optionally complete this the first time that you connect to 
the database. 

Database Define the database that will be used as the data source. 

Other Parameters Any additional provider-specific connection information 
entered in key=value format. The key parameter and valid 
values vary with the driver. See your OLE-DB driver 
documentation for more information. 

Connection 
Timeout 

Select the amount of time in seconds before the system will 
abandon an attempt to make a connection to the database. 

10.     Define the mapping of the fields to be imported on the Query Builder tab. Review the next sections for 
the specific fields available for each type of import. 

11.     To process the import, click Run. To save the import before processing, click Ok to save the import 
configuration. Click Cancel to close the configuration window without processing the import or saving 
changes. 

Defining an ODBC Data Source 

1.        Click Manage Data Sources from the Data Source tab or launch ODBC Data Sources from the 
Windows Control Panel. This runs the Microsoft ODBC Administrator program. 
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2.        Click Add and select the appropriate driver from the list. A window displays listing all of the 
ODBC drivers installed on your machine. 

3.        Highlight the desired driver then click Finish. Depending on the driver selected, the appropriate 
maintenance window displays. 

4.        At Data Source Name, type a descriptive name of the database. This is the name that displays in 
the Data Sources list. 

5.        You can type an optional description of the database. 

6.        The balance of the information to complete is specific to the driver and must be completed 
accordingly. 

7.        When finished, click Ok. 

Note: You may find some additional differences as a result of specific ODBC drivers. Refer to the ODBC 
documentation that came with the driver. 

Import Chart of Accounts 

Query Builder Tab 
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Query Builder Tab Options 

Account Number Select the field from the source table that will be used to populate the 
account number field in the account table. 

Description Select the field from the source table that designates the description 
of each account. 

Credit Define whether this account normally carries a debit balance, such as 
an asset or expense, or a credit balance, such as a liability or revenue. 
The value of 0 designates that the account typically has a debit 
balance. The value of 1 designates that the account typically has a 
credit balance. 

Actual A value of 1 assigns to this value will define the imported account as 
an Actual account. 

Budget A value of 1 assigns to this value will define the imported account as 
an Budget account. 

Statistical A value of 1 assigns to this value will define the imported account as 
an Statistical account. 

To create a query manually, click Advanced. When this option is selected, the query will override any 
values defined in the Query Builder tab. If the Advanced option is unselected, any changes made to the 
query manually will not be saved. 

Options Tab 
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Options Tab Options 

Duplicate Accounts: Leave 
duplicate accounts alone 

Select this option if existing accounts should not be 
modified by imported data. If existing accounts should 
be modified, select the option to overwrite. 

Duplicate Accounts: 
Overwrite duplicate 
accounts with imported data 

Select this option if existing accounts should be modified 
by imported data. This option only applies to records 
that exist in the accounts table that are imported. 

Remove Existing Accounts: 
Do not remove existing 
accounts 

Select this option to leave accounts that are not part of 
the import range intact. 

Remove Existing Accounts: 
Remove accounts based on 
imported account type 

Select this option to delete all account records based on 
the imported account type of actual, budget or statistical. 

Import Transaction Information 

Query Builder Tab 

 

Query Builder Tab Options 

Batch ID Define the Batch ID to be used with this group of 
transactions. Alternatively, select the appropriate field from 
the source table. 

Note: The Batch ID field is a text field. If an ID is assigned, 
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be sure to surround the ID in single quotes. 

Batch Description Define the Batch Description to be used with this group of 
transactions. Alternatively, select the appropriate field from 
the source table. 

Note: The Batch Description field is a text field. If a 
description is assigned, be sure to surround the description 
in single quotes. 

Account Number Select the field in the source table that identifies the account 
number for each transaction. 

Description Select the field in the source table that identifies the 
description of each transaction line. 

Balance Code If the transactions imported are for budget or statistical 
balances, select the field from the source table that identifies 
the balance code. Alternatively, assign a balance code. For 
actual balances, this field should have a null value defined 
using two single quotes ''. 

Note: The balance code field is a text field. If a code is 
assigned, be sure to surround the code in single quotes. 

Balance Type A value of 0 designates actual balances, 1 designates budget 
balances, and 2 designates statistical balances. 

Transaction Amt Select the field in the source table that identifies the amount 
of each transaction line. 

Transaction Date Select the field in the source table that identifies the date of 
each transaction line. 

To create a query manually, click Advanced. When this option is selected, the query will override any 
values defined in the tab. If the Advanced option is unselected, any changes made to the query manually 
will be undone. 

Options Tab 

 

Options Tab Options 

Remove Existing Select this option to leave existing transactions intact, 
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Transaction Information: 
Do not remove existing 
transactions 

regardless of transactions imported. 

Remove Existing 
Transaction Information: 
Remove transactions 
based on imported batch ID 

Select this option to delete all transaction records where the 
Batch ID matches the Batch ID assigned in the Query 

Builder tab. 

  
  
Import Balance Information 

Query Builder Tab 

 

Query Builder Tab Options 

Account Number Select the field from the source table that will be used to 
populate the account number field in the balance table. 

Balance Code If the balances imported are for budget or statistical balances, 
select the field from the source table that identifies the balance 
code. Alternatively, assign a balance code. For actual balances, 
this field should have a null value, defined by two single 
quotes (). 

Note: The balance code field is a text field. If a code is 
assigned, be sure to surround the code in single quotes. 

Balance Type A value of 0 designates actual balances, 1 designates budget 
balances, and 2 designates statistical balances. 

Net Change  Select the field from the source table that represents the period 
activity. 

Ending Balance Select the field from the source table that represents the 
ending balance, or year to date activity, for the period. 

Balance Date 

 

Select the field that identifies the fiscal period date to be 
assigned to the balances. 

Beginning Balance 
Flag 

A value of 1 designates the balance as a Beginning Balance, a 
value of 0 indicates a Net Change Value. 
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To create a query manually, click Advanced. When this option is selected, the query will override any 
values defined in the tab. If the Advanced option is unselected, any changes made to the query manually 
will not be saved. 

  

  

  

  

  

  

  

  

Options Tab 

 

Options Tab Options 

Duplicate Balance 
Information: Leave duplicate 
balance information alone 

Select this option if balance records exist and balances 
being imported should not modify the existing records. 
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Duplicate Balance 
Information: Overwrite 
duplicate balance 
information with imported 
data 

Select this option if existing balances should be modified 
by imported data. This option only applies to existing 
records in the balance amounts table where the account 
number and/or periods match balance records being 
imported. 

Remove Existing Balance 
Information: Do not remove 
existing balance information 

Select this option to leave all existing balance records in 
the table. 

Remove Existing Balance 
Information: Remove 
balance information based 
on imported balance code 

Select this option to delete all balance records that have a 
balance code equal to the balance code assigned to 
records being imported. 

Remove Existing Balance 
Information: Remove 
balance information based 
on imported balance code 
and period end date 

Select this option to delete only balance records that exist 
for the specified balance code and for the specific fiscal 
period being imported. 

  

Note:  To Remove Existing 
Balance Information: 
Remove balance information 
based on imported balance 
code and fiscal year 

From the main screen in the Open Integration ares select 
the Balances folder, this will show a list of imported 
balances based on Balance Type, Balance Code and 
Fiscal Year. Right Click on the combination you would 
like to delete and select the Delete option. This will 
remove the Balance Type, Balance Code, Fiscal year 
entries 

 

Exporting 

1.        Click on the Open Integration folder. From the menu bar select Utilities > Export. 

The export configuration listing displays: 

 

2.        Export configuration parameters can be saved allowing you to reuse a configuration once it is set up. 

a.        To export data using an existing export configuration, highlight a configuration on the list then 
click Run. 

b.       To modify an existing export configuration highlight it, then click Maintain. 

c.        To create a new export configuration, click New. 

d.       To delete an export configuration, highlight it then click Delete. 

e.        Click on Cancel to close the Export Listing window. 

3.        Click New or Maintain and the export configuration window displays. Complete the Sort Key and 
Description and select the appropriate option in Tables. 
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Main Tab Options 

Sort Key A sort key to identify the export configuration in the system. 

Description A description of the export configuration. 

Tables Balance Information - The configuration will export balance 
information. 

Prompt for Parameters Check the box to have the Export Configuration window 
display when the import is run. This allows you to confirm 
or change field entries before the process is run. 

4.        Define the destination of the data to be exported. The information to be completed on the form differs 
depending on the database selected. For file type databases, this includes a minimum of the path 
location of the files. If you select SQL Server, the Data Source tab will display as follows. The default 
database is the current company database. However, you can change this to any other database. 
Connection and login information may be required for other databases. 

 

Data Source Tab Options 

Data Source Type Select the type of database the source data is stored in.  

Test Connection Click the Test button to test the connection to the selected 
database. If the connection to the selected database is 
successful, the field displays the message "Success!" If the 
data source could not be found, an error message will 
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display. 

5.        If you select ODBC as the Database Type, the Data Source tab displays as follows: 

 

6.        If you click Manage Data Sources, a series of windows will display allowing you to define a data 
source. See Defining an ODBC Data Source at the end of the previous section for more information. If you 
have already set up your ODBC database sources, you can click on the Learn Connection button. 

7.        A lookup window with a list of the ODBC database sources configured displays. Select the appropriate 
data source. Sage Budgeting and Planning will attempt to create an ODBC connection. If the connection 
is successful, the balance of the information on the form will be completed automatically. Optionally, 
you can type in the appropriate data source name and the related fields. 

ODBC Database Fields 

User ID Complete if the database requires a user ID. You can 
optionally complete this at the time of processing the plan 
sheet calculation. 

Password Complete if the database requires a password. You can 
optionally complete this at the time of processing the plan 
sheet calculation. 

Other Parameters Any extra driver-specific connection information entered in 
key=value format. The key parameter and valid values vary 
with the driver. See your ODBC driver documentation for 
more information. 

Send SQL directly 
to ODBC 

Check the box if you want to pass the SQL query directly to 
the ODBC driver without interpreting it as a Microsoft Jet 
SQL query. You should check this box if you want to take 
advantage of any ODBC driver specific SQL syntax. Consult 
your ODBC driver manual for the SQL syntax supported. 

8.        If you select OLE-DB as the Database Type, the Data Source tab displays as follows: 
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9.        Any data providers already existing will be listed when you select the drop down list box. If you click 
on the Learn Data Link button, Sage Budgeting and Planning will list any Universal Data Link (udl) 
files that define OLE-DB connectivity. If you select one, Sage Budgeting and Planning will attempt to 
connect to the database. If the connection is successful, the connection information will be completed. If 
the connection is unsuccessful, you will need to launch the Data Link Provider program or choose 
Manage Data Links and complete the data source information. Optionally, you can complete the 
connection information manually. 

OLE-DB Connection Information 

Provider Select from the list of available OLE-DB providers. 

Server Enter the name of the server that you wish to connect to. 

Login ID Complete if the database requires a user ID. You can 
optionally complete this the first time that you connect to 
the database. 

Password Complete if the database requires a password. You can 
optionally complete this the first time that you connect to 
the database. 

Database Define the database that will be used as the data source. 

Other Parameters Any additional provider-specific connection information 
entered in key=value format. The key parameter and valid 
values vary with the driver. See your OLE-DB driver 
documentation for more information. 

Connection 
Timeout 

Select the amount of time in seconds before the system will 
abandon an attempt to make a connection to the database. 

10.     Define the mapping of the fields to be exported on the Query Builder tab. Review the next sections for 
the specific fields available for each type of export. 

11.     To process the export, click Run. To save the export before processing, click Ok to save the export 
configuration. Click Cancel to close the configuration window without processing the export or saving 
changes. 

Export Balance Information 

Query Builder Tab 
Before selecting a destination table, the Query Builder tab will display with no field names listed, as shown 
below. 
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After selecting a destination table, the Query Builder tab will be updated to list the fields available in the 
destination table. For each field in the destination table, select the appropriate field from the source table as 
needed or identify the value to be used in the export. 

Note: It may not be necessary to assign every field in the Balance Fields list to a corresponding field in the 

destination table. The fields in the destination table that need to be populated and the data required in each 
field will depend upon the destination table. 

Query Builder Tab Options Balance Fields 

Account_Number Identifies the account number for the balance. 

Balance_Code The code assigned during the Update Balances process in Sage 
Budgeting and Planning. 

Balance_Date The period end date for each balance generated when Update 

Balances is processed in Sage Budgeting and Planning. 

Balance_Type Designates the balance type as budget or statistical. A value of 1
designates a budget balance and a value of 2 designates a statistical 
balance. 

Ending_Balance The ending balance, or total activity as of the end of each period. 

Net_Change The total activity for the period. 

http://www.acutedata.com
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To create a query manually, click Advanced. When this option is selected, the query will override any 
values defined in the tab. If the Advanced option is unselected, any changes made to the query manually 
will not be saved. 

 

Create Balances From Transactions 

Once transaction records have been created, either manually or through an import, balances can be created 
based upon the transaction records. Using this function, it becomes unnecessary to import both balances and 
transactions. 

1.        Highlight Open Integration and then select Utilities > Create Balances From Transactions. The 
following window displays: 

 

2.        Select an account range and/or a date range for the balances to be generated. 

3.        Click Run to begin the process. Click Cancel to exit without updating balances. A window will display 
showing the progress. 

 

4.        At any time during the process of generating balances, the process can be canceled. If the process is 
canceled, no balances will be generated. Click on Stop Processing. 

 

5.        Click Yes to stop the process of generating balances. Click No to continue the process. A final message 
will display. Click OK to close. 

 
Create Ending Balances 

In the Balances table, there are two balances for each account, for each period. The net change reflects 
activity for the period and the ending balance designates cumulative activity for the fiscal year. Create 

Ending Balances updates the ending balances by totaling the beginning balance, if one exists, and 
cumulative activity for each period. 

1.        Highlight Open Integration and then select Utilities > Create Ending Balances. From the Generate 

Ending Balances window, select the fiscal year to be updated. Also select a balance type and, if 
applicable, select a balance code. Finally, an account range can be selected. 
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2.        Click Run to begin the process. Click Cancel to exit without updating ending balances. The following 
window will display, designating the calculation is in process. This process cannot be canceled once it 
has begun. 

 

3.        Upon completion, the original window will close. 
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Using WebView With Internet Trusted Sites Zone 

1.        Make sure Microsoft Internet Explorer version 7 or later is installed on the workstation. 

2.        Start Internet Explorer and configure the options as needed by WebView.  From the menu choose 
Tools > Internet Options, then go to Security Tab and click on Trusted Sites. 

a.        Click the Sites button and add your IIS Server as a trusted site. 

b.        Click on Custom Level and ensure you have the following minimum Security Options: 

IE Security Options 

Run Clients Not Signed with Authenticode Enabled 

Run Clients Signed with Authenticode Enabled 

Download Signed ActiveX Controls Enabled 

Run ActiveX Controls and Plug-Ins Enabled 

Allow script-initiated windows without size or position constraints Enabled 

Java Permissions Low Safety 

 

Note: Depending on the version of IE, the permissions above may vary.  If a permission is listed, ensure 
it is set as shown above. 
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