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1 

Chapter 1 - Introduction 
   

Chapter 1 

Introducing Sage Budgeting and Planning 

Welcome 

Welcome to Sage Budgeting and Planning, a powerful tool for collaborative, enterprise-wide budgeting, 
planning, and analysis. You should find the Sage Budgeting and Planning user interface easy to use and, if 
you have been using spreadsheet programs to create budgets, you will see much that is familiar. However, 
you will also find that Sage Budgeting and Planning is much more powerful and flexible than other 
spreadsheets because it is specifically designed for the planning and budgeting process. Plan participants 
use specially integrated and flexible sheets, called plan sheets, to create, analyze, manage and submit their 
individual pieces of the plan. 

Plan Manager is the control center of Sage Budgeting and Planning extending individual plan sheet 
preparation to a distributed enterprise-wide environment, allowing you to analyze and manipulate plan 
values, manage revisions, control budgetary processes, and establish security. 

Sage Budgeting and Planning incorporates cost and revenue elements, called dimensions, into the 
budgeting and planning process. These may be accounts, customers, projects, employees, or other data 
useful for planning.  In addition, enterprise data such as unit sales, compensation, and expense data may be 
included to compute valuable historical information and business drivers. 

Templates provide the ability to quickly and easily create and maintain uniform plan sheets. A prototype 
sheet is initially created that may include dimensions, column and row configurations, sections, calculations, 
and formatting. Based on the dimension ranges defined, subsheets referred to as derivative sheets are then 
generated. Any changes that are made to the template prototype can easily be transferred to the derivative 
sheets, thus maintaining consistency of the plan structure. 

The combination of dimensions and enterprise data may be analyzed within Sage Budgeting and Planning 
through the power of Microsoft Analysis Services data cubes. These cubes may be analyzed using the 
Analyzer data visualization tool included in Sage Budgeting and Planning or through direct access to 
Microsoft Excel pivot tables.  Excel pivot tables may also be edited, with the changes written back to the 
OLAP cube and, optionally, to the originating plan sheets. 

Using Sage Budgeting and Planning and WebView, you can easily access plan sheets using Microsoft 
Internet Explorer and make many changes remotely. 
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Prerequisite Knowledge 

This guide explains how to use the Sage Budgeting and Planning software to create budgets, plans, and 
analyses. However, it cannot teach planning and budgeting principles, and therefore assumes an 
understanding of basic concepts. This guide also assumes a basic knowledge of spreadsheet functionality. 

In order to create dimensions or use database calculations in formulas, this guide assumes a basic 
knowledge of SQL syntax and a detailed understanding of the database tables to be accessed. 

Chapter 14 assumes a basic knowledge of SQL Server tables, Microsoft Analysis Services and Excel pivot 
tables. 

Sources of Information 

A number of tools have been provided to aid you in understanding Sage Budgeting and Planning. Your 
individual learning style and basic computer knowledge will dictate how extensively you need to use these 
aids. 

•       This Sage Budgeting and Planning User Guide discusses basic concepts and procedures to design and use 
an integrated budgeting, planning, and analysis environment and how to set up, administer, and 
manage a distributed budget environment. 

•       The Sage Budgeting and Planning System Management Guide contains set up and maintenance procedures. 

•       Online Help provides context-sensitive help to understand and apply Sage Budgeting and Planning. 
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Conventions Used in this Guide 

•       Names of screen objects such as windows, tabs, fields, field selection options, and buttons are printed in 
bold type. 

•       Names of individual keys to press are printed in bold type. 

•       Information that appears exactly as it is stated, or that you are instructed to type exactly, is printed in 
bold type. 

•       Publication names and simple emphasis are printed in italic type. 

•       Important terms are introduced in sans-serif type. 

•       Keystroke combinations are separated using a (+) sign. For example, “Shift+F4” means to press the 
Shift key and hold it down while pressing the F4 key. 

•       Menus and menu items are separated using a (>) sign. For example, “Select File > Open” means to 
select the Open command from the File menu. “Select File > New > Sheet” means to select Sheet from 
the File menu’s New submenu. 

•       "Click" means to press and then immediately release your mouse button without moving the mouse. 

•       Options are selected using a checkbox. "Check" means to click on the option and a checkmark or X will 
appear in the checkbox. "Uncheck" means to click the option again to remove the checkmark or X from 
the checkbox. 

Special visual aids are used throughout this guide such as Notes and Tips. These appear as text in the 
format displayed below: 

Note: A note indicates additional information that may help you avoid problems or that should be considered 
in using the described features. 

 

Tip: A tip indicates additional information that may help you to do a specific task. 

Examples illustrate specific concepts: 

 
Example: 

This is example text. 
This is example details. 
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Getting Around in Sage Budgeting and Planning 

Toolbar 

Each main window has a set of toolbar icons displayed below the menus. The icons available will depend on 
the window that is open. A directory of toolbar icons and their actions is listed in Appendix B. 

Windows, Dialog Boxes, and Forms 

All three of these terms are used in this manual. Generically, any independent part of the user interface is 
displayed in some kind of window. Dialog boxes are windows that ask for specific information from you and 
then close when you click Ok, Close, or Cancel. The term form is sometimes used to indicate windows that 
display financial information in a tabbed or table format. Tabbed and table forms are explained later in this 
chapter. 

Right Mouse Click 

Clicking the right mouse button on the relevant object can also access most menu options. 

Cursor Movement 

Press the Tab key to move the cursor to the next field in a window. Press Shift + Tab to move the cursor 
back to the previous field. To edit a field, simply begin typing in the field. Press F2 to edit a cell. 

Spin Buttons 

Some fields such as dates have spin buttons. 

 

Click the up arrow to increment the value by one. Click the down arrow to decrement the value by one. In 
fields with separate sub-fields, such as a date, the arrows adjust only the highlighted portion of the field. 

Tabbed Forms 

Some forms contain overlapping index tabs. To access a particular tab, click the tab title. The clicked tab 
moves to the front. In this example, the Font tab is selected, and is therefore displayed “in front” of the 
Alignment and Border tabs.  

 

 

 

Table Forms 

Some forms consist of rows and columns. You can effectively hide or resize rows and columns by moving 

the cursor to the row or column boundary and “dragging” the boundary when the drag  icon displays. 
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In plan sheets these changes are saved for future sessions. In maintenance screens, such as Global Formula 

Maintenance, changes will only be saved if the column width is not reduced to zero (e.g. the column is 
completely hidden). 

User, Company, and Record Stamp Display 

The Sage Budgeting and Planning desktop interface always displays the current company, server, and user 
ID in the status bar at the bottom of the window. In addition, the company is displayed as part of the title at 
the top of the form. 

 

Each form displays in the status bar, the user ID, date and time the displayed record was originally created 
and last updated. 

 

Lookup Windows 

Sage Budgeting and Planning provides several types of lookup windows to assist in the selection of field 

values. A field with a lookup window has a lookup  icon to the right of it. Lookup windows are context 
sensitive. If you type the field value and click the lookup icon, the lookup window displays the starting 
value closest to what you typed. There are several types of lookup windows: 
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•       Database lookups are used for items such as chart of accounts, budget codes, and dimension values. 

 

•       Date lookups are used for fields with date values. The date lookup displays a calendar to select the 
values. Click the down arrow to display a list of months. Click the year arrows to scroll the year. Click Ok to 
return with the value to the original field. Click Cancel to exit without changing the date. 

 

•       File lookups may be used to select files from a list of directories. 

Record Lookups 

Record lookups locate specific records in the Sage Budgeting and Planning database and are activated by 
clicking the Open icon or by pressing Ctrl + O. 

 

Form Maintenance 

You can edit any maintenance form from another entry form by clicking on the Maintenance icon. This 
opens the related form and allows you to build the maintenance record “on the fly”. For example, you can 
build formulas from within a plan sheet. 
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Technical Support 

Technical support information may be retrieved by selecting Help > Technical Support from any of the 
menus. You may contact technical support by clicking on the links to the websites or by telephone. 

 

Help About 

The Help About screen may be retrieved by selecting Help > About from any of the menus. This screen 
displays information about the version of Sage Budgeting and Planning, the patch level, the database 
version and registration. You may requested to provide information from this screen to the technical 
support staff. 

 

 

Component Versions 

The Component Versions screen may be retrieved by selecting Help > Component Versions from any of the 
menus. This screen displays a list of files (DLLs and EXEs) that are part of the product along with their 
version numbers. You may requested to provide information from this screen to the technical support staff. 
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Online Help 

You can access Online Help from anywhere in the program by pressing the F1 key. You can also select 
various help options from the Help menu. Help is context sensitive to the Sage Budgeting and Planning 
form. You can then select detailed help about any specific fields in the form. 

 

Online Help 

Help Topics Lists the table of contents in chapter order. This is the same as 
Contents from the Help menu. Each option can be further 
selected to “drill down” to the appropriate subject.  

Index Searches help by keyword. The search is context sensitive so 
that typing more can narrow the search further. 

Find Allows word searches beyond keywords. 

Back Moves back to last help window accessed. 

Print Prints the current help window. 

<< Moves back one help topic. 

>> Moves forward one help topic. 
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Using this Guide 

This guide contains instructions to create, produce, maintain, and process budgets, plans and analysis 
reports. It is intended to help you get the most out of Sage Budgeting and Planning. We recommend you 
spend time with the system in advance of using it in a “live” environment. Specific examples are noted in 
this guide. 

Note: Because Sage Budgeting and Planning is flexible and easily customized, some features described in 
this manual may not be available on your system, or may not be available with a particular configuration you 
are using. Illustrations of windows, dialog boxes, and other screen elements are intended to be typical, and 
may differ slightly from what you see. 

•       Chapter 2 introduces all the major concepts of Sage Budgeting and Planning. This chapter is required for 
those that will be setting up or implementing Sage Budgeting and Planning. 

•       Chapter 3 provides a brief introduction and instructions for creating plan sheets. 

•       Chapter 4 provides instructions for setting up dimensions and integrating dimensions to enterprise data 
sources. 

•       Chapter 5 provides step-by-step instructions for creating and maintaining column groups, standard 
columns, and custom columns. 

•       Chapter 6 provides step-by-step instructions for creating and maintaining rows, row IDs and row notes. 

•       Chapter 7 discusses the various cell functions that can be applied to plan sheets. 

•       Chapter 8 discusses detailed steps on setting up and maintaining plan calculations 

•       Chapter 9 expands on the concepts introduced in the calculation chapter and details creating and 
maintaining the various formulas including database queries. 

•       Chapter 10 explains the presentation and printing options available in Sage Budgeting and Planning. 

•       Chapter 11 details advanced techniques, including sections, templates, and models, used to create plan 
sheets. 

•       Chapter 12 describes how to manage a corporate budget plan with Plan Manager, including hierarchical 
structures, process flow, and security. 

•       Chapter 13 provides step-by-step instructions for using Sage Budgeting and Planning WebView for 
remote data entry. 

•       Chapter 14 discusses OLAP processing and analysis, including how to create and process cubes.  

•       Chapter 15 introduces Analyzer, the data visualization tool included with Sage Budgeting and Planning. 

•       Appendices provide additional information on the desktop interface, toolbar icons and actions, basic 
SQL concepts, and a glossary of terms used in this guide. 

Many concepts build on one another so it is important to review the entire user guide before implementing 
Sage Budgeting and Planning. 
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Chapter 2 – Active Planner Overview 
 

 

Chapter 2 

Sage Budgeting and Planning Overview 

Logging In 

 

Sage Budgeting and Planning launches from the Start- Programs menu.  The User and password are 
maintained in the User Maintenance menu.  The Configuration is created and maintained in the 
Administrator Tool.  A configuration defines a set of data comprising the planning environment, such as 
live or demonstration data.  A single configuration may include multiple companies. 

 

When a user logs in, Sage Budgeting and Planning remembers the most recent login, and opens the last 
company accessed.  A user is prompted to choose the company in the first login.  A user may then choose 
the Change Company menu to select a different company.  
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Preparing to Plan 

Organization 

Before determining how your enterprise-wide budget, planning, and analysis system will be designed 
within Sage Budgeting and Planning, you should have an understanding of how the various budget centers 
in your organization work together to form an efficient plan. 

Hierarchy 

You will establish hierarchies in Plan Manager for the purpose of managing and controlling the process of 
the plan. While these hierarchies may be used for analysis purposes, you may wish to keep your hierarchy 
flat and use the capability contained in OLAP analysis to slice and dice the various areas within your 
organization. 

A management structure might look like the following: 

•       Departments flow into divisions 

•       Cost centers flow into responsibility areas or regions 

•       Project details flow into project summaries 

These areas tend to be focused along the lines of responsibility areas. For example, a marketing department 
may have a series of plan sheets along functional lines. This will form the hierarchy within your Plan 
Manager tree. Typically, consolidation processing takes place within these hierarchies. Within Plan 
Manager, these are branches within the plan tree. 

Process 

However, other relationships exist within a plan. These relationships typically are horizontal in nature and 
not hierarchical. We might refer to these as sibling relationships. These relationships might occur when 
certain calculations are dependent on the current results of another calculation. For example: 

➢       Revenue forecasts process first 

•         Direct cost of sales are dependent on revenue forecasts 

•         Variable selling costs are dependent on revenue forecasts 

➢       Head count and wage determined 

•         Salaries and wages computed 

•         Fringe costs computed 

•         Payroll taxes computed 

➢       Controllable factors 

•         Uncontrollable costs allocated on the basis of controllable factors 

Plan sheets are processed in order up and/or down an Sage Budgeting and Planning Plan Manager tree. 
Any components on the same level of the tree are processed in order according to the sheet key. For 
example, if you want cost of sales to process calculations based upon sales, you may wish to identify a key 
value for the cost of sales plan sheet that sorts after the sales plan sheet. By structuring the key values 
properly, you choose the order that you wish to process and ensure the ability to model results. The Sage 
Budgeting and Planning calculation engine provides some very sophisticated capabilities to calculate data 
between plan sheets. 

Create Basic Budget Wizard 

You can have your plan automatically defined using the Create Basic Budget Wizard. The Create Basic 
Budget Wizard will walk you though steps letting you select the type of budget(s) you would like to create, 
and  specify some information about your account structure and ranges of accounts. After completing the 
wizard it will create your budget(s) and build the appropriate hierarchy. 

When you are in the plan area of the tree structure you will have a menu item available: Plan->Create Basic 
Budgets. Selecting this menu item will launch the Create Budgets Wizard. 
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On the initial screen of the wizard you will be presented with the steps the wizard will take you through. 

 

 

On the second screen you will be given a list of available plan concepts that are available. 
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You may click the "Details of Resulting Budget" button to view a more detailed description of the budget. 

 

 

On the third screen you will be presented with some grids where you can specify the details of your account 
structure and specify how you would like to break down your budget. The top section is for you to identify 
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what segment of your account is the Natural segment. If there is a segment named Main or Account this will 
be selected by default. The bottom section is for you to identify how you would like to define the hierarchy 
of your plan. You can select one or two levels to build the hierarchy on. The sample tree on the right will be 
dynamically updated to give you an idea of the breakdown. The labels on the nodes will not be the actual 
nodes but will give you the information of what your tree will look like. 

 

 

On the fourth screen you will be able to specify the prefix to use with the resulting plans, the created plans 
can be renamed if desired. The Budget Key Prefix you enter will be the first part of the new Budgets getting 
created. If you enter something like NewPlan your resulting budgets will be NewPlan01, NewPlan02 and so 
on. Enter the Budgets Base Date and the Budget code you would like to use for the new budget(s). These 
setting can be changed after the budget is created if you wish. 
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On the fifth screen you will be able to specify the natural accounts that make up the different account 
categories in your system. Here you can change the default ranges add additional ranges to the account 
types of Revenue, COGS, Expense and Salary. 

 

Clicking finish will create your budget. 
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Resulting Budget will look something like this. 

 

 

Once the Budgets are create you can modify, copy, and change them as you would a plan. 

 

 

 

 

Structure 

Revenue and Cost Elements 

It is important to consider what the cost or revenue elements of each plan component are. It is not practical to 
expect that every participant in the planning process use the same method and structure to plan. For 
example, in developing a sales plan, it typically is not effective to plan by account number because the 
account number typically does not factor in territories, product lines, salespeople, etc. Likewise, it is not 
efficient to do salary planning by account number either since that is typically done by an employee. Sage 
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Budgeting and Planning gives you complete freedom to define cost or revenue elements independently to 
each plan component. 

Dimensions are the various elements that define how an organization plans and operates. Typically, 
dimensions are points of data collection or responsibility that are tracked within the various production 
systems. Typical categories include: 

•       Financial cost collection placeholders such as divisions, departments, accounts, or projects 

•       Company capital such as employees or assets 

•       Revenue producing and resource consuming dimensions such as customers, salespeople, territories, 
or product/service lines 

Every organization has a unique set of dimensions that define it. The important factor is how strategic and 
controllable those elements are. For example, one organization may choose to plan revenue by customer and 
salesperson. If you were a retail organization however, this might be impractical. Thus, dimensions, in the 
context of Sage Budgeting and Planning, define how an organization plans. For example: 

•       Departments – head count or operating costs 

•       Salespeople – sales units 

•       Assets – capital costs 

Dimensions may be further classified by the attributes associated with them. For example, the main 
identifier of an employee dimension would consist of an employee ID and the employee’s name. Additional 
characteristics associated with that record might include such classifications as gender, manager name, 
department ID, etc. In essence, attributes provide supplementary information about the dimension. 

Sage Budgeting and Planning provides the framework by which any dimension may be used 
interchangeably within a plan alongside other dimensions. 

Precision Detail 

Budget centers can be developed at any level of detail. Sage Budgeting and Planning gives you the freedom 
to create a very detailed plan or a highly summarized plan. Moreover, some components of the plan may be 
budgeted in detail while others may be at a highly summarized level. 

In Sage Budgeting and Planning, summarized values, such as annual totals, can be allocated to detailed 
budget centers using plan calculation formulas. Detailed values may be consolidated into summary values. 

Planning Cycle 

There are two factors to consider in determining the planning cycle. The first consideration is the planning 
horizon, which is the overall length of time by which you wish to plan. More and more organizations are 
planning longer than a single annual cycle. Again, Sage Budgeting and Planning gives you the ability to 
plan for any length of time. The cycle can be easily broken up into multi-year segments and data can be 
carried forward from one year to the next. The only limitation is that a plan sheet cannot have more than 256 
columns. 

The planning interval is the number of periods and the duration of each period contained in the planning 
horizon. The planning interval typically corresponds to the reporting structure of the organization, but not 
always. For example, a planning interval might be quarters while a reporting cycle might be based on 
months. 

How the planning interval and the planning horizon relate to each other defines the overall planning cycle. 
For example, the planning horizon might be fiscal year 2003 and the planning interval might be months. As 
the time to complete a planning cycle shortens, more and more organizations are expanding the planning 
horizon and allowing it to shift or “roll”. As the horizon increases, the measure of precision of the interval 
gets increased. For example, a three-year rolling plan might warrant a monthly interval for the first year, a 
quarterly interval for the second year, and an annual interval for the third year. 

Sage Budgeting and Planning gives you the ability to set up any combination of intervals and horizons. 
Moreover, different participants in the plan may plan at different intervals. For example, at one level of the 
plan, months might be the interval while at another level of the plan the interval might be quarters. Rolling 
plans are easily accommodated through the logic that is built into the system. 
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Calculations 

Historical Information 

It is highly useful to have actual information at your fingertips as a framework for good planning. With the 
integration to enterprise-wide systems provided by Sage Budgeting and Planning, there is no need to re-key 
historical information or go through a painful import process. Historical information can also be used to 
calculate projected plan values. 

Using the calculation engine, historical information can be brought in from virtually any data source. The 
calculations deploy the information defined in the dimension setup to quickly and easily derive results. For 
example, you could compute units shipped by salesperson, territory and period. This calculation is defined 
once and references the dimensions of salesperson, territory and period as variables. One single calculation 
definition could yield virtually thousands of different possibilities using dimension variables. Moreover, 
these calculations can be updated at any time to ensure the most current information is always available. 

It is important to determine what level of detailed information you wish to have to support your planning 
cycle. The opportunity exists to expand the use of this historical information, particularly as you move to a 
more dynamic business planning process, such as rolling budgets. 

Business Drivers 

Business drivers support internal computations within the plan. For example, sales commissions might be 
computed based upon sales, fringe benefits might be computed based upon salaries, or capital equipment 
might be derived based upon new hires. 

These computations are supported through the calculation engine. Very often, these relationships are driven 
by the process hierarchy, rather than being within the same person’s responsibility. Therefore, it is 
important to determine these relationships before implementing Sage Budgeting and Planning. 

Allocations 

It is important to determine which portions of your plan are allocated values vs. direct or controllable values. 
Every allocation has three pieces to it: 

•       The source values to be allocated 

•       The recipient values to receive the allocated values 

•       The basis for the allocation, such as head count 

There may be several different types of allocations used in the plan. Certain allocations are not dependant 
on the hierarchy of the plan structure. For example, an overhead allocation to departments based on head 
count would require that the overhead value (the source) and the head count (the basis) be as up-to-date as 
possible prior to computing the allocation. However, the process hierarchy described earlier must be 
established to ensure that updated information is always used. 

Other allocations are hierarchical in nature. These allocations are typically targets that are allocated from a 
high level down through the organization. For example, an annual sales target may be developed by upper 
management and then allocated based on historical sales units by territory and period. In this case, the 
source value is the annual sales target, the basis is historical sales units, and the recipients are territories by 
period. As the annual target likely shares the same management responsibility and the source must precede 
the detailed computation, this type of allocation is driven more by a hierarchical model, as described earlier 
in this section. 

Allocations can be computed in multiple ways in Sage Budgeting and Planning. These approaches are 
discussed later in this guide. 

Analysis 

A well-defined planning process will incorporate a recurring, embedded analysis process. Unfortunately, 
many analyses are doomed to fail for the following reasons: 
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•       They occur too late in the process and end up becoming a scorecard with no discernible forward 
impact 

•       The analysis occurs at the wrong level, such as a revenue analysis at an account level which would 
likely not reveal price or volume variances by territory 

Sage Budgeting and Planning gives you the ability to structure analyses in conjunction with the business 
plan and at any level, creating an interactive plan. Analysis can be incorporated into the development of the 
component budgets or plans and can be updated at any time. The analysis can leverage the historical and 
business driver computations interactively with budget and plan data. These calculations can be sent into a 
multidimensional cube using On Line Analytical Processing (OLAP). Data in multidimensional cubes can be 
sliced and diced in multiple ways and advanced data visualization can be deployed to explore and isolate 
data and variances. In addition, the data can be deployed interactively across the organization. 

When planning your analysis, keep in mind that analytical presentation and hierarchy using 
multidimensional cubes creates many more possibilities than the management and process hierarchy 
described earlier in this section. For example, a vice president of sales responsible for developing the sales 
budget for an organization might include key components (dimensions) in the budget such as salesperson, 
territory and product category. Responsibility is then assigned to each regional sales manager (the 
management hierarchy). If a target of 100 million dollars was established and the calculation and 
consolidation of the sales plan produced 95 million dollars, trial and error could be used to try to get to the 
100 million dollar target. This would require making changes to the various regions and then continually 
rolling up the components until the correct result is achieved. Alternatively, multidimensional analysis 
could be used to sift through the thousands and thousands of possibilities, which would be much simpler. 
Regional managers might also be assigned responsibility to further analyze their piece of the plan with 
multidimensional cubes. 

Management 

Once the organization, structure, calculations, and analysis are determined, you need to decide how all 
these pieces will work together. Sage Budgeting and Planning provides various features to give you the 
control you need to manage the budgeting and planning process efficiently. 

Revisions 

Organizations are dynamic and there are always many possibilities. Being flexible in the planning process 
allows you to modify the plan execution as needed to reflect changes in the business environment. 

Sage Budgeting and Planning provides the ability to create multiple iterations of the plan. For example, you 
may create a plan that reflects an aggressive view as well as a plan that is conservative. The use of these 
multiple iterations may also be used to reflect timing issues. For example, each pass of the budget may be 
shown as A, B, C, etc. 

In Sage Budgeting and Planning, the identification and deployment of these iterations is called revision 

control. While Sage Budgeting and Planning allows for multiple revisions, it is easier to manage the process 
if there is a consistent identification scheme. 

Remote Participation 

Very often organizations need to include participants in the planning process that are not part of the 
corporate site information systems infrastructure. As part of the planning process, you should identify these 
participants and their level of involvement in the plan. 

The following possibilities are available with Sage Budgeting and Planning: 

•       Access the plan using WebView. This option requires very little administration and allows access via 
the Internet to plan sheets created in Sage Budgeting and Planning. WebView users can enter and 
review data, but cannot modify the plan sheet structure. WebView supports Sage Budgeting and 
Planning's security, revision control, status codes with e-mail notification, and it allows one level of 
consolidation. 
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•       Access the plan using remote networking. This may require an investment in information systems 
infrastructure and is best used by participants that need a broader range of access to the functions in 
Sage Budgeting and Planning. 

•       Access the plan using Excel spreadsheets. Sage Budgeting and Planning gives you the ability to 
consolidate values prepared in spreadsheets into the plan. This option provides no access to the 
functions of Sage Budgeting and Planning, but does provide some off-line capability. Excel participants 
do not have access to Sage Budgeting and Planning's security, revision control nor status codes. 

Communication 

It is helpful to track the progress and the state of completion of each plan participant. 

Sage Budgeting and Planningstatus codes provide the necessary information to determine the progress of 
each participant. These status codes are user definable and can integrate with most e-mail systems, 
providing communication as the planning process progresses. 

Also, with the sorting capabilities of the desktop interface, you can easily sort on key fields to quickly 
identify the progress of each manager, plan sheet, and revision. 

Process Control 

At various points, management must review the overall results and decide whether they are acceptable. If 
this is a moving target, then it is difficult to conclude what changes are necessary. As part of the planning 
process, you should consider how often you are going to consolidate the plan, lock the components and 
review the results. Sage Budgeting and Planning gives you the ability to lock components from further data 
entry, while still providing the flexibility to run modeling scenarios. 
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Sage Budgeting and Planning Concepts 

Plan Sheets 

In Sage Budgeting and Planning you will be using plan sheets to construct your budget plans and analyses. 
Users accustomed to constructing budget plans in commercial spreadsheets will recognize many familiar 
features in plan sheets. For example: 

•       Plan sheets consist of rows and columns of cells 

•       Cell values can be entered, copied, or filled 

•       Cell formulas and functions can be used, including absolute and relative cell addressing 

•       Cells can be formatted with numeric control, alignment, fonts, borders, and background colors 

However, plan sheets are optimized to the budgeting and planning process. 

•       Dimensions, which access enterprise-wide data, can be applied to sheets, rows and columns to 
determine what elements will be used as the basis for each plan component and how these elements 
will be assigned in the planning process. 

•       Attributes, which provide additional dimension information, allow for supplementary measures for 
analysis. 

•       Calculations compute historical information such as previous year actuals or business drivers. 
Calculations can also be used to compute planned values. These calculations integrate period dates, 
dimension variables, and user-defined variables to reproduce multiple results. Once set up, calculations 
can be reused in multiple rows and multiple plan sheets. 

•       Fiscal periods can be mapped to each column. These periods can span years providing flexibility for 
varied planning horizons and intervals. 

•       Sage Budgeting and Planning provides cell functions specific to planning, such as the number of 
business days in a period. 

•       Using view options, individual columns or groups of columns can be selectively hidden and displayed 
based on column attributes. 

•       Values can be incorporated intelligently between plan sheets using calculations, consolidation or 
distribution processes, avoiding cell specific logic. 

•       Assumptions and explanations can be documented on each row using row notes, which can be 
exchanged between plan sheets. 

•       Multiple plan sheets can be generated based on various dimension ranges and on individual 
responsibility using templates or models. 

Plan Manager 

Plan sheets are managed in an enterprise-wide budget plan using Plan Manager. Plan Manager is the 
command center of Sage Budgeting and Planning and provides management, administration, processing 
control, and security. Using Plan Manager, you can: 

•          Organize plan sheets into management hierarchies, called plan trees 

•          Assign security levels to each plan sheet 

•          Change plan sheet status and trigger e-mail notification to plan participants 

•          Manage revisions 

•          Consolidate and distribute values between plan sheets and Excel spreadsheets 

•          Control the processing order of calculations, such as the computation of sales commissions after sales 
are calculated 

•          Lock plan sheets from further data entry, while still allowing for continued interactive modeling 
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Plan sheets and plan trees can be accessed using Sage Budgeting and Planning directly connected to the 
network or remotely using terminal services.  Plan sheets can be accessed across the Internet using 
WebView. From WebView, only plan sheet values, cell formulas, and notes can be edited.  

Publication and Analysis 

Plan sheets, because they are spreadsheet based, are very efficient for entering and viewing large amounts 
of data and for budget processing. However, the spreadsheet data is flat, providing little ability for data 
trending, isolation, aggregation or analysis. Sage Budgeting and Planning allows you to turn the data into 
multidimensional cubes for more in-depth analysis using Microsoft Analysis Services. This process is called 
publication and analysis. 

To analyze the data, there are two options available: Excel pivot tables and Analyzer. Excel pivot tables can 
be used to view the data. Alternatively, Analyzer can be used to provide functions such as: 

•          View OLAP data through multiple graphical aspects or grids 

•          Print views of the OLAP data 

•          Drag and drop dimensions between rows and columns 

•          Isolate, eliminate or highlight data using a variety of user-definable conditions 

•          Drill up or down between data elements 

The subsequent sections of this chapter provide high-level explanations of the relationships between the 
various components of Sage Budgeting and Planning. We suggest you review this chapter in depth before 
continuing on with your individual implementation. 
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Plan Manager Concepts 

Plan Manager is the command center of Sage Budgeting and Planning. Plan Manager takes charge of the 
plan participation across the organization. Within Plan Manager, you can manipulate plan sheets, models, 
templates and/or Excel spreadsheets. These components collectively are referred to as subsheets. 

Typically, the plan administrator will work with the entire budget plan in Plan Manager. Within Plan 
Manager, you can perform the following tasks: 

•       Organize subsheets into logical management and process hierarchies 

•       Review status and history 

•       Perform and control consolidation and distribution processing 

•       Assign and manage security access 

•       Manage revisions 

•       Perform plan management tasks 
 

The following terminology is used in this guide to identify subsheets in a plan: 

•       Tree identifies the entire plan 

•       Root identifies the plan identifier as noted by the  symbol 

•       Node identifies an individual subsheet in the plan tree 

•       Branch identifies a subsheet with one or multiple subsheets under it 

•       Leaf identifies a subsheet with no subsheets under it 

 

You can have an unlimited number of nodes and levels in a plan tree. You can have up to 256 subsheets 
assigned to an individual branch of the plan. Organization of the Plan Manager tree is controlled through 
simple drag and drop techniques. 

The primary use of the Plan Manager tree is to control processing and manage the processing hierarchy, not 
for analysis. Data from multiple plan sheets can typically be analyzed more flexibly and more efficiently 
using multidimensional cubes. This should be kept in mind as you set up your system as it may be 
preferable to keep your plan tree flat along management and processing lines. 

Subsheet Options 

The following are various subsheets identified in the plan tree. 

•       Plan sheets  can be accessed by anyone who is a user of Sage Budgeting and Planning and has the 
appropriate security. Plan sheets may also be accessed across the Internet using WebView. 
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•       Models  can be used to reproduce multiple plan sheets based on a prototype plan sheet and multiple 
dimension values. Models themselves are not used in processing, though they are part of the plan tree. 

•       Templates , similar to models, are used to generate and maintain multiple plan sheets from a master 
plan sheet. 

•       Excel spreadsheets  may be directly read and opened from Plan Manager.  

Subsheet Manager     

Subsheet Manager is an abbreviated version of Plan Manager.  Subsheet Manager has all of the functions of 
Plan Manager but is restricted to just the branch of the plan. This allows individual plan sheet users with 
authorized security to create and manipulate subsheets in their branch of the plan.  The Subsheet Manager is 
accessible from either the Plan View or the Plan Sheet View of the main menu.   
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Touring a Plan Sheet 

A plan sheet is a fully functional spreadsheet, with certain columns reserved for program functions. The 
number of columns reserved depends on the number of dimensions assigned to the plan sheet. The 
remaining columns are user-definable for values or custom information including attributes. 

 

Plan Sheet Components 

Type Reserved column, applicable if the Account Number 

dimension is selected. Used in the update balance process to 
indicate that the type of budget values in the row. 

CR Indicates that the values in the row are a Credit Value. Sage 
Budgeting and Planning will display the numbers as a 
positive instead of a negative. 

Dimensions Dimensions assigned to the plan sheet at the row level. The 
default dimension is Account Number, but any dimensions 
can be established. 

Description A description for the row, with a maximum of 255 characters. 

Flow Defines how rows are used for consolidation/distribution 
processing. 

Notes Attaches notes to the selected row. Notes are automatically 
stamped with user ID, time, and date. 

Calc Defines plan calculations that retrieve information from 
enterprise data. 

Custom Columns These columns store extra user-defined information such as a 
manager name or social security number. This information 
can be formatted as numeric, text or date. Dimension 
attribute information is displayed in custom columns.  These 
columns also allow cell formulas. 

Data Columns Up to 256 columns of data may be inserted. This data can be 
updated based on keyed values, cell formulas, calculations, or 
flow processing.  

Tip: You can hide or resize any row or column in the plan sheet by moving its boundary. Click and drag the 
boundary to the desired location. The settings for these boundaries are saved with each plan sheet for future 
use. 
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Spreadsheet Operations 

Columns other than reserved columns are available for specific plan values. The cells in these columns 
function similarly to those in commercial spreadsheets. 

There are several options for populating plan sheet cells: 

•       Type a specific value. 

•       Type a cell formula. 

Sage Budgeting and Planning supports special budgeting specific functions in addition to standard 
spreadsheet functions. The syntax is similar to Microsoft Excel. For example, to sum a range of cells the 
formula is "=SUM(D6:H6)". 

Note: If you type a value or a cell formula and then later define a plan calculation or flow process that 
updates the same cell (as described in later sections) Sage Budgeting and Planning will overwrite your 
existing value or formula with the computed results. 

You can copy and paste values or cell formulas using the Windows clipboard or using the Fill command to 
fill multiple cell values in any direction. 

Cell Formatting 

Sage Budgeting and Planning allows you to set the following cell formatting attributes: 

•       Numeric formats 

•       Cell alignment 

•       Cell fonts 

•       Cell border 

•       Cell background colors 

•       Cell protection 
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Steps to Defining a Plan Sheet 

A plan sheet is essentially a scratch pad used to develop a budget plan or analysis. Each plan sheet can have 
its own unique row and column structure. Here are the basic steps in defining a plan sheet: 

•          Decide on the convention to be used in identifying a series of plan sheets. Each plan sheet consists 
of the unique combination of a plan key, a sheet key, and a revision key (a total of 40 characters). These 
key fields must include only letters, numbers, and the underscore.  Avoid spaces or other special 
characters (/, !, &, etc. ). 

•          Determine the security profile of each of the various users that will use each of the plan sheets. 

•          Assign the initial status code to the plan sheet. Status codes can be reviewed and updated through 
Plan Manager. They allow for e-mail notifications to various users and related users of the plan 
sheet. Customized status codes can be created and are discussed at the end of this chapter. 

•          Determine what dimensions and possibly which attributes are to be assigned to the plan sheet and 
to which axis each dimension will be attached. Dimensions can be assigned to rows, columns, or 
the plan sheet. Since attributes are inserted into custom columns they may only be assigned on 
rows. 

•          Decide on a row and column structure for each plan sheet. While rows and columns can be unique 
for a plan sheet, you should ensure some consistency among all the plan sheets. This could be 
particularly true if values from plan sheets will be consolidated or distributed using Flow or if used 
in plan calculations. 

•          Determine if plan calculations are needed to provide values from databases or other plan sheets. 
Plan calculations are not required but do provide access to enterprise level information. 

•          Determine how the plan sheet will participate with other plan sheets as part of a plan tree in 
consolidation/distribution processing. Values to be updated are determined through the use of the 
row ID and parent row ID and the hierarchy within the plan tree. 

•          Define any standard spreadsheet operations necessary within the plan sheet. This includes keyed 

values, cell formulas and cell formats. 

•          Determine which columns will be visible using view options. 

•          Type any values needed to complete the plan sheet and lock any cells that users should not 
modify. Most standard spreadsheet operations are supported. 

•          Document plan sheet assumptions using row notes. 

•          Determine the system for duplicating plan sheets. Consider the capability of templates or models 
to prototype sheets or using other means of duplicating sheets. 

•          Determine how the plan sheet will be used to create OLAP cubes for analysis and how often the 
cubes will be updated. 

Each of these steps is discussed in summary in this chapter. Step-by-step instructions are contained in 
subsequent chapters. 
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Plan Sheet Identification 

Each plan sheet has a unique identification. This identification consists of the combination of the plan key 
and the sheet key.  These key fields must include only letters, numbers, and the underscore.  Avoid spaces 
or other special characters (/, !, &, etc. ). 

The plan key identifies which plan the plan sheet belongs to and corresponds to the plan displayed in Plan 
Manager. 

Each sheet key can be furthermore subdivided into multiple revision keys. One revision key is designated as 
the active revision. The active revision is always the plan sheet incorporated into any overall plan 
processing. 

The following diagram shows the relationship of the major identifiers between the plan sheet and Plan 
Manager. 

 

This identification process is critical for several reasons: 

•       The plan key identified in the plan sheet determines which plan tree the sheet belongs to for 
management in Plan Manager. 

•       The sheet key will determine the positioning within a plan branch level. For example, in the process 
model above, the sales plan sheets would process before the design and departmental plan sheets. Any 
dependencies on sales such as sales commissions would then be computed after the sales branch is 
processed. 

•       The active revision is always the plan sheet that is processed during plan processing. A plan sheet user 
can change the plan sheet active revision (with appropriate security) or the plan administrator can force 
the revision. 
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Security 

Security within Sage Budgeting and Planning is applied at two levels; security at the plan level and at the 
sheet level. The System Administrator (System Admin.) is the highest level of security and they have access 
to everything in Sage Budgeting and Planning. The plan and all of its component subsheets have a security 
environment that includes one Plan Administrator (Plan Admin.) and one or more Plan Controllers (Plan 
Ctrl.). These individuals have unlimited access to the plan tree and all of the component subsheets, 
including all plan sheets. 

Control of certain budgeting and planning operations may be assigned at the sheet level as well. Each sheet 
is assigned to one Sheet Manager (Sheet Mgr.) and permissions may be granted to multiple Sheet Planners 
(Sheet Plnr.) and Sheet Reviewers (Sheet Rvwr.). Sheet Managers are typically granted access to sheets that 
are specific to his or her department or functional area. Sheet Planners are permitted to enter data into the 
sheet, whereas Sheet Reviewers have view only rights to a sheet. 

 

 

User security levels and their respective task privileges accessible from Plan Manager 

Tasks System 
Admin. 

Plan 
Admin. 

Plan 
Ctrl. 

Sheet 
Mgr. 

Sheet 
Plnr. 

Sheet 
Rvwr. 

Assign Plan Security X X     

Update Plan Properties X X     

Copy Plan X X X    

View Plan Security X X X    

Update Plan Hierarchy X X X    

Delete Plan X X X    

Update Balances X X X    

Update Branch Properties X X X    

Change Base Date X X X    

Plan Processing X X X    

Delete Sheet X X X    

Print Sheet and Sheet Definition X X X    

View History X X X    

Update Sheet Properties X X X    

Create Templates X X X    

Define Template Derivatives X X X    

Generate Sheets from Templates X X X    
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User security levels and their respective task privileges accessible from Subsheet Manager 

Tasks System 
Admin. 

Plan 
Admin. 

Plan 
Ctrl. 

Sheet 
Mgr. 

Sheet 
Plnr. 

Sheet 
Rvwr. 

Modify Branch Properties X X X X   

Plan Processing X X X X   

Change Base Date X X X X   

Copy Plan X X X X   

Delete Sheet X X X X X  

Print Sheet and Sheet Definition X X X X X  

View History X X X X X  

Modify Sheet Properties X X X X X  

 

User security levels and their respective task privileges accessible from Plan Sheet List View 

Tasks System 
Admin. 

Plan 
Admin. 

Plan 
Ctrl. 

Sheet 
Mgr. 

Sheet 
Plnr. 

Sheet 
Rvwr. 

Define Template Derivatives X X X X   

Generate Sheets from Templates X X X X   

Delete Sheet X X X X X  

View History X X X X X  

Update Sheet Properties X X X X X  

View Sheet X X X X X X 

Print Sheet and Sheet Definition X X X X X X 

 

User security levels and their respective task privileges accessible from Plan Sheet 

Tasks System 
Admin. 

Plan 
Admin. 

Plan 
Ctrl. 

Sheet 
Mgr. 

Sheet 
Plnr. 

Sheet 
Rvwr. 

Update Balances X X X X   

Sheet Protection X X X X   

Apply Security X X X X   

Create Template X X X X   

Change Derivative Sheet Status X X X X   



Sage Budgeting and Planning User Guide 

32 

Save Sheet X X X X X  

Save as Spreadsheet X X X X X  

Delete Sheet X X X X X  

Editing X X X X X  

Add/Remove Dimensions X X X X X  

Update Parent Distribution X X X X X  

Consolidate All Subsheets X X X X X  

Save as Spreadsheet X X X X X X 

Save as HTML X X X X X X 

Import Spreadsheet X X X X X X 

Print Sheet and Sheet Definition X X X X X X 

View Security X X X X X X 

View Sheet X X X X X X 

View Revisions X X X X X X 

 

To summarize, the levels of security are defined as follows: 

•       Plan Administrator has full control over the entire plan including creation, security, and processing. 

•       Plan Controllers have the same control as the plan administrator with the exception of assigning 
plan security and modifying plan properties. 

•       Sheet Managers can perform any function within a plan sheet and can set up additional plan sheet 
security. 

•       Sheet Planners can change values in non-protected cells in the authorized plan sheet. Sheet 
protection will automatically be turned on when the sheet is opened. Sheet Planners can perform any 
processes in a plan sheet, except grant security, set cell protection, and perform system updates. 

•       Sheet Reviewers - can only read values in an authorized plan sheet and cannot make any changes. 

A plan can have only one plan administrator, but may have many controllers assigned to it. At the sheet 
level, only one manager can be assigned to a single plan sheet with an unlimited number of planners and 
reviewers. Note that all users must be valid users of the Sage Budgeting and Planning program itself. See 
the Sage Budgeting and Planning System Management Guide for information on creating Sage Budgeting and 
Planning users. 
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Dimensions 

What are Dimensions? 

Dimensions are the various elements that define how an organization plans and operates. Typically, 
dimensions define points of data collection or responsibility that are tracked within the various production 
systems. Typical categories are: 

•       Financial dimensions such as divisions, departments, accounts, or projects 

•       Capital dimensions such as employees or assets 

•       Revenue producing and resource consuming dimensions such as customers, salespeople, territories, or 
product/service lines 

Every organization has a unique set of dimensions that define it and it is important to decide how strategic 
and controllable those elements are. For example, one organization may choose to plan revenue by 
customers and salespeople. If you were a retail organization however, this might be impractical. Thus, 
dimensions, in the context of Sage Budgeting and Planning, define how an organization plans. 

A second consideration is how each dimension will be used in the planning process. For example: 

•       Departments – plan head count or operating costs 

•       Salespeople – plan sales units 

•       Assets – plan capital costs 

Sage Budgeting and Planning provides the framework by which any dimension may be used 
interchangeably within a plan alongside other dimensions. Dimensions can be used dynamically and can be 
analyzed within multidimensional cubes. Sensitivity analysis (what-ifs) may be performed within these 
cubes and can also be written back to the plan. 

Defining a Dimension 

In their most simplistic form, dimensions consist of a unique key value and a description. For example, a 
customer dimension may consist of a customer key and customer description. 

Dimensions may also be related. For example, a retail organization may plan revenue by store by customer 
category by product line. In a non-profit world, an organization may plan by grant by project. Thus, the 
combinations of dimensions form a unique planning and analytical framework. In Sage Budgeting and 
Planning, there is virtually no limit to the dimensions and the relationships between them that may be 
defined. 

Using dimensions allows you easy access to information from any database source that supports SQL 
Server, standard file types such as Access or Excel spreadsheets, or any data source OLE-DB compliant. For 
control purposes, you may set various restrictions to the data that may be read from these databases. 

Once dimensions are defined, they may be dynamically deployed within Sage Budgeting and Planning. 
Dimensions are seamlessly attached to plan sheets at the sheet, row, and column levels. The system directly 
reads the underlying data and makes it available to users in various places within the program. For 
example, if the user double clicks on a row dimension, it will present a list of possible values. If the user 
inserts a range of dimension values, it will automatically read the underlying database to determine the 
appropriate values. Information about the dimension value, such as the description, may be placed within 
row, column, or sheet headings. Additional attribute information may also be applied to corresponding 
custom columns. 

Dimensions are also incorporated into the calculation engine. For example, a single query could calculate 
units shipped by customer and product. The dimension variables of customer and product could be 
substituted into the query, yielding thousands of possible permutations. Dimension variables provide 
additional flexibility in retrieving multidimensional values from databases that support the OLE-DB 
standard. 
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Finally, dimensions allow you to go beyond a simple planning framework. Dimension keys, attributes and 
values can be used to generate multidimensional databases (cubes). Sage Budgeting and Planning directly 
integrates with Microsoft Analysis Services and uses analysis tools to both analyze output and adjust 
prospective plan values. Any changes made to the cube data can be “written back” to the original plan sheet 
source. 

Dimension Attributes 

As mentioned previously, dimensions in their most simplistic form are comprised of a key value and a 
description. However, there is usually additional information associated with the dimension that may be 
useful or meaningful for the planning process. That information can be classified as attributes. For example, 
an employee dimension may consist of the employee ID as the dimension key and the employee name as the 
description. Other characteristics associated with the employee record, such as hire date, social security 
number, and manager would be attributes. Attributes can be further subcategorized into standard attributes 
and linked attributes. In addition, you may assign up to eight attributes to each dimension. The key and 
description are required and expend two attributes; therefore, only six additional attributes may be applied 
to a dimension definition. 

Standard Attributes 

Think about employee information and how that data is stored. Typically most of the employee information 
such as employee ID, name, address, hire date, social security number, etc. is stored as columns in one table. 
If the employee ID is used as the dimension code and the employee name is used for the dimension 
description, all of the other columns that exist in that table are considered to be standard attributes. 

Linked Attributes 

Linked attributes are similar to standard attributes and are applied to dimensions in the same manner, 
however linked attributes provide a connection to other previously defined dimensions, and ultimately to 
additional database tables. This allows for a key value that is stored in one table to be linked to a description 
in another table. In addition, linked attributes are the only attributes that may be published out to an OLAP 
cube for analysis. 

Suppose that in planning, you are interested in knowing which salesperson is assigned to each customer. 
Also, the salesperson ID is stored in the same table as the customer information. While the salesperson ID is 
helpful, displaying the name would be more meaningful. If a salesperson dimension has been previously 
defined, with the salesperson ID as the key value and the salesperson name as the description, then the 
salesperson dimension can be assigned to the customer dimension as a linked attribute and the salesperson 
name will display instead of the key value. 

Note: The key value for the linked attribute must exist in the primary table as a standard attribute and as the 
key value in the linked table. Thus, in the above example, the salesperson ID must exist in the customer 
table and in the salesperson table. 

Dimension Types 

System Dimensions 

System dimensions are pre-configured within Sage Budgeting and Planning and may not be changed. They 
come directly from the general ledger. While these dimensions may not be changed in their structure, it is 
not required that they be used. Other dimensions can replace them. 

Using system dimensions, Sage Budgeting and Planning can read the following general ledger data, once it 
has been imported: 

•       Balances 

•       Transactions (posted and unposted) 

•       Companies 

Accounts 

The account number is automatically read directly from the general ledger. The mask of the account, which 
defines the segments in the account number, is also pre-defined. 
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Fiscal Periods 

Fiscal periods are automatically used as a column dimension within each plan sheet. These periods are read 
directly from the source ledger. 

Database Dimensions 

Database dimensions are used to retrieve data sets and source values from existing databases. The 
integration to the databases is dynamic, requiring no staging of the data. For example, a customer 
dimension may be defined by using the customer table from an accounts receivable system. 

Values may be supplied from any database that employs SQL Server, OLE-DB, or standard file formats. By 
directly integrating with enterprise data sources, you eliminate the step of having to recreate values in your 
planning and budgeting system and ensure that the latest dimension values are available. Furthermore, the 
dimension values may be used in calculations that will provide essential information to your plan. For 
example, a customer dimension may be used as a variable to retrieve the number of customer units sold by 
month. 

Tiered Dimensions 

In many cases, there may be a need to combine dimensions in a logical fashion. For instance, dimensions 
may be hierarchical, such as salespeople that are part of a territory. 

Dimensions that are related in a hierarchy are referred to as tiered dimensions. Tiered dimensions consist of 
individual dimensions that are joined together in a hierarchical structure. For example, territories may 
consist of salespeople, as illustrated below. In this example, certain salespeople belong to certain territories. 
The tiered dimension defines the possible combinations that make up this hierarchy. 

 

To build the combination of territories and salespeople, a SQL query is used. This query can relate values 
from any database, including dissimilar database sources. For example, territories may be stored in an AS-
400 database accessed using linked server connection and salespeople may be stored in a SQL Server 
database. An Excel worksheet may provide the relationship between the two. Up to four individual 
dimensions may be assigned into a tiered dimension. 

Multicompany Processing 

Database dimensions may be built in such a way that they may come from multiple companies and multiple 
databases. Creative use of company and database variables allows you to create aliases that can span 
dissimilar database structures. For example, consider a case with two different companies using two 
different customer management systems. In one customer management system the field is identified as 
customer _key and in the other it is identified as cust_code. Using variables, you may specify that cust_code 
and customer_key be substituted based on the company processed. 

Dimensions in Plan Sheets 

Assigning 
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Dimensions may be placed into a plan sheet in the row axis, column axis and/or at the sheet level. Up to ten 
dimensions may be assigned to a single plan sheet. Tiered dimensions are automatically counted as four 
dimensions towards this limit. 

Note: A Dimension may only be used once per plan sheet. If you create a Dimension named Dept and use 
in a Tiered Dimension named Loc_Dept, then you cannot use both Dept and Loc_Dept as dimensions on a 
plan sheet.  

The plan administrator, plan controller and plan sheet manager are the only users that may assign 
dimensions to a plan sheet. Dimensions may be assigned upon creation of a new plan sheet, or dimensions 
may be added or removed after a plan sheet has been saved. It is advisable to seriously consider the impact 
that adding or removing dimensions may have on subsheets, parent sheets, and the entire 
consolidation/distribution processing. The system always assumes a column dimension of fiscal periods. 
And, by default, a single row dimension of account number is assigned to a plan sheet. 

When a dimension is assigned to a plan sheet, a default range of values for the dimension may be specified 
and used to insert values into the plan sheet. This range may be overridden or changed at any time. For row 
dimensions, in addition to the dimension ranges that may be assigned, you may also select attributes to be 
applied to the row. 

Sheet Dimensions are used to assign a single overall dimension value to a plan sheet. More than one sheet 
dimension may be applied to a plan sheet however only one dimension value may be assigned for each 
dimension. 

Row Dimensions allow for the use of dimensions in the rows of a plan sheet and are aligned vertically. 

Column Dimensions are used to assign dimensions to columns in a plan sheet and are aligned horizontally. 
Because of the overall limitation of 256 columns and the practicality of working with many columns, 
dimensions with many values would typically not be used as a column dimension. 

 

To create dimensions, a user must have the appropriate authority, which is assigned by the system 
administrator in User Maintenance. See the Sage Budgeting and Planning System Management Guide for more 
details on setting up users. 

Inserting Values into Rows 

Special operations apply to row dimensions that allow you to insert rows based on ranges of dimension 
values. The dimension values inserted will be based upon an assigned range of values. 

Dimensions in Calculations 

Dimension values can be used as variables within calculations. For example, you could calculate customer 
units shipped by product line and period using the customer key and product line key as variables. Thus, 
you could set up the calculation once and run it for many possible combinations of customers and product 
lines. This information may be quite useful when analyzed with multidimensional cubes. 

Dimension Values in Headings 

You may assign dimension values to display automatically within rows, columns, or within the sheet 
header. 
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Dimensions in Templates 

Since template definitions may be defined from new or existing plan sheets, the procedure for applying 
dimensions in templates is the same as with plan sheets. Therefore, if a plan sheet was created with a sheet, 
row, or column dimension and was saved as a template definition, then those dimensions are translated 
directly to the template definition and any subsheets that are generated from the template. 

Dimensions in Models 

Models provide the means to generate multiple plan sheets based on similar structures. One component of a 
model is the defined dimensions. Each plan sheet generated out of a model may be assigned a range of valid 
dimension values. For example, you may wish to generate sales projections for each territory. Each territory 
will receive its own plan sheet. In this case, the territory would be defined as a sheet dimension and each 
territory would be created based on the change in territory key. 

Dimensions in Publication and Analysis 

Common dimensions across one or multiple plan sheets are sent to a SQL Server table and then may be 
published to an OLAP cube using Microsoft Analysis Services. Values that share common dimension keys 
can automatically be aggregated into the table or cube. Once the values are in the table or cube, they may be 
edited and optionally written back to the source plan sheets. 
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Row Structures 

A plan sheet’s row structure is similar to the structure of commercial spreadsheets. When setting up rows, 
keep in mind these basic concepts: 

•       The default dimension assigned to the row axis of a plan sheet is the system Account dimension. This 
can be changed after a new plan sheet has been created. 

•       A row can be assigned to a dimension, but is not required. 

•       If the account number is not used as a dimension, the Type and Credit Flag columns can be left blank. 

•       Using consolidation/distribution processing or plan calculations, rows can be updated from rows in 
other plan sheets. 

•       Certain columns on the left side of each plan sheet row are reserved for special program functions. The 
display of these columns can be controlled using View Options. 

•       You can insert rows manually or you can use the Insert Dimension Ranges option to automatically 
populate rows based on row dimension values. 
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Column Structures 

Introduction 

Before you start defining plan sheet columns, you should plan exactly what column structures you need. 
Careful planning will give you maximum flexibility in using your plan sheets. 

You can define up to 16 custom columns in a single plan sheet, which can be used to record information that 
further describes the dimension. For example, you may wish to add social security number and hire date to 
an employee dimension. These descriptions, also known as attributes, may be automatically or manually 
inserted in to custom columns, depending on how the dimension was defined. Custom column variables 
can be used as variables within calculations, described later in this chapter. 

In addition to custom columns, up to 256 data columns can be defined in a single plan sheet. These columns 
can display budget values, statistical factors, actual values, variances, or virtually any other type of value. 
Any value can be displayed and compared side by side. For example, budget values for future periods can 
be viewed next to actual values for completed periods, with the associated variances. 

Columns may also be assigned to column sets. Column sets are only necessary when implementing 
templates. In this case, utilizing column sets maintains the plan sheet structure so that when changes are 
made to the primary template definition, those changes will correctly filter to the subsheets. 

You can categorize your data columns into logical column groups. Column groups not only organize 
columns; they also determine how columns interact with other Sage Budgeting and Planning features. You 
can assign up to 16 column groups per plan sheet. The columns in a column group do not have to be 
contiguous. For example, you can compare actual values with budget values side-by-side, even though the 
columns are assigned to separate column groups. 

Each column, in addition to being assigned to a column group and a range of periods, is also assigned to a 
valuation type. Valuation types consist of beginning balance, net change, and ending balance. These 
valuation types are used primarily with plan calculations (discussed in the next section) in order to be able 
to reference information from multiple years and to keep track of what each column represents. By default, 
valuation types are assigned a type of net change. 

Valuation types can be viewed similarly to the way a typical general ledger processes from year-to-year. As 
each year is closed, certain ending balances are transferred to beginning balances. By designating these 
columns, plan sheet values between years can be processed. 

Here are some important ways Sage Budgeting and Planning uses column groups: 

•       Calculations are based on column groups. By assigning columns to groups, you can apply specific 
calculations to specific columns, and not to others. For example, actual type columns may require a 
separate plan calculation from budget type columns. Alternatively, you could designate separate 
groups to compute complementary calculations such as units shipped alongside the average selling price. 

•       View options allow you to hide and display columns based on column groups. For example, you could 
restrict the display to just the current year plan and hide prior year actual values. 

•       Spreading is applied based on column groups. For example, you might designate a column group 
covering all of the periods in the current year and another group covering prior and future years. If you 
specified a calculation that is to be spread over just the current year, you could restrict the calculation to 
that group. 

•       Publication is also based on column groups. Selecting the option to publish or not publish a group 
determines which values will be available for certain plan calculations and OLAP cube analysis. 

How do I Determine which Groups to Set Up? 

Here are some factors to consider: 

•       Assign columns by balance type (actual, budget, statistical). 
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•       Assign columns by the type of period presentation. For example, if budgeting in detail by period for the 
current year and summary for the next year, assign these two columns to separate column groups. 

•       Assign columns based on the plan calculation required. For example, separate groups would be 
assigned to columns that calculate units shipped for the year and columns that calculate the average 
selling price. 

•       Assign columns such as total or variance columns to separate column groups, allowing you to turn on 
and off the display of those columns as desired using View Options. 

•       Assign columns based on values to be analyzed using OLAP cubes. 

Note: Total or variance columns do not need to be assigned to a column group. You may wish to assign 
these columns to the group of columns that make up the total or variance. If you leave these columns in the 
same group, you may wish to make the valuation type ending balance. 

How do the Dates Work with Columns?  

Columns must be assigned to a range of periods that correspond to periods in your fiscal calendar. These 
dates may or may not be used in plan calculations. 

Column periods can be either absolute or relative. Absolute periods correspond to fixed periods and the 
assigned period numbers do not change, regardless of any other date changes in the plan sheet. Relative 
periods are based on the group date in the plan sheet. 

The hierarchies of these dates are as follows: 

•       The overall plan base date is always fixed. 

•       A plan sheet has a base date that can be defined as either a specified date or equal to the plan base date. 

•       A group date can be defined as either a specified date or a relative period and year offset from the sheet 
base date. For example, assume the sheet base date is for a 2003 budget. If you want to include 2002 
actual columns, you would put a year offset of -1. For 2004 budget columns, you would put +1. 

•       Column dates are defined as either a range of absolute periods or relative period offsets from the group 
date. For example, a fixed quarter for the first quarter of a calendar year would be absolute periods 1 to 
3. A rolling quarter column based on the group date would be relative periods with offsets of -2 to 0. 

If column periods are absolute, the dates will be computed based on the fiscal calendar defined in the 
general ledger. The year is based upon the group date. Therefore, if the group date is changed to a new 
fiscal year, the column dates will be recomputed to reflect this change. 

If column periods are relative to the group date, they are recomputed automatically when the group date is 
recomputed or changed. If a group with a specified date is changed, any columns with relative period 
offsets also adjust to reflect the new group date. 

In summary, column and group periods are always translated into physical dates. In the case of groups, it is 
a single date. In the case of columns, it is a range of dates. 

Tip: You can always see how the system computes the column and group dates by reviewing the date 
column in Column Manager or Group Manager. 

For example, consider a basic budget plan for the year ending 12/31/2006. Suppose management requests a 
quarterly budget for the budget year and one year of history to assist in the formulation of the budget. In 
addition, budget planners are asked to submit a total year budget for the following year (12/31/2007). 

 

The column and group dates are all relative to the sheet base date: 
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The column groups have the following attributes: 

•       A calculation is assigned to the prior year actual for comparison purposes. 

•       The current year budget is set up separately. 

•       The future year budget in the budgeting system is a total year value. 

When the 12/31/2005 budget is closed and the base plan date is changed to 12/31/2006, the prior year 
actual becomes 12/31/2005 and the future year budget is 12/31/2007. In other words, the dates 
dynamically adjust and any plan calculations can be recomputed. 
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Column View Options 

Using View Options, you can display or hide columns. This feature hides and displays columns as follows: 

•       Individually hide or display reserved columns (dimension columns, buttons, etc.) 

•       Individually hide or display custom columns 

•       Hide data columns according to their column group and valuation type. For example, you could hide 
budget columns to display only actual columns or hide detail monthly columns to display only 
summary columns. 

Sheet Options 

Using Sheet Options, you can set numerous default values at the sheet level. This feature controls special 
formatting, cell calculations, cell editing, sheet publication, and other sheet-specific parameters.  
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Plan Calculations 

Plan calculations are used to retrieve values from your system, including financial data, data from ERP 
systems and other plan sheets. Plan calculations can be used for many purposes: 

•       Compute historical information such as prior year financial actuals or units shipped 

•       Compute business drivers such as sales mix, fringe benefit ratio, or salary information 

•       Compute the results of various plan sheet values such as sales commissions calculated from sales 

•       Compute allocations of accounts or departments 

Calculation Concepts 

Plan Calculations are Reusable 

A single plan calculation can be used across multiple rows. What makes plan calculations reusable is the fact 
that they use filters and variables. Dimensions, such as a customer code or account number, are variables 
that can be passed to the calculation from the rows and/or columns. In addition, dates can be passed to the 
calculation as a variable from the columns. 

For example, a calculation consisting of the prior year balance plus 5% might be used across many rows and 
columns. The effect would be to take the prior year January increased by 5%, prior year February increased 
by 5%, etc. Thus, the row and column variables produce a cell effect. 

 

Finally, account, company, and currency variables can be overridden for every row, using special 
calculation overrides. 

Plan Calculations are Optional 

You do not have to use plan calculations in any plan sheet. Plan calculations are just one of the many tools 
available in a plan sheet. A plan sheet can consist of the following coexisting values: 

1.        Values manually keyed or copied 

2.        Values calculated from cell formulas 

3.        Values updated from other plan sheets or Excel spreadsheets using consolidation or distribution 
processing 

4.        Values calculated using plan calculations 

Plan calculations, when they are computed, always take precedence over any other source of values (i.e. #1 
through #3). In other words, if both a cell formula and a plan calculation exist for the same cell, the plan 
calculation will overwrite the cell formula. However, cell formulas and plan calculations often coexist, not 
only in the same plan sheet, but possibly even in the same row. This is possible because plan calculations 
can be restricted to only specific rows and columns. Thus, where no plan calculations exist, all cell values 
and cell formulas remain intact. 

Plan Calculations are Based upon Rows, Column Groups, and Column Valuations 

A plan calculation is defined based on a row, column group, and column valuation combination. Thus, the 
maximum number of calculations that can exist for a single row is 48 (16 maximum groups times three 
different valuation types). Plan calculations are not defined on a per cell basis because the calculations will 
intelligently use columns assigned to the group to either spread values (as discussed in the following 
section) or to perform calculations with other columns groups (and even other plan sheets). 
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For example, a single row may have two calculations. The first calculation might compute an ending balance 
using prior year actual amounts. Another calculation in the same row might use that calculated value and 
adjust it by an anticipated management increase that is entered in a completely different plan sheet. 

Sage Budgeting and Planning intelligently uses the identification characteristics of ending balance, net 
change, and beginning balance valuation identifiers. For example, a project budget could be created which 
carries over from one fiscal year to the next. As the columns identify the valuation, it is easy to compute 
monthly, quarterly and annual amounts, even with disparate project start and completion dates that may 
span years. 

By having many calculations in a row based on column characteristics, you can easily mix side-by-side 
calculations of actual, budget, and variance values. 

Tip: By manipulating valuation types (sometimes artificially), you can force multiple calculations for a single 
row. For example, you may wish to compute a minimum, midpoint, and maximum salary based on a single 
column group. You could designate a column group called Salaries and designate each of the three 
columns as beginning balance, net change, and ending balance valuation types respectively. 

Plan Calculations are Very Flexible 

Calculations can be simple or complex. A simple calculation consisting of an increase from prior year actual 
balances can be created in a few mouse clicks. More complex calculations consisting of enterprise-wide 
sources of data can also be created. 

There are three types of plan calculations: 

•       Fixed Amounts - Fixed values entered by the user 

•       Source Calculations - Simple variations of percentages or amounts from either balances or plan sheet 
values based on the account number dimension 

•       Formulas - Simple or complex calculations using a variety of data sources 

The following sources of information are available to formulas. These sources can be combined or 
manipulated. 

•       Fixed Amounts 

•       Plan Sheet Values 

•       Account Balances 

▪       Fixed or Relative periods 
▪       Actual, Budget, or Statistical Balances 
▪       Beginning, Change, Ending, or Average Daily Balance valuations 
▪       Multiple Currencies 
▪       Multiple Companies 
▪       Database Queries 

➢       SQL Server 
➢       Standard file types (Access, Excel) 
➢       OLE-DB 

Plan Calculations Can Be Computed Two Ways 

How a plan calculation is interpreted can make a dramatic difference in the results returned. Again, it 
important to note that plan calculations are attached to combinations of groups and valuation methods. 

There are two basic ways that a plan calculation can be interpreted. 

•       The plan calculation is calculated individually for each column in the group (individual columns). 

•       The plan calculation is calculated once for all columns in the group and the result is spread back to 
individual columns based on spreading criteria (entire group). 
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The definition of how the calculation is interpreted is referred to as the calculation scope. If a scope is 
defined as the entire group, you must define how to spread the calculated values back to the individual 
columns. You have two options for spreading values: 

•       Evenly 

•       By Ratios 

Ratios use database values to spread the result back. There are two additional options: 

•       Actual, budget, or statistical account balances 

•       Plan sheet values (primarily used for user-defined spreading criteria) 

How are Plan Calculations Different from Cell Formulas? 

Plan calculations and cell formulas (discussed later in this chapter) coexist in a plan sheet. The following are 
some of the differences between the two options. 

•       Cell formulas reside in memory and are live. Thus, as values change in a plan sheet, the cell formula will 
recalculate (unless turned off in Sheet Options). Plan calculations access information stored from disk. 

•       Plan calculations can access information from many different databases. Cell formulas can only access 
values from the same plan sheet. 

•       Plan calculations calculate values upon demand and have priority over cell formulas. Thus, cells 
updated from a plan calculation will overwrite any cell formulas. 

When do Calculation Results Get Updated 

Calculations results are refreshed upon user demand. This can occur multiple ways: 

•       An individual plan sheet user may refresh calculations at any point in time from the plan sheet. 

•       Using Plan Manager or Subsheet Manager calculations can be refreshed for any plan sheet within a 
user’s responsibility. The calculation operation is an option within plan processing. 

The use of calculations is varied. For example, in a single plan sheet, one calculation might update historical 
values and another might calculate a current commission cost based on planned sales. In the case of the 
calculation of historical sales, that calculation needs to occur once per planning cycle and not every time the 
plan sheet calculations are refreshed. In the case of the commission calculation, the calculation needs to be 
refreshed each time the change in sales is modeled. 

Sage Budgeting and Planning gives you the ability to restrict calculation updates originating from Plan 
Manager or Subsheet Manager (plan processing). This selection is defined in the column group and includes 
the following options: 

•       The calculation always occurs from plan processing. 

•       The calculation never occurs from plan processing. 

•       The calculation only occurs from plan processing if it meets a date range criteria. This allows you to 
define calculations that might occur based upon a rolling cycle. For example, you may wish to define a 
plan that projects a year end number based upon actual months completed plus plan values for 
uncompleted months. As actual results are completed, you could simply adjust the date range. 

Further discussion of how calculations and plan processing interact is presented later in this manual. 

Formulas 

Formulas are advanced calculations that can be used to calculate various values used in plan sheets. 
Formulas are essentially mathematical expressions, consisting of combinations of account balances, 
constants, and database queries. Any value that can be calculated with a mathematical expression can be 
computed within formulas. Here are some examples of how you might use formulas: 

•       Annualize sales for the last quarter for a fast growing company 

•       Derive account values as a percentage of previous year’s sales 

•       Group together accounts to derive a budget 
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•       Compute the average daily balance of debt for an interest calculation 

•       Use database queries to retrieve sales units from order entry 

•       Calculate purchases for project commitments 

•       Query values from other plan sheets 

 

Each formula line is identified as one of these line types: 

•       Accounts 

•       Constants 

•       Database Queries 

•       Plan Sheet Lookup by account number 

•       Plan sheet Lookup by row ID 

•       Published Data Retrieval 

•       Database queries using Linked Server definitions 

The appropriate steps to complete the line will depend on the line type selected. 

The following mathematical operands can be used to join lines together: 

•       Addition (+) 

•       Subtraction (-) 

•       Multiplication (*) 

•       Division (/) 

Lines joined by these operands form the equivalent of a left-to-right mathematical expression. The 
expression is evaluated starting at the top, and according to normal algebraic precedence. Multiplication 
and division operands are evaluated first, then addition and subtraction operands. Parentheses can be used 
at the beginning or end of a line to change the order of precedence. 

You can create an unlimited number of formulas and each formula can be unlimited in length. By 
incorporating filters and variables with each process, a single formula can be computed many times to 
return multiple values. However, the overall result of each formula is a single value. That value can consist of 
many component values, but the result is a single value. 
 

Global vs. Plan vs. Sheet Formulas 

Formulas are classified into three general categories, global, plan and sheet. 

•       Global formulas are created outside of the plan and plan sheet by users with those rights. All global 
formulas are viewable by anyone in the system and may be applied by anyone with plan sheet edit 
rights. 

•       Plan formulas are created within and attached directly to a plan. Only users with plan rights (Plan 
Admin and Plan Controller) may access the formula. If a plan is deleted, all plan formulas attached to it 
are also deleted. 
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•       Sheet formulas are created within and attached directly to a plan sheet. Only users with plan sheet edit 
rights may access the formula. If a plan sheet is deleted, all sheet formulas attached to it are also 
deleted. 

While in the Plan Formula Maintenance screen, plan formulas can be saved as global formulas or vice-versa. 
Plan formulas and global formulas can also share the same key identification, however, the plan sheet will 
always use the Plan formula if the key values are the same. 

While in the Sheet Formula Maintenance screen, sheet formulas can be saved as global formulas, plan 
formulas or vice-versa. Sheet formulas, plan formulas and global formulas can all share the same key 
identification, however, the plan sheet will always use the sheet formula if the key values are the same. 
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Consolidation/Distribution Processing 

Structure 

The nodes within a Plan Manager tree must follow an interrelated logical structure to properly work 
together. Sage Budgeting and Planning uses the following terminology to define the interrelationship of 
these nodes: 

•       Parent plan sheets define the plan sheets that either consolidate or distribute values to subsheets. 

•       Subsheets define any subsidiary components of a parent plan sheet. This includes other plan sheets and 
Excel spreadsheets. You can define up to 256 subsheets for a single plan sheet. There is no limit to the 
number of parent plan sheets in a plan tree. 

•       Flow defines how information flows at the individual row level between parent plan sheets and 
subsheets. 

•       Row ID defines a relationship with a subsheet. 

•       Parent Row ID defines a relationship with a parent plan sheet. 

Subsheets that are plan sheets (rather than Excel spreadsheets) must be part of the same plan (e.g. share the 
same plan key). 

Some examples of distributions may include: 

•       Management distributes strategic targets to many different profit centers. 

•       Plan sheets distribute calculated values based upon information received from budget participants 
(such as fringes based on salaries). 

•       An analysis is created and distributed to many other budget centers. 

Processing 

Calculations provide a means to calculate values using mathematical expressions including integration to 
outside databases (including plan sheets). However, using calculations as a means to do hierarchical type 
processing is not as efficient. Thus, hierarchical processing such as consolidation and distribution may be 
handled through a separate set of processes. Whereas calculations can occur independent of the plan tree, 
consolidation/distribution processing is based upon the tree. 

Values from subsheets (plan sheets or Excel spreadsheets) in the plan tree can process both up and down in 
Sage Budgeting and Planning. These definitions describe this process: 

•       Consolidation – Values are summarized up to a parent (bottom-up process). The action is initiated from 
the parent plan sheet or from within Plan Manager regardless of whether the subsheet is another plan 
sheet or an Excel spreadsheet. 

•       Distribution – Values distribute down to a subsidiary subsheet (top-down process). The action is initiated 
from the parent plan sheet or from within Plan Manager. However, there are several ways that the 
values can be pushed down: 

▪         Plan Sheets – The parent plan sheet pushes down the values to the child plan sheet. Alternatively, 

the child plan sheet can pull down the values from the parent. 

▪         Excel Spreadsheets – The parent plan sheet creates the new values in the child Excel 

spreadsheet. 

Note: When distributing values to an Excel spreadsheet, the system cannot merge values into an existing 
file. It will overwrite the Excel file with a new file that contains the distributed values. However, cells in the 
new spreadsheet created by Sage Budgeting and Planning can be referenced in another existing 
spreadsheet. 

Prerequisites 

•       The row ID in the parent plan sheet must match the parent row ID in the subsheet. 
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•       The column keys must match. This does not mean that the entire column structures must match, but 
simply those columns that you want to process. 

•       The subsheet must exist and be part of the plan tree hierarchy. 

•       The operation and the subsheet must also have been selected in the parent plan sheet. 

Sage Budgeting and Planning attempts to find a match based upon the hierarchy selection and the row and 
column intersection. If the relationship is found, the appropriate cells are updated. All found columns and 
rows are reported in a log report generated during the consolidation or distribution process. 

For example, a parent plan sheet can consolidate values from a subsheet, even with dissimilar column 
structures. In the illustration below, the parent plan sheet is above the subsheet in the plan manager tree. If 
Flow is selected from the parent plan sheet, all subsheets can be seen. The row ID in the parent plan sheet, 
labeled as A, is matched to the parent row ID in the subsheet, also labeled as A. The column keys in the 
parent plan sheet and subsheet are also matched. Based on this structure, the value from the subsheet is 
consolidated to the parent plan sheet. This value is labeled as B in the illustration. 

 

Parent Sheet 

 

Child Sheet 

The same process occurs with Excel spreadsheets. Sage Budgeting and Planning looks for a column 
identifier in the spreadsheet for the parent row ID. Other columns are scanned for matching relationships 
with the plan sheet. If a match is found, the plan sheet value is updated. To assist in this matching process, 
you can also restrict the spreadsheet to specific range names or coordinate ranges. 

Row IDs in the parent plan sheet must be unique. However, subsheets can have duplicate parent row IDs 
and multiple subsheets can have the same parent row ID. In these cases, the parent row ID values are 
summarized into the row ID if a consolidation action is requested. If a distribution action is requested, the 
value from the row ID is duplicated into each row containing a matching parent row ID. 

Consolidation/Distribution Processing vs. Plan Sheet Calculations 

Sage Budgeting and Planning can also consolidate values by including plan sheet values in plan 
calculations, using formulas or source calculations. However, there are a number of differences between 
using consolidation/distribution processing and plan sheet calculations: 
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•       Plan sheet calculations can be based on the account number or the row ID, but the planner must know 
the accounts or the row ID to properly configure the formula. Plan sheet table lookups can retrieve data 
across companies, plans, and sheets and the account number may be filtered. 
Consolidation/distribution updates all matches within the plan tree hierarchy. 

•       Plan sheet calculations are based on column period ranges. A given calculation can add or subtract 
column values based upon a range of requested periods, except in the case of plan sheet table lookups. 
In that case column values are retrieved based on an exact match of period dates or can add columns 
within a range, not subtract them. Consolidation/distribution processing is based on the column key 
and does not span columns. 

•       Consolidation/distribution processing is significantly faster as the entire plan sheet is loaded into the 
computer’s memory as possible matches are found. 

•       Plan sheet calculations do not enforce any security while only managers and planners can initiate 
consolidation/distribution updates. 

•       Consolidation/distribution processing is more procedural. Process and error logs are generated. 

Plan sheet calculations are best used in the following situations: 

•       Calculations, such as top-down allocations from a parent plan sheet, are needed. In this case, the value 
is not passed down directly, but is allocated based upon some factor. 

•       Supporting schedules or analyses that are not a formal part of the budgetary process, are desired. 

•       Any situations where varying time intervals need to be manipulated. An example of this would be a 
rolling project schedule where project start dates vary among fiscal periods. 

•       Evaluation of cross-company, cross-plan, cross-sheet, and cross-group information. 

Consolidation/distribution processing is more advantageous in the following situations: 

•       The value is based on a consolidation of values rather than a calculation or there is a one to one 
distribution of values. 

•       The process to be performed is dependent on the hierarchy of more than one set of plan sheets. 

Calculation Updates that are Dependent on Flow Processing 

In many cases, you may wish calculations to occur selectively, dependent upon a consolidation or 
distribution action. For example: 

•       Sales are consolidated into a territory plan sheet and the resulting commission is computed based on a 
calculation formula. 

•       Head count is distributed and a travel allowance dependent on that head count value is computed. 

•       Calculations dependent on a certain date condition, such as historical actuals for months completed, are 
recomputed. 

Calculations may be selectively processed based upon these and other criteria from Plan Manager and 
Subsheet Manager Plan Processing. 

Plan Processing 

Selecting Plan Processing provides the summary of processing operations available from within Plan 
Manager or Subsheet Manager. The following describes the order of these operations: 

1.        Calculations for the current plan sheet plan (the plan sheet highlighted when Plan Processing is 
selected) are refreshed and cell formulas are recomputed. 
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2.        Values are distributed down to subsheets in the plan tree. The distribution process occurs in order 
down each level of the plan tree. In this example, all of the values at the branch level 1 are distributed first, 
followed by level 2, etc. until all values have been distributed to the lowest level of plan sheets. Cell 
formulas are always recomputed. Optionally, plan calculations can be recomputed again in the subsheets 
immediately after the distribution. This option should be selected where the result of the distribution 
impacts any subsequent plan calculations. 

 

3.        Values are consolidated from subsheets in the plan tree. The consolidation process occurs up each level 
of the plan tree. However, each branch is fully processed from the lowest subsheet to the highest (right to 
left). As in this example, the values from the lowest level 1 are consolidated first, followed by the next 
lowest level 2, etc. until the entire plan is consolidated. Cell formulas are always recomputed. Optionally, 
plan calculations can be recomputed again in the subsheet immediately before the consolidation. This option 
should be selected where the result of the consolidation affects any subsequent plan calculations. 

 

4.        Once the plan tree is fully processed, you have an additional option to refresh calculations for the 
current plan sheet again. You should select this option when the result of either the consolidation or the 
distribution affects any subsequent plan calculations. 
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The plan sheets are individually saved after each operation. 

Note: Plan Processing may be set to begin up to 24 hours after the process is initiated. This allows you to 
set up the process before going home, but delay the start until SQL Server activity is minimized, perhaps 
after core hours or after the backup has completed. 
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Duplicating Plan Sheets 

Once plan sheets are created, they can easily be reproduced to quickly create a complete planning 
environment. 

Manual Duplication 

To duplicate plan sheets manually, you can simply change the sheet key and choose the option to insert a 
new record as described in Chapter 3. If you insert a new record manually, it will be inserted into the same 
position in the plan tree. You may wish to rearrange your hierarchy within Plan Manager or Subsheet 
Manager. 

It will typically be necessary to change dimension key values and descriptions once the copying process is 
completed. You can use the Search and Replace feature to do this quickly and easily. You may also need to 
change row IDs and can use the Row ID Generation feature to do this quickly and easily. 

Templates 

Templates are used to generate a series of plan sheets using a defined set of assumptions with similar 
structures. Templates provide the following benefits: 

•       Implementing templates is fairly straightforward. A new plan sheet is created, or an existing plan sheet 
is opened, and then the original plan sheet is designated as the template definition. Once a plan sheet 
has been saved as a template definition, multiple subsheets may be generated. 

•       By providing a central plan sheet, the process of building and maintaining multiple plan sheets is 
streamlined. 

•       Changes to the plan structure can be made in one place, and translated to linked subsheets. 

Templates assume that a group of plan sheets are relatively uniform in structure, with the exception of the 
dimension values and calculated amounts. At the time the plan sheets are generated, the template will 
determine which dimension values apply to each plan sheet, based upon the range defined in the template. 
Column and row cell formulas will automatically adjust to the number of columns and rows identified 
through the dimension values. If more than one dimension is specified, the system will create nested cell 
formulas for each dimension. 

With templates, any of the plan sheet components can be defined and translated to subsheets, including: 

•       Dimensions 

•       Attributes 

•       Custom columns 

•       Column groups 

•       Column periods 

•       Sections 

•       Sheet formatting 

•       Calculations 

•       Column comparisons 

•       Summary totals 

•       Notes 

•       Sheet Options 

•       View Options 

•       ID Generation 

Templates are a component of an existing plan tree and are identified within the plan tree with the 

Template  icon as an identifier. Templates may be used to generate any or all of the plan sheets contained 
within the tree. Templates can also be used to update or overwrite existing plan sheets by regenerating one 
or more of the plan sheets. 

Note: When plan sheets are initially generated from templates, they are created in the branch that the 
template resides in. Plan sheets must be assigned in the hierarchy once they are generated. If plan sheets 
are regenerated, the plan sheets maintain the user-defined hierarchy. 
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The process of building templates assumes a basic understanding of plan sheets, the Plan Manager tree, 
dimensions, and sections. 

To effectively start using templates, it is important to have an understanding of the purpose and content of 
the plan sheets that will be created. Information needed includes: 

•       The dimensions and possibly the attributes to be used in the plan 

•       The column layouts, including custom columns, if any, required groups and the columns in each group 

•       The column types, such as input columns, calculated columns, total columns and/or variance columns 

•       The plan sheet calculations to be applied 

•       The subtotals to be applied to dimensions on rows and/or columns 

•       The standard formatting characteristics that will be applied to the body, column, and/or row totals 

•       The role of the plan sheet in the tree hierarchy as the recipient of distributed values or the source of 
consolidated values 

•       The plan sheet manager, the status code and the revision code 

•       The range of dimension values for each dimension 

•       The sections for which the range of dimension values will be applied 

•       The sheets to be generated and how each sheet is to be separated based on any dimension key breaks 

Models 

Models are used to generate a series of plan sheets using a defined set of assumptions. Models provide the 
following benefits: 

•       By providing a single starting point, the process of building plan sheets is streamlined. 

•       Models can be selectively or completely regenerated at any time, providing “what-if” analysis. 

•       A prototype of a plan sheet is visible in the background, allowing for review prior to generating a group 
of plan sheets. 

Models assume that a group of plan sheets are relatively uniform in structure, with the exception of the 
dimension values and calculated amounts. At the time the plan sheets are generated, the model will 
determine which dimension values apply to each plan sheet, based upon the range defined in the model. 
Column and row cell formulas will automatically adjust to the number of columns and rows identified 
through the dimension values. If more than one dimension is specified, the system will create nested cell 
formulas for each dimension. 

The model wizard steps you through the process of defining a model and the plan sheet assumptions. These 
assumptions can be reviewed and revised at any time. 

Models define the following plan sheet components: 

•       Dimensions 

•       Custom columns 

•       Column groups 

•       Column periods 

•       Calculations 

•       Column comparisons 

•       Sections 

•       Summary totals 

•       Sheet Options 

•       View Options 

•       ID Generation 
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Models are a component of an existing plan tree and are identified within the plan tree with the Model 

 icon as an identifier. Models may be used to generate any or all of the plan sheets contained within the 
tree. Models can also be used to overwrite existing plan sheets by regenerating one or more of the plan 
sheets. 

Note: When plan sheets are initially generated from models, they are created in the branch that the model 
resides in. Plan sheets must be assigned in the hierarchy once they are generated. If plan sheets are 
regenerated, the plan sheets maintain the user-defined hierarchy. 

The process of building models assumes a basic understanding of plan sheets, the Plan Manager tree, and 
dimensions. 

To effectively start using models, it is important to have an understanding of the purpose and content of the 
plan sheets that will be created. Information needed includes: 

•       The dimensions to be used in the plan 

•       The column layouts, including custom columns, if any, required groups and the columns in each group 

•       The column types, such as input columns, calculated columns, total columns and/or variance columns 

•       The plan sheet calculations to be applied 

•       The subtotals to be applied to dimensions on rows and/or columns 

•       The standard formatting characteristics that will be applied to the body, column, and/or row totals 

•       The role of the plan sheet in the tree hierarchy as the recipient of distributed values or the source of 
consolidated values 

•       The plan sheet manager, the status code and the revision code 

•       The range of dimension values for each dimension 

•       The sections for which the range of dimension values will be applied 

•       The sheets to be generated and how each sheet is to be separated based on any dimension key breaks 

Before creating the model, it is a good idea to create a sample of one of the plan sheets to be built. The 
desired result can then be compared to the prototype that the model displays as you move through the 
wizard. 
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Publication and Analysis 

The advent of data warehouses and multidimensional databases has created new opportunities for in-depth 
business analysis. Microsoft Analysis Services is included as part of SQL Server 2000, SQL Server 2005 and 
SQL Server 2008. So this capability is available by simply installing and configuring the Analysis Services. 

Sage Budgeting and Planning leverages this environment as an integrated extension to the planning 
environment. The analysis is not separated from the planning process, but is integrated with it. Thus, SQL 
Server and Analysis Services can be leveraged as follows: 

•       Actual results can be sent from Sage Budgeting and Planning to a cube for analysis 

•       Results can be modeled in the cube 

•       Sensitivity analysis and modeling can be performed against the cube 

•       Plan values can be changed in the originating plan sheets using the writeback feature 

Sage Budgeting and Planning provides a closed-loop planning process by integrating multiple ERP data 
sources into plan sheets, then processing this information into SQL Server and multidimensional cubes. The 
entire process is depicted as follows: 

 

•       ERP data is leveraged from the general ledger integration, consisting primarily of accounts, segments, 
balances, and transactions. ERP data can also come from virtually anywhere in the organization, as 
long as there is connectivity to the data. 

•       ERP data can be used to define dimensions. 

•       ERP data can be used in calculations to produce values in one or multiple plan sheets. 

•       The plan sheet presents data in a spreadsheet paradigm, which is optimized for planning. Periods are 
automatically shown as a dimension across the top. Other dimensions may be strategically placed on 
any axis within the plan sheet. However, in plan sheets, the data is viewed in a linear, flat fashion. 
While this is effective for viewing large blocks of data, this is not the optimum way of slicing and 
dicing data. 

•       Data can be published to SQL Server tables for further analysis and reporting using the tool of your 
choice. 

•       Data can also be published through to SQL Server Analysis Services cubes. 

•       Data can be analyzed using the Sage Budgeting and Planning Analyzer Tool and/or Excel pivot 
tables. 

•       As data is analyzed, plan sheets may be changed using the modeling feature in Analyzer. 

This entire closed-loop process is referred to as Publication and Analysis. The components of this process are 
discussed in subsequent sections. 

Note: While Sage Budgeting and Planning shields you from many of the technical aspects of this cycle, the 
setup process assumes a working knowledge of SQL Server and a working knowledge of SQL Server 
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Analysis Services. For more information, consult the SQL Server reference guide and your database 
administrator. 

Publication Source – Plan Sheets 

The starting point for publication and analysis is plan sheets. While plan sheets have multidimensional 
components, they do not present data a relational or multidimensional format. Dimensions are presented in 
a flat, spreadsheet format that is ideal to a planning paradigm as it presents large volumes of data quickly, is 
ideal for data entry, and provides a familiar framework. However, data is not presented in its most 
optimum framework for analysis and manipulation. This is best presented in a relational and/or 
multidimensional format. Plan sheets are used as the source for the original values published to the tables. 

The following elements are essential to the publication process. 

•       Dimensions assigned at sheet, column, and row levels are published to the table 

•       Dimension key values for each of the above are used for the descriptions of the dimensions 

•       Group keys are used for separation of blocks of column data 

•       Fiscal periods are applied for period presentation 

•       Cell values - either entered data, cell formulas, or calculations, are applied to the dimensions 

Since many columns of data may be available for publication, the data sets may be restricted based on the 
column groups. Thus, a set of columns that represent actual values may be differentiated from budget or 
plan columns using column groups or measures. This allows you to choose which sets of data to publish for 
a meaningful analysis. You can also publish more than one group to the same table or cube for comparative 
analysis. 

The power of the published tables is enhanced using the Sage Budgeting and Planning calculation engine. 
Since virtually any database source can be included within a calculation, data may be passed into the 
published tables with no incremental effort. This eliminates the complex setup time of a separate 
transformation process. Furthermore, since the Sage Budgeting and Planning system is aware of fiscal 
information, it is able to intelligently transform data in a fraction of the time that it would take to transform 
data using a fiscally unaware transformation process. 

You may select entire plans, individual sheets and specific groups to publish. 

Publication Process 

Publication is the process in Sage Budgeting and Planning which makes values from the plan sheets 
available as Published Data.  This Published Data is available both inside of and outside of the Sage 
Budgeting and Planning environment.  Inside of Sage Budgeting and Planning, these values are retrieved by 
the calculation engine using Published Data Retrieval formulas. The Published Data is stored in standard 
SQL tables so it is easily available outside of Sage Budgeting and Planning by report writers and by end 
users tools such as Access and Excel. 

The first step in the Publication Process is to set the Allow Publishing option at the Plan level, which would 
allow plan sheets within the plan to be published. Not every plan sheet should be included in the publishing 
process, so individual plan sheets can be excluded using the Publish Sheet option. You can also specify 
which column groups within a plan sheet will be published. When a plan sheet that is marked for 
publishing is saved, values from the plan sheet are published into shared tables. These tables are shared for 
the following criteria: company, plan and dimension set. When a plan sheet is saved, the system will 
compare the old published data with the new published data and insert/update/delete only the net changes 
into the shared tables.   

There are two shared tables for each combination of company, plan, and dimension set; one is the 
publication change table and the other is the publication master table. During a plan sheet save, the values 
are posted to the change table, then a background process, the Publication Service, consolidates the change 
table into the master table at short intervals. In this way the publishing of plan sheet data can be done to a 
smaller change table thereby reducing the time to save a sheet. The Publication Service runs on the SQL 
Server. See the System Management Guide for information on installing the service. 
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For each combination of company, plan, and dimension set, there is a corresponding publication view which 
will union the change and master tables. This view will provide a single query source to obtain accurate 
publication results. You should use this view when accessing Sage Budgeting and Planning published data 
from your report writer or other end user tools. 

OLAP Cube Process 

When a cube definition is specified and processed within Sage Budgeting and Planning, Analysis Services 
OLAP cubes are created from the Published Data.  Sage Budgeting and Planning automatically creates all 
table properties and metadata, as long as Analysis Services is installed and configured correctly. You simply 
need to designate an OLAP cube name and cube type, the system will create the cube fact table and 
optionally the dimension tables (star schema). 

Analysis Options 

Analyzer 

Analyzer provides advanced data visualization into the multitude of possible data combinations. This tool 
allows you to interact directly with the data easily in the form of graphs and charts, with the ability to drill 
down or around the data. You can also save views of the data using the Analyzer Book feature. With 
Analyzer, you can model various scenarios and optionally make changes directly to cube data. 

Excel Pivot Tables 

You can also use Excel pivot tables to view and analyze data cubes. Views of the pivot tables can be saved.  
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WebView 

WebView is used to access plan sheets remotely using a web browser. WebView provides the following 
system benefits: 

•       Simple installation to a web server running Microsoft Internet Information Services (IIS). 

•       The installation automatically occurs the first time the user accesses the web server. 

•       Access to plan sheets for all valid WebView users. 

The following plan sheet operations can be performed when using WebView: 

•       Retrieve plan sheets based upon your current security profile 

•       Edit or enter values into any unlocked plan sheet cells 

•       Edit or enter cell formulas into any unlocked plan sheet cells 

•       Edit or enter data into any unlocked custom columns 

•       Change the status 

•       Change the revision or create a new revision 

•       Consolidate/Distribute values to one level 

•       Enter values into unlocked plan sheet cells using the Spread feature 

•       Save and submit changes 

You cannot change the structure of the plan sheet or initiate plan calculations using WebView. Also, 
template definitions and model definitions cannot be accessed using WebView. 
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ERP Configurations 

ERP configurations allow you to import and export global definitions from your Sage Budgeting and 
Planning system, including the following: 

•       Dimensions (including tiered dimensions) 

•       Global formulas 

•       Import and Export scripts 

The definitions are stored in a Microsoft Database format (mdb). You can easily transfer this information to 
other Sage Budgeting and Planning systems. 

Note: In many cases, it may be necessary to change database connection or file path information once the 
definitions are imported. 
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Custom Status Codes 

Prior to building plan sheets, you may wish to customize the status codes used in Sage Budgeting and 
Planning. The status code is used to indicate the status of an individual plan sheet. Any user who has been 
assigned access to the status codes can configure them. See the Sage Budgeting and Planning System 
Management Guide for more information on setting up this option for users. 

Status codes can also be configured to automatically customize e-mail notification to other users. Before 
using Sage Budgeting and Planning, you should establish status codes that are meaningful to your 
organization. A status code must always be assigned to a plan sheet. Default codes are created when you 
install Sage Budgeting and Planning. 
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Chapter 3 

Plan Sheet Overview 

Plan sheets are used to construct a budget plan or analysis. Plan sheets offer functionality similar to 
commercial spreadsheets, in that you can create rows and columns, type in cell values, calculate cell 
formulas, apply cell formatting, and edit cells. However, plan sheets offer advanced budgeting options that 
commercial spreadsheets do not, including a direct integration to the general ledger, the ability to 
incorporate data from other data sources, the ability to perform complex data analysis, and much more. 

This chapter discusses the basic steps of creating and maintaining plan sheets. It is also assumed that you 
have reviewed the Sage Budgeting and Planning concepts detailed in Chapter 2. 
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Creating New Plan Sheets 

From Sage Budgeting and Planning Desktop 

1.        Highlight the Plans node in the list pane of the Sage Budgeting and Planning desktop. 

2.        Click the New Sheet  icon or select File > New (Ctrl + N). The New Sheet form displays. 

 

3.        Type a unique Sheet key of up to 16 alphanumeric characters to identify the individual sheet. 

4.        Type a Description of the plan sheet of up to 40 alphanumeric characters. 

5.        Select the sheet Type from the drop-down box. Sheets may be defined as plan sheets, Excel 
spreadsheets, model definition sheets, or template definitions. Models and templates are discussed later in 
the guide. 

6.        Next, assign a Status for the sheet. You can use the lookup option to search for a list of valid status 
codes. Maintaining status codes is discussed later in this chapter. 

7.        Assign a Manager to the plan sheet. You can use the lookup option to search for a list of valid users. 
Security is discussed later in this chapter. 

8.     You may select the options Lock and Publish Sheet. These options are discussed along with other sheet 
options later in this chapter. 

9.     You may specify the Upload Company Code if want to update balances to another company. 

10.     Click Ok to create and save the sheet. You may now open the sheet and begin creating the budget 
structure. 

Column Creation Wizard 

When a new sheet is opened for the first time, this feature will allow you to easily create columns for the 
most common column layouts.  All codes, descriptions, and column headers will automatically be created.  
You can automatically create columns for Prior Year, Budget, Actual and Variance.  If the system is set up 
for 12 periods per year, then you can select between Individual Periods or Quarterly Periods.  Optionally, a 
Year-To-Date Total column can be created. 

The standard Group and Column Definition options are still available and should be used for more complex 
definitions or to modify definitions created by the wizard. 
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To Use the Column Creation Wizard 

1.        Select a base date for the sheet to be created.  The columns may be tied to this date.  Click Next to 
continue with the wizard or click Cancel to exit the wizard. 

 

2.        Select the types of columns to be created.  Then click the Next button 

 

3.        Select the number of columns to be created.  Then click the Next button.  On the next screen click 
on the Finish button. 

 

4.        Click on the Finish button. 
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Maintaining Plan Sheets 

Check-In/Check-Out Process 

Before any sheet can be edited in any way, the sheet will need to be officially checked out by the person who 
is attempting to edit the sheet. Check-Outs are done on a sheet basis, not a revision basis. This check-out 
process does not produce a record lock on the database. The application will track if a sheet has been 
checked out and by whom. All Check-Outs remain on the sheet until it has been Officially Checked-In (or if 
an administrative function was done to undo a Check-Out). Check-Outs can be maintained even if the user 
does not have the sheet open or even if the user exits Sage Budgeting and Planning.  

If the user opens up a sheet that is not checked out to them, a message box will let them know who has the 
sheet checked out. They will have read-only access to the sheet and the title bar will indicate this with the 
words [Read Only].  

Sheet icons are used to indicate the status of checked out sheets. The  icon will indicate that the sheet is 

checked-out by the current user and the  icon will indicate that it is checked out by another user. 

Sheets can only be checked out by individuals who have some sort of editing capabilities on a sheet. This 
includes Plan Administrators, Plan Controllers, Sheet Managers, and Sheet Planners.  

An option in Plan Properties indicates if Check-Outs are permitted in the Plan. If this option is turned off, 
users will not be able to Check-Out any sheets unless they are Administrators, Plan Administrators, or 
Controllers. 

All Check-In, Check-Out, and Undo activity will be logged and available in the History Reports. 

Check-In/Check-Out from Plan Manager 

Check-Out 

From the Plan Manager, a user with appropriate rights will be able to click on a sheet and check it out as 
long as it is not locked sheet or already checked out.   

1.        In Plan Manager, highlight the sheet you wish to Check-Out. 

 

2.        Click the Check-Out  icon, select File > Check Out Sheet. 

Check-In 

If the user has the sheet checked out, the user will be able to click on the sheet and choose Check-In from the 
menu.  The user will not be able check-in a sheet this way if they currently have it open for editing.  They 
will then need to check it in from the Sheet Editor. 

1.        In Plan Manager, highlight the sheet you wish to Check-In. 
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2.        Click the Check-In  icon, select File > Check In Sheet. 

All Sheets in a Branch 

Users will also be able to Check-In and Check-Out all of the sheets within a branch.  When Checking Out 
Sheets, only those sheets that they have editing security to and are not checked out to another user will be 
checked out.  When Checking-In from a branch, only those sheets that are checked-out to the user would be 
checked-in. 

1.        In Plan Manager, highlight the Branch sheet you wish to Check-In or Check-Out. 

 

2.        To Check-Out the branch, click the Check-Out  icon, or select File > Check Out Sheet. The 
following confirmation message displays: 

 

3.        Click Check Out this sheet and all attached sheets to and then click Yes Check-Out the entire branch, 
Click No to cancel the Check-Out. 
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4.        To Check-In the branch, click the Check-In  icon, or select File > Check In Sheet. The following 
confirmation message displays: 

 

5.        Click Check In this sheet and all attached sheets to and then click Yes Check-In the entire branch, 
Click No to cancel the Check-In. 

Undo Check-Out 

If the user is a Plan Administrator or Controller, the user will have the ability to undo a check-out on any 
sheet that is checked-out using the menu.  The user who had the sheet checked out will then lose their 
check-out status.  

1.        In Plan Manager, highlight the Branch for which you wish to Undo Check-Outs. 

 

Tip: Highlight the Plan Root to Undo Check Outs for all sheets in the plan. 

2.        Click the Undo Check-Out  icon, or select File > Undo Check Out Sheet. The following 
confirmation message displays: 

 

3.        Click Undo Check Out this sheet and all attached sheets and then click Yes to Undo Check-Outs for 
the entire branch, Click No to cancel the Undo Check-Out. 
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Note: If the user who had it checked out had it open for editing at this time, they will be unable to save 
their sheet and will lose all of their changes. 

Check Out Status Report 

An option will exist from Plan Manger to allow Plan Administrators and Plan Controllers to generate a 
report of all of the currently Checked-Out Plan Sheets.  It will display the Sheet Key, Sheet Name, and the 
name of the person who checked out the sheet. 

1.        Click the Plans node in the desktop Task Pane. 

2.        Click the plan for which you want to run the status report. 

3.        Select Plan > Check Out Report. . 

4.        An output log documents a list of the plan sheets that are checked out and to who has them checked 
out.. To cancel the process while it is running, click the Stop Processing button. 

 

5.     When processing is complete, the log can be printed or saved to file. 

6.     Click Close to exit. 

Check-In/Check-Out from Sheet Maintenance 

To simplify the check-in and check-out process, Sage Budgeting and Planning will assist users depending on 
the actions that they are taking.  When a user with editing rights opens an unlocked sheet, the program will 
check its check-out status.  If the user has the sheet checked-out, it will just open the sheet as normal.  If the 
sheet is available to be checked-out, it will prompt the user if they wish to check-out the sheet.  If the sheet is 
checked-out by someone else, it will inform the user that the sheet is checked-out and indicate who has 
checked-out the sheet.   

When closing down a sheet that is checked-out by the user (by closing the editor or by opening another 
sheet in the editor), it will prompt the user if they wish to check the sheet in.  This prompt will occur after 
the save process on the sheet has been completed. 

Note: A Plan Administrator or Controller can remove the Check-Out while a sheet is opened by another 
user.  Therefore, every time a sheet is saved, Sage Budgeting and Planning will confirm that the user 
still has the sheet checked-out. In this event, the user will not be able to save their sheet and any 
changes will be lost. 

Check-Out 

1.        When you open a plan sheet that you have rights to edit, you will be prompted to Check-Out the sheet. 
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2.        Click Yes to Check-Out the plan sheet or No to open the sheet in Read Only mode. 

3.        You can also Check-Out a plan sheet after it has been opened. Click the Check-Out  icon, or select 
File > Check Out. 

Check-In 

1.        When you close a plan sheet that you have checked out, you will be prompted to Check-In the sheet. 

 

2.        Click Yes to Check-In and close the plan sheet. Click No to close the sheet without checking it in. Click 
Cancel to return to editing the plan sheet. 

3.        You can also Check-In a plan sheet while it is open. Click the Check-In  icon, or select File > Check 

In Sheet. 

 

Auto Check-In/Check-Out 

The Auto Check-In/Check-Out feature allows users to automatically check-in and check-out plan sheets 
without being prompted. The settings for the Auto Check-In/Check-Out feature are stored per user in the 
registry, so these settings are machine and user dependant. 

If Auto Check-Out is turned on, the sheet will always be checked out (if able) by the user, even if they do not 
intend to make any changes. This would prevent any other user from checking out the sheet while it is being 
edited.  

If  Auto Check-In is turned on, but a plan sheet is not properly closed (power failure, application 
abnormally terminated, etc.), then the sheet will still be checked out by the user, even if the sheet is not 
open.  

When Auto Check-In is turned on, the user will not be able to hold a check-out status between editing 
sessions. They will lose their exclusive check-out whenever a sheet is closed. They would have to remember 
to turn off the Auto Check-In before saving their sheet to maintain the checked-out status.   

Auto Check-Out 

When Auto Check-Out is turned on, the user will no longer be prompted to check out plan sheets. If the 
sheet is able to be checked out for the user when opening the sheet, check-out will automatically occur.  

1.        When you open a plan sheet that you have rights to edit, you will be prompted to Check-Out the sheet. 
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2.        A checkbox is available on the check-out prompt screen labeled Automatically check out sheets upon 

opening sheets. Checking this box will activate the Auto Sheet Check-Out. Click Yes to Check-Out the plan 
sheet. You will no longer be prompted to Check-Out a sheet in the future. 

3.        You can also turn on Auto Sheet Check-Out using a menu item in the Plan Sheet Editor. This is a 
toggled menu item allowing the option to be easily turned on or off. Select File > Auto Sheet Check Out to 
turn this option on or off. 

Auto Check-In 

When Auto Check-In is turned on, the user will no longer be prompted to check in plan sheets when the 
sheets are closed. Whenever a sheet is properly closed by the user, checked in will automatically occur.  

1.        When you close a plan sheet that you have checked out, you will be prompted to Check-In the sheet. 

 

2.        A checkbox is available on the check-in prompt screen labeled Automatically check in sheets upon 

closing sheets. Checking this box will activate the Auto Sheet Check-In. Click Yes to Check-In and close the 
plan sheet. You will no longer be prompted to Check-In a sheet in the future. 

3.        You can also turn on Auto Sheet Check-In using a menu item in the Plan Sheet Editor. This is a toggled 
menu item allowing the option to be easily turned on or off. Select File > Auto Sheet Check In to turn this 
option on or off. 

 

Opening an Existing Plan Sheet 

From Plan Manager 

1.        Click the Plans node in the desktop Task Pane. 

2.        Click the plan that the desired sheet is associated with. 

3.        In Plan Manager, highlight the sheet you wish to open. 
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4.        Click the Open Sheet  icon, select File > Open Sheet (Ctrl +O), or double-click on the sheet. 

From the Plan Sheets List Pane 

1.        Click the Plan Sheets node in the desktop Task Pane. 

2.        In the Plan Sheets list view; highlight the sheet you wish to open. 

 

3.        Click the Open Sheet  icon, select File > Open (Ctrl +O), or double-click on the sheet. 

Note: The list of available plan sheets can be limited based on security that has been assigned to a user 
if the Secure Sheet Lookups option has been selected in User Maintenance. See the Sage Budgeting 
and Planning System Management Guide for more information on user settings. 

From within a Plan Sheet 

1.        You may retrieve an existing plan sheet while viewing another plan sheet by clicking the Open Sheet 

 icon or by selecting File > Open (Ctrl + O). 

2.        The Look Up Plan Sheet window displays. 
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3.        Highlight the desired plan sheet and click Ok, or double-click on the selected plan sheet. Click Cancel 
to exit without opening a plan sheet. 

Note: The list of available plan sheets can be limited based on security that has been assigned to a user 
if the Secure Sheet Lookups option has been selected in User Maintenance. See the Sage Budgeting 
and Planning System Management Guide for more information on user settings. 

Deleting an Existing Plan Sheet 

From Plan Manager 

1.        Click the Plans node in the desktop Task Pane. 

2.        Click the plan that the desired sheet is associated with. 

3.        In Plan Manager, highlight the sheet you wish to delete. 

 

4.        Click the Delete  icon, select File > Delete, or use the Del key. 

5.        The following confirmation message displays: 
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6.        Click Yes to delete the sheet and all associated revisions, or No to cancel the action. 

From the Plan Sheets List Pane 

1.        Click the Plan Sheets node in the desktop Task Pane. 

2.        In the Plan Sheets list view; highlight the sheet you wish to delete. 

 

Tip: To delete multiple sheets at the same time, hold the Ctrl key down while clicking on the desired 
sheets. 

3.        Click the Delete  icon, select File > Delete, or use the Del key. 

4.        The following confirmation message displays: 

 

5.        Click Ok to delete the selected sheet(s) and all associated revisions or click Cancel to cancel the action. 
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From within a Plan Sheet 

1.        From the Plan Sheet Maintenance window, click the Delete icon  or select File > Delete. 

2.        The following confirmation message displays: 

 

3.        Click Yes to delete the plan sheet and all associated revisions or No to exit without deleting the plan 
sheet. 

Copying Plan Sheets 

1.        To create a copy of a useful plan sheet, change one of the key values (plan key, sheet key or revision 
key) on the Main tab of an open plan sheet. 

2.        Select File > Save (Ctrl +S) from the menu or click the Save  icon. 

3.        The following message box displays: 

 

4.        Click Insert New Record. A new plan sheet is created that is identical to the original, with the 
exception of the changed key value(s). Thus, two plan sheets exist – the original plan sheet and the new, 
copied plan sheet with the altered key value(s). 

Note: Selecting Update Existing Record overwrites the original plan sheet with the altered key 
value(s). As a result, only one plan sheet exists. 

 

Tip: You can quickly create multiple copies of a useful plan sheet by designating it as a template 
definition and then generating derivative sheets. 



Chapter 3 - Plan Sheet Overview 

77 

 

Plan Sheet Components 

The following section describes some of the components necessary for constructing a plan sheet. Rows, 
columns, calculations, and advanced processes are discussed in subsequent chapters. 

Plan Sheet Security 

Plan sheet security is divided into three roles; the sheet manager, the sheet planner, and the sheet reviewer. 
Sheet managers are assigned when a sheet is created and may be changed at any time by a plan 
administrator, controller, or the sheet manager. The sheet manager typically assigns sheet access to planners 
and reviewers. For additional information on security, refer to Chapter 2. 

Sheet Manager 

Only one manager can be assigned to a plan sheet at a time. Sheet managers are assigned when a new plan 
sheet is created, however, the manager may be modified from the Sheet Properties form or on the Main tab 
of an open plan sheet. In the Manager field, type the name of the user to be assigned as the sheet manager, 
or select the user from the browse list. This action is accomplished in one of three ways: 

•       A system administrator user assigns a user as the manager of an existing plan sheet. 

•       The plan administrator assigns a user as the manager of an existing plan sheet within the plan. 

•       A user creates a new plan sheet and assigns himself/herself as the manager of that plan sheet. 

The plan sheet manager may be changed at any time; however, the user that was originally assigned as the 
manager will lose access to the plan sheet unless he or she is granted access to the sheet as a planner or 
reviewer. 

Sheet Planners and Sheet Reviewers 

Sheet managers assign sheet planners and sheet reviewers to specific sheets. This action is performed from 
directly within the plan sheet. 

1.        From an open plan sheet, click the Security Manager  icon or select Management > Security. The 
security window displays. 

 

2.        Highlight a user and in the Security Level box, select the appropriate security level. To change the 
security level, simply repeat the process and select a new security level. 

3.        When all of the necessary changes have been made, click the Close button. 

4.        Save the plan sheet to enable the changes. 

 

User Security Interface 

Management of the Sheet and Plan security can also be accomplished from the User Maintenance area by 

selecting the user desired and selecting Security  from the right click pop up menu or from the menu or 
toolbar at the top of the screen. 
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1.        From this interface you can select the plan which the desired security settings would like to be 
changed. 

2.       You can set the Plan security for the selected plan by changing the appropriate radio button for 
Controller, Administrator, or None.. 

3.       In the bottom section you can select the security level desired and check the boxes for the parts of the 
tree which you want to apply the currently selected Security Level. 

4.       Select Apply Changes or OK to save the changes for the current Plan 

 

  

Reassign User Security 
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Management of the Sheet and Plan security can also be reassigned from one user to another using the menu 

option "Reassign Security" .  

1.        Select the user you would like to remove security from and right click to access the pop up menu or 
select from the menu or toolbar at the top of the screen. 

 

2.        Assign security to a different Active User. The Preview window will display all Plans, Sheets, and 
Cube Security to be changed. 

 

3.       Selecting Ok will apply the security changes, selecting Cancel will not make the changes. 

  

Status Codes 

Overview 
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Status codes are used to indicate the state of an individual plan sheet within the planning process and must 
be applied to every plan sheet. Four system status codes are provided when Sage Budgeting and Planning is 
installed, however, these codes may be modified and additional codes may be created. Status codes can also 
be configured to automatically e-mail customized notifications to defined users. 

As part of the design process, you should create status codes that are meaningful to your organization. The 
default status codes that are supplied with Sage Budgeting and Planning include: 

•       Approved (A) 

•       Complete (C) 

•       In Process (IP) 

•       Under Review (UR) 

A status code must always be assigned to a plan sheet, thus when a new sheet is created, the default code of 
IP (In Process) is assigned to the sheet, however it may be replaced with a different code that is more 
meaningful to the plan sheet manager. 

Note: Only users who have been given permission to modify status codes may do so. See the Sage 
Budgeting and Planning System Management Guide for more information on setting up this option for users. 

Modifying Status Codes 

1.        Click on the Status Code node in the Task Pane. 

2.        To maintain an existing code, highlight the code and select File > Open from the menu or click the 

open status code  icon. To create a new status code, select File > New from the menu or click the new 

status code  icon. 

 

3.        The Status Code Maintenance form displays. 

 

4.        Type a Status Code of up to 16 alphanumeric characters and a Description of up to 40 alphanumeric 
characters. 

5.        An e-mail message may be sent to one or more users when a new or updated status code has been 
applied to a plan sheet. Click on the Set Event Message tab to define a message to be sent for this event. 
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Send Message To Options 

User Identify a specific user that the message should be sent to. This 
must be a valid user in the Sage Budgeting and Planning 
system. 

Sheet Manager The current sheet manager will receive the message. 

Parent Sheet Manager The sheet manager of the parent plan sheet, based on the Plan 
Manager tree, will receive the message. 

All Ancestor Sheet 
Managers 

All parent sheet managers of the current plan sheet will 
receive the message. 

Plan Administrator The plan administrator will receive the message. 

6.        In the Message box, type a combination of characters and variables, to be used as the body of the 
message. 

Variables 

&COMPANY& Inserts the company name, based on the company setup 
information. 

&DESC& Inserts the plan sheet description. 

&MANAGER& Inserts the name of the plan sheet manager. 

&PLANKEY& Inserts the key of the plan. 

&REVISION& Inserts the revision code. 

&SHEETKEY& Inserts the key of the plan sheet. 

&UPDATEDATE& Inserts the date the plan sheet was set to the status code. 

&UPDATETIME& Inserts the time the plan sheet was set to the status code. 

&USER& Inserts the name of the user who set the plan sheet to the 
status code. 

7.        Click Save Event Message tab to define a message to be sent any time a plan sheet is saved with the 
designated status code. The Send Message To, Message, and Variables fields are the same as those 
described above. 

http://acutedata.com
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8.      Click Ok to save the changes and return to the Status Codes listing. 

Deleting an Existing Status Code 

1.      From the list view, highlight the status code to be deleted. 

2.        From the menu, select File > Delete or click on the Delete  icon. 

Note: Status codes assigned to existing plan sheets cannot be deleted. 

Revisions 

You can edit any plan sheet revision at any time. Each revision is a complete stand-alone working plan 
sheet. Thus, each revision can have its own unique set of rows, columns and values. However, the following 
plan sheet properties apply across all revisions: 

• Description 

• Manager 

• Status 

•       Plan sheet security 

Note: Changing dimensions on a per revision basis will affect information saved to the published tables, 
possibly invalidating Plan Sheet Table Lookup calculations and processed cubes. 

Applying Revisions 

1.  To apply a revision to a plan sheet, type or change the revision key in the Revision field on the Main 

tab of the plan sheet. 

2.  Select File > Save (Ctrl + S) from the menu or click the Save  icon. 

3.        A message box displays. 

4.        To create a new revision, click Insert New Record. A new plan sheet is created with the new revision 
key. Click Update Existing Record to overwrite the original revision key. 

Selecting Revisions 

1.        Select Sheet > Revision Control from the menu, or click the Revision Control icon. 

2.        The Revision Control window displays. 
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3.        Highlight the desired revision. 

4.        Click Ok or double-click on the selection to open the revision. 

Activating Revisions 

Sage Budgeting and Planning provides the ability to designate a specific revision as the active revision for a 
plan sheet. The active revision indicates the plan sheet that is to be used for consolidation or distribution 
processing or for calculations. Thus, you can easily change revisions for various scenarios in a distributed 
budget environment. 

To activate a revision: 

1.        From the open plan sheet, select Sheet > Revision Control, or click the Revision Control  icon. 

 

2.        Highlight the revision to be designated as the active revision and apply that revision to the plan sheet 
by clicking Ok or by double-clicking on the selected revision. 

3.        Select Sheet > Active Revision from the menu to designate that the current revision will be the active 
revision. A check box will display next to the Active Revision option on the drop-down menu. 

4.        Select File > Save (Ctrl + S) or click the Save icon to activate the revision. Note that any other 
revision designated as the active revision will automatically be de-activated. 

Revision Comparison 

This tool compares two revisions of a single plan sheet.  The tool will assume that the sheets have exactly the 
same structure in row and column formats and will be comparing the two revisions for value differences 
only (not formatting, calculation, cell formulas, flow, or any other items).   

All cells that are different between the two sheets will be highlighted with a yellow background with red 
text.  If you hover over a highlighted cell, it will display the value for that cell in the other sheet.  This tool is 
for comparison purposes only so no changes can be made to the comparison sheet.  

1.  Select Sheet > Revision Comparison.  The Revision Selection dialog box displays. 
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2.  Highlight the revision to be compared, and click OK. 

Deleting a Revision 

You can delete any plan sheet revision from the Revision Control window, with the exception of the 
revision that is designated as the active revision. 

1.        Select Sheet > Revision Control, or click the Revision Control icon. The Revision Control window 
displays. 

 

2.        Highlight the revision to be deleted and click Delete. 

3.        A warning displays. 

 

4.        Click Yes to delete the revision or No to return to the Revision Control window without deleting the 
revision. If the active revision is selected, the following warning displays. 

 

5.        Click Close to exit the Revision Control window. 

Note: Deleting a plan sheet rather than a specific revision deletes all revisions associated with that plan 
sheet. 

Base Date 

Base Date Types 

There are two types of Base Dates, the Plan Base Date and the Specified Base Date. Base date represents the 
primary plan year that you are working with and can be used to drive relative group and column dates. The 
Plan Base Date allows Base Dates to be centrally controlled for a Plan without having to set them 
individually on each sheet in a Plan. The Specified Base Date allows the Base Date to be specified for 
individual Plan Sheets. 

Assigning the Base Date 

The plan sheet base date represents the primary plan year that you are working with and can be used to 
drive relative group and column dates. A plan sheet base date may be changed at any time. At that time, 
any relative dates in the group and column definitions are automatically adjusted to reflect the new base 
date. Absolute dates in the columns are also changed if the plan base date is changed to a different fiscal 
year. 

Note: The base date for multiple plan sheets can be changed by changing the Plan Base Date or by 
selecting the Change Base Date option within Plan Manager. 
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1.        To assign the plan sheet base date, set the Base Date Type to Specified Base Date, then click the 

Maintenance  icon next to the Base Date field. The Plan Date form displays. 

 

2.        In the Current Date field, type a valid date, use the spin buttons to scroll to a valid date, or click the 
lookup icon to select a valid date from a calendar. 

3.        Optionally, select the Recalc Cell Formulas option. If this option is selected, any cell functions that are 
dependent on the base date information, such as the DAYS() or NUMPER() functions, will recalculate. 

4.        Click Ok to accept the date. 

Changing the Base Date 

The base date may be changed at any time. When the base date is changed, any relative dates in the group 
and column definitions are automatically adjusted to reflect the new base date. Absolute dates in the column 
definition are also changed if the fiscal year is changed. When the base date is changed the following 
message displays notifying you of the impact of the change: 

 

Tip: The base date for multiple plan sheets can be changed by changing the Plan Base Date or by selecting 
the Change Base Date option within Plan Manager. 

Dimensions 
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Dimensions may be applied to a sheet either initially or update later.  When a plan sheet is initially created, 
the default Account Number row dimension is assigned. Dimensions may be modified or added to a sheet 
from the Sheet Maintenance screen by selecting Sheet > Dimensions. Dimensions, discussed in more detail 
in Chapter 4, may be assigned to the row, column, and/or sheet axes. Up to ten dimensions may be applied 
to one plan sheet with the default Account Number row dimension being assigned by the system. 

Note: Dimensions may not be added or removed from the Sheet Properties form accessed through Plan 
Manager. 

 

1.        To change dimensions, select Sheet > Dimensions from the Sheet Maintenance Screen.  Rows can be 
inserted, deleted, or appended to each axis. 

•          To append a dimension, click the append row  icon. The Lookup Dimension window 
displays with a list of valid dimensions to select. 

•          To insert a dimension, highlight a row and click the insert row  icon. The Lookup Dimension 

window displays with a list of valid dimensions to select. The selected dimension will be inserted 
above the highlighted row. 
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Note: Selecting All Dimensions will list System, Regular and Tiered Dimensions. Selecting 
Dimensions will list System and Regular Dimensions. Selecting Tiered Dimensions will list Tiered 
Dimensions only. 

•          To delete a dimension, highlight the row to be deleted and click the delete row  icon. 

Tip: It is important to consider the limitation of 256 columns before applying dimensions on the column 
axis. Another consideration is that the Insert Dimension Ranges and Missing Dimension Report 
features are only available for row dimensions. 

2.        In the From Value and Thru Value fields, enter a range of default values for the dimensions to be 
applied to the plan sheet. Alternatively, checking the All Values? checkbox assumes that all dimension 
values are to be used in the plan sheet. These values will be the basis for default values when using the 
Insert Dimension Values option. 

Note: Ranges are based upon individual segment ranges. 

 

Note: The range restrictions referred to here do not restrict any valid values that may be used in plan 
sheets, but are strictly defaults when Insert Dimension Values is used. You may restrict plan sheets to 
valid values in plan sheets using a WHERE condition in the dimension setup. You can also lock the 
cells in the dimension column through cell formatting. 

3.        Click Ok to automatically assign the dimension(s) to the plan sheet. 

•          The dimension key assigned will be used as the column title for any row dimensions. 

•          The default list of values as defined by the dimension setup will be displayed within the Insert 

Dimension Values window. 

Note: Dimensions may be added to or removed from a plan sheet by selecting Sheet > Dimensions 
from the menu; however, existing data may be affected by this change. 

Sheet Options 

Sage Budgeting and Planning provides a number of options for formatting and manipulating plan sheets. 

1.        To set specific options for a sheet, open the desired plan sheet. 

2.        Select Sheet > Sheet Options from the menu. 
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Sheet Options Plan Sheet Tab 

Frozen Columns This option allows you to freeze a specified number of visible 
columns. You can either type a value or use the spin buttons to 
adjust the value. 

Note: This option will also freeze these columns for printing. 

Display Row Numbers Check this box to display row numbers in the plan sheet. By 
turning off the display of row numbers, you can save screen 
real estate and see more of the working column area. 

Automatically 
Recalculate Cell 
Formulas 

Check this box to automatically recalculate any cell formulas 
each time a cell value is changed. If the box is not checked, 
cell formulas are not recalculated until you either press the F9 

key or select Sheet > Recalculate Cell Formulas. 

Edit Mode Permanent Check this box to allow edits to each cell in a plan sheet as the 
cursor moves into that cell. If the box is not checked, you can 
still edit a cell by pressing the F2 key or by selecting Edit > 

Cell Contents. 

Note: If this option is enabled, you will only be able to select 
and edit one cell at a time.  

Replace Text on Edit Check this box to automatically replace the existing contents 
of the cell with any new values. If the option is not checked, 
then any values typed in the cell will append to the end of the 
existing cell value. 

Note: This box should be checked if Edit Mode Permanent is 
selected. 
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Numeric Format Type the default numeric formats to be used for each cell, 
including the currency character, the decimal character, and 
the thousands separator. You can still override numeric 
formats on an individual cell basis. 

Grid Use these fields to control the display of grid lines. You can 
select whether to show vertical or horizontal grid lines, solid 
or dotted lines, and the line color. 

Page Breaks Select whether page breaks are visible and, if visible, the 
formatting of page breaks. 

Locked Cell Colors Use these fields to select a foreground and background color 
for Locked Cells. These cells will display this regardless of the 
colors placed on the cell directly. 

 

3.        For additional sheet options, click the Other tab. 

 

Sheet Options - Other Tab 

Calculation Options: 
Include Unposted 
Transactions 

Check this box to include the results of any unposted general 
ledger transactions in plan calculations. 

  

Calculation Options: 
Enable Calculations in 
Plan Processing 

Check this box to make any calculations defined in this plan 
sheet available from plan processing. By default, all 
calculations are available from plan processing, but can be 
individually restricted in Group Maintenance. Uncheck this 
box to disable all calculations from plan processing. 



Sage Budgeting and Planning User Guide 

90 

Dimension Options: Auto 
Dimension Description 
Entry 

Check this box to populate the Description column with the 
information defined for the Description key of the dimension 
definition. 

Dimension Options: 
Dimension Description 
Spacing 

Enter a value to determine the number of spaces before the 
default account description. 

Other Options: Publish 
Sheet 

Check this box to save the plan sheet data to the publication 
database. Published data is used to create OLAP cubes and 
for advanced calculations. 

Other Options: Publish 
Sheet (for derivative 
sheets) 

This option is only available on template definitions. Check 
this box to save the generated derivative plan sheet data to 
the publication database. Published data is used to create 
OLAP cubes and for advanced calculations. 

Other Options: Sheet 
Template 

Check this box to switch the plan sheet to a template 
definition. Once a sheet has been designated as a template, 
then multiple derivative sheets may be generated with the 
same structure as the template definition. 

Other Options: Auto 
Lock Template Row 
Changes 

This option is only available on derivative sheets. Check this 
box to automatically set the Template Row Lock column 
value to Locked for the template row you are editing. By 
default, this option will be left unchecked for newly created 
plan sheets. 

Other Options: Derivative 
Sheet 

This option identifies the plan sheet as a derivative sheet, in 
other words, a sheet that has been generated from a template. 
De-selecting this option changes the derivative sheet to a 
standard plan sheet, thus breaking the link between this sheet 
and the template definition. 
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Chapter 4 

Building Dimensions 

Dimension Components 

As discussed in Chapter 2, dimensions are a key part of Sage Budgeting and Planning and allow you to plan 
in any way that suits your unique business requirements. Certain dimensions are pre-configured, such as 
account number and time. This chapter discusses how to create additional customized dimensions in Sage 
Budgeting and Planning. 

Defining a dimension can be as simple as identifying a code, a description, and a table where the data 
resides. However, Sage Budgeting and Planning gives you the complete flexibility to define where and how 
these values will be obtained using SQL syntax and linked servers. For that reason, this chapter assumes a 
basic knowledge of SQL and linked server definitions. For a primer on SQL syntax, review Microsoft SQL 
documentation. 

Dimensions are stored in the Sage Budgeting and Planning system database, not in the company database. 
This allows you to define dimensions that can extract data across multiple company databases using 
company variables. Only authorized users can create dimensions. See the Sage Budgeting and Planning System 
Management Guide for more information on the system database and on user security. 

There are several things to consider as you build dimensions. 

•       What are the unique elements that define my business and how I plan and analyze? These are 
individual dimensions. 

•       Are there unique relationships between the elements? For example, is there a unique relationship 
between employees and departments? If there is, you can apply linked attributes to the dimension 
definition or create a tiered dimension. 

•       Do the values that make up these dimensions already exist in my system? Are they one of the supported 
database types or do they support OLE-DB? If so, these dimensions can be database dimensions. 

•       Are there proposed changes to these dimension values? Typically, if there are minor changes, you may 
wish to simply edit the values once they are inserted into a plan sheet. If there are major changes, you 
may wish to define a separate database consisting of the new values. This may be as simple as creating 
an Excel spreadsheet with the proposed values. 



Sage Budgeting and Planning User Guide 

92 

Defining a Dimension 

Overview 

A simple dimension definition requires a minimum of identifying a dimension code and description, the 
location of the data source, and a key value and description from the data source. 

1.        Click the Dimensions node in the desktop Task Pane. 

2.        Select File > New or click on the new dimension icon . 

 

5.        On the Dimensions tab, define a unique code of up to 16 alphanumeric characters that identifies the 
dimension. This code will be used to identify the dimension in the plan sheet dimension lookup. 

6.        Enter up to a 40-character description that identifies the dimension. This description will be used as the 
column header for a row dimension and the description identifies the dimension in the plan sheet 
dimension lookup. 

7.        A list of the configured companies will be displayed in Configured Companies list box with a check 
box next to each one. Select each of the companies to which the dimension will be applied. 

Note: By default, no companies will be selected when the dimension is created. You will need to select 
each company to which the dimension will be applied. However, if there is only one company 
configured, by default that one company will be selected. A warning message will be displayed when 
saving a dimension if no companies are selected. 

8.        Click the Tables tab to define the location of the data source. 
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9.        Click the New button to add a table definition. 

10.        The Dimension Table Maintenance screen displays. Click the lookup button  to add a table. 

 

 

11.     The Lookup Table screen displays a list of previously defined linked servers. Scroll through the list of 
servers, databases, catalogs, and tables. 

 

12.     Highlight the desired table and click Ok. 
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13.     Click Ok to add the table to the list on the Tables tab. 

 

14.     Repeat the above steps to join additional tables to the dimension definition. 

15.     Click the Attributes tab. An association MUST be defined between the dimension code and description 
identified on the Dimensions tab and the data source key and description for the dimension to work 
properly. 

 

16.     Type up to a 40-character name for both the Key and Description. 
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17.     From the drop-down list, select the corresponding Table.Field name. You may wish to adjust the field 
length and define a mask. 

18.     Click the Test button or the Test SQL  icon to test the SQL query syntax to ensure that the correct 
dimension values are being returned. 

 

19.     Select File > Save or click the Save  icon to save the dimension definition. 

For additional information regarding the functions of each tab, refer to subsequent sections. 

Note: The user you've defined for the SDA (System Database Administrator) is used to access 
dimension data. Before creating dimensions, you will need to give appropriate permission to the SDA 
user in SQL Server to access the data used by the dimensions. 

Dimensions Tab 

The Dimensions tab is the initial screen that is displayed when creating a dimension definition. The 
dimension code and description are entered at this point of definition the process. You will need to select 
each of the companies for which the dimension will be applied.  The ability to test the dimension definition 
and to verify expected values is also provided. Since dimensions are company-specific, dimensions may be 

tested on a per company basis. To test the dimension, click the Test button or click the Test SQL  icon. 

 

Dimension Maintenance – Dimension Tab 

Code Define a unique code of up to 16 characters that identifies 
the dimension. This code will be used to identify the 
dimension in the plan sheet dimension lookup. 
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Description Type a description of up to 40 characters that describes the 
dimension. This description will be used as the column 
header for the plan sheet row description and identifies the 
dimension in the plan sheet dimension lookup. 

Configured Companies Select all companies for which this dimension should 
apply. 

Test Dimension: 
Company 

Select a company you wish to test the dimension definition 
against. The field defaults to the company in which you are 
currently logged in. 

Tables Tab 

One of the components necessary for defining a dimension is to identify the table or tables where the data is 
stored. A list of available tables is displayed as you navigate through all previously defined connections to 
linked servers, databases, and tables. 

Note: Any data source that you wish to access MUST be defined through a linked server definition prior to 
creating a dimension definition. See the Sage Budgeting and Planning System Management Guide for more 
information on defining linked servers. 

 

The first table that is selected is considered to be the primary table. Since table names can be long or not very 
meaningful, you may define an alias of up to 40 characters. The alias is displayed for each Table.Field 
combination. 

 

In the Join section, designate the type of join (inner, right, left, full outer), the fields to be joined and the join 
criteria. Refer to Appendix D for additional information on joining tables and fields. 
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Tables may be removed from the dimension definition by highlighting the table name and clicking the 
Delete button. Also, you may update table information by highlighting the table name and clicking the 
Maintain button. 

Note: Deleting the table removes the table from the dimension definition and does not delete the actual data 
source. 

Attributes Tab 

In addition to the 2 required attributes, dimension key and description, up to 6 additional attributes may be 
applied to the dimension definition for a total of 8 attributes. Rows may be inserted, appended, or deleted 
by clicking on the appropriate icon or selecting the action from the edit menu. 

 

Dimension Maintenance – Attributes Tab 

Attribute Type You are required to define a key and description for the 
dimension. If you choose to apply additional attributes to 
the dimension, you may choose to classify them as a 
Standard Attribute or Linked Attribute. 

Dimension This field is activated only when the Attribute Type of 
Linked Attribute is selected. Select a previously defined 
dimension from the drop-down list. 

Name Type an identifier of up to 40 characters for the Attribute 

Type. This name is displayed when performing a lookup 
on an attribute. This name is also the identifier used when 
publishing the attribute to an OLAP cube. 

Dimension/Column 
Reference 

Select the Table.Column Heading that corresponds to the 
Name. The dimension data will be retrieved from the table 
and the column selected here. 
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Data Type Select a data type that best describes the attribute type. 

▪          Integer – identifies the attribute as a number. 
The default separator character is applied, 
however, you may change the separator character. 

▪          Float – identifies the attribute as a number with a 
decimal point. The character separator is set to a 
comma by default and the number of decimal 
places to be displayed is set to 2. 

▪          String – this is the most common data type and 
allows for any alphanumeric character and special 
character to be displayed in this field. You may 
also define a mask to be applied so that the data is 
displayed in a particular format. 

▪          Date – identifies the attribute as a date. You may 
define the separator and also the format of the 
date to be displayed. 

Length Define a limit to the number of characters that will be 
displayed for the attribute. All characters beyond this limit 
will be truncated.  

Mask Enter a mask for the attribute. Sage Budgeting and 
Planning uses this mask to determine how the returned 
value should be displayed. The mask defines how Sage 
Budgeting and Planning interprets the attribute value. See 
the explanation below for additional information on 
masks. 

Sep This field is activated when the data types of integer, float, 

and date are applied. You may change the default 
character to another special character such as a period, 
dash, etc. 

Decs This field is only activated when the float data type is 
selected. You may define up to 6 decimal places  

Date Format This field is only activated when the date data type is 
defined. You may select from the following formats: 

▪          DDMMYY 
▪          DDMONYY 
▪          MMDDYY 
▪          YYMMDD 
▪          DDMMYYYY 
▪          DDMONYYYY 

Masks 

Attribute masks define how Sage Budgeting and Planning should evaluate and return the key value. When 
defining a mask, enter an exclamation point (!) for the first digit of each segment and a pound sign (#) for 
other digits. Separator symbols, such as hyphens (-), may be used to separate segments. You may also use 
any other characters that occupy placeholders in the field. These characters will be fixed and not be 
substituted from the database. 

For example, a 6-character customer code defined in a customer table may be defined as !#####. If you 
wished to interpret the 6-character code as two 3-character segments, you would enter !##-!##. 

Tip: Sage Budgeting and Planning assumes that there is no mask stored in the database. In the example 
above, the 6-character code is not physically separated in the production database, but Sage Budgeting and 
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Planning will interpret it as two separate segments. This may be quite useful within the calculation engine, 
which interprets each segment individually, regardless of how it is physically stored. 

You may also wish to put other placeholder characters or even omit characters to obtain a certain result. In 
the above example !## returns only the first three characters of the customer code. If you were to specify 
!##-000, the system would return the first three characters of the customer code, then add an additional 
three zeroes with a dash separator in between. 

Tip: In this regard, consider the flexibility of the Row ID generation available from within the plan sheet. This 
can create roll-up and distribution options based on the components of the dimension. 

 

Note: Dimension segments are used in multiple places throughout the program including Insert 
Dimensions Ranges, Missing Dimension Report, Calculations, Row ID Generation, and OLAP Cube 
Creation. These options are discussed individually throughout this guide. 

Advanced Field Criteria 

In addition, you may manually type additional criteria into a freeform text box. Click on the column field to 

be edited; then click on the Edit Column  icon. 

 

Type the query text into the text box. Drop-down lists with Key Words, Fields, Operations, and Variables 
may also be selected to assist in the query building process. When the query is complete, click Ok to return 
to the Attributes Tab. 

Advanced Tab 

The Advanced Tab allows you to modify the standard dimension query. An interface is provided to 
simplify the query writing process. Restrictions may be applied by either selecting the limiting criteria from 
the drop-down lists or by typing directly into the fields. 
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In addition, you may manually type additional search criteria into a freeform text box. Click on the column 

field to be edited; then click on the Edit Column  icon. 

 

Type the query text into the text box. Drop-down lists with Key Words, Fields, Operations, and Variables 
may also be selected to assist in the query building process. When the query is complete, click Ok to return 
to the Advanced Tab. 

Variables Tab 

Dimensions are defined independently of individual company information, which allows you to define one 
set of dimensions that can be used across multiple companies. This is accomplished using variables. 
Variables are pre-processed prior to execution of the query; thus, a single dimension can retrieve 
information from multiple columns or multiple databases, depending on the company or the users. 
Accordingly, these variables will replace general parameters that have been defined, to return the proper 
resultant. These user-defined variables offer additional control over the company information selected. 

Up to 12 different parameters, including the linked server and catalog variables may be defined. The 
parameters can be any series of up to 60 alphanumeric characters. 

 

Note: Literal text in a SQL query should always begin with quotes. Otherwise, SQL Server will interpret the 
variable as a column. You may either use quotes in the variable itself or surround the &PARM& with quotes. 

 

Tip: A good use of company variables is to apply a variable when there is a single database that contains 
information for multiple companies. You could use the company variable as part of a WHERE condition to 
restrict the valid values to a specific company. 

Since the company variables can be up to 60 characters in length, you could even put a whole WHERE 
condition that is dependent on a specific company. For example, if you are dealing with a subsidiary only, 
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you may wish to restrict the values to just that subsidiary, but for the parent company, you may wish to see 
all values. 

 

Tip: Another use of company variables is a situation where you have different column values or a different 
table that might be selected, dependent on a company. For example, if a chart of accounts has four 
segments and division and department represent two of the segments, subsidiaries may plan based on 
department, while the parent company plans based on divisions. You could set up one dimension that looks 
at one column or the other, dependent on which company is used. 

You can also use the company variables as aliases that can be passed into a query. For example, if the 
Sage Budgeting and Planning database is stored in a separate database from the company data, you may 
use the company variables to specify the SQL Server database where each company’s data is stored. 

Note: When a new company is created, it will not have any dimensions active besides the pre-defined 
Accounts dimension. You will need to go through dimension maintenance and select the company for each 
appropriate dimension. 
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Tiered Dimensions 

Overview 

Tiered dimensions are those dimensions that have a hierarchical structure and a pre-defined relationship 
between the dimensions. The relationship is defined by the combination of key values between the 
individual dimensions and must be unique. Tiered dimensions consist of a combination of database 
dimensions. 

A SQL query is used to define the relationship. The SQL query can use any supported database to relate the 
dimensions. For example, a customer dimension may be defined in a SQL Server database and lead 
generation activity may be in an Access database. Through the use of linked server definitions, you could 
use a history table in the Access database to relate the customer to the lead activity or you could even use an 
Excel spreadsheet to relate them. In this way, you can relate any combination of dissimilar databases. 

Up to four individual dimensions can be combined into a single tiered dimension. Each relationship must 
then be defined to construct the tier. 

Once the tier is defined, it may be assigned to a plan sheet in the same way a single dimension is applied. 
All individual dimensions within the tiered dimension will be included automatically. Also, since tiered 
dimensions are a set, you cannot split them across row, column, or sheet axes. 

Note: To activate a Tiered Dimension for a company, each of the Dimensions that a company is based 
upon will also have to be activated for the same company. Also, the program will not permit the 
deactivation of a Dimension for a company if it is involved in a Tiered Dimension that is active for a 
company. 

Building a Tiered Dimension 

Selecting the Tiers 

1.        Click the Dimensions node in the desktop Task Pane. 

2.        Select File > New Tier or click on the new tiered dimension  icon. 

 

3.        In the Code field, define a unique code of up to 16 alphanumeric characters that identifies the tiered 
dimension. 

4.        Next, enter a description of up to 40 characters. 

5.        In the Dimension fields, use the lookup or double-click in the field to apply dimensions in the order 
that they relate to create the tiered relationship. 
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6.        A list of the configured companies will be displayed in Configured Companies list box with a check 
box next to each one. Select each of the companies to which the tiered dimension will be applied. 

Defining Relationships 

The relationship between each combination of tiers from the top to the bottom must be defined. For 
example, if you defined a tiered dimension consisting of territory, salespeople, customers, and products (in 
that order), you would need to define a relationship between: 

•       Territory and salespeople 

•       Salespeople and customers 

•       Customers and products 

Note: Each key combination must be unique. To ensure uniqueness of the key values, use either the 
DISTINCT key word in the SELECT statement or the GROUP BY statement. 

1.        To define the relationship between the dimensions, click on the Tier Definition tab. 

2.        Next, identify the tables that contain the source information. Click New to add tables to the definition. 

 

3.        Once the source tables have been identified, then the link may be defined. This can be done using the 
simple screen, or you may write an advanced SQL query by clicking on the Advanced button and typing the 
query into the text box. 
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Note: If the Advanced button is clicked after changes are made in the text box, any changes made to 
the query manually will not be saved. 

4.        You may use the company variables, defined on the Variables tab, to both connect to the databases 
and/or variables within the query itself. 

Tip: You can use a transaction database as a source for relating dimensions in a tiered dimension. 
Since most transactions will allow duplicates, you will likely need to use the GROUP BY clause to group 
the transactions by the key values. 

5.        Once the tiered dimension is defined, you may test the definition to verify that the correct results will 
be returned. On the Dimension tab, you may select the company to test against from the drop-down list, 
and then click the Test Tiers button. 

 

6.        Select File > Save or click the Save  icon to save the tiered dimension definition. 

Accounts Dimension in a Tiered Dimension 

In previous releases, when a tiered dimension was created which included the Accounts dimension, an 
account number could be duplicated in the returned range if multiple companies were stored in the same 
database. 

For this release, if the Accounts dimension is used in a tier, the dimension will automatically filter the 
accounts returned based on the current company you are in.  

Furthermore, when creating a tiered dimension, you may now edit the tier link definition source tables. 
(This also applies in the normal dimension maintenance when selecting a table.) You can use the normal 
substitution variables like &LINKEDSERVER&, &CATALOG&, &COMPCODE&, &COMPDB&, 
&COMPANY&, &PARM&, etc. This allows you to use replacement variables in the table or view name and 
vary the source view by company.  

As an example, if you created a regular dimension on tglAccounts with a filter by company, when saved, it 
will create a dimension view for each company, which is then available for use by the tier as a linker source. 
The linker source table selection can now be manually typed over, allowing use of &...& variables in the 
table name. This allows the use of multiple views which vary by company code, for example (multiple 
views already created in the database elsewhere).   

Note that these changes take affect when you save a dimension or tier. If you have an existing tier which 
uses the system Accounts dimension, it will work the previous way (i.e. no automatic company filter) until 
you re-save the tier. 
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ERP Configurations 

ERP configurations allow you to import and export global configurations from your Sage Budgeting and 
Planning system including the following: 

•       Dimensions 

•       Global formulas 

•       Import and Export scripts 

The definitions are stored in the ERPCustom.MDB file located in the directory where you launched Sage 
Budgeting and Planning. You can copy this file to other Sage Budgeting and Planning systems and use it to 
import or export dimensions. It can also be used to import or export dimensions, formulas and definitions 
between multiple Sage Budgeting and Planning systems. In some installations, the file may have been 
already installed but can be edited. 

ERP configurations may be shipped with Sage Budgeting and Planning.  If they are, then they are stored in 
the ERPConfigs74.mdb file. 

Note: In many cases, it may be necessary to change database connection or file path information once the 
configurations are imported. 

1.        From the main menu, select Setup > ERP Configurations. 

 

2.        Type a new data source code or select a list of existing data source codes. Click the Remove Data 

Source button to delete a data source code and the associated custom configurations. 

3.        If a new data source code is defined, enter a description for the data source code. If an existing data 
source code is selected, the description will be shown. 

4.        Configurations already available are displayed in the right hand section of the screen. You may export 
these configurations by using the Copy button. Click the Select All button to select all of the 
configurations for copying. You can also restrict the display to a particular type of configuration by 
selecting the Type of Configuration to View. This will restrict both the available system configurations 
and the exported system configurations. 

Tip: In the Configurations to be Imported pane, click the Type heading to arrange the configurations in 
alphabetical order. This will copy the single dimensions first, followed by the tiered dimensions. 

5.        To delete any exported configurations, highlight the configuration to delete and click the Delete 

button. 

Note: This option does not delete any system configurations. 
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6.        To delete a data source code, select the code to delete and click the Remove Data Source button. 

Note: This option deletes the source code as well as the associated saved configurations. However, 
system configurations are not deleted. 

7.        Click Close button to close the window. Any changes are automatically saved to the ERPCustom.MDB 
file. 
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Chapter 5 

Defining Columns 

Columns are an essential component of the budgeting process. They may be comprised of actual, budget, 
and statistical values; date, text, and numerical data; as well as variances, assumptions, and other calculated 
information. Columns are generally categorized into functional collections of groups, which are essential in 
computing sophisticated calculations and for analyzing data using OLAP cubes. Each plan sheet may 
contain a maximum of 256 standard columns, 16 custom columns and 16 column groups. 

This chapter discusses the basic steps of creating and maintaining columns. It is also assumed that you have 
reviewed the Sage Budgeting and Planning concepts detailed in Chapter 2. 

Note: See Chapter 3 for an explanation of the Column Creation Wizard. 
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Column Groups 

Creating Column Groups 

When you first create a plan sheet, there are no column groups or columns. If you want to use plan 
calculations, you must first create the groups and then assign columns to the groups. 

1.        To create a new group, click the Group Manager  icon or select Columns > Group Manager. 

 

Note: The group date is computed and displayed in Group Manager. 

2.        Enter a Group Key, Description and select other options. 

 

Group Maintenance 

Group Key Type up to 16 characters to identify the group. This key will 
also be used as the measure key if the plan sheet data is 
published to an OLAP cube. 

Description  Type up to 40 characters to describe the group. This key will 
also be used as the measure description if the plan sheet data 
is published to an OLAP cube. 

Group Date: Type Select either Specified or Relative. A relative offset is based 
on the overall plan base date specified in the Main tab.  
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Group Date: Specified 
Date 

If the Group Date: Type selected is Specified, type the date 
to be applied to the group. You can also use the calendar 
lookup option or spin buttons to select the date. The date 
only has to be within the desired period, and the fiscal period 
containing the date will be used. 

Group Date: Year/Period 
Offset 

If the Group Date: Type selected is Relative, select a Year 
Offset and Period Offset to be added to or subtracted from 
the overall plan base date. You can also use the spin buttons 
to adjust these values. 

Recalc Cell Formulas Check this box to force a recalculation of any cell formulas 
that are dependent on column dates such as the DAYS() or 
NUMPER() cell functions. This option is checked by default if 
the group date is changed.  

Balance Type Select the Balance Type to be used as the default type for 
columns applied to the group. Options are Actual, Budget, 
Statistical, or Plan Sheet. 

Any plan calculations that specify the group default as an 
option will use the balance type selected here. By using the 
group default in a plan calculation, you can change the 
balance type for a whole series of rows and columns. 

Use Plan Budget Code If the Balance Type selected is a Budget type, then the Use 

Plan Budget Code checkbox will appear.  Check this option 
to use the Plan Budget Code or uncheck it to specify a budget 
code.   

By default, the Balance Type  is set to a Budget type and the 
Use Plan Budget Code is checked when you create a new 
Column Group. 

Balance Code If the Balance Type selected requires a specific balance code, 
type or select a valid Balance Code. 

If the Balance Type selected is Plan Sheet, type or select a 
Plan.Sheet.Group key combination. 



Sage Budgeting and Planning User Guide 

110 

Calculation Options: 
Plan Processing 

Select one of these options to determine how calculations 
within this group will be updated when Plan Processing is 
launched from Plan Manager or Subsheet Manager. This 
option allows you to separate recurring calculations that are 
part of a plan process from those that are used to compute 
historical values. 

• Always - Select this option if the calculations in this 
group are to always be refreshed when Plan 

Processing is initiated. For example, you might use 
this option for columns that calculate a current year 
plan value. 

• Never - If calculations in this group are to be excluded 
from any consolidation or distribution processing, 
select this option. This option might be selected for 
columns that compute prior year actual values in an 
annual planning process. As these calculations 
would produce the same results over and over, there 
may not be a need to ever refresh calculations using 
Plan Processing. 

• Columns Within Date Range – This option restricts 
calculation processing to only those columns in the 
group that are within the date range defined in Plan 

Processing. The date range option might be used 
when processing a rolling plan that requires the 
computation of a rolling set of monthly actual 
values. The new historical actual value can be 
updated without updating all other historical 
values. 

Regardless of the option selected, calculations in selected plan 
sheets may still be forced to be refreshed directly from Plan 

Manager or Subsheet Manager. 

Publication: Publish  

Group 

Check this box to save the group data to the publication 
database. 

3.        Click Ok to create the new group. 

Editing Group Definitions 

You can change group information at any time, including the group key and group date. If you change the 
group key, any columns belonging to the group are changed to the new group key value. If you change the 
group dates, any relative column dates are automatically adjusted. Absolute dates are also adjusted if the 
group date is changed to a different fiscal year. 

1.        To edit a group definition, click the Group Manager  icon or select Columns > Group Manager. 
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2.        Highlight the group to be modified and double-click the selection or click the Maintain button. 

3.        Modify the group definition and click Ok to enable the changes. 

4.        If the group date was modified, the following message displays: 

 

5.        Click Ok to continue. 

Copying Column Groups 

You can copy Columns Groups including all the columns that belong to the source Group being copied. This 
can help rapidly produce Groups and Columns that are common. 

1.        To copy a group definition including the columns that belong to the group, click the Group Manager 

 icon or select Columns > Group Manager. 

 

2.        Highlight the group to be modified and click the Copy button. 
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3.        Fill in the Group Key and Description.  This key and description will then be used to generate an initial 
set of keys and descriptions for the Destination Column Key(s) and Description(s) in the Grid.  The 
destination key(s) and descriptions(s)  can then be modified if so desired.  Once a value has been entered 
into any of the destination column(s) and/or destination description(s) – this value will not be replaced by 
the automatic generation of Destination Key(s) and/or Description(s).  

Note: The Caption of the Form shows the Source Group (Group being copied). 

 

4.        Set the Group Date, Balance Type, Calculation Options and Publication settings. 

5.        Select where you would like to have the new columns placed in the sheet.  Append new columns will 
append to the end of the sheet.  Insert Columns will place the new columns to the right of the source 
column(s). 

6.        Press the OK button and the columns will be inserted.     

Note: All columns can be modified or moved using the Column Manager 

 

Deleting Column Groups 

1.        To delete a group definition, click the Group Manager  icon or select Columns > Group Manager. 
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2.        Highlight the group(s) to be deleted. 

3.        Click the Delete button. When you delete a group, any columns belonging to that group will also be 
deleted and following warning message is displayed: 

 

4.        Click Yes to delete the selected group(s) or No to exit without deleting any groups or columns. 
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Creating Columns 

Creating Standard Columns 

1.        To create a new column, click the Append Column  icon. A new column can also be created using 

Column Manager which is opened by clicking the Column Manager icon or selecting Columns > 

Column Manager. 

 

Note: Column dates are computed automatically and are displayed in Column Manager. These dates 
are critical to plan calculations and updates to other systems. If you set up a column without a 
corresponding valid fiscal period date, you will receive an error message. Any plan calculations that are 
dependent on dates will not process correctly. 

2.        From Column Manager, click the Insert or Append button. 

 

Column Maintenance 

Column Key Type up to 16 characters to identify the column.  

Group Key Select from a list of valid column groups to assign the column 
to. You can also leave the column unassigned by selecting 
<none>. If a column is not assigned to a group, that column 
will not be available for plan calculations. 

Column Description Type up to a 40-character description to describe the column. 
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Valuation Select the Valuation method for this column. Options include 
Beginning Balance, Net Change, and Ending Balance. 

Only Net Change valuation columns can incorporate 
spreading techniques described in plan calculations. 

Also, only Beginning Balance and Net Change valuation 
columns can update the general ledger integration budget or 
statistical tables. 

Column Set Key If the column is part of a column set, the column set key is 
displayed. Column sets are only used when implementing 
templates, which are described in detail later in this guide. 

From/Thru Period: Type Select Absolute for an absolute range of periods or Relative 
for a relative range of periods. Periods are based on the group 
dates. 

From/Thru Period: Period Type the period number to use with this column. The period 
number processed is based on the selection made in the 
From/Thru Period: Type fields. Negative numbers work 
backwards from the group date. Positive numbers work 
forwards from the group date. 

Recalc Cell Formulas Checking this box will force a recalculation of any cell 
formulas that are dependent on column dates such as the 
DAYS() or NUMPER() cell functions. This option is checked 
by default if the column dates are changed.  

Column Title Type up to 255 characters of text. Text will word wrap 
automatically. You can also embed variable codes for values 
such as column dates.  

 

Column Title Variables 

&COLKEY& Column key value 

&COLDESC& Column description 

&COLNO(alpha)& Alphabetic column number 

&COLNO(numeric)& Numeric column number 

&DIMENSION(code[,fmt])& A specified column dimension code displayed optionally 
with the format mask. For example, if a salesperson code is 
ABC01 and the format is !##-!#, then the salesperson code 
displayed would be ABC01 without the format and ABC-01 
with the format. 

&DIMENSIONSEG(code, 
seg)& 

A specified column dimension segment. For example if the 
account number is 1234-567-890, and the second segment is 
designated to display, then 567 appears in the column 
heading. 

&DIMDESC(code)& A specified column dimension description. 

&PERNO(from)& Beginning period number identified in the column 

&PERNO(thru)& Ending period number identified in the column 

&PERBEGIN(‘Short 
Date’)& 

Beginning period date in short date format 

&PERBEGIN(‘Long 
Date’)& 

Beginning period date in long date format  
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&PERBEGIN(format)& Beginning period date in a user-defined format 

For example: (yyyy/mm/dd), (mm/dd/yyyy), (mmm-yyyy). 

&PEREND(‘Short Date’)& Ending period date in short date format 

&PEREND(‘Long Date’)& Ending period date in long date format 

&PEREND&(format) Ending period date in a user-defined format 

For example: (yyyy/mm/dd), (mm/dd/yyyy), (mmm-yyyy).  

 

3.        If column dimensions have been established, click the Dimension Values tab. 

 

a.        Type or select a dimension value for the column. 

b.       Click Ok to complete the action or click Cancel to close the Column Maintenance 
window without creating the column. 
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Custom Columns 

Creating Custom Columns 

While standard columns are assigned to a range of periods and are typically used for numeric values, 
custom columns contain non-numeric as well as additional numeric data. These columns are typically used 
to provide additional information about a row dimension value. Custom columns can be formatted to allow 
for text, date, numeric values, or dimension attributes. Custom columns may be used in cell formulas and 
standard cell formatting can be applied to all column types. Custom columns always display to the left of 
standard columns with a limit of up to 16 custom columns defined. 

Note: For attribute information to display, custom columns must be created prior to inserting the dimension 
ranges. 

1.        To create a custom column, click the Append Custom Column  icon. You can also use the Custom 

Column Manager by clicking the Custom Column Manager  icon, or by selecting Columns > Custom 
Column Manager. 

2.        From Custom Column Manager, click the Insert or Append button. The New Custom Column form 
displays: 

 

Custom Column Maintenance 

Column Key Type up to 16 alphanumeric characters to identify the column.  

Description Type up to a 40-character description to describe the column. 

Column Set Key If the column is part of a column set, the column set key is 
displayed. Column sets are only used when implementing 
templates, which are described in detail later in this guide. 

Dimension Attribute Additional row dimension information can only be displayed 
in custom columns. Click on the browse button and choose 
the attribute to be displayed in the custom column. The Data 

Type and Format fields are automatically populated with the 
type and format information defined for the attribute. The 
default is (None). 

Data Type Select from a list of valid data types, including Text, Date and 
Numeric. Depending on the data type selected, various 
formatting fields will be available. When creating a new 
custom column, the default data type is Text. 

Format This field changes depending on the Data Type selected. 

Column Title Type up to 60 characters of text. Text will word wrap 
automatically. You can also embed variable codes for values 
such as the column description. Variables are described in the 
previous section. 
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3.        Type a Column Key and Description for the custom column. 

4.        Assign an attribute or define the data type and formatting characteristics. 

5.        Define the column title information. 

6.        Click Ok to apply the custom column to the plan sheet or click Cancel to close the New Custom 

Column window without creating a custom column. 

Custom Column Types 

Attribute 

1.        To apply an attribute to the custom column, click the lookup button for the Dimensional Attribute 

field. 

2.        Select the attribute to be applied to the custom column. 

Note: The Data Type and Format fields are automatically populated with the type and format 
information defined for the attribute. The default is (None). 

 

3.        Click Ok to apply the attribute to the custom column, or click Cancel to cancel the action. 

Text 

If Text is selected as the data type, the Format field is available. Type pound signs (#) to designate the 
maximum number of characters the field will contain. You may also include separators within the mask. For 
example, a social security number is formatted as ###-##-####. 

 

Date 

If Date is selected as the data type, choose a date format from the drop-down list. Select Show Century to 
display a four-digit year, instead of a two-digit year. Type a character, such as a forward slash (/), in the 
Separator field to designate the separation between month, day and year. 
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Numeric 

If Numeric is selected as the data type, select the number of decimal places the values in the column will 
display. If a separation between thousands is desired, select Separator and type a character, such as a 
comma, in the field. 
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Formatting Column Headers 

Column Header formatting allows you to change the font, alignment, or protection attributes of the column 
header. 

1.     To format the column header, click on the column heading. The entire column will be highlighted. 

2.        From the menu, select Columns > Header Format (Ctrl+F3). 

 

3.        You may format the header alignment, the font, and you may lock the column. 

4.        Click Ok to apply the formatting changes. 

5.        Save the plan sheet to retain any formatting changes. 
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Copying Columns 

Once you set up a new column, you can easily copy the structure to other columns. Since the column key is 
unique, you must simply modify the column key for the new column. Depending on the date type applied 
to the column, you may find it necessary to edit the periods. 

Using Toolbar Icons 

1.        Highlight the column to be copied. 

2.        Click the Copy Column  icon 

3.        In the Copy Column or Copy Custom Column screen, type in a Column Key. 

 

4.        Next, specify the column position. The new column will be inserted to the right of the highlighted 
column. 

5.        Click Ok to create the new column or Cancel to exit without creating a new column. 

Using Column Manager or Custom Column Manager 

1.        Open Column Manager or Custom Column Manager. 

2.        Highlight the column to be copied. 

 

3.        Click the Copy button and complete the Copy Column or Copy Custom Column screen. 
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Inserting Columns 

UsingToolbar Icons 

1.        Highlight the column to the right of where you want to insert the new column. The column type to be 
inserted, standard or custom, will depend on the column type highlighted. 

2.        Click the Insert Column  icon. 

3.        Complete the New Column or New Custom Column screen. 

Note: If column sets have been defined in the template definition, then new columns cannot be inserted 
into an existing column set of the derivative sheet. See the Templates section for additional information 
on column sets. 

Using Column Manager or Custom Column Manager 

1.        To insert a standard column, click the Column Manager  icon or select Columns > Column 
Manager. 

To insert a custom column, click the Custom Column Manager  icon or select Columns > Custom 
Column Manager. 

2.        Highlight the column that is positioned to the right of where you want to insert the new column in the 
plan sheet. The new column will be inserted above the highlighted column in Column Manager or Custom 
Column Manager. 

 

3.        Click the Insert button. 

4.        Complete the New Column or New Custom Column window. 

Note: If column sets have been defined in the template definition, then new columns cannot be inserted 
into an existing column set of the derivative sheet. See the Templates section for additional information 
on column sets. 
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Deleting Columns 

Using Toolbar Icons 

1.        Highlight the column(s) to be deleted. 

2.        Click the Delete Column  icon. A confirmation warning displays. 

 

3.        Click Yes to delete the selected column(s) or No to exit without deleting any columns. 

Note: If column sets have been defined in the template definition, then columns cannot be deleted from 
the column set of the derivative sheet. See the Templates section for additional information on column 
sets. 

Using Column Manager or Custom Column Manager 

1.        To delete a standard column, click the Column Manager  icon or select Columns > Column 

Manager. To delete a custom column, click the Custom Column Manager  icon or select Columns > 
Custom Column Manager. 
2.        Highlight the column(s) to be deleted. 

 

3.        Click the Delete button. A confirmation warning displays. 

 

4.        Click Yes to delete the selected column(s) or No to exit without deleting any columns. 

Note: If column sets have been defined in the template definition, then columns cannot be deleted from 
the column set of the derivative sheet. See the Templates section for additional information on column 
sets. 
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Moving Columns 

Columns can be moved at any time, unless the columns are part of a column set in a derivative sheet. 
Remember that columns in a group do not have to be displayed contiguously; however, all custom columns 
are grouped to the left of standard columns. There are several ways to move a column. 

Using Toolbar Icons 

1.        Highlight the column(s) to be moved. 

2.        Depending on whether you want to move the column(s) to the left or right: 

a.        Click the Move Column Left  icon to move the column(s) to the left. 

b.       Click the Move Column Right  icon to move the column(s) to the right. 

Note: If column sets have been defined in the template, then those columns in the derivative sheet 
cannot be moved within or outside of an existing column set. See the Templates section for additional 
information on column sets. 

Using Column Manager or Custom Column Manager 

1.        To move a standard column, click the Column Manager  icon or select Columns > Column 

Manager. To move a custom column, click the Custom Column Manager  icon or select Columns > 
Custom Column Manager. 
2.        Highlight the column(s) to be moved. 

 

3.        Use the arrow buttons on the right of the window to change the column(s). Moving columns up in 
Column Manager moves the columns to the left on the plan sheet. Moving columns down in Column 

Manager moves the columns to the right in the plan sheet. 

Note: If column sets have been defined in the template, then those columns in the derivative sheet 
cannot be moved within or outside of an existing column set. See the Templates section for additional 
information on column sets. 
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Importing Rows and Columns from an Excel Spreadsheet 

Another way you can create rows and columns in a new plan sheet is by transferring information from an 
Excel spreadsheet. This process is used primarily for creating new plan sheets and not for merging Excel 
data into existing plan sheets. An Excel spreadsheet can also be designated as a subsheet within Plan 
Manager or Subsheet Manager. 

The following basic rules apply when importing rows from an Excel spreadsheet: 

•       Reserved columns are imported by matching the column titles to the plan sheet fields of Type, 
[Dimension Name], CR, and Description. 

•       Additional columns are loaded from left to right in the plan sheet. 

•       Columns are generated with the spreadsheet headings assigned as column titles. 

•       Rows are imported in the plan sheet under the column titles. 

•       Information will not be inserted into the Flow, Notes, or Calc fields. 

•       Sections and custom columns and will have to be maintained manually once the import is complete. 

When importing an Excel spreadsheet into an existing plan sheet, the following rules apply: 

•       The contents of the plan sheet are wiped out and any sections, groups or named ranges are removed. 

•       Any columns or custom columns are replaced. 

•       Views, page breaks and plan sheet options (on Plan Sheet tab) are reset to the defaults. 

•       The sheet and revision information are kept intact. 

•       The parent and tree location are kept intact. 

•       Dimensions, ID generation, Sheet Security and other plan sheet options (on Other tab) are kept 
intact. 

Note: After importing, columns will need to be assigned to column groups and further plan sheet 
maintenance will be required to take advantage of other Sage Budgeting and Planning program features. 

 

Note: The import function wipes out the current plan sheet and replaces it with the imported values. Flow, 
Calc, Group and Section definitions will be lost during import, thus you cannot merge values into an existing 
plan sheet structure. Best practice is to create a new plan sheet and then import the Excel spreadsheet into 
the new sheet. 

 

Tip: For a good idea of the spreadsheet format for an adequate import, use the Save As Spreadsheet 
option. This option is discussed in chapter 10. 

 

Follow these steps to create a blank plan sheet and then import an Excel spreadsheet into it: 

1.        Highlight the Plans node in the list pane of the Sage Budgeting and Planning desktop. 

2.        Click the New Sheet  icon or select File > New (Ctrl + N). The New Sheet form displays. 
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3.        Type a unique Sheet key of up to 16 alphanumeric characters to identify the individual sheet. 

4.        Type a Description of the plan sheet of up to 40 alphanumeric characters. 

5.        Set the sheet Type to Plan Sheet, using the drop-down box.  

6.        Next, assign a Status for the sheet. The default status codes may be used or you may create your own. 
You can use the lookup option to search for a list of valid status codes. Maintaining status codes is discussed 
later in this chapter. 

7.        Assign a Manager to the plan sheet. You can use the lookup option to search for a list of valid users. 
Security is discussed later in this chapter. 

8.     You may select the options Lock and Publish Sheet. These options are discussed along with other sheet 
options later in this chapter. 

9.     You may specify the Upload Company Code if want to update balances to another company. 

10.     Click Ok to create and save the sheet.  

11.     Open this newly created Plan Sheet., which will start the Column Creation Wizard.  Click Cancel to 
stop the Wizard. 

 

12.     Click No at the confirmation screen. 
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13.     The blank Plan Sheet will appear. 

 

14.     Select File > Import Spreadsheet. On the Import Spreadsheet screen, type or browse to the path that 
contains the spreadsheet to be imported. You may restrict the information that is imported from the 
spreadsheet by completing the Range Name or Specified Coordinate fields. 

 

15.        Click Ok to process the import. A log report displays the results of the import process. You may print 
the report or save it to a file. 

16.     Click Close to exit the output screen. 
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Chapter 6 

Defining Rows 

Row Options 

A plan sheet's row structure is similar to the structure of commercial spreadsheets. When setting up rows, 
keep in mind these basic concepts: 

•       The default dimension assigned to plan sheets on the row axis is Accounts. Both the dimension and 
the axes can be changed when you create a new plan sheet. 

•       A row can be assigned to a dimension, but is not required. If Accounts is not used as a dimension, 
the Type and Credit Flag columns should be left blank. 

Certain columns on the left side of each plan sheet row are reserved for special program functions. Some of 
these columns may or may not be displayed depending on the settings defined in View Options. The 
options are discussed in summary below, but are detailed in various other sections of this user guide. 

Row Options 

Type Select whether this row is to update budget or statistical balance 
tables in an integrated general ledger. If the Type field is blank, Sage 
Budgeting and Planning does not update these tables for this row. 

Template Row 
Action (only 
available on 
template 
definitions) 

This field is only available in sheets that have been designated as a 
template definition. The action specified here determines if row 
information is to be passed on to generated derivative sheets. 

•          Ignore - If the row action is set to this option, then any 
changes made to the template for this row will not 
transfer down to the derivative sheet. 

•          Replace - If the row action is set to this option, then any 
changes made to the template for this row will replace the 
row values of the derivative sheet. 

Note: If no action is selected or the field is left blank for a row, then 
the replace action will be executed. 
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Template Row Lock 
(only available on 
derivative sheets) 

This field is only available in sheets that have been generated from 
a template definition. The action specified here determines if row 
information is to be passed on to generated derivative sheets. 

•          Unlocked - If the row lock option is set to unlocked, 
then any changes made to the template will be transferred 
to the row in the derivative sheet. 

•          Locked - If the row lock option is set to locked, then any 
changes made to the template will not be transferred to 
the row in the derivative sheet. 

Note: If no option is selected or the field is left blank for a row, then 
it is considered to be unlocked and will accept changes from the 
template. 

Section Designates the section the row belongs to. This column is not 
visible by default but may be displayed using View Options. 

Parent Row ID The parent row ID to be used in consolidation/distribution 
processing will display or can be entered. This column is not 
visible by default but may be displayed using View Options. 

Row ID The row ID to be used in consolidation/distribution processing 
will display or can be entered. This column is not visible by default 
but may be displayed using View Options. 

Dimensions Type the dimension value for this row. You can also select from a 
list of valid dimensions using the lookup window. When the 
complete dimension is filled in, the system automatically 
completes the Description column, unless the auto complete 
option turned off in Sheet Options. 

The dimension value must be completed if using the following 
program features: 

•       Plan calculation(s) with dimension variables, including 
formulas and source calculations. 

•       Spreading of values in a source calculation using account 
number as the basis. 

•       Updating budget or statistical general ledger tables using 
the account number dimension. 

A partial dimension value can be entered, particularly if the 
dimension is formatted with segments. However, if the row value 
will be updated to the budget or statistical tables, an entire account 
number must be entered. 

CR Check this box to indicate that the normal balance of the account is 
a credit balance. For budgeting purposes, the number is displayed 
as a positive number.  

You can also check this box to reverse the sign of a plan 
calculation. For example, when computing sales values from a 
general ledger, a credit balance will return a negative value unless 
this box is checked. 

Description Type in a description for this row. This can be any combination of 
up to 255 characters. The description defaults to the dimension 
description when inserting a dimension, unless the auto complete 
option is turned off in Sheet Options. The description is for 
information purposes only. 
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Flow This button is used to define the sheets that are involved in 
consolidation/distribution processing. 

Notes Select this button to enter a note that will be attached to this row. 

Calc This button allows you to define plan calculations for this row or 
specific columns in the row. 

Company Code The company code from the override tab of the plan calculation 
will be visible or can be entered here. This column is not visible by 
default but may be displayed using View Options. 

Currency Code The currency code from the override tab of the plan calculation will 
be visible or can be entered here. This column is not visible by 
default but may be displayed using View Options. 
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Row Manipulation 

Inserting Rows 

1.        Highlight one or more rows. The number of rows inserted depends on the number of rows 
highlighted. 

2.        Click the Insert Row  icon or select Rows > Row Control > Insert. 

3.        Rows are inserted above the highlighted row(s). 

Appending Rows 

Rows may be appended to the bottom of a plan sheet by clicking the Append Row  icon or by selecting 
Rows > Row Control > Append. 

Deleting Rows 

1.        Highlight the row(s) to be deleted. 

2.        Click the Delete Row icon or select Rows > Row Control > Delete. 

3.        The remaining rows are moved up in the plan sheet. 

Update Dimension Attributes 

You can update Row Attributes by selecting Rows > Refresh Current Row's Dimension Attributes. This 
will reevaluate any attribute column on the row and update it with current information. It will also update 
which Account Dimension columns are available based on the Account number entered on the row. The 
description column of the sheet will also be updated with current descriptions based on the values entered. 

You can update Row Attributes for all rows in the plan sheet by selecting Rows > Refresh All Dimension 

Attributes. 
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Row Values 

Inserting a Dimension Range 

Sage Budgeting and Planning provides a special feature that inserts one or more rows into the plan sheet 
based on a range of dimension values defined. During the insert, the following columns are updated: 

• The Type column is identified as Budget if the account number dimension is used. 

• Values are inserted into the dimension code columns. 

• If the account number is used as a dimension and the account number has a typical credit balance, 
the CR column is checked. 

• The dimension description is inserted into the Description column, if the auto complete option is 
checked on the Sheet Options. If there is more than one row dimension, the descriptions will be 
concatenated using the dash (-) separator. 

To insert a range of dimension values, complete these steps:   

1.        Move the cursor into the row below where the dimension values will be inserted. 

2.        Select Rows > Insert Dimension Ranges. 

3.        In the Insert Range screen, type the From Value and Thru Value range for the dimension. The default 
values displayed originate from the values defined in dimension setup.  You can also select from a list of 
valid dimension values by using the lookup window, or to insert all dimension values, check the All 

Values? checkbox. 

 

4.        If you are inserting account ranges, select the account balance type, Actual, Budget or Statistical. 

5.        Click Ok to insert the dimension range into the plan sheet. 

 

Example: 

As mentioned previously, Sage Budgeting and Planning evaluates account numbers on a segment-by-
segment basis. The following examples display the account numbers that will be returned for the designated 
range based on the account numbers listed below. 
The account dimension is used and the chart of accounts consists of the following: 

6000-100-100-00 

6000-200-100-00 

6000-100-200-00 

6000-200-200-00 

7000-100-100-00 

7000-200-100-00 

7000-100-200-00 
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7000-200-200-00 

 

The following are examples of account ranges and their results: 

 
 

Results in      6000-100-100-00 

                7000-100-100-00 

 

 
 

Results in      6000-100-100-00 

                6000-200-100-00 

                7000-100-100-00 

                7000-200-100-00 

 

 
 

Results in      6000-100-100-00 

                6000-200-100-00 

                6000-100-200-00 

                6000-200-200-00 

 

Note: You cannot use masked positions (?) in this form. By using segment ranges, Sage Budgeting and 
Planning offers the same flexibility as a mask applied to a dimension table. For example, the account range 
0000-100-000-00 to 9999-100-999-99 yields the same results as an account mask of ????-100-???-??. 

Missing Dimension Report 

The Missing Dimension Report compares the requested dimension values range to the dimension values 
listed in the plan sheet. This report is useful in identifying dimension values that may have been added to 
the data source after the plan sheet was created, such as in the case of an employee dimension. For example, 
the report will detect if an employee name has been added to the payroll database and is not listed in the 
plan sheet. 

1.        Select Rows > Missing [Dimension Name] Report. 

 

2.        Type or lookup the From Value and Thru Value range to evaluate. 

3.        Click Ok to process the report. Sage Budgeting and Planning retrieves a valid dimension set from the 
data source, based on the range indicated, and compares it to the values in the plan sheet. 

4.        The system displays all dimensions that are missing from the plan sheet. You may choose to print the 
results or save to disk. 

Find and Replace Dimension Values 
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Once you create a plan sheet format, you may want to "clone" it to other plan sheets. You can copy a plan 
sheet by changing the sheet key and/or revision key. Since the dimension value may be unique to the plan 
sheet, you may want to change a particular dimension segment to another value. The Find and Replace 

utility allows you to do that for any part of or the entire plan sheet. 

1.        Move your cursor to the starting point in the dimension column from which to conduct the process. 

2.        Select Edit > Replace [Dimension Name] (Ctrl + H). 

 

3.        Type the Find Mask for the dimension value to locate. If your cursor is on the dimension column, this 
field defaults to the dimension highlighted. You can also type a mask for the dimension consisting of 
specific values and question marks (?). 

4.        Type the Replace Mask in a similar way for the value to replace. 

5.        Select whether to replace the Entire Document (plan sheet) or Selected Rows. To replace selected 
rows, those rows must be highlighted prior to opening this utility. 

6.        Click Replace to replace only the highlighted value. Click Replace All to replace the entire document 
or selected rows. 

7.        If you select to only replace one value at a time, you can also click Find Next to locate the next value. 
The Find and Find Next options are also available directly from the Edit menu. 
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Importing from an Excel Spreadsheet 

Another way you can create rows and columns in a new plan sheet is by transferring information from an 
Excel spreadsheet. This process is used primarily for creating new plan sheets and not for merging Excel 
data into existing plan sheets. Read Importing Rows and Columns from an Excel Spreadsheet in Chapter 5 
for detailed instructions on this feature. 



Chapter 6 - Defining Rows 

137 

Defining Flow 

This procedure of defining flow identifies individual rows for consolidation or distribution processing. The 
actual consolidation and distribution process, known as Plan Processing, is discussed in Chapter 12. 

Overview 

An individual row can be used in consolidation and distribution processing in the following ways: 

• Included in consolidation up to a parent plan sheet 

• Receive a distribution from a parent plan sheet 

• Receive the results of consolidated values from other subsheets (plan sheets or Excel spreadsheets) 

• Send a distribution to other subsheets (plan sheets or Excel spreadsheets) 

Any or all four of these operations may be performed from an individual row in a single plan sheet. This is 
possible because Plan Manager hierarchy may be multi-level. Thus, a single row may consolidate values 
from subsheets and in turn be summarized into other plan sheets. 

Row IDs identify how the rows are to be grouped together when performing consolidation/distribution 
processing. There are two types of row IDs: 

• A row ID defines the consolidation and distribution row grouping from subsheets under the current 
plan sheet in the branch. The row ID must be unique in a plan sheet and the row ID must match the 
corresponding parent row IDs in the rows of selected subsheets. 

• A parent row ID defines the distribution and consolidation row grouping into plan sheets above the 
current subsheet in the branch. The parent row ID does not have to be unique to the plan sheet. 
Any parent row IDs that are the same in rows of the subsheets are summarized into a single value 
during consolidation. The parent row ID is matched to the row ID in the parent plan sheet. 

When establishing a row ID, only those plan sheets established as subsheets in Plan Manager or Subsheet 
Manager will be visible.  In order for the rows to be processed, the column keys in the parent plan sheet and 
subsheets must match. However, the exact column structures or even the order of the columns do not have 
to match. 

Defining Row IDs 

1.        Go to the individual row to define the row ID. 

2.        Click the Flow button. 
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3.        In the Consolidate From and Distribute To sections, determine which action should be taken and 
which sheets will be affected by the operation. 

4.        If the Selected Sheets option is chosen, highlight one or more subsheets in the appropriate list. 

5.        Type the Row ID to consolidate from and/or distribute to the selected subsheets in the branch. By 
default, the system assigns a sequential number. You can override the default value by typing in a more 
meaningful ID of up to 64 alphanumeric characters. 

6.        Type the Parent Row ID to consolidate from and/or distribute to a parent plan sheet in the plan tree. 
While the parent row ID is defined in the plan sheet, it must match the row ID of the parent plan sheet and 
the subsheet must be selected for the consolidation/distribution operation. 

7.        Click Ok to assign the IDs to the row. The Flow button for this plan sheet row is now displayed in bold 

type indicating that flow has been defined for the row. 

Troubleshooting Duplicate Row IDs 

Row IDs must be unique in an individual plan sheet; therefore, if the row ID is not unique, then the 
consolidation or distribution process will fail. Using the Duplicate Row IDs utility will help you find 
duplicate row IDs within a plan sheet and they can be corrected. 

1.        Select Rows > Flow > Find Duplicate Row IDs. 

2.        Sage Budgeting and Planning generates a list of duplicate row IDs. 

 

3.        In the Duplicate Row ID screen, highlight a row and click the Go To button. The cursor will go to the 
Flow button of the row that contains the duplicate row ID. 

4.        Click the Flow button to modify the row ID. 

5.        Click the Run button to run the process again as needed. 

6.        Click Close to exit the screen. 

Automatic Row ID Generation 

Rather than establishing row IDs or parent row IDs on an individual basis, they can be automatically 
created for all rows in a plan sheet based upon a combination of dimensions or dimension segments. These 
IDs can also be updated based on changes to the component dimension values. 

1.        Select Sheet > ID Generation. From this window, row IDs and parent row IDs can be generated based 
upon all or portions of row dimensions. The process is the same for both Row IDs and Parent Row IDs. 
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ID Generation Options 

Row IDs: Automatically 
Generate 

Select this option to set the generation options and to create row 
IDs for all of the rows in the plan sheet. 

Row IDs: Refresh IDs Select this option to automatically update the value for the row 
IDs when a dimension value or segment is changed. 

Row IDs: Check for 
Duplicates 

Select this option to search for duplicate row IDs. If duplicate 
row IDs exist in a plan sheet, then the consolidation and 
distribution process will not run. 

Row IDs: Consolidate 
All Sheets 

This will set the Flow option Consolidate From, All Sheets. 

Row IDs: Function Create the row ID format by typing and/or using the Insert 

Dimension and Insert Dimension Segment options. 

Parent Row IDs: 
Automatically 
Generate 

Select this option to set the generation options and to create 
parent row IDs for all of the rows in the plan sheet. 

Parent Row IDs: 
Refresh IDs 

Select this option to automatically update the value for the 
parent row IDs when a dimension value or segment is changed. 

Parent Row IDs: 
Function 

Create the parent row ID format by typing and/or using the 
Insert Dimension and Insert Dimension Segment options. 

2.        To generate Row IDs and/or Parent Row IDs, select the Automatically Generate option. 

3.        Optionally select any additional processing options. 

4.        Enter the function to be used to define the format. The function can be manually typed or can be 
inserted using Insert Dimension or Insert Dimension Segment. The function can be a combination of user-
defined characters and values from the dimension. 
a.        To use the entire dimension value, click Insert Dimension and highlight the dimension. Select the 

Format Dimension Value option to format the dimension. For example, if a salesperson code is ABC01 
and the format is !##-!#, then the salesperson code would display as ABC-01 with formatting or as 
ABC01 without formatting. Click Ok to continue. 
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b.       To use one or more segments of the dimension, click Insert Dimension Segment. Highlight the 
dimension and define the segment to be used by either typing the segment number or by using the spin 
buttons. Segment definitions are defined when the dimension is created and are identified with the ! 
symbol at the beginning of the segment. Click Ok to continue. 

 

5.        Once the row ID and parent row ID information has been defined, click Ok to create and insert the IDs 
in the Flow setup. 

Note: IDs will only be generated for rows that have a dimension defined, therefore, you may need to 
modify Flow for any row that should not have row or parent row IDs. 
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Row Notes 

Introduction 

Row notes can be used for any number of purposes. Several examples include: 

•       Explaining any assumptions used in the budgeting process 

•       Documenting the process of developing the values in the row 

•       Explaining variances 

Notes are automatically stamped with the user ID, date, and time and may be consolidated from or 
distributed to other plan sheets. Similarly to Microsoft WordPad or Notepad, plan sheet notes are text fields 
that can accept up to 32,000 characters per individual note. 

Creating a New Note 

1.        On any row, click the Notes button. The note displays initially with the user ID, date, and time 
stamped in the first line of the text box. 

 

2.        Next, type text into the note field. 

3.        Click Ok to save the new note or click Cancel to exit the note without applying any changes. 

Editing an Existing Note 

1.        On any row, click the Notes button. Initially, the note is in a read-only mode. 

 

2.        To add comments or to modify existing information, click the Edit button. 

3.        A new user, time, and date stamp is automatically inserted, and the note may be edited. 

4.        Type any additional text in the note. 

5.        Click Ok to save the new note or click Cancel to exit the note without applying any changes. 

Note: Notes are stored and sorted in descending order from the newest note to the oldest note. 
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Chapter 7 

Cell Functions 

Once rows and columns have been created in the plan sheet, there are several options available in Sage 
Budgeting and Planning to populate plan sheet cells. 

•          Type a specific value 

•          Type a cell formula 

•          Define a plan calculation to update the cell with calculated values 

•          Define a row ID to update values from other plan sheets using Plan Manager and Plan 
Processing  

•          Spread a value across multiple columns  
 

Note: If you type a value or a cell formula into a cell and then later define a plan calculation or a row ID that 
references the same cell, Sage Budgeting and Planning will overwrite the existing value or cell formula with 
the computed results. 

In addition to the standard spreadsheet functions, Sage Budgeting and Planning also supports special 
budgeting-specific functions. A list of these cell functions can be found in Appendix C. 
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Spreadsheet Operations 

Editing Cells 

To edit a cell, press F2 or select Edit > Cell Contents. This highlights the existing cell and allows you to 
make changes. The first value you type overwrites the cell value, unless the Replace Text on Edit check box 
in Sheet Options is disabled. 

Sage Budgeting and Planning supports standard spreadsheet cut, copy, and paste operations. However, 
these operations differ slightly from commercial spreadsheets in that the paste area must be at least as large 
as the area cut or copied. 

Filling Cells 

You can also copy values across plan sheet cells using the Fill operation. Highlight the cell(s) you want to 
copy and then highlight the cells to fill with the copied value(s). 

Fill Actions 

Edit Menu  Shortcut Key Action 

Fill Right Ctrl + R Fills values to the right of the cell based on 
the cell furthest to the left in the selected 
range. 

Fill Down Ctrl + D Fills values down based on the cell at the top 
of the selected range. 

Fill Left None Fills values to the left of the cell based on the 
cell furthest to the right in the selected range. 

Fill Up None Fills values up based on the cell at the bottom 
of the selected range. 

Clearing Cell Values 

1.        Highlight the cell(s) to be cleared. 

2.        Select Edit > Clear. 

3.        Choose whether to clear Values Only or Formulas and Values. If you clear values only, any defined 
cell formulas will be retained. 

Tip: You can also press the Delete key to delete formulas and values. 

 

Spread Values Tool 

Spreadsheet values may be entered or re-calculated by using the Spread Values tool. The Spread Values 
Tool is a useful tool for spreading values across the cells in a column group. Values may be spread evenly, 
or by ratios, according to the existing pattern for the data in the affected column group. 

To use the Spread Values tool, select the row you want to affect, then select Row > Spread Values, or select 
Spread Values... from the right mouse click menu. The following dialog box is displayed: 
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1.        Choose the spreading approach from the Spread Options box. The default spreading option is 
Evenly. 

Spread Options 

Evenly Divides a defined amount evenly across the total number of 
affected columns. 

By Ratio Divides a designated amount across affected columns based 
upon the ratio assigned to the column. 

Fill Fills the defined amount into every affected column. 

 

Note: The default setting for Spread is Evenly. If you are editing existing data, the By Ratio option should 
be selected to ensure that the data contained in each column is accurately reflected. 

2.        Select the column Group and Valuation Type to be affected from the Group Filters box. 

3.        Use the Amount Scratch Pad to compute the value to be spread. The total value for the selected 
group will be displayed in the Quantity box. You may use this value, change it by entering a new 
value, or compute a new value by choosing an Operation (* / - +) and entering a Rate. 

4.        Click on Calculate Values to update the Spread Amounts per Column grid which shows the 
amounts that will be entered in each column. Un-check any column that you don't want affected by 
the Spread Values Tool. 

5.        Click on OK. 

6.        A confirmation will appear. Click on Yes to write the values to the sheet. 

 

Note: Values entered by the spread values tool are treated as cell entries, and will be overwritten by any cell 
calculations or by consolidation and distribution from other sheets.  

 

Cell Notes 

Notes may be entered in an individual cell.  Notes are automatically stamped with the user ID, date, and 
time. If a note is entered, a red dot will be displayed on the upper right hand corner of the cell.  Moving the 
mouse over the cell will display the note. Note entry and editing is done in a pop-up note editor.  
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To enter a cell note, right click on a cell and select  Add/Edit Cell Notes... from the right mouse click menu.  

To delete a cell note, right click on a cell and select  Delete Cell Notes... from the right mouse click menu. 

Note: Cell notes are for display only and cannot be printed.  Consider using Row Notes instead of Cell Notes 
since they can be printed and consolidated.  
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Cell Formulas 

Sage Budgeting and Planning cell formulas are very similar to formulas found in commercial spreadsheets. 
Most standard spreadsheet functions (referred to as cell functions) are available. In addition, there are 
several cell functions that have been developed that apply specifically to a planning and budgeting 
environment. Note that Sage Budgeting and Planning supports limited click and drag actions when defining 
cell formulas. 

Operands 

Sage Budgeting and Planning plan sheets support the following mathematical operators: 

Symbol Operation 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

^ Exponent (raising to a power) 

& Logical AND 

| Logical OR 

: Range indicator 

> Greater Than 

< Less Than 

= Equal To 

<> Not Equal To 

Cell References 

As in commercial spreadsheets, cell references can be relative, absolute, or mixed. You can copy formulas 
between cells and the copied formula will adjust for any relative referencing. 

 
Example: 

P$10 refers to relative column P and absolute row 10 

$P10 refers to absolute column P and relative row 10 

$P$10 refers to absolute column P and absolute column 10 

 

Copying P$10 to cell R15 yields R$10 

Copying $P10 to cell R15 yields $P15 

Copying $P$10 to cell R15 yields $P$10 

 

Cell Names 

A particular cell or a range of cells may be assigned a User Defined Name.  These cells may be referenced in 
formulas by using this name.  The Name string can contain up to 255 characters and can include letters, 
numbers, or underscores. The first character must be a letter or an underscore. 

To create a name, first select the cell or range to be named, then select New from the Named Range drop-
down Menu. 

When plan sheets are generated from templates: 
If a named range is included in a template, it will be added to the derivative sheet. 
If the named range already exists in the derivative sheets, it will be overwritten. 
If a named range is deleted from a template, it will not be deleted from the derivative sheet. 
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When named ranges are manually added to a derivative, it is recommended they be named in such a way 
that it is unlikely that the template will have a named range of the same name, so overwrites would be 
avoided. 
 

Note: See Chapter 11 for an explanation of Templates and Derivatives. 

 

Cell Functions 

Syntax 

Every function description includes a syntax line. For example, the syntax line for the AVERAGE function is 
AVERAGE(value1[,value2[,.]]). 

In the syntax line, optional arguments are included in brackets ([ ]). All other values are required. If you do 
not type the required arguments to a function, you will not be able to type the function in a cell. In the 
preceding example, the argument for value1 is required, but value2 is not. 

Note: When typing the syntax into a cell, do not type the brackets. They are displayed here only to 
distinguish required arguments from optional arguments. 

When an argument is followed by an ellipsis (...), you can have more than one argument of that data type. 
You can have up to 30 arguments for some functions, as long as the total number of characters in the 
formula does not exceed 1024. Also, no individual string can be longer than 255 characters. For example, the 
syntax for the MAX function is MAX(value1[,value2[,.]]). 

Any of the following formulas would be allowed: 

•       MAX(26) 

•       MAX(26,31) 

•       MAX(26,31,29) 

Functions with an empty set of parentheses after the name take no arguments, although you must include 
the parentheses for the function to be recognized. 

  

Arguments 

Many argument names tell you what kind of information to use as the argument. If the abbreviation value, 
values, or number appears in the name of the argument, that argument must be a number, cell reference, or a 
logical value. Similarly, words like places refer to the number of decimal places in the function. All 
arguments are explained in the detailed function listing in Appendix C. 

Arguments are the information that a function uses to produce a new value or perform an action. 
Arguments are always located to the right of the function name and are enclosed in parentheses. All 
arguments for Sage Budgeting and Planning cell functions are expected to result in numerical values. For 
example, you can give the SUM function any of the following four types of arguments, which produce a 
number or numbers: 

1.        A value that is a number, such as SUM(1,10,100) 

2.        A formula that results in a number, such as SUM(0.5+0.5,AVERAGE(5,5),10^2) 

Using a function as an argument to a function, as in the preceding example, is called nesting functions. 
In this example, the AVERAGE function is an argument to the SUM function. You can nest an unlimited 
number of functions in a formula. 

3.        A reference to a cell or range of cells that contains a number or a formula that results in a number, such 
as SUM(P1,P2) or SUM(P1:P4) 
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The second example above is equivalent to the formula SUM(P1,P2,P3,P4). An advantage of using the 
range form is that the argument P1:P4 counts as only one argument, while the other form counts as four 
arguments. If you wanted to add more than 30 numbers, you would have to use the range form, 
because you can only use 30 arguments in a function. 

Arguments to a function can be any of the following: 

      Numbers 
      Logical values 
      References 
You can also use the reference type of argument to provide numbers or logical values to a function. 

Examples of numbers are 5.003, 0, 150.286, and -30.05. Numbers without decimals are called integers. 
Examples of integers are 5,0,150, and -30. Numbers are accurate to 15 decimal places. 

Logical values are TRUE and FALSE. Logical arguments can also be statements such as P10>20 that 
evaluates to TRUE or FALSE. 

Examples of references are $P$10, P10, or $P10. References can refer to single cells, ranges, or multiple 
selections, and can be relative, absolute, or mixed. When you use a reference as an argument that is 
supposed to be a number or logical value, the contents specified by the cells specified by the reference are 
used as the argument. 

Functions that return references display the value contained in the reference instead of the reference. 

You must separate individual arguments with commas, but be careful not to type extra commas. If you 
specify an optional argument, you must specify all of the optional arguments preceding it in the function. 
For example, the function DAYS(1,3) will calculate the number of days from period 1 to period 3. For this 
function, the syntax is 

DAYS([fromperiod[,thruperiod[,excludesaturdays[,excludesundays]]]]) 

In this example, the optional argument is left off to exclude Saturdays and exclude Sundays. These 
arguments will default to include these days. If you specify that you want to exclude Sundays, then you 
must specify all of the arguments since the excludesundays argument is the last one in the function. Thus, the 
appropriate syntax would be DAYS(1,3,0,1) where 1 is the argument to exclude Sundays. 

For most arguments, the value substituted for an omitted argument is 0 or FALSE depending on the data 
type of the argument.  
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Chapter 8 

Plan Calculations 

Calculations provide extensive power to access data from your enterprise production systems as well as 
from other plan sheets. This chapter provides step-by-step instructions for creating and manipulating 
calculations. A basic understanding of plans sheet calculation concepts is assumed. Refer to Chapter 2 for 
additional information. 
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Initiating Calculations 

Plan calculations are defined for any given row by clicking the Calc button. If this is the first calculation 
defined, a grid of blank cells displays. 

 

 

As indicated in the above graphic, the column groups defined for the plan sheet are listed vertically and the 
valuation types are listed horizontally. Only the column definitions that have been configured in the sheet 
are displayed.  Each column created in the plan sheet and assigned to a column group will fit one of these 
categories. Clicking in any grid cell displays a list of affected columns assigned to that column group and 
valuation. 

The grid forms the 48 plan calculations that can be assigned to a specific row. By clicking on the drop-down 
list for each of the grid cells, you can define an independent plan calculation for the columns belonging to 
that column group and valuation type. 

By default, all columns assigned to the column group are affected by the plan calculation. You can deselect 
any columns that should not be affected by the plan calculation. 
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Amount Calculations 

Amount plan calculations insert specified values into the row/column intersection. Selecting the Amount 

option from the drop-down displays the following form: 

 

Amounts Options 

Amount Type a fixed value. You can use the spin button to adjust 
amounts up or down. The value can be as high as 1 billion and 
can include as many as 4 decimal places. 

Rounding Factor Enter a precision factor to round the result. This factor can be 
anywhere from 1 million to 0.0001. You can use the spin 
buttons to adjust amounts up or down. 

Note: The rounding value is a factor and not the number of 
decimal places. Thus, to round to the nearest 10, type 10. To 
round to the nearest 50, type 50. Rounding primarily applies in 
this case to where the fixed amount will be spread over 
multiple columns. If the fixed amount is applied to each column 
individually, you can simply adjust the fixed amount without 
using rounding. 
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Source Calculations 

Overview 

You can calculate values using account balances and plan sheet values for specific periods by using source 
calculations. You also have the flexibility to increase the account balance by a specified Amount or a 
Percentage and round the results.  Source calculations are only available if you have specified the account 
number dimension in your plan sheet. 

Sage Budgeting and Planning uses the Account Number dimension as the source account to calculate the 
value.  The Account Number can be overridden with values in the Overrides tab, discussed later in this 
section. 

Selecting the Source option from the drop-down displays the following screen: 

 

Source Calculation 

Source Year Select from the current year or up to ten prior years. 

Note: The source year is based on the column dates. Thus, if 
budgeting for a 2009 column and 2008 actual values are 
needed, specify the source year Prior Year 1. 

Balance Type Select the balance type to use for the source calculation. 
Options include: 

•       Group Default 

•       Actual 

•       Budget 

•       Statistical 

•       Plan Sheet 

Group default uses the balance type specified for the group in 
the Group Maintenance form. This option makes it easy to 
change multiple plan calculations in a column. Group default 
and plan sheet options are explained in more detail later in 
this section. 

Balance Code If the selected balance type requires a specific code, type a 
valid balance code or use the lookup to choose a balance 
code. If you are using plan sheet values, you can type a valid 
Plan.Sheet.Group key combination. Optionally, you may 
leave this field blank and the values will be evaluated from 
the column group. This option is explained in more detail 
later in this section. 
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Adjust Calculation By You can adjust the calculated result by a fixed amount or a 
percentage. Type the amount or percentage or use the spin 
buttons to adjust the value. Amount adjustments can range 
from 0.0001 to 1 billion. Percentage adjustments can range 
from 0.0001 to 1000. 

Rounding Factor Enter a precision factor to round the result. The factor can be 
anywhere from 1 million to 0.0001. You can use the spin 
buttons to adjust amounts up or down. 

Note: The rounding value is a factor, not the number of decimal 
places. For example, to round to the nearest 10, type 10. To 
round to the nearest 50, type 50. 

Differences in Source Calculations Based on Valuation Type 

Source calculation options differ depending on the valuation type of the columns selected (beginning 
balance, net change, ending balance). The following are the options available based upon each valuation: 

Valuation Source Calculation Option 

Net Change Source Net Change 

Ending Balance Source Ending Balance 

Beginning Balance Source Beginning Balance 
Source Ending Balance 

Essentially, the character of the source calculation stays with the column valuation type. A beginning or 
ending balance column in a group corresponds to start-of-year or end-of-year values such as in a carryover 
of a balance sheet or project value. Change values on the other hand correspond to period activities such as 
income statement values. For example, a source net change calculation is specified for a series of quarterly 
columns in a group. If Source Year: Prior Year 1 is specified, the equivalent quarterly period balances for the 
prior year will be returned. 

If a source ending balance is specified for a column with a valuation type of ending balance, the ending 
balance at the end of the last period defined in the column for the year specified will be returned. For 
example, if you specified the column to be a range of periods 1-3, a source ending balance calculation will 
return the balance at the end of period 3. Remember that the source year is relative to beginning and ending 
column dates. 

Note: More extensive manipulation of period balances can be done using formulas. 

Group Defaults 

You can use the group default balance type on a source calculation to quickly change a whole series of 
calculations. Suppose you have created a detailed budget for the fiscal year. Once you are into the new fiscal 
year, you now want to do a pro-forma financial statement through the end of the year consisting of 
completed month actual results and budget for uncompleted months. 

1.        Create a group for completed months with the default balance type as actual. 

2.        Assign any columns for months completed to the completed months group. 

3.        Set up a source calculation as current year and the balance type as group default. 

4.        As months are completed, reassign the column to the completed months group. 

Tip: Another option is to use the selective recalculation option from Group Maintenance. Simply select the 
option to compute calculations for the group based on a date range. You may then selectively process the 
calculation from plan processing for only the new completed month and avoid processing all of the 
completed months each time. In this case, you would keep the group the same for all of the columns, but 
manipulate the results through the date ranges. Selective recalculation is discussed in the next section. 
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Plan Sheet Values in Source Calculation 

You can include other plan sheet values in a plan calculation. Plan calculations using plan sheet values work 
similarly to plan calculations using account balances. The plan sheet components that the plan calculation 
requires are as follows: 

•       Account numbers from each plan sheet, unless overridden in the Overrides tab. 

•       A plan, plan sheet and group combination in the form of Plan.Sheet.Group (with periods separating 
the key values). You can also use the lookup window in the Balance Code to retrieve any eligible 
combinations. This will identify the specific portion of the plan sheet that you want to include in the 
calculation. Optionally, if you leave the field blank, the calculation looks to the column group to 
resolve the field. While the current open plan sheet can be used, the system does not read values in 
memory. Thus, you must save the plan sheet before these values will be incorporated into the 
calculation. 

•          Column date ranges correspond exactly to the dates of the column using the calculation. To apply 
flexible period ranges, a formula should be used. 
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Formulas 

The third calculation type is a defined formula. Formulas are essentially mathematical expression that 
provides the ability to calculate plan values using combinations of balances, constants, database queries and 
plan sheet values. By incorporating filters and variables, a single formula may be regenerated many times, 
however, the overall resultant of each formula is a single value. Formulas are discussed in more detail in the 
next chapter. 

Selecting the Formula option from the drop-down displays the following screen: 

 

Formula Options 

Formula Enter the formula key to be used for this calculation or select 
the key from a lookup list. You may also create a new or 
maintain an existing formula definition by clicking on the 

Maintenance icon. 

Rounding Factor Enter a precision factor to round the result. This factor can be 
anywhere from 1 million to 0.0001. You can use the spin 
buttons to adjust amounts up or down. 

Note: The rounding value is a factor and not the number of 
decimal places. Thus, to round to the nearest 10, type 10. To 
round to the nearest 50, type in 50. 

Query Parameters You can type a parameter of up to 80 characters in length that 
can be used in a database query within a formula. 

Tip: What is the difference between using a source calculation and a formula? Source calculations are 
limited to the account number dimension and only retrieve amounts from the same periods specified in the 
column group. Formulas are more flexible, allowing you to combine periods and constants. Formulas can 
also incorporate enterprise data using database queries. 

Applying Global or Local Formulas to a Calculation  

You can apply a global, plan or local formula at any time to a plan calculation. 

1.        From the Calculations screen, select Formula as the calculation type. 

2.        Click the Lookup icon. 

3.        Choose whether to browse global, plan or local formulas. 
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4.        Highlight the formula to apply to the row. 

5.        Click Ok. 

6.        Optionally, define a rounding factor. 

7.        Optionally complete the Query Parameter 1 and Query Parameter 2 fields if database queries were 
defined in the formula. 

Tip: A single row can have many local formulas; therefore, you can even use those formulas to perform 
additional “what-if” analyses. 

User-Defined Query Parameters 

Up to two special query parameters defined on the Calculations form may be used for any database query 
formulas defined. 

 

The query parameters can be any text value up to 80 characters in length. Examples of query parameters are: 

•       Salesperson name for a sales forecast 

•       Purchasing agent for a purchasing forecast 

•       Product line for an inventory forecast 
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Tip: Sage Budgeting and Planning will use the query parameter exactly as it is typed. Thus, if you are using 
a query parameter as a “Where” condition in a SQL statement, you may need to surround the value in 
quotes, depending on the field type. You can even use whole SQL clauses such as a “Where” clause in 
these parameters. 

 

Tip: You may also wish to use custom column variables instead of the user-defined variables. 
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Calculation Selection Options 

Calculation Overrides 

A source calculation normally uses these values in processing the calculation. 

•       Account number specified in the Account Number dimension 

•       Current processing company 

•       Home currency 

You can override any of those options using the Overrides tab on the Calculations form. The company and 
currency codes can also be updated by entering the value in the appropriate column in the plan sheet. 

Tip: You can display the company and currency overrides using View Options. 

Some examples of situations where you might use calculation overrides are: 

•       Consolidated budgets 

•       Foreign subsidiary budgets 

 

Overrides 

Company Code Type a valid company code or select one from the lookup window. 

From/Thru Account Type valid account numbers or select from a list of accounts using 
the lookup window. You can also use a filter these fields. 

  

Note: Sage Budgeting and Planning uses the fiscal calendar of the company identified on the Overrides tab. 
For example, if a column is defined as first quarter for a calendar year-end company and an override 
company with a year-end of June 30th is specified, Sage Budgeting and Planning uses the column period 
dates (Jan to March) and calculates the appropriate balances from the override company (periods 7-9). 
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Account Substitution in Calculation Overrides 

Source Calculation 

Overrides Host Company with company entered in Overrides tab 

Overrides Account Dimension from ROW with Account/Account Range entered in Overrides tab 

Formula Calculation with Override 

If the Override contains a range of accounts the formula is separately calculated for each account in the 
range, respecting any filtering used in the override fields and in the formula.  So, if your override range 
contains 3 accounts, the formula is calculated 3 times, once for each account in the override.   

Amount Calculation with Override 

If there are three accounts included in the range of the override and the Source CALC chosen is of type 
Amount and $100.00 is placed in the Amount Field - then $100.00 will be calculated regardless of the 
override. 

Columns 

You can apply the plan calculation to any or all of the columns belonging to a column group. The system 
default is to apply the calculation to all columns in the group. You can deselect individual columns to 
exclude them from the plan calculation. 

If you deselect columns from the plan calculation, you can type a value or cell formula into the excluded 
cells. The system will not overwrite these cells when processing the calculations. 

Scope 

The Scope tab defines how Sage Budgeting and Planning is to interpret the calculation. If Individual 

Columns is specified the same calculation will be processed for each individual column. If Entire Group is 
specified the result will be calculated for the entire group as one value and spread back to the columns, 
based upon the spread method specified. Spreading to the group is supported only if the account number 
dimension is used within the plan sheet. The spreading methods include: 

•       Evenly 

•       By Ratios 

Also, the scope option only applies to those columns identified with a valuation type of Net Change. 

 

Plan Calculation Scope Tab 
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Scope Select whether the plan calculation is to be calculated for each 
column individually or for the entire group. If you select 
Individual Columns, then the calculation will be computed 
separately for each individual column in the group. If you 
select Entire Group, the calculation will be computed once for 
the whole group and the result will be spread back to the 
individual columns according to the spread method defined. 

Tip: Individual Columns is the default. Thus, if you are 
generally applying calculations to individual columns, you do 
not have to define any parameters on the Scope tab. 

Apportion By Select whether to apportion an entire group by All Columns 
or only Affected Columns. If you select All Columns the 
calculated result is apportioned using the ratios of the values 
in all of the columns, however, it will only update the 
selected columns. If you select Affected Columns, the 
calculated result is apportioned only to the selected columns. 

Spread Select Evenly to divide the group evenly or By Ratios to use 
the weighted average of the individual columns and the total 
of all the columns in the group. 

If you select By Ratios, you must also select a Source Year 
and Balance Type (see below). 

Source Year Select from the current year or up to ten prior years. This field 
is required if you selected Spread: By Ratios. 

Balance Type If Spread: By Ratios is selected, also choose one of the 
following balance types: 

•            Group Default 

•            Actual 

•            Budget 

•            Statistical 

•            Plan Sheet 
By selecting Plan Sheet, a user-defined spread can be created. 

Note: If you specify Plan Sheet, the column dates and the 
account number used for spreading must match the rows and 
columns deploying the calculation. 

Balance Code Type a valid balance code or use the lookup window to select 
one from the list. If using plan sheet values, type a valid 
Plan.Sheet.Group key combination or leave this field blank to 
use the column group default plan sheet.  

When applying the scope option, consider the following basic rules: 

•       The column group determines the columns affected by the plan calculation. 

•       Columns can be specifically excluded from the calculation. 

•       Plan calculations using a scope of Individual Columns apply the calculation method to each column 
individually using the range of column dates as potential variables. 

•       Plan calculations using a scope of the Entire Group calculate one value for the group and spread the 
result back to the individual columns in the group based upon the specified spreading criteria. The 
periods included in the calculation are based upon the first and last periods covered by the group. 

To understand spreading more completely, review the following examples. Note that each example assumes 
a calendar year and monthly periods. 
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Example 1 - Fixed Amounts 

Suppose you are using a fixed budget value for professional fees of 120,000. If you specify a scope of 
individual columns, then the calculation will be 120,000 for each column. If you specify a scope of entire 
group and to spread evenly, the column value will be 10,000 (120,000/12 monthly columns). 
If you use the same calculation and specify a scope of entire group and to spread by ratios based on the 
prior year actual balances, the 120,000 will be spread to each column based on its proportional prior year 
actual to the total of all the columns in the group. In the partial plan sheet that follows, the first row shows 
the actual prior year balances and the second row shows the proposed budget with a spread based upon the 
prior year results. Thus, January is computed based upon a total of 120,000 times the January actual of 9,000 
divided by the total for the year of 108,000. 

 
Note: In these examples, row 1 is shown for informational purposes and is not a part of the calculation directly. The 
actual balances are used in the calculation. 
It is important to note that when spreading in a group, the values are spread proportionately only within the 
column group. Therefore, if only nine months were specified in the group, row 2 would still total 120,000, but 
it would be spread proportionately in the nine columns of the group. A potential application of this 
situation would be to make a prospective change in a budget for the remainder of a partially completed fiscal 
year. 
 
 

 
Example 2 - Source Calculation 

The plan calculation is defined as the prior year balance increased by 10%. The calculation scope is 
individual columns. The Professional Fees account results are displayed here: 

 
Each column is computed individually. Thus, January is computed using the prior year January balance 
increased by 10%, February balance is increased by 10%, etc. If the scope is the entire group and the spread 
is evenly, the calculation is made once for all the columns in the group, and the result is spread back to the 
columns individually. In this case, the entire prior year balance (108,000) is increased by 10% and the result 
is spread back evenly to the individual columns. The result is displayed here: 

 
Note that the year-end totals are the same, but the individual columns are different. 
 
 

 
Example 3 - Source Calculation with Partial Selection 

Normally, a plan calculation will be processed for all columns in a group. However, Sage Budgeting and 
Planning provides a feature that allows you to restrict which columns in a group that the plan calculation 
affects. This is particularly useful where a calculation is the norm for most columns, but an exception exists 
for a specific column. Since plan calculations will overwrite any entered values or cell formulas, we may 
want the system to skip the processing of the exception columns. 
In our previous examples, we want to calculate professional fees for all months using the same calculation 
method for all columns in the group. In this case, we will apply the calculation to all columns except for the 
April column. We will override the April column with an entered value of 200,000 (a big legal bill will hit 
our desks!) and leave the scope as individual columns. 
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However, what happens if we make this calculation scope the entire group? What happens to April? Is it to 
be included in the spread or just ignored? In other words, should the calculation be calculated proportional 
to the 12 columns in the group (all months) and applied to the 11 selected months or calculated and applied 
to the 11 selected months? In essence, are the other column months to pick up the slack (calculation based 
on 11 months) or is the calculation to ignore the unselected column (calculation based on 12 months)? This is 
a decision that is configurable in the plan calculation. If you select to apportion by all columns (the default), 
the calculation divides the spread by all columns in the group, regardless of whether they are selected. 

 
If you choose to apportion by selected columns, the spread is made over the 11 selected columns only. 

 
Note that the calculation spread over the selected columns is higher because the total is apportioned over a 
smaller number of columns (11 vs. 12). 
 
 

 
Example 4 - Source Calculation with a Range of Periods in a Column 

Consider the same circumstances as Example 2. The same calculation (prior year actual plus 10%) is 
designated. However, in this case, the columns are structured as follows: 

 
•  Column M is the first quarter of the plan year 

•  Columns N and O are May and June individual months. 

•  April is purposely skipped as a period identified by any column 

•  Column P, the Totals column, is a cell function of the sum of columns M through O. 
The same source calculation will use both beginning and ending column date intervals to construct the 
calculation. Thus, beginning and ending dates in a single column are passed as variables into the plan 
calculation. The quarterly column L provides a range of periods into the calculation instead of a single 
period. Furthermore, column dates can span years and the plan calculation will also span years. 
If the calculation were to use a scope of the entire group and a spread of prior year actual, the calculation 
results would be as follows: 

 
The calculation determined a total of 79,200. This was calculated by determining the first and last period 
covered by the group. In this case, January is the first period and June is the last period. Even though April is 
not a specific column, it is included in the calculation by this span of periods (51,000 for row 1 plus April of 
21,000 times a 10% increase). The result is spread back proportionately to the column values that make up the 
group. Thus, column M receives 60,565 (79,200 * 39,000/51,000). Columns N and O also receive their 
proportional share of this calculation. 
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Maintaining Calculations 

Once a plan calculation is defined, it is easy to duplicate it for other rows. Since the calculation will typically 
use variables such as account number, each row should receive a different calculated value. 

Copying Calculations 

1.        Click a cell in the row that contains the calculation you wish to copy. 

2.        Select Rows > Calculations > Copy or click the Copy Calculation  icon. 

3.        Highlight one or more rows to copy the calculation to. 

4.        Select Rows > Calculations > Paste or click the Paste Calculation  icon. 

5.        Save the plan sheet to save the calculation modifications. 

Note: Once a calculation is copied it remains on the clipboard until either the copy or cut function is used 
again. 

Cutting and Pasting Calculations 

1.        Click a cell in the row that contains the calculation you wish to cut. 

2.        Select Rows > Calculations > Cut. 

3.        Highlight one or more rows to paste the calculation to. 

4.        Select Rows > Calculations > Paste or click the Paste Calculation  icon. 

5.        Save the plan sheet to save the calculation modifications. 

Note: Once a calculation is cut it remains on the clipboard until either the copy or cut function is used again. 

Editing Calculations for Multiple Rows 

1.        Highlight the rows that contain the calculations to be edited. 

2.        Select Rows > Calculations > Edit or press Shift+F2. 

3.        Make the necessary modifications and click Ok. 

4.        Save the plan sheet to save the calculation modifications. 

Refreshing Calculation Results 

Refreshing a Range of Cells 

1.        Highlight the cells that contain the calculations you wish to update. 

2.        Select Rows > Calculations > Refresh Range (Ctrl + F9) or click the Refresh Calculations  icon. 
The following message displays: 
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3.        Click Yes to continue with the recalculation or click No to cancel the process. 

Note: If you click Yes, Sage Budgeting and Planning overwrites any values or cell formulas in the selected 
cells that contain plan calculations. The only way to recover those values is to retrieve your plan sheet from 
disk. 

4.        A processing output window displays showing the status of the calculations and any errors. 

 

5.        You may print the report or save the report to a file. Click Close to return to the plan sheet. 

Refreshing the Entire Plan Sheet 

1.        Select Rows > Calculations > Refresh Entire Plan Sheet (Shift+Ctrl+F9). 

2.        Complete the remaining steps as outlined for Refreshing a Range. 
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One-Time Calculations 

One-time calculations are special calculations that may be applied to any range of cells in a plan sheet. These 
calculations use the methods described in this chapter but are not saved for future use. One-time 
calculations are mainly used to calculate quick “what if” analyses prior to committing to a permanent 
calculation method. If you use the one-time calculations, you can still adjust your plan sheet back to the 
original values generated by a saved plan calculation by using the Refresh Calculations option, which will 
update the plan sheet for the original calculation. 

To execute a one-time calculation: 

1.        Highlight the cells to be used in the one-time calculation. 
2.        Select Rows > Calculations > One Time Calculations (Shift+F9). 
3.        The following message displays: 

 

4.        Click Yes to continue with the recalculation or click No to cancel the process. 

Note: If you click Yes, any values or cell formulas already in the selected cells will be overwritten with plan 
calculations. To get those values back, refresh calculations or restore your plan sheet from disk. 

5.        The Calculation form, similar to the original plan calculation definition, will display. Complete the 
desired calculation parameters. 

6.        Click Ok to refresh the calculations or Cancel to exit without refreshing calculations. 

7.        A processing output window displays showing the status of the calculations and any errors. 

 

8.        You may print the report or save the report to a file. Click Close to return to the plan sheet. 
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Selective Recalculation 

Calculations provide extensive flexibility to calculate virtually any value from a database. The uses of 
calculations are varied. For example, formulas can be used to: 

•       Compute historical values for comparison purposes in an annual plan. 

•       Compute business drivers for modeling. 

•       Compute derivative values, such as sales from one plan sheet times a sales commission rate from 
another. 

•       Compute historical values for the last closed month in a rolling forecast. 

In the first case, the historical values are computed once for the planning cycle. In the case of examples 2 and 
3, values need to be computed every time we generate the model from plan processing. In the last case, we 
want to compute the values when the cycle is rolled to the next period. The first and last example may seem 
similar. However, in example 4, only a single month is computed, rather than all of the completed months. 

To accommodate these different calculation requirements and to provide an additional level of control over 
calculations, the selective recalculation feature is used. Calculations can be managed using Plan Processing 
from Plan Manager or Subsheet Manager. 

•       In Sheet Options, you can specify whether calculations within the plan sheet are to be included when 
plan flow is processed. 

•       In Group Maintenance, you can further refine the calculations that belong to that group. Options 
include: 

➢Always calculate when plan processing 
➢Never calculate when plan processing 
➢Only calculate when plan processing if the column dates are within the specified range 

 

•You can optionally force all calculations to process during plan processing. 

•In Sheet Options, you can always refresh calculations manually from each individual plan sheet. 

 
Common Calculation Errors 

Division by Zero The calculation divides by a zero value, usually because you: 

•       Attempted a spread with no valid values to spread by. 

•       Used a formula with a division operand, and the value in 
the denominator evaluated to zero. 

Formula Key of ‘____’ 
does not exist 

Formula key does not exist. Check any local or global formula 
references in the plan calculation form. 

Any errors returned 
by Database Queries 

The SQL query failed from within a formula. Try to run the SQL 
Query Test as described later in this chapter.  

Plan Sheet 
Initialization Error 

A plan sheet was used in a calculation and the plan sheet could 
not initialize. This is likely due to insufficient memory. 

Plan Sheet Retrieval 
Error 

A plan sheet was used in a calculation that did not exist. 
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Cannot Find 
Appropriate Balance 
Information for Plan 

A plan sheet was used in a calculation and the system could not 
locate or resolve the periods requested. 

Check the year and periods requested as correlated to the 
columns using the calculation. For example, if a plan sheet 
column using a calculation has a year of 2009 and you are 
requesting plan sheet columns with 2008 dates, make sure your 
calculation specifies a year of prior 1. 

The periods requested must either match exactly or the system 
must be able to resolve them. For example, a plan sheet column 
has periods 4-6 and uses a plan sheet in a calculation. The values 
can be retrieved from a plan sheet using the same combination of 
periods, individual net change columns of 4,5, and 6, or a 
combination of the ending balance at the end of period 6 and a 
beginning balance at the beginning of period 4. 
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Chapter 9 

Formula Concepts 

Formulas are mathematical expressions that provides the ability to calculate plan values using combinations 
of balances, constants, database queries and plan sheet values. By incorporating filters and variables, a 
single formula may be regenerated many times, however, the overall resultant of each formula is a single 
value. 

Formulas are classified into three general categories, global, plan and sheet. 

•       Global formulas are created independently and can be retrieved and used by anyone in the system, 
consequently, they are available to every plan sheet. 

•       Plan formulas are attached to a plan. If you delete a plan, all plan formulas attached to it are also 
deleted. 

•       Sheet formulas are attached to an individual plan sheet and cannot be copied by other users. If you 
delete a plan sheet, all sheet formulas attached to it are also deleted. 
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Formula Maintenance 

Creating Global Formulas 

1.        Highlight the Global Formulas node in the tree-view pane. 

2.        Select File > New (Ctrl + N) or click the New  icon. 

3.        Complete the Main tab. 

4.        Complete the Formula tab. 

5.        Click the Save  icon to save the formula. 

 

Formula Main Tab 

Formula Key Type a unique maximum 16-character key to identify this 
formula. 

Description Type a maximum 40-character description of the formula. 

Note: A user must be given Edit Formulas permission in order to view, create, edit or delete global 
formulas. See the Sage Budgeting and Planning System Management Guide for more information on 
maintaining user permissions. 

Creating Plan Formulas 

1.        Highlight the desired Plan from the Plans node in the tree-view pane. 

2.        Select File > New (Ctrl + N) or click the new  icon. 

3.        Complete the Main tab. 

4.        Complete the Formula tab. 

5.        Confirm that the Plan  icon is indented and click the Save  icon to save the formula as a Plan 

Formula. To save the formula as a Global Formula, click the Global  icon and then click the Save 

 icon. 
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Note: A user must be a Plan Administrator or Plan Controller and be given Edit Formulas permission in 
order to view, create, edit or delete global formulas. See the Sage Budgeting and Planning System 
Management Guide for more information on maintaining user permissions. 

Creating Sheet Formulas 

1.        From a plan sheet calculation, select Formula as the calculation type. 

2.        Click the Maintenance icon. The Sheet Formula form is virtually the same as the Global Formula 

form with the addition of the global formula  icon, plan formula  icon and the sheet formula 

 icon. If the global formula icon is indented, the formula is a global formula. If the plan formula icon is 
indented, the formula is a plan formula. If the sheet formula icon is indented, the formula is a sheet formula. 

 

3.        Complete the Main tab. 

4.        Complete the Formula tab. 

5.        Click the Save icon. 

6.        Close the form (Ctrl+F4). The following message displays: 
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7.        Click Yes to apply the formula to the plan calculation. 

8.        Optionally, define a rounding factor. 

9.        If database queries were defined in the formula, complete the Query Parameter 1 and Query 

Parameter 2 fields. 

Note: A global, plan and a sheet formula can have the same formula key. If this occurs, the system will 
always use the sheet formula in the plan sheet calculation. If there is no Sheet Formula, it will use the Plan 
Formula if it exists instead of a Global. 

 

Note: Sheet formulas may be edited from the desktop interface, however, the formula key and description 
may not be changed. 

Editing a Global Formula 

1.        Highlight the Global Formulas node in the tree-view pane. 

2.        In the list pane, highlight the global formula to be edited. 

3.        Double-click on the formula or select File > Open (Ctrl + O) from the menu. 

4.        Make the necessary modifications and click the Save  icon. 

Saving a Local Formula as Global or Plan Formula 

1.        Open an existing local formula from Plan Sheet Maintenance. 

2.        Click the Globe  icon to save it as a Global formula or click the Plan  icon to save it as a Plan 
formula. 

3.        Click the Save icon. 

4.        The following confirmation message displays: 

 

5.        Click Yes to save the formula or No to cancel the save process and return to the formula maintenance 
screen. 

Note: From the Plan tree, Plan formulas can be saved as Global formulas and Global formulas can be saved 
as Plan formulas. From Sheet Maintenance, any formula type can be saved as any other formula type. 

Printing Formula Definitions 

1.        Highlight the global, plan or sheet formula you wish to print. 

2.        Select File > Print Definition or click the print  icon. 

3.        The Output Location form displays. Select an output option. 
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4.        The formula definition output may be viewed on the screen, printed or saved. 
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Formula Components 

The next step to completing a formula is to complete the detail lines in the formula. A formula can consist of 
multiple formula lines joined together by mathematical operands and parentheses. 

 

Each formula line is identified as one of these line types: 

•       Accounts 

•       Constants 

•       Database Queries 

•       Plan Sheet Lookups by Account Number 

•       Plan Sheet Lookups by Row ID 

•       Published Data Retrieval 

•       Database Queries using Linked Server Definitions 

Determining the appropriate procedure to complete the line depends on the line type selected. 

The following mathematical operands can be use to join formula lines together: 

•       Addition (+) 

•       Subtraction (-) 

•       Multiplication (*) 

•       Division (/) 

Lines joined by these operands form the equivalent of a left-to-right mathematical expression. The 
expression is evaluated from the top, down according to normal algebraic precedence. Multiplication and 
division operands are evaluated first, then addition and subtraction operands. Parentheses can be used at 
the beginning or end of a line to change the order of precedence. 

Tip: Sage Budgeting and Planning does not support multiple parentheses without an operation between 
them . Use a constant and operand combination such as “0+” or “1*” to avoid multiple parentheses. For 
example: (10 * (2 + 3)) should be entered as (10 * (2 + 3) * 1) 

Each line independently computes a value based on the selection criteria. All formula lines combine to 
produce a single value at a time. However, the same formula can be computed repeatedly with different 
values by using filters and variables. These are discussed later in this chapter. 

The Check Formula button at the bottom of the form ensures the validity of the formula expression. This 
option checks the formula to ensure that: 

•       All required fields are populated. 

•       If multiple rows exist, that operands are selected. 

•       Each open parenthesis is followed by a close parenthesis. 

Note: Clicking the Check Formula button does not ensure that the data is entered correctly or that the 
formula is useful. It only ensures that the expression is mathematically valid. 
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Accounts Formula Type 

The following are the steps for defining the Accounts formula type: 

 

1.        Select the Year and the Periods to process. 

2.        For intercompany processing, select the Company. 

3.        Select the Balance Type to process (actual, budget, or statistical). 

4.        Select the Balance Code, if applicable. 

5.        Select the balance Valuation. 

6.        Select the Accounts to process. 

7.        Select the Account Dimensions to process, if applicable. 

Note: Selecting Accounts summarizes the total of all of account balances resulting from segment ranges. 

Periods and Years 

Sage Budgeting and Planning can read balances from any period or range of periods. The periods specified 
may be either fixed period numbers or periods relative to the column date being processed. 

Year 

When selecting a year, you may choose the current year or any year up to the prior ten years. The year 
evaluation is based on the column dates of the column being processed. 

Fixed Periods 

You may specify the fixed periods that you wish to process. These periods correlate to your company’s fiscal 
calendar to determine the balances to process. 

Tip: You cannot use period 0 when specifying fixed period numbers. To obtain a beginning balance sheet 
balance, you can use period 1 and specify the valuation as Beginning. 

 

Note: The Thru Period must always be higher than the From Period for the formula to retrieve balances 
properly. 

Relative to the Current Column 

You may also select a period range relative to the column date being processed. A range of periods can be 
positive or negative. Positive period numbers work forward in the fiscal calendar. Negative period numbers 
work backward in the fiscal calendar. 

Period ranges that are relative to the current column are resolved using the following factors: 

•       If the formula is set up with Scope: Individual Columns each set of column dates is substituted into 
the equation as it is processed. 

➢       The value of Current +/- 0 in the formula From Period is calculated based on the column 

From Period. 

➢       The value of Current +/- 0 in the formula Thru Period is calculated based on the column 

Thru Period. 

➢       Any changes to the period numbers will be adjusted from these fiscal periods. 

•       If the formula is set up with Scope: Entire Group: 

➢       The value of Current +/- 0 in the From Period is calculated based on the first period found in 

the column group. 
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➢       The value of Current +/- 0 in the Thru Period is calculated based on the last period found in 

the column group. 

Tip: You can span years with relative periods. 

Note: The Thru Period must always be higher than the From Period to retrieve balances properly. A range 
of periods can be positive or negative. Positive period numbers work forward in the fiscal calendar. Negative 
period numbers work backward in the fiscal calendar. 

 
 
Example 1: 

Suppose you are developing a budget plan for telephone expense for the next fiscal year (2007). In developing 
the budget, you want to begin with the balances for the prior year (2006). The following are the net change 
balances for the prior two fiscal years for the subsequent examples (assuming a calendar year) of account 
7035-000-100-00 as displayed in the following plan sheet (note the plan sheet below is only for purposes of 
referencing balances). 

 
The following formula is used: 

 
Note that the formula references the previous fiscal year (2006) as Prior 1 because it is one year prior to the 
plan fiscal year (and all the columns). If prior year values were displayed as a separate set of columns, the 
formula year could be displayed as the current year. 
If this formula is used and the calculation is set to Scope: Individual Columns, the result is calculated for 
each column in the plan sheet, e.g. period 1 would be 30,000, period 2 would be 30,400, period 3 would be 
31,600, etc. If the calculation is set to Scope: Entire Group, the result is computed as a single value of 382,000 
that can be spread either evenly or by historical ratios. Spread evenly, each column would be 31,833 
(382,000/12). 
 

 
 
Example 2: 

For the same account 7035-000-100-00 and balances as the previous example, the following formula is used: 

 
In this case, the periods specified are fixed. With the calculation set to Scope: Individual Columns, each 
column using the formula in the plan sheet receives the calculated result of 92,000 (30,000+30,400+31,600). 
If the calculation is set to Scope: Entire Group and Spread: Evenly, each column in the plan sheet receives 
the calculated result of 7667 (92,000/12). 
If you only checked to apply this calculation to the first three columns and set the calculation scope to 
apportion only by the affected columns, the result is 30,667 (92,000/3) for columns 1-3 only. 
 

 
 
Example 3: 

For the same account 7035-000-100-00 and balances as the previous example, the following formula is used: 

 
In this case, the periods specified are relative to the current column. With a calculation set to Scope: 

Individual Columns, the result is computed for each column by looking back three periods plus the current 
period. If the calculation is applied to the first three columns, the system will “wrap-around” to the previous 
fiscal year (2005) to get the values. Results would be as follows: 
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This same formula, with calculation settings of Scope: Entire Group and Spread: Evenly, results in a single 
number based on the range of periods of October 2005, which is two years prior through December 2006, 
which is one year prior. When the scope of the calculation is the entire group, Sage Budgeting and Planning 
interprets From Period -3 as the first fiscal period in the column group and Thru Period 0 as the last fiscal 
period in the column group. Because there is a -3 in the From Period field, Sage Budgeting and Planning 
looks back three periods, into 2005. This results in a total computation of 481,000 comprised of all of 2006 
and the last three months of 2005. 
Each column would show a value of 40,083 (481,000/12). 
 

Tip: What does all this mean? You can combine a nearly unlimited variety of balances or calculations to 
achieve the desired result. Sage Budgeting and Planning can either calculate each column individually or all 
the columns in a group with a spread to the columns. By combining formulas with spreading and cell 
formulas, you can explore many different budget scenarios. 

Company 

By default, the balance is restricted to the current company. You can  specify a different company by using 
the lookup window or by typing the value. You can also use filters (?) and the system will complete the filter 
from either the current processing company or the company designated in the Calculation Overrides tab. 
Filters are discussed in detail later in this chapter. 

Note: Sage Budgeting and Planning uses the fiscal calendar of the specified company. 

Balance Types 

Balance type options include: 

•       Actual 

•       Budget 

•       Statistical 

You will also need to specify a balance code to use for any balance types that are configured with codes. You 
can use the lookup window to select from a list of valid balance codes. 

Valuations 

Valuation determines what balance to use in calculating the value. Options include: 

•       Average Daily Balance 

•       Beginning Balance 

•       Net Change 

•       Ending Balance 

Selecting Average Daily Balance calculates the average daily ending balance for the periods selected based 
on the historical transactions for the account. You can select whether to exclude Saturdays or Sundays from 
the calculation. To change this option, select Setup > Options. 
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Tip: Average Daily Balance is a powerful option. For example, you might calculate average daily debt 
balance to calculate planned interest expense. Note that you can calculate the average daily balance for a 
range of periods, not just the current fiscal period, allowing you to perform ratio analyses or other 
calculations that require a range of periods. 

 

Tip: Selecting Average Daily Balance calculates the average daily ending balance. To calculate average 
daily activity, you could specify a formula with net change valuation and divide the result by the number of 
days in the fiscal period using the Days() cell function. 

 
Example: 

The following is an account balance and its activity for the month of June. 
Beginning Balance 30,000 

6/5 Transaction   10,000 

6/27 Transaction  15,000 

  

The average daily balance would be computed as follows if Saturdays and Sundays were included: 
30,000 * 30/30 = 30,000 

10,000 * 26/30 =  8,666 

15,000 *  4/30 =  1,995 

                 40,661 

The average daily balance would be computed as follows if Saturdays and Sundays were excluded (based 
on the 2002 calendar): 

30,000 * 20/20 = 30,000 

10,000 * 18/20 =  9,000 

15,000 *  2/20 =  1,500 

                  40,500 
 

Filtering Account Values 

For the Accounts formula line type, Parameter 1 is used for the beginning account and Parameter 2 is used 
for the ending account. Sage Budgeting and Planning displays the account with the appropriate segment 
separators. 

Options are to: 

•       Type a valid Account Number. You can select from a list of valid accounts using the lookup window. 

•       Filter any portion of the field. This results in separate calculations for different account combinations. 
The value will be derived either from the Account Number column in the row containing the 
formula, or from each account in the range of accounts specified in Calculation Overrides, if any are 
specified. Calculation overrides are discussed later in this chapter. 

The benefit of using filters is that a single formula can be used for multiple plan sheet rows. Filter characters 
are identified with a question mark (?) and should not be confused with a wildcard designation. For 
accounts, you can filter individual positions in the field. 

Filter positions for formula accounts will be fulfilled from the Account Number dimension in the plan sheet 
on a segment-by-segment or position-by-position basis. As each account number is processed, the filters will 
be replaced with the appropriate account segment. If you have specified a calculation override, each account 
in the range will be used to evaluate the formula filters, as discussed later in this section. 

 
Filter Example: 

Budget Account:     1200-100-300-12 

                        
Filter:             ????-000-000-00 

                        
Resulting Number:   1200-000-000-00 
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Budget Account:     1200-100-300-12 

                        
Filter:             5000-???-???-?? 

                        
Resulting Number:   5000-100-300-12 

 

Budget Account:     1200-150-300-12 

                        
Filter:             1100-?00-000-00 

                        
Resulting Number:   1100-100-000-00 

 

 
 
Example: 

You might use filters in the following ways: 
1.        This example derives each account processed as a percentage of sales (in this example, accounts 4000-
000-000-00 to 4040-999-999-99). 

 
 
2.        This example multiplies each account processed by a 50 percent increase. 

 
 
3.        This example retrieves the balance of each natural account (segment 1) specified in the Account 

Number column. 

 
 
4.        This example retrieves salaries and wages (account 6000) for each department segment specified in the 
Account Number column. 

 
 

Note: Formula account ranges are based upon the individual segment ranges, not the account number in its 
entirety. 

When using a range of accounts in the calculation override and applying them to a formula, each valid 
account in the override range will be used to evaluate the formula. The results of each pass are then 
combined for the value applied to the plan sheet cell. 

 
Example: 

This range of accounts is specified in a calculation override: 
 Account               Balance 

6000-000-100-00        $1,000 

6000-000-200-00        $2,000 

6005-000-200-00        $3,000 

6010-000-100-00        $4,000 

6010-000-200-00        $5,000 

 
The following formula was specified: 
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These calculations are the result: 
 6000-000-100-00 / (6000-000-100-00 through 6005-000-100-00)     $1,000/$1,000 =    1.0 
 6000-000-200-00 / (6000-000-200-00 through 6005-000-200-00)     $2,000/$5,000 =    0.4 
 6005-000-200-00 / (6000-000-200-00 through 6005-000-200-00)     $3,000/$5,000 =    0.6 
 6010-000-100-00 / (6000-000-100-00 through 6005-000-100-00)     $4,000/$1,000 =    4.0 
 6010-000-200-00 / (6000-000-200-00 through 6005-000-200-00)     $5,000/$5,000 =    1.0 
                                                                                                                  Formula result = 7.0 
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Constants Formula Type 

Constants are fixed values used in the formula. The constant value is completed in the Parameter 1 column. 
Constants can range from -999,999,999 to 999,999,999 and can include as many as eight decimal places. 

 

Tip: You would normally only use constants if the value is fixed. If the value is variable, you might use 
another line type such as Accounts or Database Queries. 
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Database Query Formula Type 

Introduction 

Database queries are used in formulas to calculate and deploy values from other data sources. Sage 
Budgeting and Planning can retrieve and manipulate values from many sources either through a direct 
connection or by implementing linked servers.  

The following data sources may be accessed through Sage Budgeting and Planning: 

•       Microsoft SQL Server 

•       Microsoft Access 

•       Microsoft Excel 

•       ODBC sources 

•       OLE-DB sources 

•       dBase 

•       FoxPro 

•       HTML 

•       Paradox 

•       Text files 

Sage Budgeting and Planning uses the Microsoft Jet database engine to natively access all of the above 
databases with the exception of SQL Server (which uses Transact SQL). This is the same engine that is used 
in Microsoft Access. The Microsoft Jet query engine is designed to accept user requests for information or 
actions in the form of SQL statements. Microsoft Jet parses, analyzes, and optimizes these queries, and 
returns the resulting information. 

Microsoft Jet database engine is generally ANSI Level 1 compliant. However, certain ANSI SQL features are 
not implemented in Jet SQL. Conversely, Jet SQL includes keywords and features not supported in ANSI 
SQL. These differences are discussed in more detail in Appendix D. 

Sage Budgeting and Planning can process a complete SQL query, but only returns the value found in the 
first row-column intersection. Thus, SQL expressions such as GROUP BY and ORDER BY are accepted but 
generally not used in Sage Budgeting and Planning database queries. In addition, multiple columns can be 
selected, but only the first column value will be returned to the formula. 

In addition to the databases natively supported with Jet Database SQL, Sage Budgeting and Planning can 
communicate with any ODBC compliant database. ODBC databases can be queried using the Jet SQL engine 
or using the ODBC driver supported SQL dialect. You should note that each ODBC driver might have 
differences in the SQL query dialect supported. Consult your individual ODBC driver for these specific 
differences. 

Linked servers allow SQL Server to connect to other data sources through the OLE-DB provider.  This 
allows Sage Budgeting and Planning to access the data sources as if they were databases on the SQL Server. 
These connection definitions are created in a centralized location using the Admin Tool. For additional 
information on creating linked server definitions and steps on creating linked servers on 64-bit SQL Servers , 
see the System Management Guide. 

Database queries can be implemented for any line in a formula. Some examples of host system data you 
may want to query may be: 

•       Spreadsheet statistical factors 

•       Member data from fund software 

•       Marketing data from a marketing database 
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Sage Budgeting and Planning database queries can also be used to create dynamic forecasts. These forecasts 
can be based on virtually anything in your system. For example, you can create: 

•       Sales forecasts by territory 

•       Purchasing forecasts by buyer 

•       Inventory forecasts by product line 

Completing the Database Formula Line 

1.        Select Database as the formula type. 

 

2.        Click the Database Query button in the Parameter 1 field. The Database Query form displays. 

 

3.        In the Data Source Type field, select the data source to query against. 

4.        Complete the connection information based on the data source selected. 

5.        Optionally, you may click the Test button in the Test Connection section to verify that the connection 
information has been defined correctly. 

6.        Next, click the Query Builder tab to build the SQL query. 
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The SQL query may be completed by: 

•          Selecting items from the Tables, Fields, Key Words, Operations and Variables list boxes 
to complete the SQL statement. Double-click on an item to add it to the Query field. 

•          Clicking the Advanced button and manually typing the SQL statement. 

Note: If you switch from the Advanced mode back to the query builder box, you will lose any 
changes that were made. 

7.        Once you have created the SQL statement, you may test the query. Select the desired test query options 
and then click the Test Query button. 

Test Query Options 

Show Parsed Query Check this option to show the query with the SQL variables 
translated before processing. 

Execute Query Check this option to process the query. 

Show Entire Query 
Result 

Check this option to show the entire result of the query. When 
actually using the query in a database formula, Sage Budgeting 
and Planning will only return the first value of the first row 
returned. 

a.     Input the values of the desired test SQL variables. Any variables not required for the test can be left 
blank. 
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b.    Click Ok to process the test query or Cancel to return to the Query Builder screen. If the test query is 
processed, and Show Parsed Query was selected, the following window will display, showing the 
resulting SQL statement. 

 

c.     Click Ok to continue. If Execute Query was selected, the query will be processed to retrieve a value 
from the data source and the value will be displayed.  Click Ok to complete the testing of the database 
query. 

 

Note: Only the first row and column value will be retrieved when a query is processed. 

d.    When both Execute Query and Show Entire Query are selected, the query will be processed and all 
results from the query are displayed.   
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e.     Click Ok to display the single value that will be returned to the database query formula.  Click Ok to 
complete the testing of the database query. 

 

8.        On the Query Builder screen, click Ok to complete and save the query definition. 

Microsoft SQL Server Data Source Definition 

 

SQL Connection Options 
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Use Logon 
Connection 
Information 

Check this option to use the server that you are currently 
connected to. This option also uses the Database Query 
Authority (DQA) assigned to the logged on user. 

Server This field is enabled when the Use Logon Connection 

Information option is deselected. Type the server name that 
contains the database you wish to query. 

Login ID This field is enabled when the Use Logon Connection 

Information option is deselected. Type a valid user ID to 
connect to the specified server. 

Password This field is enabled when the Use Logon Connection 

Information option is deselected. Type the corresponding 
password for the login ID specified. 

Database Type the name of the database you wish to query. If this field 
is left blank, then the current company database is used. 

Microsoft Access Data Source Definition 

 

Access Connection Options 

Database Filename Type the path and filename or browse to the source file. 

Login ID For secure Access databases, type the correct login name. To 
access unsecured Access databases, you MUST use the login 
name Admin. 

Password For secure Access databases, type the password associated 
with the designated login ID. For unsecured Access databases, 
leave this field blank. 

  

Microsoft Excel Data Source Definition 
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Excel Connection Options 

Database Filename Type the path and filename or browse to the source file. 

Login ID N/A, leave the field blank. 

Password N/A, leave the field blank. 

Note: You cannot use a password protected Excel file as the data source. 

ODBC Data Source Definition 

 

 

 

ODBC Connection Options 

Data Source Name Type the name of the data source that you wish to query. 
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User ID Type a valid user ID to connect to the specified data source, if 
required. You may also opt to complete this information at 
the time of plan sheet calculation processing. 

Password Type the corresponding password for the user ID specified. 
You may also opt to complete this information at the time of 
plan sheet calculation processing. 

Retype Password Retype the user ID password for verification. You may also 
opt to complete this information at the time of plan sheet 
calculation processing. 

Other Parameters Complete this field if any additional driver-specific 
information is required to access the data source. The key 
parameter and valid values, specified in the key=value 
format, vary for each driver. See your ODBC driver 
documentation for additional information. 

Send SQL directly 
to ODBC 

Select this option to pass the SQL query directly to the ODBC 
driver without interpreting it as a Microsoft Jet SQL query. 
Selecting this option allows you to take advantage of any 
ODBC driver-specific SQL syntax. Consult your ODBC driver 
manual for a listing of supported SQL syntax. 

Manage Data 
Sources 

Click this button to view existing or to create new ODBC 
connections. 

Learn Connection Click this button to view a list of existing ODBC configurations 
and to select the data source you wish to query. 

OLE-DB Data Source Definition 

 

OLE-DB Connection Options 

Provider Select from the drop-down list, the data source provider to be 
used to access the desired data. 

Server Complete this field with the information pertaining to the 
location of the data source, i.e. SQL server name, Access file 
path, Oracle server name, etc. 
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Login ID For secure data sources, type the corresponding password for 
the user ID specified. 

Password Retype the user ID password for verification. 

Database Type the name of the database to be queried. 

Other Parameters Complete this field if any additional provider-specific 
information is required to access the data source. 

Connection 
Timeout 

If desired, type a maximum number of seconds available to 
connect to the data source. 

Manage Data Links Click this button to view existing or to create new OLE-DB 
connections based on the provider selected. 

Learn Data Link Click this button to view a list of existing OLE-DB 
configurations and to select the data source you wish to query. 

Completing the Linked Server Query Formula Line 

Prior to creating a formula using linked server queries, you must define a linked server configuration for the 
data source(s) you wish to query. For information on defining linked servers and steps on creating linked 
servers on 64-bit SQL Servers, see the System Management Guide. 

The process of using linked server queries in formulas is as follows: 

1.        Select Linked Server as the formula type. 

 

2.        Click the Linked Server button in the Parameter 1 field. The Linked Server Query form displays. 

 

3.        Select the Query User that will be used to access the data source. If the Specified User option is 
selected, type the corresponding User ID and Password in the designated fields. 

 

Query User Options 
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Default Query User Select this option to use the query login ID defined in User 

Maintenance for the current user logged into Sage Budgeting 
and Planning. Depending on the options set, this login ID may 
use the Database Query Authority (DQA) defined using the 
Admin Tool, or it may use another login ID. For more 
information on setting the default query user, see the System 
Management Guide. 

Specified User Select this option to indicate a specific user ID and password 
to access the data source that may be different than the query 
user defined in User Maintenance. If this option is selected, 
type the corresponding user ID and password. 

4.        In the Tables section, click the New button to select a table from the data source to be queried. 

5.        A table lookup form displays. Expand through the previously defined linked server definitions and 
highlight the desired table. 

 

6.        Click Ok to add the table to the Data Source tab. 

7.        The Alias Maintenance form displays with the selected table name. At this point, you can define an 
alias for the table or accept the existing table name as the alias. 

 

8.        At this point, you may click the Test button in the Test Connection section to verify that the Query 

User can connect to the defined data source. 

9.        Next, click the Query Builder tab to build the SQL query. 
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The SQL query may be completed by: 

•          Selecting items from the Tables, Fields, Key Words, Operations and Variables list boxes 
to complete the SQL statement. Double-click on an item to add it to the Query field. 

•          Clicking the Advanced button and manually typing the SQL statement. 

Note: If you switch from the Advanced mode back to the query builder box, you will lose any 
changes that were made. 

10.     Once you have created the SQL statement, you may test the query. Select the desired test query options 
and then click the Test Query button. 

Test Query Options 

Show Parsed Query Check this option to show the query with the SQL variables 
translated before processing. 

Execute Query Check this option to process the query. 

Show Entire Query 
Result 

Check this option to show the entire result of the query. When 
actually using the query in a database formula, Sage Budgeting 
and Planning will only return the first value. 

a.        Input the values of the desired test SQL variables. Any variables not required for the test can be left 
blank. 
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b.       Click Ok to process the test query or Cancel to return to the Query Builder screen. If the test query is 
processed, and Show Parsed Query was selected, the following window will display, showing the SQL 
statement. 

 

c.        Click Ok to continue. If Execute Query was selected, all results will display. 
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d.       Click Ok to continue. If Show Entire Query is selected, the single value that will be returned by the 
query is displayed. 

Note: Only the first row and column value will be retrieved when a query is processed. 

11.     On the Query Builder screen, click Ok to complete and save the query definition. 

SQL Variables 

Sage Budgeting and Planning SQL variables are values derived at the time of processing similar to filters. 
SQL variables begin with an ampersand (&) and are evaluated at the time plan sheet rows are calculated. 

For example, the SQL variable &ACCT& uses the equivalent parameters of Account Number column (or the 
From Account field in the Calculation Override, if specified) as it is processed. The &PEREND& variable 
uses the column period end dates as it is processed. Two user-defined query parameters are provided in the 
Calculation form that can be used as SQL variables. Variables are converted or pre-processed before 
running the SQL query against the database. 

Note: Although a database query can retrieve multiple columns and multiple rows, only the value from the 
first column in the first row is returned. However, by using the above SQL variables, the same query can be 
processed multiple times and return multiple values. 

 

Tip: You can be quite creative in using database queries with other tables in your system. For example, you 
might have a sales territory that mirrors a segment in your chart of accounts. You could therefore construct a 
query to calculate a sales basis for territory using the &ACCTSEG& variable as a restriction to the territory. 

SQL Variables 

&& This variable will be evaluated to be a single 
ampersand (&). This will allow you to use an 
ampersand in your query without the program 
attempting to evaluate it as another variable. 

&ACCT& Account number without any formatting 
characters. 

&ACCTDIM(n)& Account Dimension Key for the nth Account 
Dimension. 
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&ACCTSEG(segno)& Account segment value for the segment number 
indicated as the parameter. No formatting 
characters will be included. For example, 
&ACCTSEG(2)& for account 6000-100 returns 100. 

&AMASK(mask)& Account number after it has been passed through 
the indicated mask without any formatting 
characters. You should not place any formatting 
characters in the mask of this function. For 
example, if &AMASK(6100??????)& is used with 
account 2000-100-100, the result is 6100100100. 

&BASEDATE&(ShortDate)& The plan sheet base date formatted with the short 
date specified in you system configuration. 

&BASEDATE&(LongDate)& The plan sheet base date formatted with the long 
date specified in you system configuration. 

&COL& The column key of the column being calculated. If 
the calculation is scoped as a group, the group key 
will be substituted for the column key. 

&COMPANY& Returns the Current Sage Budgeting and Planning 
Company Name. 

&COMPANYCODE& Returns the Current Sage Budgeting and Planning 
Company Code. 

&COMPDB& Returns the Current Sage Budgeting and Planning 
Company Database. 

&CURRENCY& Currency key - defaults to home currency unless 
calculation override currency is specified. 

&CUSTCOMCOL(code,type[,fmt])& The value from a Custom Column.   

Code is the Custom Column Code. 

Type is the type of Custom Column.   Possible 
values are 'Text', 'Date', or 'Numeric' 

Fmt is Optional.  It designates how the value 
should be formatted.  For text values, it should be 
either True or False indicating if the value should 
be formatted.  For Date values, it can be set to 
'Julain', 'Short Date', 'Long Date' or 'Current Value' 
to use the same formatting as the plan sheet, or any 
of the other available formats discussed later in this 
section. 

&DIMENSION[code[,fmt[,masked]])& The value from a Dimension. 

Code is the Dimension Code. 

Fmt indicates if the Dimension Code should be 
formatted.  This is set to either True or False. 

If a Mask is specified, the dimension will pass 
through the masking characters before being 
placed in the query. 
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&DIMENSIONSEG(code,segno)& Returns a specified dimension code segment 
(identified with the ! symbol when creating the 
dimension. 

Code is the Dimension Code. 

Segno indicates which segment number to return. 

&FACCT& Account number with account format separators 

&FAMASK(mask)& Account number after it has been passed through 
the indicated format mask. This is similar to the 
&AMASK& variable, but has the formatting 
characters in it. You should not place any 
formatting characters in the mask of this function. 
For example, &FAMASK(6100??????) used with an 
account 2000-100-100 yields 6100-100-100. 

&GLCOMPCODE& N/A  

&GLDB& N/A 

&GROUP& The group key associated with the column or 
group being calculated. 

&PARM(parmno)& User-definable parameters defined in the plan 
calculation form. 

&PERBEGIN[(Format[,Delimiter])]& Period beginning date. If the calculation scope is 
individual columns, the date will be the beginning 
date of each column in the group as it is processed. 
If the calculation scope is the entire group, the date 
will be the beginning date of the first period 
specified in the group. 

Options for Format and Delimiter are explained 
later in this section. 

&PEREND[(Format[,Delimiter])]& Period ending date. If the calculation scope is 
individual columns, the date will be the ending 
date of each column in the group as it is processed. 
If the calculation scope is the entire group, then the 
date will be the ending date of the last period 
specified in the group. 

Options for Format and Delimiter are explained 
later in this section. 

&PERNO(From)& Beginning period number. If the calculation scope 
is individual columns, the period number will be 
the period number of each column in the group as 
it is processed. If the calculation scope is the entire 
group, the number will be the beginning period 
number of the first period defined in the group. 

&PERNO(Thru)& Ending period number. If the calculation scope is 
individual columns, the number will be the period 
number of each column in the group as it is 
processed. If the calculation scope is the entire 
group, the number will be the ending period 
number of the last period defined in the group. 

&PLAN& The Plan Key of the Sheet that is being calculated. 
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&SHEET& The Sheet Key of the Sheet being calculated. 

&USER& The Current User Code. 

PERBEGIN and PEREND Date Formatting Options  

The &PERBEGIN& and &PEREND& SQL variables are very flexible and should handle multiple date 
variations that may be dictated by the data source. The various options available with the &PERBEGIN& 
and &PEREND& SQL variables are shown below. The typical formatting options are displayed in the list of 
SQL Variables.  Formatting options can also be typed in manually to create the specific format needed by the 
data source. The examples shown assume a period ending date of January 1, 2007. 

SQL Variable Date Formatting Options 

Format Description 

&PERBEGIN& 

&PEREND& 

With no parameters specified 

Date format is based on the data source.  

Examples: 

SQL Server: &PEREND& = '20090131' 

Jet SQL: &PEREND& = CVDate("1/31/2009") 

ODBC with Jet SQL: &PEREND& = CVDate("1/31/2009") 

ODBC with ODBC Driver Syntax: &PEREND& = the date 
format is based on Control Panel Regional Settings 
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&PERBEGIN[(Format[,Delimiter])]& 

&PEREND[(Format[,Delimiter])]& 

Date formatted as specified by the Format parameter. A 
variety of examples are shown to illustrate this option. 

Format: A text string identifying the month, day and year 
style for the date format. Use m to designate months, d to 
designate days and y to designate years. 

m 1-12 

mm 01-12 

mmm Jan-Dec 

mmmm January-December 

d 1-31 

dd 01-31 

ddd Sun-Sat 

dddd Sunday-Saturday 

yy 00-99 

yyyy 1900-9999 

Delimiter (optional): Characters used at the beginning and 
end of the formatted date. If field is omitted, the formatted 
date will be delimited with a single quote at the beginning 
of the date and a single quote at the end of the date. 
Specifying the [,{,< and ( characters will delimit the date 
format with the open and close of the specified character. 

Examples: 

&PERBEGIN('YYMMDD')& = '090131' 

&PEREND(' YYMMDD', #)& = #090131# 

&PEREND(' YYMMDD', [)& = [090131] 

&PEREND('MM/DD/YYYY')& = '01/31/2009' 

&PEREND('MMM-DD-YYYY')& = 'Jan-31-2009' 

&PERBEGIN(Julian)& 

&PEREND(Julian)& 

Date formatted as specified by a Julian Long Integer 
Representation 

&PEREND(Julian)& = 732707 

&PERBEGIN(CVDate)& 

&PEREND(CVDate)& 

CVDate function with the date formatted as specified by 
the Control Panel 
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&PERBEGIN(Control)& 

&PEREND(Control)& 

&PERBEGIN('Short Date')& 

&PEREND('Short Date')& 

Date formatted as specified by the Control Panel (the Short 
date format from the Regional Settings) 

Examples: 

&PEREND(Control)& = 1/31/2009  

&PEREND('Short Date')& = 1/31/2009 

- when the regional settings are United States with a Short 
date format of M/d/yyyy 

&PEREND(Control)& = 31/01/2009  

&PEREND('Short Date')& = 31/01/2009  

- when the regional settings are United Kingdom with a 
Short date format of dd/MM/yyyy 

&PERBEGIN('Long Date')& 

&PEREND('Long Date')& 

Date formatted as specified by the Control Panel (the Long 
date format from the Regional Settings) 

&PEREND('Long Date')& = 'Wednesday, January 31, 2009'  

- when the regional settings are United States with a Long 
date format of dddd, MMMM dd, yyyy  

&PERBEGIN(SQLServer)& 

&PEREND(SQLServer)& 

Date formatted as specified by the SQL Server Generic Date 
format (YYYYMMDD) 

&PEREND(SQLServer)& = '20090131'  
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Plan Sheet Values 

Overview 

One of the most powerful components to a formula is the ability to read in values from existing plan sheets. 
There are a number of ways to use this option: 

•       Compute derivative values, e.g. sales commissions from sales times sales commission rate 

•       Compute allocations 

•       Compute derived business drivers, e.g. fringe benefit rate 

•       Consolidate unlike period intervals, i.e. months to quarters, quarters to year, etc. 

•       Create analysis reports. 

Within a formula, there are three formula line types that reference plan sheet values. 

•       Plan Sheet Lookups by Account Numbers (PS-Acct. #) 

•       Plan Sheet Lookups by Row IDs (PS-Row ID) 

•       Published Data Retrieval (Pub Data) 

To access plan sheet values based on account numbers, the range of accounts is evaluated based on the 
Account Number column and the periods are based on the configured periods for each column. For plan 
sheet row IDs, the row ID defined in the formula is matched to the row ID in the plan sheet and the periods 
are based on the configured periods for each column. 

The PS-Acct.# and PS-Row ID options retrieve values from one specific plan sheet. The Pub Data option 
can retrieve plan sheet values that cross companies, plans, sheets, groups, and dates. 

Completing a Plan Sheet Formula Line 

1.        Select the plan sheet formula line type of PS-Acct.# for a plan sheet account number or PS-Row ID for 
a row ID match. 

2.        Select the Year and Periods to process. 

3.        Select the Balance Code to process. The balance code is defined as the combination of the plan, plan 
sheet and column group containing the value to be retrieved. This is expressed in the form of a 
Plan.Sheet.Group key identification. Optionally, you may leave this field blank. If the field is left blank, the 
calculation looks to the column group to resolve the blank. When the calculation is refreshed, an error will 
display if a valid Plan.Sheet.Group combination is not found. 

4.        Type the appropriate parameter, based on the formula line type. 

a.        For the PS-Acct. # formula type, enter the beginning and ending account number into the Parameter 1 
and Parameter 2 fields. You can use a filter in these fields and the system will substitute information 
either from the Account Number dimension on the row or from the range of accounts assigned in 
Calculation Overrides, if any are specified. 

b.       For PS-Row ID formula type, enter the required Row ID in the Parameter 1 field. Filters may be used 
in the Parameter 1 field and the system will substitute information from the Row ID on the row; 
however, the entire field must be filtered. 

Lookup Plan Sheet Group Wizard 

The Lookup Plan Sheet Group wizard will assist the selection of the Balance Code for the PS-Acct. # or PS-

Row ID formula type. 

1.        Double click on the Balance Code field to launch the Lookup Plan Sheet Group wizard.  Alternatively, 

move to the Balance Code field and click the Lookup  icon to launch the wizard. 

2.        Select a specific Plan Key or choose the &PLAN& variable. The variable is a good choice for global 
formulas. When the formula is executed, it will replace the variable with the actual Plan identifier.  Click 
Next to continue. 
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3.        Select a specific Sheet Key or choose the &SHEET& variable. The variable is a good choice for global 
formulas. When the formula is executed, it will replace the variable with the actual Plan Sheet identifier. 
Click Next to continue. 

 

4.        Select a specific Group Key or choose the &GROUP& variable. The variable is a good choice for global 
formulas. When the formula is executed, it will replace the variable with the actual Group identifier. Click 
Next to continue. 
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5.        Click Ok to the end the wizard and enter the Plan.Sheet.Group key identification into the Balance 

Code field. Optionally, you may type characters into the Plan Key, Sheet Key or Group Key fields.  An 
example would be to type an X at the end of the &SHEET& variable., which would look like &SHEET&X. 
When the formula is executed, it will look up data from the Current Sheet Name with an X appended to it.. 

 

 

Processing Plan Sheet Lookup Formula Lines 

The system completes the following steps to obtain values using PS-Acct # and PS-Row ID formula lines: 

1.        Determines the year to process from the periods being processed. For example, if you are processing a 
column with a year of 2009 and you want to retrieve values from a column in a plan sheet with a 
column date of 2006, specify a year of Prior 1. 

2.        Determine the periods to process. This can either be fixed periods for the year or relative periods. 
Relative periods, just as in any other calculation, are substituted from the column dates. For example, if 
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a column has a range of periods from 1 to 1, then the equivalent dates will be constructed for the 
calculation. 

3.        Determine the account ranges or the row ID to process. If you specify a filter in an account range, the 
system substitutes the filtered positions with information from either the Account Number column or 
the Calculation Override accounts. If you specify a filter based on the row ID, then the entire row ID 
will be substituted in from the plan sheet. 

Once the variables are determined, the system can calculate the plan sheet values. The system processes the 
calculated values based upon the following criteria: 

•       An exact match of column periods in the plan sheet being read. For example, if you are calculating a 
value for a column assigned a valuation of Net Change with a period range of 4 to 6, the system will 
look for an exact match of periods 4 to 6 in the plan sheet group being referenced. 

•       The system will look for various other calculations that will construct the balance requested. Using 
the same example, individual net change columns of 4, 5, and 6 could be added together to get a 
column value of periods 4 to 6. The system also uses combinations of ending balance columns and 
beginning balance columns to achieve the result. For example, ending balance at the end of period 6 
minus the beginning balance at the beginning of period 4. 

 
Example: 

Consider the following project detail (Proposals.Detail). Projects are identified beginning with A or N 
depending on the project. One column group (CY_PLAN) is established for this plan sheet consisting of Net 
Change columns. The Account Number column is used as a project number. 

 
The following plan sheet is set up to summarize the proposed project funding by quarter. 

 
The following formula was used to summarize the proposed projects. 

 
The quarterly column periods are passed as the From and Thru Periods in the formula. 

•          The balance code is used to select the plan sheet Proposed Detail plan sheet (Proposals.Detail) and the 
CY_PLAN Column Group. 

•          Parameter 1 and Parameter 2 are used to select the range of projects beginning with A or N. 
The system will determine the calculation of the quarterly columns based upon the summarization of the 
appropriate individual monthly columns. 
It is easy to adjust the column periods of the project summary. For example, a column could be added to 
summarize proposed projects for all periods and use the same formula. 
 

Completing the Pub Data Formula Line 
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1.        Select the formula line type of Pub Data to retrieve cross-company, cross-plan, cross-sheet and cross-
group plan sheet data. 

2.        Select the Year and Periods to process. 

3.        Select the Company and Valuation. 

4.        Click the Pub Data button in the Parameter 1 field to bring up the Pub Data Retrieval Query 

Definition form. 

 

Pub Data Retrieval Query Definition Options 

Company The company will fill in from the formula row, but you can 
 select a different company using the lookup window.   

Optionally the Company will allow masking with ??? 
characters. During execution, the company value from the 
current sheet will be used to fill in the masks.  

Plan Enter a Plan Key or select a plan using the lookup window. 
 The list of plans will be dependent on the company selected 
in the formula line. If a masked company is used, the plan list 
will be the current company’s. 

Optionally the Plan will allow masking with ??? characters. 
During execution, the Plan value from the current sheet will 
be used to fill in the masks.  

Dimensions Select a dimension set using the lookup window.  The list of 
dimension sets available will be dependent on the company 
and plan selections. If the Plan is masked, the list will contain 
all the dimension sets for the company selected. 

Sheet Enter a Sheet Key or select a sheet using the lookup window. 
 The list of sheets will be dependent on the company, plan, 
and dimension set selections.  

Optionally the Sheet will allow masking with ??? characters 
or enter * to indicate all sheets. During execution, the sheet 
value from the current sheet will be used to fill in the masks.  
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Group Enter a Group Key or select a group using the lookup 
window.  The list of groups will be dependent on the 
company, plan, dimension set and sheet selections.  

Optionally the Group will allow masking with ??? characters. 
 During execution, the group value from the cell being 
calculated will be used to fill in the masks.  

Valuation Type The valuation type will fill in from the formula row, but you 
can select a different valuation using the lookup window. 

Dimension Ranges Enter the FromValue and Thru Value for each dimension in 
the dimension set. The from and thru values will allow 
masking with ??? characters. During execution, the 
dimension values from the row will be used to fill in the 
masks.   

Audit Output Checking this box will cause the publication query to display 
an audit report of the query result detail. 

  

Processing Pub Data Formula Lines 

The system completes the following steps to obtain plan sheet values: 

1.        Determines the year to process from the periods being processed. For example, if you are processing a 
column with a year of 2009 and you want to retrieve values from a column in a plan sheet with a column 
date of 2008, specify a year of Prior 1. 

2.        Determine the periods to process. This can either be fixed periods for the year or relative periods. 
Relative periods, just as in any other calculation, are substituted from the column dates. For example, if a 
column has a range of periods from 1 to 1, then the equivalent dates will be constructed for the calculation. 

3.        The formula engine will first validate the definition against the company/plan/sheet context it is 
running in. If any part of the definition is not valid during execution, an error message will be produced. If 
the definition is valid, then the appropriate substitutions for masked data will be made, masked dimension 
values will be filled in, and a query will be built to go against the appropriate publication view for the 
selected company/plan/dimension set. If the Audit Output flag is checked, an audit report of query detail 
will be produced.  This report will include the company, plan, group, sheet, from and thru dates, dimension 
values, and the corresponding detail amounts. A summary total of the detail will be printed which will be 
used as the result of the calculation. 

Once the masking is determined, the system evaluates published plan sheets to calculate the plan sheet 
values based on the selected criteria. The system processes the calculated values based upon the following 
criteria: 

•       The system looks for a match for the selected valuation type. 

•       The system looks for any data which falls entirely within the period range requested and adds it 
together. 

Note: If single monthly columns exist in a sheet with quarterly columns, then all of the column 
values will be added together. To avoid returning duplicate values, quarterly columns should be 
applied to a different group than the monthly columns. Then the option to publish the group 
associated with quarterly columns should be disabled. 

 
Example: 

Assume that you have budget plans for four companies that you would like to combine into one large plan. 
For all of the companies, the fiscal calendar is defined as a calendar year with monthly periods. The following 
plan sheets represent a sample of an expense item for each company. 
Company A: 
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Company B: 

 
Company C: 

 
Company D: 

 
Depending on the processing dates selected, different results will be returned. 

 
The above formula returns a value of 123,929. 

 
The above formula returns a value of 570,251. 

 
The above formula returns a value of 2,765,176. 
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Chapter 10 

Presentation 

Once you have created the basic structure of the plan sheet, Sage Budgeting and Planning provides several 
tools to enhance the plan sheet presentation. In addition to applying various formatting options, this chapter 
describes printing plan sheets and saving them in various formats such as HTML and Excel spreadsheets. 
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Cell Formatting 

Sage Budgeting and Planning allows you to set the following cell formatting attributes: 

•       Numeric formats 

•       Alignment 

•       Fonts 

•       Borders 

•       Background colors 

•       Protection 

To change cell formats, select one or more cells and select Edit > Cell Formats (Ctrl+F2) or click the cell 

format  icon. The fields for setting each attribute are displayed on a separate tab. Cell formatting options 
are discussed in the following sections. 

Numeric Formats 

  

 

Numeric Formats 

Decimal Places Choose the number of decimal places displayed in the selected 
cell(s). 

Display As Select whether the cells are to be displayed as Number, 
Currency or Percent 

Display Style Select how negative numbers will be displayed. 

Thousands Separator Select whether to separate the cell values with a separator 
character. 

Override Default 
Characteristics 

Type a separator to override the default Decimal Character 
and Thousand’s Separator specified in Sheet Options. 

Restrict Cell Value 
Amounts 

Set any restriction on values that a field may permit for manual 
entry by setting the largest negative value and the largest 
positive value. 

Tip: The Percent Capability is a very useful feature in Sage Budgeting and Planning . Setting the Display As 
to Percent does more than just display a percent sign in the cell. It allows you to enter percentages as a 
whole numbers. When referencing them in calculations, they will be evaluated as the appropriate decimal 
value.  Entering 10 into cell with Percent formatting will cause it to display 10%. It will evaluate as 0.10 when 
referenced in a formula. 
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Alignment 

Indicate the appropriate alignment for the selected cells. Text and values can be aligned both horizontally 
and vertically. Select the desired alignment for each from the drop-down box.  In addition, the data can be 
displayed Horizontal, Vertical, Up or Down.   

 

 

Fonts  

You can specify individual cell fonts, font attributes, and font colors. 

 

Cell Fonts Options 

Font Name Select from the list of font names installed on your computer. 

Size  Select from the list of font sizes available or type in a specific 
point size. 

Font Attributes Check the box to indicate the font attributes to attach to the 
selected cells. 

Color Select the appropriate font color to use for the selected cells 
from the drop-down box. 

Sample Displays sample text formatted in the selected font and 
attributes. 

Tip: You can also use shortcut keystrokes, Ctrl+B for bold, Ctrl+I for italics, and Ctrl+U for underlines, to 
apply font attributes for specific cells in the plan sheet 
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Borders 

You can specify borders and border colors to attach to the selected cells. 

 

Cell Border Options 

Border Select the appropriate border characteristics to attach to the 
selected cells. 

Style Select the appropriate border styles to attach to the selected 
cells. 

Color Select the border color to attach to the selected cells. 

Background Color 

Select a background color from the drop-down box to attach to the selected cells. 

 

Note: You may have to adjust your row height after changing cell formats. Drag the row boundaries to the 
desired size. 

Cell Locking 

Locking cells is a 2 step process.  The first step is to mark the cells which should be locked. Checking the 
Locked option in the Protection tab marks the highlighted cells as locked.   Changes can still be made by 
users with sheet design permission (Plan Administrators, Plan Controllers and the Sheet Manager) 

The second step is to protect the plan sheet. Sheets are automatically locked in WebView every time a sheet 
is opened by any user.  Sheets are automatically locked in Sage Budgeting and Planning when a sheet is 
opened by a user with Sheet Planner permission.  Once the sheet design is completed, turn on sheet 
protection to prevent other users with sheet design permission from entering values in the locked cells. To 
protect a plan sheet, select Sheet > Protection. 
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Cells are only locked from keyed entries, therefore all other cell updates from plan calculations, flow 
updates, and cell formulas will still occur. 

 

 

Note: Only users with sheet design permission can lock cells and turn plan sheet protection on or off. Also, 
WebView users do not have access to the Calc operation and could potentially overwrite pertinent cell 
information, therefore, it is important for the plan sheet manager to lock these cells. 

 

Tip: You can lock plan sheet reserved cells, such as the dimension columns, and the Calc, Notes, or Flow 
buttons. Thus, you can lock all cells in a plan sheet and selectively unlock designated cells. It may be a good 
idea to lock the entire plan sheet (select the column-row intersection) and unselect just those cells that 
require user entry. 
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Page Breaks 

By default, Sage Budgeting and Planning will attempt to format output based on the characteristics of the 
printer and the presentation formatting of the plan sheet itself. In addition, a Best Fit option will attempt to 
reduce output to fit within a printed page. In many cases, you may wish to control the printed output by 
forcing page breaks. 

To create a page break, highlight either a row or column and click the Page Break  icon or select Edit > 

Page Break. A page break will be inserted either above the selected row or to the left of the selected column. 

To remove page breaks, highlight the row or column and then click the Page Break  icon or select Edit > 

Page Break. The page break will be removed. 

The format of page breaks and whether they are visible can be set in Sheet Options. The viewing of page 

breaks can also be turned on and off by clicking the View Page Breaks icon. By default, page breaks are 
designated with a broken red line. However, this can be changed in Sheet Options. 
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View Options 

Using View Options, you can display or hide columns for presentation purposes and to see more of your 
working spreadsheet area. This feature hides reserved and custom columns individually. Standard columns 
are displayed and hidden according to their group and valuation type. For example, you can hide budget 
columns and display only actual columns, or hide detail monthly columns and display only summary, end-
of-year columns. View Options also allows you to turn off the display of the reserved columns to display 
more of the working spreadsheet area. 

1.        To hide or display columns, select Sheet > View Options. Reserved and custom columns are displayed 
individually and standard columns are displayed in group/valuation type order. 

 

2.        To modify the display of reserved columns uncheck the box next to the desired columns in the 
Reserved Columns section. If the box is checked, the column will be displayed. 

3.        To modify the display of custom columns, click the Custom Columns tab and uncheck the box next to 
the desired columns in the Custom Columns section. If the box is checked, the column will be displayed. 

4.        To modify the display of specific groups or column valuation types in a group (Beginning Balance, 
Net Change, or Ending Balance), check or uncheck the desired group and/or valuation. You may also sort 
the view options by valuation type or by group. If the box is checked, all the columns in the group and/or 
valuation will be displayed. 

5.        Click Ok to apply the changes or Cancel to exit the View Options selection without applying the 
changes. The view options selected will be saved when the plan sheet is saved. 
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Printing 

Printing the Plan Sheet 

Plan sheets are printed as they are displayed on the screen, with cell formats and attributes. User-defined 
page breaks will determine the data printed on each page. Columns that are frozen as defined in Sheet 

Options will be printed on each page.  The print options provide a large amount of flexibility over how to 
scale the printing, the page order and numbering, the plan sheet items to be included in the printing, and 
headers and footers. 

Plan sheets may be printed from an open plan sheet, from Plan Manager, from the plan sheet list view, or 
from Subsheet Manager. 

Tip: Only the plan sheet columns that are displayed will be printed. You can resize columns or use View 
Options, described earlier in this chapter, to display the intended printing result. The Flow, Notes, and Calc 
buttons will never print. 

1.        To print the plan sheet from Plan Manager, Subsheet Manager, or from the plan sheet list view, 
highlight the sheet to be printed and select File > Print > Plan Sheet. 
To print an open plan sheet, select File > Print > Plan Sheet (Ctrl + P). 

2.        Select the desired printing options on the Print Plan Sheet form. 

 

Print Plan Sheet 

Sheets to Print This option is available when printing from Subsheet Manager or Plan 
Manager as discussed in Chapter 12. The selected plan sheet, all 
subsheets, or the next level of subsheets can be selected. If Include 

Next Level Only is selected, specific subsheets can be selected. 

Range Select whether to print All of the plan sheet or Selected Cells. 

Scale There are four options available for scaling the printing.  

As Formatted: Prints sheet as formatted with no Scaling 

Best Fit: Sage Budgeting and Planning follows a set of internal rules 
to determine how the plan sheet would best fit on a page 

Adjust to: Allows the user to adjust the specified size based on an 
entered percentage 

Fit To: Allows the user to enter the number of pages Wide and Tall 
they want it to print within. 

Orientation If Best Fit is selected, Sage Budgeting and Planning will 
automatically format the orientation. If As Formatted is selected, 
specify the orientation as either Portrait or Landscape. This setting 
overrides any setting in the Printer Setup. 
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Print Select the appropriate options to print for this plan sheet. The options 
available are: Center Vertically, Center Horizontally, include 
Gridlines, Color Printing, include Row Headings, include Column 
Headings and Letters, include Plan Sheet Border, include Row Notes 
and Exclude Zero Balance Rows. 

Page Order Designate the order in which pages should be printed. 

Page Numbering Designate the starting page number. Select Consecutive Page 

Numbering if printing multiple plan sheets. If this option is not 
selected, each plan sheet will start a new page sequence. 

Tip: Use the Print option, Notes, to print the text entered into the Row Notes. Row Notes will print on a 
separate page at the end of the plan sheet pages. You can easily see what row a Note is associated with 
because it is identified with its DImension(s) and row number. 

3.        To customize and format headers and footers, click the Header and Footer tab, and select the area you 
want to edit. 

 

4.        Start typing or double-click the variable(s) you would like to use. Also select the font, size, and font 
attributes to apply to the cell. 

 

Edit Header and Footer 

Variables Select from the list of custom variables to include in the header 
or footer. One or multiple variables can be included in a line. 

Font Name Select from a list of fonts installed on your computer. 

Font Size Select from a list of font sizes installed on your computer. 

Font Attributes Select from a list of standard attributes. 

Header and Footer Variables 

&COMPANY& Company name 

&DATE(format)& System date in the specified format (e.g., yyyy/mm/dd or 
mm/dd/yyyy) 

&DESC& Plan sheet description 

&MANAGER& Plan sheet manager 

&PAGE& Current page number of the report. 
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&PLANDATE(format)& Plan sheet base date in the specified format (e.g., 
yyyy/mm/dd or mm/dd/yy) 

&PLANKEY& Plan key 

&REVISION& Revision key 

&SHEETKEY& Sheet key 

&TIME(format)& System time in the specified format (e.g., hh:mm). 

&USER& User ID 

5.        To preview the plan sheet layout, the Preview button. The preview offers a number of alternatives to 
scan between printed pages and between plan sheets. 

Note: Print Preview shows the plan sheet cell formatting but does not reflect the Best Fit print option. 

6.        To choose the printer that Sage Budgeting and Planning will use for printing, click the Printer Setup 

button and choose the desired printer. 

Note: Sage Budgeting and Planning supports printing on 8.5 x 11 paper, 11 x 17 paper or other special 
printer settings. To accomplish this, set the printer default to the desired settings, then go into Sage 
Budgeting and Planning and print the plan sheets, then set the printer default back to the normal 
settings. 

7.        Click Ok to print the plan sheet with the options selected.  If you click Cancel, the sheet will not be 
printed. 

Printing the Plan Sheet Definition 

The plan sheet definition prints an audit trail of plan calculations and formulas used in the preparation of 
the plan sheet. The plan sheet definition also includes the details of any local formulas used in the 
calculations. To print global formulas, print the global formula listing as discussed in Chapter 9. The plan 
sheet definition can be printed from an open plan sheet, from the plan sheet list view, from Plan Manager, 
or from Subsheet Manager. 

1.        To print a plan sheet definition from Plan Manager, Subsheet Manager, or from the plan sheet list 
view, highlight the desired sheet and select File > Print > Definition. 

To print the definition of an open plan sheet, select File > Print > Definition 

2.        Select the desired printing options on the Print Definition form. 
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Print Definition 

Sheets to Print This option is available when printing the plan sheet definition 
from Subsheet Manager or Plan Manager. The selected plan 
sheet, all subsheets, or the next level of subsheets can be 
selected. If Include Next Level Only is selected, specific 
subsheets can be selected 

Range Select whether to print the definition for All Rows of the plan 
sheet or only Selected Rows. 

Include Select which definitions to include on the report. 
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File Formats 

Save as Excel 

You can save a plan sheet as an Excel spreadsheet. 

1.        Select File > Save as Excel. 

 

2.        Select the directory and the file name to be used. Click Save to continue or Cancel to exit without 
saving the plan sheet as a spreadsheet. 

3.       A prompt will display asking if you wish to save visible columns only. Visible columns are those that 
have not been resized to zero or hidden using View Options. 

 

4.        Click Yes to save only visible columns, click No to save all columns, or click Cancel to exit without 
saving the plan sheet as a spreadsheet. 

Save as HTML 

You can save a plan sheet as a read-only HTML document. 

Note: Plan sheets can also be maintained interactively using WebView as discussed in Chapter 13. 

1.        Select File > Save as HTML. 

 

2.        Select whether the Entire Sheet should be saved or just Selected Cells. 

3.        Select whether to Save Visible Cells Only. This option will only save those columns visible on the 
screen and not those that have been hidden in View Options. 

4.        Click Ok to save the sheet as an HTML page or click Cancel to cancel the action. 
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Chapter 11 - Advanced Techniques 
 

 

Chapter 11 

Advanced Techniques 

Sage Budgeting and Planning offers tools that allow you to automate plan sheet creation and maintenance, 
which are discussed in the subsequent sections. 
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Sections 

Overview 

Sections allow you to manage a range of dimension values in a plan sheet. Row characteristics are assigned 
to the section, including formatting, cell formulas and plan calculations. For example, if new general ledger 
accounts have been created or additional employees join the organization, those values may be easily 
inserted into your existing plan sheet without disturbing or overwriting existing data, calculations, notes, 
etc. 

Users can also create standard information for each dimension within the defined range. Information that 
may be controlled for each section include: 

•       Cell Formats 

•       Cell Formulas 

•       Plan Calculations 

•       Flow 

•       Notes 

•       Custom Column Data 

 

Creating Sections 

The section definition is comprised of a header row, a section row and a footer row. When the section is 
generated, the header row will be inserted at the top of the section, the footer row at the bottom and the 
middle row will expand or contract depending on the range defined. Any row options such as Flow, Notes, 

Calc, cell formulas or formatting defined on the Section Maintenance form will be applied to the plan sheet 
rows. For the section row, with the exception of the Type column, all reserved columns to the left of the 
Flow button, are locked and may not be edited. All reserved column fields for the header and footer row are 
locked except for the Description column field and the Notes button. 

Note: Values inserted into section cells must follow an equal sign (=) or the value will not display when the 
section is generated. eg: =500 

 

Note: Only the columns that are visible in the plan sheet are displayed in Section Manager. 

1.        To create a new section, select Sections > Section Control > Append. A new section can also be created 
using Section Manager which can be accessed by selecting Section > Section Manager. 
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2.        From Section Manager, click the Insert or Append button. The Section Maintenance screen displays. 

 

Section Maintenance Options 

Section Define a key of up to 16 alphanumeric characters to identify the 
section. 

Description Define a description of up to a 60 characters to describe the section. 

Define Ranges Click this button to identify the dimension range to be used for the 
section.  

Note: If you are defining a section within a template, all or any part 
of the section range may be filtered. Refer to Templates for 
additional information on this option. 

Cells In the area that resembles the plan sheet, define headers and footers 
for the section, apply formatting, define Flow, Notes, and Calcs, and 
create cell formulas. 

Tip: When referencing absolute cell addresses, the cell that you are 
referring to should be above the section for the correct information to 
be retrieved. 

Tip: If the first row of the generated section body is changed on the plan sheet, then the entire section 
definition is automatically updated.  You may find it easier to format the Section in the plan sheet rather than 
in the Section Maintenance.  Define the Flow, Calcs, cell formulas and cell formatting for the first row, then 
Regenerate the Section to apply this definition to the whole Section.. 

3.        Click Ok to generate the section in the plan sheet, or click Cancel to exit Section Maintenance without 
committing any changes. 
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Maintaining Existing Sections 

1.        To maintain an existing section, select Sections > Maintenance from the plan sheet menu or click the 
Maintain button in Section Manager. 

 

Section Maintenance Options 

Section Represents a key of up to 16 alphanumeric characters to identify the 
section. This field may be edited. 

Description Provides a description of up to a 60 characters to describe the 
section. This field may be edited. 

Define Ranges Click this button to identify the dimension range to be used for the 
section. The same Insert Range screen that is used to insert 
dimension ranges into plan sheets displays. 

Generate: Generate 
Missing Rows 

Select this option to insert additional dimension values that fall 
within the defined range. 

Note: Any formatting, editing, or calculations applied to the original 
section is retained when this option is selected. 

Generate: Remove 
Invalid Rows 

Select this option to remove any previously defined rows that fall 
outside of the defined range. 

Note: Any formatting, editing, or calculations applied to the original 
section is retained when this option is selected. 

Generate: 
Regenerate All 
Rows 

Select this option to completely remove the previously defined 
section and regenerate it. 

Cells In the area that resembles the plan sheet, define headers and footers 
for the section, apply formatting, define Flow, Notes, and Calcs, and 
create cell formulas. 

Note: Only the columns that are visible in the plan sheet are displayed in Section Manager. 

2.        Click Ok to save the changes made to the section, or click Cancel to exit Section Maintenance without 
committing any changes. 

Tip: Flow, Notes, and Calc information applied to a section may be edited in Section Maintenance. 
Then the section may be regenerated to reflect the changes. 

Section Manipulation 

Inserting Sections 

1.        Highlight an empty row or the top row of an existing section. 

2.        Select Sections > Section Control > Insert. 
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3.        Complete Section Maintenance. 

4.        Click Ok to insert the new section into the plan sheet or click Cancel to exit out of Section 

Maintenance without initiating any changes. 

Note: Inserting a section into a blank row adds the section rows above that row. Inserting a section into an 
existing section inserts the section rows above the existing section. 

Appending Sections 

1.        Highlight any row in the plan sheet. 

2.        Select Sections > Section Control > Append. 

3.        Complete the Section Maintenance. 

4.        Click Ok to append the new section to the bottom of the plan sheet or click Cancel to exit out of 
Section Maintenance without initiating any changes. 

Copying Sections 

Copying sections allows you to quickly add sections with similar characteristics to the plan sheet. 

1.        Highlight any row in the section you wish to copy. 

2.        Select Sections > Section Control > Copy. 

3.        Modify the Section key and any other information in Section Maintenance. 

4.        Click Ok to append the copied section to the end of the plan sheet or click Cancel to exit out of Section 

Maintenance without initiating any changes. 

Note: Any formatting characteristics such as flow, notes, calculations, or manually keyed numbers defined in 
Section Maintenance of the original section will be applied to the copied section. 

 

Note: If flow is copied to another section, duplicate row IDs will result. Therefore, you must regenerate the 
row IDs for the plan sheet for consolidation or distribution to operate properly. 

Deleting Sections 

1.        Highlight any row in the section you wish to delete. 

2.        Select Sections > Section Control > Delete. 

3.        A warning message will display confirming the deletion. 

 

4.        Click Yes to delete the section or click No to return to the plan sheet without initiating any changes. 

Generating Sections 

Sections are initially generated when a new section is created, however, sections may be regenerated at any 
time. Sections may be regenerated during Plan Processing, from the Section Maintenance screen, or from 
the menu of an open plan sheet. 

1.        To generate sections from an open plan sheet, select Sections > Generate. 
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2.        The Generate Sections window displays. 

 

3.        Select an Action from the drop-down list. 

Generate Sections Actions 

(blank) The default action is blank, therefore when you click Ok the section 
will not be generated. This option is useful when you wish to 
generate one section but not another. 

Generate Missing 
Rows 

Select this option to insert additional dimension values that fall 
within the defined range. 

Note: Any formatting, editing, or calculations applied to the original 
section is retained when this option is selected. 

Generate 
Missing/Remove 
Invalid Rows 

Select this option insert additional dimension values that fall within 
the defined range and to remove any previously defined rows that 
fall outside of the defined range. 

Note: Any formatting, editing, or calculations applied to the original 
section is retained when this option is selected. 

4.        Click Ok to generate the section(s) or click Cancel to exit out of Generate Sections without initiating 
any changes 
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Templates 

Templates are a powerful feature that enables users to create and update multiple plan sheets with similar 
structures without sacrificing the ability to individualize them. Users familiar with the creation and 
modification of plan sheets will be able to easily utilize this feature since template definitions are nearly 
identical to standard plan sheets with a few exceptions as described in later sections. 

While templates are discussed as a general concept, they consist of the following three components: 

•       Template Definition the master definition from which subsheets will be defined and globally 
updated. 

•       Template Source Definition a list of subsheets to be generated from the template definition. 

•       Derivative Sheets plan sheets that have been generated from the template definition. 

The steps for creating, maintaining, and removing templates always involve actions related to these 
components. Templates support both the initial creation of a number of similar derivative sheets and the 
ongoing maintenance of these derivative sheets, allowing for successful planning. Some of the key terms for 
this process are: 

Template Key Terms 

Templates A feature that allows multiple plan sheets with similar structures to 
be created and maintained. 

Template Definition A special plan sheet that serves as the definition for creating and 
maintaining derived plan sheets. One template definition is 
associated with zero to many derivative sheets. 

Derivative Sheet A plan sheet that is created from the template definition. Each 
derivative sheet is associated with only one template definition. 

Template Source 
Definition/Template 
Value List 

The list of derivative sheets to be created or updated during the 
generation process. This list does not have to directly correspond 
to the actual derivative sheets that exist at any point in time. 

Generation/Replication The process that describes the replication of derivative sheets from 
the template definition. Associated with the initial creation of 
derivative sheets. 

Regeneration The process that describes the updating of previously existing 
derivative sheet from the template definition. 

Creating Template Definitions 

Template definitions may be created in two ways. You may create the definition from scratch, or you may 
convert an existing plan sheet into a template definition. 

Creating a New Template Definition 

Defining the Properties 

Each template definition is identified by a plan key, sheet key and description. The plan key is very 
important, as it will determine which plan in Plan Manager the template definition is assigned to. The plan 
key is also used for the derivative sheets. 

1.        To create a new template definition, you must designate a new sheet as a Template Definition Sheet. 

2.        Create a new sheet by selecting File > New > New Sheet from Plan Manager or from the plan sheet list 

view, select File > New. You may also click the New Sheet  icon. 
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3.        Type a unique Sheet Key of up to 16 alphanumeric characters to identify the template definition. When 
the template definition is saved, this key will become the Template Sheet key. 

4.        Type a Description of the template definition of up to 40 alphanumeric characters. 

5.        In the Type field, select Template Definition Sheet. 

6.        Next, assign a Status for the template definition. You can use the lookup option to search for a list of 
valid status codes. The status code will be used as the default for each new derivative sheet identified in the 
Template Source Definition form; however, the status code may be changed on an individual basis for each 
derivative sheet. 

7.        Assign a Manager to the definition. You can use the lookup option to search for a list of valid users. 
The manager will be used as the default for each new derivative sheet identified in the Template Source 

Definition form; however, the manager may be changed on an individual basis for each derivative sheet. 

8.     Finally, you may select the option Lock the sheet. 

9.     Once the Properties tab is completed, you may apply sheet, row, and column dimensions to the 
definition. 

10.     Click Ok to save the initial template definition. The definition will be saved in the plan tree and 

identified with the template definition  icon. 

Defining the Structure 

1.        In Plan Manager or from the plan sheet list view, highlight the template definition for which you wish 
to create a plan sheet structure. 

2.        Select File > Open or click the Open Sheet  icon. 

3.        Define all of the necessary components of the template definition as you would for a standard plan 
sheet, including groups, columns, sections, rows, calculations, formulas, formatting, views, and sheet 
options. 

4.        If you insert a dimension range, on a row-by-row basis, indicate which dimensions or dimension 
segments will change for each derivative sheet by using filter characters (???). For example, if the template 
definition is a departmental Operating Expense sheet, the department dimension or dimension segment will 



Chapter 11 - Advanced Techniques 

231 

change. Filter the corresponding dimension or dimension segment. When the derivative sheets are 
generated, the appropriate department segment will replace the filters for each sheet. 

 

Tip: Since the Find & Replace feature uses question marks (?) as a mask instead of a filter character, 
there is no direct means for globally replacing dimensions or dimension segments with filters. 
Alternatively, you can highlight the column, copy and paste the column to Excel, use the Excel replace 
function and then copy and paste the results back into the template definition instead of manually 
changing each dimension or dimension segment. 

5.        Optionally, you may define sections with filtered dimensions or dimension segments, then, when the 
derivative sheet is generated, the rows will expand accordingly. Insert or append a section to the template 
definition. In Section Maintenance, click the Define Ranges button and define the section range. Substitute 
filters (???) for the dimension or dimension segment to be affected during derivative generation. In the case 
of the departmental Operating Expense sheet example, the department dimension or dimension segment is 
filtered. 

Because the dimension range is filtered, valid dimension values are not returned and the section will not 
generate any rows in the template definition. However, once the derivative sheets are generated, the 
appropriate dimension or dimension segment value will replace the filters and the section will generate 
the appropriate rows. The example below demonstrates the affect of adding a section with filtered 
dimension ranges for the department dimension segment. Note that no section rows can be generated in 
the template definition. 
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Note: If you are defining a section that will contain identical dimension values for all sheets, then you do 
not need to filter the dimension range and the section will generate within the template definition in 
accordance with standard section operations. 

 

Note: Sections initially attempt to generate when they are defined for the first time in the template 
definition. As derivative sheets are generated, each section will regenerate completely. 

 

Tip: When referencing absolute cell addresses, the cell that you are referring to should be above the 
section for the correct information to be retrieved. 

 

Tip: The use of sections and cell calculations in templates can be extremely powerful, however there are 
a few caveats. Since template section row counts can differ in size compared to the section rows 
generated in a derivative sheet, the use of subsequent cell formulas can be tricky. The first time the 
section is generated in the derivative, the cell formulas are passed correctly. However, there is a risk that 
when the derivative is regenerated, the cell formula will be adjusted incorrectly and reference an 
incorrect range. There are two solutions. The first is to set the template row lock to Ignore for the row 
that contains the cell formula after the derivatives have been generated the first time. The second 
solution is to always regenerate the derivative section when the derivative sheets are regenerated. 

 

6.        Next, select the appropriate sheet options to be applied to the derivative sheets. 
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Template Specific Sheet Options 

Publish Sheet (for 
derivative sheets) 

Check this box to set the publish flag for all derivative sheets. 
If this option is checked, then all of the data on the derivative 
sheets will be saved to the publication database. 

Sheet Template Identifies this plan sheet as a template definition. 

Tip: If you want the row description to update automatically based on the dimension value, check the 
Auto Dimension Description Entry option. If you want to maintain the row description for all derivative 
sheets, then you should leave the Auto Dimension Description Entry option unchecked. 

7.        Finally, save the template definition by selecting File > Save or by clicking the Save  icon. 

Creating a Template Definition From an Existing Plan Sheet 

Occasionally, you may have an existing plan sheet that contains the structure that you would like to 
replicate. The sheet can easily and quickly be changed to a template definition. To change a standard plan 
sheet to a template definition, open the plan sheet and select Sheet > Sheet Options. On the Other tab, 
check the Sheet Template option. 

 

Click Ok to activate the changes and save the plan sheet to create the template definition. Once the plan 
sheet is defined as a template definition, the standard template instructions for creating derivative sheets 
apply. 

Defining Derivative Sheets 

Template Source Definition 
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Once the template definition has been created a list of derivative sheets may be defined for generation. The 
list of derivative sheets may contain derivative sheets that have previously been generated from the 
template or new sheets may be added to the list to be generated. In addition, sheets may be removed from 
the list and therefore will not be regenerated. Thus, while the list of derivative sheets would generally have 
a one-to-one correspondence to the actual sheets derived from the template, the product does not enforce 
this relationship. 

To define the list of derivative sheets to be generated: 

1.        Highlight the template definition that the defined sheets will be generated. 

2.        Select Management > Define Derivative Sheets or click the Define Derivative Sheets  icon. The 
Define Derivative Sheets form displays. 

 

4.        Click the Append Row  icon or select Row>Append. This will insert a row that will allow you to 
begin defining derivative sheets to be generated from the template definition. At any point in time you may 
insert or delete rows identifying the derivative sheets to generate. 

5.        Enter the appropriate values to define each derivative sheet. 

Template Source Definition Fields  

Sheet Key Enter a sheet key. 

Description  Enter the sheet description. 

Manager (optional) Assign a manager to the plan sheet. You may use the lookup to 
select from a list of valid managers. The default manager is 
based on the manager assigned to the template definition. 

Status Assign a status for the generated sheet. You may use the lookup 
to select from a list of valid status codes. The default status is 
based on the status code assigned to the template definition. 

Revision (optional) Assign a revision for the generated sheet. 

Dimension Value 
(optional) 

Enter a value to be used to replace any filtered dimensions or 
dimension segments. 

Note: Filtered dimensions are defined in the template definition by 
using a ? in the dimension or dimension segment. Thus if the 
dimension range is 6000-000-???-00 and     -    -100-  is entered 
into the Value field, then the resulting dimension value would be 
6000-000-100-00. 
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6.        Click the Save  icon to save the definition. 

Template Automatic Sheet Definitions 

While users may add each derivative sheet to the list on an individual basis, it is also possible to 
automatically define multiple derivative sheets based on dimension or dimension segment items. For 
example, a derivative sheet can be generated for each territory and/or department using this feature. 

1.        From the Template Source Definition window, click the Automatic Sheet Definitions  icon or 
select Template > Automatic Sheet Definitions. 

 

2.        Complete the fields with the essential information. 

Template Automatic Sheet Generation 

Sheet Prefix (optional) Enter a sheet prefix. This value will precede the dimension key 
value to create a unique plan sheet key. Click the Insert 

Dimension Segment button to specify the dimension segment(s) 
to be used in the prefix. 

Note: If the generated prefix length is greater than the length of 
the sheet key field, it will be truncated but a unique identifier will 
be created. 

Description Prefix 
(optional) 

Enter a sheet description prefix. Click the Insert Dimension 

Segment button to specify the dimension segment(s) to be used 
in the description. 

Note: If the generated prefix length is greater than the length of 
the sheet description field, it will be truncated. 

Manager (optional) Assign a manager to be applied to all of the derivative sheets. 
You may use the lookup to select from a list of valid managers. 
The default manager is based on the manager assigned to the 
template definition. 

Status Assign a status to be applied to all of the derivative sheets. You 
may use the lookup to select from a list of valid status codes. The 
default status is based on the status code assigned to the 
template definition. 
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Revision Assign a revision to be applied to all of the derivative sheets. 

Dimension Values  Type the From and Thru range for the dimension values to be 
applied to the derivative sheets. Optionally, check the All 

Values? box to apply all possible dimension values. 

New Sheet on 
Segment 

Specify the dimension segment to be used to generate new 
derivative sheet entries in the Template Source Definition list. 

Note: If multiple dimensions have been applied to the template 
definition, only one dimension may be specified for this option or 
errors will display. 

Generation Options Select Delete All Existing Sheet Definitions to delete all 
derivative definitions previously defined in the Template Source 

Definition form. Note that this selection does not overwrite any 
derivative sheets. Only the derivative list definition is 
overwritten. 

Select Append to Existing Definitions to add the derivative 
definitions to those defined previously on the Template Source 

Definition form. 

 

Example: 

When specifying the range of accounts, the list of all accounts within the specified range will be generated. 
Each time the selected dimension in the New Sheet on Segment field changes within the list, an entry will 
be generated. For example, the third segment (department) is specified as the one to break and the account 
dimension includes the following accounts: 

6000-000-100-00 
6000-000-200-00 
6000-100-100-00 
6000-100-200-00 

If a range from 6000-000-100-00 to 6000-100-200-00 is specified, then, four sheets will be generated. Note that 
the departments are separated. Consequently, careful consideration should be given when defining account 
ranges. In order to generate just two sheets, one for department 100 and one for department 200, you should 
specify the range as 
6000-000-100-00 to 6000-100-100-00 and another of 6000-000-200-00 to 6000-100-200-00. 
 

3.        Click Ok to process the definition generation. The entries are added to the list of derivatives on the 
Template Source Definition form and are ready for generation. 

Generating Derivatives 

Generation 

Once the template definition has been created and one or more derivative sheets have been defined in the 
Template Source Definition list, generation of derivative sheets may be initiated. The generation process 
may involve the initial creation of a derivative sheet or it may entail subsequent updating of a derivative 
sheet from the template definition. 

1.        Highlight the template definition that will be used to generate the derivative sheets. 

2.        Select Management > Generate From Templates or click the Generate from Template  icon. 

3.        The Generate Sheets From Template form displays. 
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4.        Specify the appropriate generation options. 

Generation Options 

Generate? Check this box to specify the derivative sheets to be generated or 
regenerated. You may select all derivative sheets for generation by 

clicking the Select All  icon in the Generate ? column. 

Clicking the Unselect All  icon unchecks all of the boxes so 
that none of plan sheets will be generated during the generation 
process. By default, the Generate? flag will not be selected. At any 
time, you may select one or more derivative sheets to be 
generated. 

Calculate? Check this box to specify whether to refresh calculations for the 
plan sheet(s) generated. You may choose to select all derivative 
sheets for calculation in the Refresh Calculations column by 

clicking the Select All  icon or you may click the Unselect 

All  icon to not refresh calculations for any derivative sheets 
generated. By default, the Refresh Calculations? flag will not be 
selected. 

Calculation Options  If you are refreshing calculations, specify the Calculation 

Options to be used. 

Note: Selecting Calculation Options: All overrides all plan 
sheet and group calculation operations and recalculates all 
calculations. To preserve the calculation options selected for the 
plan sheet and/or groups, select Calculation Options: Date 
Range and specify a date range. 

Section Generation Specify the section generation options to be used for all sections in 
all derivative sheets being generated. 

Note: This option applies for regeneration of derivative sheets 
only. For derivative sheets being generated for the first time, 
sections will be created and generated regardless of the option 
specified here. Also, sections that are specific to a derivative 
sheet (not defined in the template definition) will not be affected by 
these options. 

5.        Click Ok to generate the selected derivative sheets. 
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6.        An output log is created, identifying the derivative sheets that were generated. You can Print the log or 
Save to File. 

7.        Click Close to exit out of the output screen. 

Field Replication 

In order to properly utilize templates, it is important to understand how items move from the template 
definition to the derivative sheet. Most of the items on the template definition are copied directly from the 
template definition to the derivative sheet; however, there are some exceptions, rules, and differences that 
apply for initial derivative sheet creation versus existing derivative sheet replication. The table below 
identifies these exceptions. Unless otherwise noted, items will be updated in the derivative sheet when 
generated from the template definition. 

Derivative Sheet Field Population 

Plan Key Created within the same plan as the template definition. 

Sheet Key Populated from the information indicated on the Template 

Source Generation form. 

Description Populated from the information indicated on the Template 

Source Generation form. 

Manager Populated from the information indicated on the Template 

Source Generation form. 

Status Populated from the information indicated on the Template 

Source Generation form. 

Revision Populated from the information indicated on the Template 

Source Generation form. 

Cell Values Values are not updated unless the template definition has a cell 
formula or a non-blank value in the cell. 

Columns All columns will be created upon the initial derivative sheet 
generation. Columns within column sets will be updated, added, 
or deleted during regeneration. 

Security Security will be copied on the initial generation for a derivative 
sheet, but not the regeneration. 

Sections The section definition is always copied from the template 
definition to the derivative sheet even if all of the section rows are 
locked. 

Section Rows If the template section is generated or regenerated, individual 
section rows are not copied to the derivative sheet. If the template 
section is not regenerated, individual section rows are copied to 
the derivative sheet and normal row locking rules apply. 

Template Definition 
Locked Rows: 
Ignore 

All rows will be copied on the initial generation of a derivative 
sheet. Template definition rows designated as Ignore will not 
update the corresponding derivative sheet rows during 
regeneration. 

Derivative Sheet 
Locked Rows 

Rows designated as Locked in the derivative sheet will not be 
updated during the regeneration process. 

Publish Sheet Indicates state of the publish sheet flag on the derivative sheet. If 
the option is turned off in the template definition, the derivative 
sheets will not be published and vice versa. 

Dimension Values 
(non-filtered) 

Dimension values that are not filtered (???) in the template 
definition are copied to the derivative sheet during both the initial 
generation and regeneration process. Section generation rules and 
row locking rules apply. 

Dimension Values Dimension values that are filtered (???) in the template definition 
are updated from the dimension value designated in the 
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(filtered) Template Source Generation form. Section generation rules and 
row locking rules apply. 

Dimension 
Description 

The dimension description field will be copied from the template 
definition to the derivative sheet during the generation or 
regeneration process. However, if one of the dimension values is 
filtered in the template definition and the Auto Dimension 

Description Entry option is turned on in the derivative sheet, the 
description will be changed based on the result of the new 
dimension values. Row locking rules apply. 

All others All other objects are copied from the template definition for both 
the initial generation and the regeneration process unless noted 
above. 

All other template definition objects will be added to or updated in the derivative sheet during the 
regeneration process. The regeneration process will not affect derivative sheet specific items such as rows, 
columns, cell calculations, formatting, etc. added to the sheet after the fact. An exception to that situation is 
if rows are added in the middle of a section and the Regenerate All Rows or Remove Invalid Rows option 
is selected during regeneration. 

Named Range 

When a named range is added to a template, it will be added to the derivative. If the named range already 
exists in the derivative, it will be overwritten. If a named range is deleted from a template, it will not be 
deleted from the derivative. If named ranges are manually added to a derivative, then they should be 
named in such a way that it is unlikely to conflict with named ranges in the template. 

 

Maintaining Existing Templates 

Editing Template Definitions 

Templates allow you to maximize plan sheet maintenance throughout the budget lifecycle. Changes are 
expected during the initial budget development phase, as well as during monthly reforecasting and 
business changes. The table below identifies the general areas that may be modified within a template 
definition that can be applied to derivative sheets. 

Template maintenance may involve changes to the template definition, Template Source Definition, and/or 
derivative sheets. 

Template Definition Changes 

Structure Additional rows, sections, groups, and columns can be easily 
added to the template definition and replicated to the specified 
derivative sheets. Additionally, dimensions can be modified, 
added or removed. Finally, date orientation can be modified 
for forecasting and modeling requirements. 

Values The values associated with cells, dimensions, or other entry 
fields may be modified and replicated to derivative sheets. 

Formatting The formatting associated with the sheet may be modified 
and replicated to derivative sheets. Additionally, the view of 
the sheet may be revised and replicated as requirements 
change. 

Template Source 
Definition 

Derivative sheets may be added, updated, or deleted from the 
Template Source Definition. Also, some of the properties may 
be revised. In addition some or all of the derivative sheets may 
be regenerated. 

Template Row Locking 
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Template editing allows global changes performed in the template definition to be applied to each 
derivative sheet through the regeneration process. However, it is also possible to prevent individual rows 
from replicating from the template definition to derivative sheets through the use of template row locking. 

This feature is primarily useful when a row should be initially added to a derivative sheet, but not 
replicated after the initial creation. One example of this would be for any calculation factor (e.g. travel 
expense) for which an initial global factor is specified, but may be overridden at the derivative sheet level. In 
a case where the derivative sheet manager or planner may revise any part of the rows relating to its 
structure (formatting, dimension value, calculation, cell formula, etc.), row locking may be extremely useful. 

As displayed in the example below, the Template Row Action column is added for template definition. 

 

 

Template Row Action 

Ignore Indicates that this row should not be copied to the 
corresponding row in each derivative sheet during 
regeneration. 

Replace/<blank> Indicates that this row should be copied to the corresponding 
row in each derivative sheet during regeneration. 

Note: For the initial creation of new derivative sheets, all rows are added regardless of this setting. 

Editing Derivative Sheets 

Once a derivative sheet is created, it is nearly identical to a standard plan sheet in terms of structure, 
function and utilization. Generally, multiple derivative sheets will be incorporated within the budgeting 
process and individual derivative sheets will essentially have the same structure as all other derivative 
sheets with the exception of dimension values and cell values. 

In other cases, exceptions are required within the budgeting process. In these cases, structural modifications 
such as the addition of rows or columns, specific calculations, formatting, or other changes are necessary. 
These alterations are supported by allowing structural modifications, with minimal restrictions, to 
individual derivative sheets. 

Note: While changes can be made directly to the derivative sheet, many will be overwritten when the 
derivative sheet is generated unless proper precautions are made. For example, if a row is deleted in a 
derivative sheet and the derivative sheet is regenerated from the template definition, the row will be 
recreated in the derivative sheet. 

Some of the key differences between derivative sheets and regular plan sheets include the following: 
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Derivative Sheet Differences 

Plan Key Created within the same plan as the template definition. 

Dimensions Cannot be directly modified within the derivative sheet. 

Template 
Row Lock 

This column can protect the derivative sheet from changes applied at the 
row level from the template definition. 

Columns Columns cannot be inserted or moved within column set boundaries. 

Derivative Row Locking 

Individual rows on the derivative sheet may also be protected or locked from changes made in the template 
definition. 

Note: Locking only prevents row specific changes from occurring during the regeneration process. 

In the following example, one of the rows is set to Locked. Therefore, if changes are made in the template 
definition, the derivative row will not accept the changes upon regeneration. Other rows are set to 
Unlocked and they will allow changes from the template definition upon regeneration. One final row is 
specific to the derivative sheet and is not impacted by the locking since it does not exist in the template 
definition. 

Note: This locking does not prevent users from making changes to the derivative sheet. It only allows or 
prevents changes from the template definition regeneration process. 

 

Derivative Row Lock Options 

Locked Indicates that this row should not be replaced by changes 
made to the template definition during regeneration. 

Unlocked Indicates that this row should be replaced by changes made 
to the template definition during regeneration. 

Blank Indicates that this row is specific to the derivative sheet. 
Locking options cannot be specified since the row does not 
exist in the template definition. 

Auto Lock Template Row Changes 

If manual changes are made to a derivative row, you must set the Template Row Lock column value to 
Locked to prevent the template regeneration from changing the row. In the derivative sheet's options tab, 
you may check the Auto Lock Template Row Changes option. If checked, this option will automatically 
change the Template Row Lock column value to Locked if any changes are made to a derivative sheet's 
template generated rows, with the exception of changing a user defined column value which has no 
formula. By default, this option will be left unchecked for newly created plan sheets.  
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If this option is unchecked, the row will not be automatically locked for you when you manually change a 
row, however you can manually set the Template Row Lock column to Locked yourself. 

Note: Once the Template Row Lock is set to Locked, it can only be set to Unlocked manually. 

Template Regeneration 

If changes have been made to a template definition, then the selected derivative sheets must be regenerated 
in order to reflect the changes. The list of derivative sheets may be modified prior to the generation process, 
if necessary. 

Copying, Renaming, Moving, Deleting, and Recategorizing Templates 

Each template consists of a template definition, a list of derivative sheets to be generated, and associated 
generated derivative sheets. In order to copy, rename, move, or delete an entire template, the user must 
copy, rename, move, or delete all of the individual items associated with the template. Since the Template 

Source Definition list is attached to the template definition, it does not have to be individually copied, 
renamed, or deleted, but it may need to be edited. Each individual template definition and associated 
derivative sheets may also be copied, renamed, or deleted. 

Copying Templates 

Template definitions and derivative sheets can be copied as part of the Copy Plan function. This will allow 
multiple items to be copied based on the branch selected. Individual items can also be copied by changing 
the Sheet Key, saving the template definition or derivative sheet and selecting the Insert New Record 

option. Template Source Definition lists will automatically be copied along with the associated template 
definition. 

Note: If you wish to copy the items individually, the template definition should be copied first, otherwise the 
derivatives will be converted into standard plan sheets since the system will not find the associated template 
definition. 

Another option is to copy the template definition and generate the derivative sheets. This option will create 
new derivative sheets based on the current Template Source Definition list. 

Note: If a derivative sheet is copied without the corresponding template definition, the derivative sheet will be 
converted to a standard plan sheet. 

Renaming Templates 

Template definitions and derivative sheets may be renamed by changing the Sheet Key, saving the template 
definition or derivative sheet and selecting the Overwrite Existing Record option. Template Source 

Definition lists will remain attached to the template definition. 
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If a template definition is renamed, no additional modifications are required, however if a derivative sheet is 
renamed, the Template Source Definition list must be updated to reflect the new derivative name. 
Otherwise, when the derivative sheet is regenerated, the old name will be used for a newly created 
derivative sheet. 

Moving Templates 

Moving templates from one plan to another can best be accomplished by first copying the templates to a 
new plan and then deleting the templates in the old plan. Individual derivative sheets may be moved to a 
new plan, but they will be converted to standard plan sheets. 

Deleting Templates 

Template definitions and derivatives sheets can be deleted just as standard plan sheets are deleted. When a 
template definition is deleted, the associated derivative sheets are converted to standard plan sheets since 
the link has been broken. If a derivative sheet is no longer required within the planning process, it may be 
deleted using the normal process for deleting a plan sheet, however, the entry in the Template Source 

Definition list remains and thus, the derivative sheet may be recreated. 

Deleting Template Definitions 

1.        To delete a template definition, highlight the definition in Plan Manager or the plan sheet list view. 

2.        Select File > Delete or click the Delete  icon. 

3.        The following message displays: 

 

4.        Click Yes to delete the template definition or click No to cancel the action. 

Note: Deleting the template definition will break the link to the associated derivative sheets, thus 
converting them to standard plan sheets. 

Deleting Derivative Sheets 

1.        To delete a derivative sheet, highlight the plan sheet in Plan Manager or the plan sheet list view. 

2.        Select File > Delete or click the Delete  icon. 

3.        The following message displays: 

 

4.        Click Yes to delete the derivative sheet or click No to cancel the action. 

Note: Deleting the derivative sheet removes it from the plan; however, the entry remains in the 
Template Source Definition list and therefore may be regenerated. 

Recategorizing Template Definitions 

At any time, a template definition may be changed to a standard plan sheet by unchecking the Sheet 

Template check box on the Sheet Options form of the template definition. 

1.        Open the template definition and select Sheet > Sheet Options from the menu. 

2.        Click the Other Tab and uncheck the Sheet Template option. 
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3.        The following message displays: 

 

4.        Click Yes to break the association with the derivative sheets and convert the template definition to a 
standard plan sheet. Click No or Cancel to cancel the action. 

Note: Existing derivative sheets will be changed to standard plan sheets as they are no longer 
associated with a template definition. 

Recategorizing Template Derivatives 

At any time, a derivative sheet may be changed to a standard plan sheet by unchecking the Derivative 

Sheet check box on the Sheet Options form of the derivative sheet. 

1.        Open the derivative sheet and select Sheet > Sheet Options from the menu. 

2.        Click the Other Tab and uncheck the Derivative Sheet option. 
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3.        The following message displays: 

 

4.        Click Ok to initiate the action. 

Note: Once a derivative sheet is changed to a standard plan sheet, it cannot be changed back to a 
derivative sheet unless the item exists in the Template Source Definition list and it is regenerated. If 
you attempt to regenerate the sheet once it has been changed to a standard plan sheet or generate a 
derivative sheet with the same sheet key as the changed sheet, a warning displays stating that the 
sheet key already exists and cannot be generated. 
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Models 

Models provide a wizard to guide you through the process of creating one or multiple plan sheets based on 
a prototype or model. You can then replicate the model sheet based on a range of dimension values and 
assign users, revisions, and status. While models are a very useful tool for initially creating multiple plan 
sheets, it is not advisable to use it to maintain multiple sheets in that regenerating a model overwrites 
changes made to the replicated sheets. Thus, for maintenance purposes, it may be more suitable to utilize 
templates. 

Models are a practical way to get started with Sage Budgeting and Planning. Most standard plan sheet 
operations can be performed within models. The only significant exceptions include: 

•       Security for users other than the plan sheet manager cannot be set up 

•       Only one section may be defined 

Models are also very useful for creating analysis plan sheets that can be regenerated at any time. Several 
examples are noted in the demonstration data. The steps executed in building a model are the same as those 
used to build an individual plan sheet. For further explanation, see the applicable section described in this 
chapter. 

Model Identification 

Each model is identified by a plan key, model key and description. The plan key is very important, as it will 
determine which plan in Plan Manager the model is assigned to. The plan key is also used for the resultant 
plan sheets. 

1.        To create a model definition, you must designate a new sheet as a Model Definition Sheet. 

2.        From Plan Manager, select File > New > New Sheet or from the plan sheet list view, select File > New. 

You may also click the New Sheet  icon. 

 

3.        Type a unique Sheet key of up to 16 alphanumeric characters to identify the individual sheet. When 
the model definition is saved, this key will become the Model key. 

4.        Type a Description of the plan sheet of up to 40 alphanumeric characters. 

5.        In the Type field, select Model Definition Sheet. 
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6.        Next, assign a Status for the sheet. The default status codes may be used or you may create your own. 
You can use the lookup option to search for a list of valid status codes. The status code will be used as the 
default for the plan sheets however; it can be changed on an individual plan sheet basis. 

7.        Assign a Manager to the definition. You can use the lookup option to search for a list of valid users. 
The manager will be used as the default for the plan sheets however; it can be changed on an individual 
plan sheet basis. 

8.     Finally, you may select the option Lock the sheet. 

9.     Once the Properties tab is completed, you may apply sheet, row, and column dimensions to the sheet. 

10.     Click Ok to save the initial model definition. The definition will be saved in the plan tree and identified 

with the model  icon. 

11.     Open the model definition to initiate the budget building process. The system will display in the 
background a prototype of the plan sheet being built. The prototype can be reviewed at any time during the 
construction process. 

 

12.     Assign a Revision key, if desired. The revision key will be used as the default for the plan sheets 
however; it can be changed on an individual plan sheet basis. 

13.     Assign a Base Date to the plan by clicking on the Maintenance icon. You can enter a valid date, 
use the date lookup, or use the spin buttons to select a date. The base date will be used as the default for the 
plan sheets created. 

14.     Click Next to advance to the Define Dimension screen and apply dimensions to the model definition. 

Assign Dimensions 

The next step in the process is to assign dimensions to the model, which will then be applied to the resulting 
plan sheets. Each plan sheet generated from the model must share the same dimension structure. However, 
the plan sheets do not have to share the same dimension values. 
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1.        The Define Dimensions screen shows a summary of the dimensions that have been applied to the 
model. Each plan sheet generated from the model must share the same dimension structure, though the 
dimension values can be different. 

 

2.        Click on the Maintain Dimension button. 

 

 

3.        Apply the necessary sheet, row, and/or column dimensions. The default dimension is Accounts. 
Dimensions are applied in the same way they are applied to individual plan sheets. 

4.        Identify a range of dimension values or click the All Values? checkbox to select all values for a 
dimension. These ranges will be used in the model to generate the plan sheet prototype in the background. 
Ranges to be used for the actual plan sheets generated are defined in the last screen of the model wizard. 
This range should be small, yet large enough to create a useful prototype. 
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5.        When the range is completed, select Ok to return to the wizard or Cancel to exit the dimensions 
maintenance window without making any changes. 

6.        Upon returning to the Define Dimensions window in the wizard, click Next to advance to the Define 

Custom Columns screen. 

Create Custom Columns (Optional) 

As with individual plan sheets, the next step of the model is to create custom columns. Custom columns are 
useful for displaying dimension attribute information as well as additional date, text, and numerical data for 
reference in the plan sheet. If the plan does not require the use of custom columns, click Next to continue to 
the Define Column Groups screen. 

 

1.        The Define Custom Columns screen shows a summary of the custom columns applied to the model. 
The order of the custom columns shown here identifies the order in which the custom columns will display 
in the plan sheet. 

2.        To create or maintain custom columns, click the Maintain Custom Columns button. The Custom 

Column Manager screen displays. Custom columns are defined in the same manner as they are defined in 
individual plan sheets. 

 

3.        Create custom columns as necessary. To change the order in which the custom columns will display, 
click the up or down arrow keys on the right side of the screen. When finished, click Close to return to the 
Maintain Custom Columns screen. 

4.        Click Next to advance to the Define Column Groups screen. 

Create Column Groups 

At this point, column groups are assigned to the model definition. It is necessary to create column groups if 
plan calculations will be defined. The order of the groups is very important, as this will determine the order 
of the columns generated from the group. 
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1.        The Define Column Groups screen displays a summary of the column groups. The order of the 
groups shown here identifies the order of the columns generated in the group. 

2.        To create or maintain columns, click the Maintain Column Groups button. The Group Manager 
screen displays and groups are defined in the same manner as they are defined in individual plan 
sheets. 

 

3.        Create the necessary column groups. Click Close to return to the Define Column Groups screen. 

4.        To change the group order select a group and click the up or down arrow key above and below 
Change Group Order. The order of the groups will determine the column placement in conjunction with the 
column style selected (see next section). 

5.        Click Next to advance to Define Group Columns. As the model wizard progresses, the Define Group 

Columns screen displays for each column group. 

Define Group Columns 

The next step is to define how the columns are to be configured for each group. Each group is assigned to a 
period range and interval for the first and last columns. Sage Budgeting and Planning will automatically 
derive the number of columns based on this information. You can define a column title for each group of 
columns. 

There are two styles for displaying each group of columns. Section style shows the columns in the group as 
a contiguous block of columns. Comparison style will show each column within the group alongside of 
other columns in other groups. 

Note: An implicit assumption in this option is that the columns in the groups are comparable. For example, it 
will not make sense to compare 12 individual months of detail budgets to an annual prior year actual. 

Column totals can also be added for each group. Sage Budgeting and Planning will automatically derive the 
cell formulas to create the column. 

1.        For each column group, the Define Group Columns screen displays. 
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2.        Complete the Column Key Prefix and Description. The column key prefix and the description will be 
assigned as prefixes to each column created from the group. For example, if the column key prefix is ACT, 
then column keys will be ACT000001, ACT000002, etc. If the description is Actual, the column description 
will be Actual001, Actual002, etc. for each column. Note that the prefix and the description are populated 
with the group key and description, however this information may be modified. 

3.        Assign the Valuation to be used on each of the columns. In most cases, this will be the default of Net 

Change. 

4.        Complete the Column Period Ranges for each column grouping. This is the range of periods that will 
be covered within the group consisting of a range of periods for the first and last columns and a period 
increment. 

Column Period Ranges 

Type Select whether the columns generated will be Absolute or 
Relative to the base date. 

First Column Enter the range of periods to be covered by the first column 
in the group. You may also use the up or down arrow buttons 
to select the periods. The dates that will result will depend on 
the base date, group date and period range. 

Last Column Enter the range of periods covered by the last column in the 
group. You may also use the up or down arrow buttons to 
select the periods. The dates that will result will depend on 
the base date, group date and period range. 

Period Increment Enter the period increment to use between the first and last 
column. You may also use the up or down arrow buttons to 
select the periods. This will determine the number of columns 
that the system will generate. 

For example, to create four quarterly columns, select periods 1 
to 3 for the first column and periods 10 to 12 for the last 
column. Define period increments of 3 for both the first and 
last column. 

5.        Select whether each column grouping is to be shown as Comparison Style or Section Style. 

a.        Comparison style displays each column individually, side-by-side against columns from other groups. 
You may optionally show a variance column or variance percentage column when you use this 
particular style of column presentation. 

 

b.       Section style will display all columns within the grouping side by side. 
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6.        Determine whether to include totaling columns for each group. Select Totaling Columns: Include? to 
include totaling columns for each group and Totaling Columns: View Columns? to make the totaling 
columns visible in the plan sheet. If the Totaling Columns: View Columns? option is selected, a summary 
column is automatically inserted at the end of each group. 

Note: If the Totaling Columns: View Columns? option is not selected in the model, the totaling 
column is sized to zero in the plan sheet. To view the totaling column, you must resize the column by 

moving the column boundary using the drag  icon. 

7.        Type text or insert variables into the Column Title section to be use for each column within the group. 

8.        Click Next to advance to the next Define Group Columns screen (if additional column groups have 
been defined), or to the Define Group Calcs screen. 

  

Define Calculations (Optional) 

Once you have defined all of the columns, the next step is to define any desired calculations. This process is 
identical to the calculation process in plan sheets, described in Chapter 8. At the end of the model wizard, 
calculations can be refreshed when plan sheets are generated. 

1.        The Define Group Calcs screen displays a summary of the calculations for the column groups and 
valuations. 

 

2.        To create or maintain calculations, click the Define Group Calcs button. The Calculations screen will 
display. Calculations are defined in the same manner as they are defined in individual plan sheets. 

 

3.        Click Ok to save the calculation definition. 
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4.        Click Next to advance to the Define Comparison Formula Columns screen. A screen will display for 
each column group. 

Column Comparisons 

You can create columns that calculate or compare results from other generated group-based columns. The 
model wizard displays the columns to be generated in a simulated spreadsheet format. For example, if you 
have actual and plan groups, you could create a variance calculation and a variance percentage calculation. 

1.        A window will display for each column group. If columns have been defined as comparison columns, 
multiple groups will display. 

 

2.        To add a formula comparison column, click on the Column Append or Column Insert icons. 
The initial screen consists of the column properties. The column properties determine how the 
comparison column keys and titles will be identified when the columns are generated from the model. 

 

Formula Column Maintenance 

Column Key Prefix Enter a column key prefix to be attached to each column 
created through the model. Each column key created from the 
model will consist of the column key prefix plus a unique 
system assigned number. 

Column Description Enter a column description to use for all formula comparison 
columns created from the model. 

View Column? Check whether to view the formula comparison column. The 
default is to view the column. 
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Column Title Enter a column title to use for all formula comparison 
columns created from the model. You may use column 
variables within the title. Typically, you will use a consistent 
description such as Variance or % Variance. 

Formula Total: Include 
Column? 

Check whether to create a total column for the comparison 
columns created. For example, you may wish to total all 
variances. The default is to not include a totaling formula 
column. 

Formula Total: View 
Total? 

Check whether to view the formula totaling column. 

Note: In order to view the totaling column, you must select 
Include Column. 

Formula Total: Column 
Key Prefix 

If the formula total column is created, enter a column key 
prefix to be attached to each column created through the 
model. Each column key created from the model will consist 
of the column key prefix plus a unique system assigned 
number. 

Formula Total: Column 
Description 

Enter a column description to use for formula total columns 
created from the model.  

Formula Total: Column 
Title 

Enter a column title to use for all formula total columns created 
from the model. You may use column variables within the title. 
Typically, you will use a consistent description such as 
Variance Total. 

3.        Click Ok to continue and to define the cell formula for the comparison columns. The system displays a 
reproduction of the groups that were selected. This is only for display purposes. The actual number of 
columns generated will be based on how the period ranges were defined in the previous section. 

4.        Click on a cell in the newly created comparison column. Type a cell formula for the comparison 
column using the column identifiers for the displayed columns. For example, if you have two groups, 
Actual and Budget, respectively, and you want to calculate a variance and a variance percentage as shown 
above, you would enter: 

•       Column E (variance column): =D1-C1 

•       Column F (variance percentage column): =E1/C1 

5.        If you did not indicate in the initial column maintenance to generate a total column, the Totaling 

Columns? box will be empty. You can check it at this time and it will redisplay the Column Maintenance 
window. 

6.        Click Next to advance to the next Define Comparison Formula Columns screen or to proceed to the 
Column Summary screen. 

Formatting Column Comparisons 

Cell formatting may be defined at this point to be applied to any rows generated from the model. 

1.        Highlight any combination of cells that are shown in the Define Comparison Formulas Column 
window. 

2.        Click the cell formatting  icon or select Edit > Cell Formatting (Ctrl+F2). 

3.        Complete the formatting options. 

Column Summaries 
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The next step is to create column summaries (totaling rows) for each column created. You select from a 
number of options. A column summary can be created for each dimension break and a grand total can be 
created at the bottom of the generated plan sheet. The following options are available: 

•       None 

•       Total 

•       Count 

•       Average 

•       Minimum 

•       Maximum 

This option creates a row that summarizes each dimension. If you have multiple dimensions, it will 
summarize each dimension from the innermost dimension to the outermost dimension as illustrated below: 

 

Creating column summaries disables the option to create sections. Likewise, if you wish to generate sections 
from the model, you cannot create column summaries. Therefore, if you plan to generate sections from the 
model, you must select None as the Summary Type for every dimension in the Define Column Summary 

screen. 

Note: While selecting None as the Summary Type in the Define Column Summary screen disables the 
column summary option, it does not force you to generate sections. If the Section Name and Section 
Description fields are left blank in the Define Sheets To Generate screen, then sections will not be 
created. 

Once the column summaries have been defined, click Next to move to the Define Plan Sheet Options 
screen. 

Formatting Column Summaries 

Any totaling rows generated from the model may be displayed using the cell formatting options. 

1.        Highlight any combination of cells that are shown in the prototype screen. 

2.        Click the cell formatting icon or select Edit > Cell Formatting (Ctrl+F2). 

3.        Complete the formatting options. 

Define Plan Sheet Options 

The next step is to define Plan Sheet Options, row ID Generation, or View Options for each plan sheet 
created from the model. These options are the same as those for individual plan sheets. 

 



Sage Budgeting and Planning User Guide 

256 

When you are finished defining the plan sheet options, click the Next button to move to the Define Sheets 

to Generate window. 

Before continuing, you will be prompted to save the model definition. Click OK to save the model and 
proceed to the next screen or Cancel to return to the Define Plan Sheet Options window. 

 

Assign Sheets to Generate 

The final step required before actually generating the plan sheets is to define the criteria for the sheets to be 
generated. Some of the criteria include identifying the manager of each sheet, the status of each sheet, and 
the ranges of dimension values for each sheet. This is the point of the model building process where you 
may choose to generate the plan sheets. 

1.        After saving the model, following screen displays: 

 

2.        Click the Append Row  icon or select Row>Append. This will insert a row that will allow you to 
begin defining plan sheets to be generated from the model. At any point in time you may insert or delete 
rows identifying the plan sheets to generate. 

3.        Enter a plan sheet key and description for each plan sheet that you wish to generate. 

4.        Assign a manager to the plan sheet. You may use the lookup to select from a list of valid managers. 

5.        You may optionally define a revision code to be added to every generated plan sheet. 

6.        Select whether to generate the plan sheet(s) at this time. You may choose to select all plans sheets for 

generation in the Generate ? column by clicking the Select All  icon or you may click the Unselect All 

 icon to not generate any plan sheets during the generation process. By default, the Generate? flag will 
not be selected. At any time, you may select one or more plan sheets to be generated. 

7.        Select whether to refresh calculations for the plan sheet(s) generated. You may choose to select all 

sheets for calculation in the Refresh Calculations column by clicking the Select All  icon or you may 

click the Unselect All  icon to not refresh calculations for any plan sheets generated. By default, the 
Refresh Calculations? flag will not be selected. 

8.        Enter a range of values for each dimension to be applied to each plan sheet when it is generated. 

9.        If no column summaries have been defined, a section name and description can be entered. These 
fields will not be available if any column summaries have been defined. 



Chapter 11 - Advanced Techniques 

257 

10.     Select the appropriate Sheet Overwrite Options: 

•     Confirm Each Overwrite -- a message displays confirming the overwrite process of each plan sheet 
that already exists. 

•     Always Overwrite -- creates new plan sheets without any confirmation. 

•     Never Overwrite -- does not overwrite a plan sheet and therefore is not regenerated by the model. 

11.     Click the Generate from Models  icon, select Models > Generate from Models, or click Finish to 
initiate the generation process. All plan sheets identified in the model definition will be generated and 
applied to the appropriate plan. 

12.     An output log is created, identifying which plan sheets were generated. You can Print or Save to File 

the log. Click Close to exit out of the output screen. 

 

Automatic Sheet Definition 

You can automatically define which plan sheets are to be generated based on a break in one or more 
dimension values. For example, a plan sheet can be generated for each territory or department using this 
feature. 

1.        In the Define Sheets to Generate window, click on the Automatic Sheet Definition  icon or select 
Models > Automatic Sheet Definitions. 

 

2.        Complete the fields with the essential information. 

Note: If column summaries have been defined, the Section Name and Section Description fields will 
not be available. 
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Automatic Sheet Generation  

Sheet Prefix (optional) Enter a sheet prefix. This value will precede the dimension key 
value to create a unique plan sheet key. 

Description Prefix 
(optional) 

Enter a sheet description prefix. This value will precede the 
dimension description value to create a sheet description. 

Manager (optional) Assign a default manager. The manager may also be 
individually assigned to any defined plan sheets. 

Status Assign a default status to all sheets to be created. The status may 
also be individually assigned to any defined plan sheets. 

Revision (optional) Assign a default revision to all sheets to be created. The revision 
may also be individually assigned to any defined plan sheets. 

Section Name 
(optional) 

Enter a section name for all sheets to be created. A section name 
may also be individually assigned to any defined plan sheets. 

Section Description 
(optional) 

Enter a section description for all sheets to be created. A section 
description may also be individually assigned to any defined 
plan sheets. 

Dimension Values 
(optional) 

You can restrict a range of possible dimension values to be 
associated with any defined plan sheets. Check the All Values 

box to assume all dimension values for the dimension. 

New Sheet on Break? Check this box to indicate that a new plan sheet is to be defined 
each time the value of the dimension changes. 

Generation Options Select Delete All Existing Sheet Definitions to delete all sheet 
definitions previously defined in Define Sheets to Generate. 

Note: This selection does not overwrite any plan sheets. Only the 
plan sheet definition is overwritten. 

Select Append to Existing Definitions to add the sheet 
definitions to those defined previously. 

3.        Click Ok to process. 

4.        A log report displays the sheet definitions created. Click Close to return to the Define Sheets to 

Generate Window. The log can also be printed or saved to file. 

 
5.        The sheets are now ready to be generated. 

Maintaining Models 

Editing an Existing Model Definition 
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1.        From Plan Manager, highlight the model definition sheet. Select File > Open Sheet (Ctrl + O), click the 

Open Sheet  icon, or double-click the definition. 

From the plan sheet list view, highlight the model definition sheet. Select File > Open (Ctrl + O), click the 

Open Sheet  icon, or double-click the definition. 

2.        To modify components of the model, step through the model by clicking the Next button on each 
screen and changing the appropriate parameters. At any point in the wizard, click the Define Plan 

Sheet to Generate icon or select Model > Define Sheets to Generate to skip to the Define Sheets 

to Generate screen. 

3.        To change only the definition of the plan sheets to be generated, click the Define Plan Sheet to 

Generate icon or select Model > Define Sheets to Generate. The model will move through each 
screen automatically until the Define Sheets to Generate window is reached. 

4.        Click the Save  icon to save any changes that were made. 

Deleting a Model 

1.        To delete an existing model definition, highlight the definition and click the Delete icon or select 
File > Delete. 

2.        A message displays, asking for confirmation. 

 

3.        Click Yes to delete the model definition or No to cancel the delete action. 

Processing Models 

From the Model Definition Screen 

To generate plan sheets from the model definition without stepping through the entire model manually, 

click the Define Plan Sheets to Generate  icon. This will advance you to the last screen of the wizard 
where plan sheets are defined. You may change the values for the plan sheets, add new plan sheets and 
generate one or more plans sheets. 

From the Plan Manager Tree 

Sage Budgeting and Planning will track any plan sheet that was originally generated from a model. 

Highlight the plan sheet that you wish to regenerate and click the Generate from Model icon or select 
File > Generate from Models to start the generation process. 

Note: Regenerating a plan sheet from a model will replace the existing plan sheet including any manual 
modifications. 
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Allocations 

This section discusses several of the ways to handle allocations within Sage Budgeting and Planning. The 
treatment of allocations is closely tied to the use of the plan tree and plan processing. 

Typically, allocations consist of the following: 

•       Source values of the allocation, e.g. departmental expenses 

•       Recipient values, e.g. lines of business that receive the allocation 

•       Basis values that derive the allocation, e.g. head count 

The location of the calculation of source and basis in the plan tree is critical to ensuring the accuracy and 
timeliness of the allocation. For example, if you were allocating administrative expenses to other 
departments and the administrative department was listed last on the plan tree, it would be consolidated 
after the other departments. In this case, the recipient departments would receive the administrative 
allocation before it was consolidated with the latest values. Therefore, it may be best to have any source 
departments listed before the recipient departments. 

It can be more difficult to define the plan tree structure to compute basis calculations. For example, if head 
count is the basis for an allocation, then the head count of a recipient department is proportional to the total 
of the head counts of all the other departments. The timing of the calculation could be an issue since the 
head counts may be consolidated and the consolidated head count values must be reflected in your basis 
calculation. 

Using the above example, the head counts for a department could be summed up at the time of processing 
the department. For example, head counts for a marketing department would be totaled. However, any 
departments that are processed after the marketing department may have their head counts updated, thus 
creating a timing difference for the marketing department. 

The best approach may depend most on the timeliness of the allocation alongside of other planning 
processes, such as consolidation and distribution. 

The pros and cons of several options are noted below: 

Allocation Options 

Option Pros/Cons 

Create a separate branch at the top of the 
plan tree that calculates the source, basis, 
and recipient values. The calculation is 
based on input from all other 
departments using a plan sheet 
calculation. Use cell formulas in the 
allocation sheet to calculate the 
allocation. Finally, reference the 
allocated value through a plan 
calculation in the recipient plan sheet. 

Most efficient because it gathers all the 
numbers at one time. Because it is 
calculated initially prior to any other 
processes, it will reflect any allocation 
calculations prior to any other processing. 
Therefore, the allocation would not reflect 
the most current consolidated values. 

Same as above, but if all values are in the 
same branch, you may also consolidate 
all source and basis values and use cell 
formulas to compute the allocation. 

Same as above but will process faster since 
consolidations process faster than plan 
calculations. 
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Use a formula in a plan sheet calculation 
in each sheet to receive an allocation. The 
formula uses a simple mathematical 
equation of source * basis/total basis 
values. 

Results in the most current allocation at the 
time of processing. However, as discussed 
above, it creates some timing difficulties 
with other recipients that may not have been 
processed yet. In addition, the total basis 
value is computed repeatedly, which is 
inefficient. The number of sheets that make 
up the source and basis may make it 
impractical.  
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Chapter 12 - Plan Manager Tasks 
 

 

Chapter 12 

Plan Manager Tasks 

In its simplest form, a plan is merely a collection of subsheets. These subsheets may have nothing in 
common, however, there is typically a natural flow or structure associated with the budget process. 
Establishing the plan flow or hierarchy along with various other administrative and management tasks can 
be performed from either Plan Manager or Subsheet Manager. 
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Plan Maintenance 

A plan is automatically created when you complete the main tab of a plan sheet and save that sheet with a 
new, unique plan key. Plans may also be created from Plan Manager as well. If it is the first plan sheet that is 
created for the plan, it is automatically assigned as the primary plan sheet. Any subsequent subsheets are 
given an unassigned status and can be dragged under the primary plan sheet into the desired structure using 
Plan Manager. 

Creating a New Plan 

1.        Highlight the Plans node in the tree-view pane. 

2.        From the menu, select File > New > Plan or click the New Plan  icon. 

 

3.        Type a Plan Key (up to 16 alphanumeric characters). 

4.        Type a Description (up to 40 alphanumeric characters). 

5.        Assign an Administrator. Typically, this is the planning or financial manager, who has full authority 
over all aspects of the plan including all updates and all security. 

6.        Enter a date to be used for the Plan Base Date. 

7.        Assign the default Budget Code. 

8.        Determine if you wish to allow Sheet Managers and Planners to Check Out any of the Plan Sheets in 
this Plan. 

9.        Determine if you wish to publish the entire plan including all of the selected subsheets and groups to 
the publication database. If this option is turned off, then the sheets and groups enabled for publication will 
not be saved to the publication database. 

  

  

Creating a Plan using the Create Basic Budget Wizard 

From the plan menu selecting the "Create Basic Budget" item will launch a wizard. This wizard will take 
you through the steps of creating a Plan based on account segments and values that you select. You will 
have the options to select from a list of multiple templates to base the plan sheets off of. 
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The Template Selection tab allows you to select one or multiple plan templates to create from your chart of 
accounts. When you select one of the Available Budget Templates from the left, the basic description will be 
given on the right if you would like to see more detail about the plan click the "Details of Resulting Budget" 
button. 

 

Clicking the "Details of Resulting Budget" button will load a detailed document about the plan and sheets 
that are generated from that template. 
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After selecting the Template or Templates click the Next button and you will then be on the screen  to create 
the basic layout of your plan hierarchy. If your Account segment descriptions have a segment using Main or 
Account it will be selected by default as the natural account, but you can change it if you would like. The 
selected Natural account will be used to create a company specific dimension named xNatSeg$$$ where $$$ 
is the company code. This new dimension will be available for use where you see fit however if you run the 
wizard again and used a different segment as your natural account it will change the definition of that 
dimension. You will also be identifying what segment breakdown you would like to use for your plan roll-
up. You can have 2 levels of roll-up using the wizard at this point. Place a check in the box for the segment 
that you want the roll-up to be based on in the column labeled "First" place a check in the column labeled 
"Second" for the segment to have the detail sheets based on. The right side will give a sample of what the 
layout will be based on your selections. Click the Next button when you are happy with the layout. 
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The next screen is for the plan level settings such as Name, Base Date and Budget Code for the plan. The 
Budget Key Prefix will be important if you selected multiple plan templates to generate as it will result in 
each budget having the Prefix followed by 01, or 02 and so on based on how many plan templates were 
selected. The Budget base Date will default to January 1 of the current year by can be changed to fit your 
needs. Click the next button when you are ready for the next step. 

 

 

This page you will be specifying what accounts are involved in each of the account types. Clicking the Add 
Range button allows you to set up multiple ranges for the current type of account if you wish.  There are 
some default ranges filled in automatically but these can be changed or removed or added based on your 
chart of accounts. Click the "Finish" button when you have the ranges you want. 

 

 

This page shows the progress of the template generation process, the bottom bar is over all progress and 
each of the other bars will fill in starting with the top bar then the next and so on. 
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After the process is complete you will have a budget created and you can review it to see if it will fit your 
needs, you can always do the process again and try a different plan as your template. You can modify the 
plan the same as a plan you created manually to tweak it or update it based on changes in your company.  

 

Deleting a Plan 

Deleting the plan deletes the plan and all of its subsheets. This action should be done with great caution. 

1.        Highlight the plan you wish to delete in the tree-view pane. 

2.        Select File > Delete or click the Delete  icon. 

3.        A warning message displays: 

 

4.        If you click Yes, a final confirmation message displays: 

 

Note: This action deletes a plan and all of its subsheets. This action cannot be undone. 
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Copying an Entire Plan 

A new plan can be created based on an existing plan by copying the entire plan and all of its subsheets. 

1.        Highlight the plan root to be copied and select Plan > Copy Plan or click the Copy Plan  icon. The 
New Plan Properties window displays. 

 

2.        Type a Plan Key (up to 16 alphanumeric characters). 

3.        Type a Description (up to 40 alphanumeric characters). 

4.        Assign an Administrator. 

5.        Enter a date to be used for the Plan Base Date. 

6.        Assign the default Budget Code. 

7.        Determine if you wish to allow Sheet Managers and Planners to Check Out any of the Plan Sheets in 
this Plan. 

8.        Determine if you wish to publish the entire plan including all of the selected subsheets and groups to 
the publication database. If this option is turned off, then the sheets and groups enabled for publication will 
not be saved to the publication database. 

9.        Select the copy revision options. 

•     All Revisions - creates a copy of each revision for each plan sheet. 

•     Active Revision Only - creates a copy of only the revision that is designated as the active revision 
for each plan sheet. 

10.        Select to whether to copy any cube definitions that have been defined for the plan. 

Note: Only the cube definition is copied, not the actual cube, thus, any cube definitions created for the 
copied plan must be reprocessed. 

11.        Select the publication options to be copied. 

•     Copy Publication Settings - this option copies the existing publication settings for the sheets and 
groups. Thus, if a sheet in the original plan is set to not publish, then the same sheet in the copied 
plan will also be set not to publish. 

•     Mark all Sheets for Publication - this option enables the publish option on all sheets copied to the 
new plan even if they were not set in the copied plan. 

 

(Copy plan to another company) 
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12.         If you would like to copy the plan to another company you can use the Destination Company Tab. 
The Destination Company drop down shows companies that are available to copy to based on account 
structure and other factors that allow for a plan to be copied. 

13.         After selecting the company you will see a list of dimensions that are involved in the plan, which at 
this point you can change the dimension used in the new plan by selecting the appropriate dimension in the 
drop down on the right side. 

•     Only compatible Dimension and Tiers that use the same dimensions in the same order are available. 

•     If the dimension you want is not available it may just be the desired dimension may need to be 
made active for the destination company. (Dimension Maintenance) 

•    The bottom grid will show which Sheets and Templates are affected by the selected dimension. 
(Derivatives are not included in the list, because they will be replaced by generation from template, 
which takes place during the cross company copy process.) 

14.        Click Ok to create a copy of the selected plan or click Cancel to exit without creating a new plan. 

15.        An output log documents a list of the plan sheets that were copied. To cancel the process while it is 
running, click the Stop Processing button. Any plan sheets copied will be deleted. 

 

16.     When processing is complete, the log can be printed or saved to file. 

17.     Click Close to exit. 

18.     If you are copying to a different company you will see another window show up to process the new 
plan in the new company which will have a log that can be printed as well. 
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Copying Part of a Plan 

A segment or branch of the plan can be copied from one plan to another. The selected plan sheet and all of its 
subsheets will be copied to an existing plan. This operation may be performed from either Plan Manager or 
Subsheet Manager. 

1.        Highlight the plan sheet at the top of the branch to be copied and select Plan > Copy Plan or click the 

Copy Plan  icon. The Look Up Plan window displays. 

 

Note: When performing a partial plan copy to an existing plan, make sure that no duplicate sheet keys 
exist in the plan receiving the copied plan. 

2.        Highlight the plan to receive the copied branch and click Ok to continue. 

3.        The Copy Partial Plan screen displays. 

 

4.        Select the revision options. 

•     All Revisions - creates a copy of each revision for each plan sheet. 

•     Active Revision Only - creates a copy of only the revision that is designated as the active revision 
for each plan sheet. 

5.        Select the publication options to be copied. 

•     Copy Publication Settings - this option copies the existing publication settings for the sheets and 
groups. Thus, if a sheet in the original plan is set to not publish, then the same sheet in the copied 
plan will also be set not to publish. 
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•     Mark all Sheets for Publication - this option enables the publish option on all sheets copied to the 
new plan even if they were not set in the copied plan. 

6.        Click Ok to copy the branch to the selected plan or click Cancel to exit without copying the branch. 

7.        An output log documents a list of the plan sheets that were copied. To cancel the process while it is 
running, click the Stop Processing button. Any plan sheets copied will be deleted. 

 

8.        When processing is complete, the log can be printed or saved to file. 

9.        Click Close to exit. 

Modifying Plan Properties 

Once a plan has been created, plan specific properties may be modified at any time. Only system 
administrators and plan administrators have the ability to modify this information. The Plan Properties 
screen is a multi-tabbed screen with a Main Tab, Security Tab, Advanced Tab and Publication Tab. From 
this one screen all the important properties of the plan can be modified. 

1.        Highlight the plan to be modified. 

2.        Select Plan > Properties or click the Properties  icon. The Plan Properties form displays. 

3.        Click the Main Tab and modify the necessary fields. 
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Plan Properties - Main Tab 

Plan Key Type a key of up to 16 characters. 

Description Type a description of up to 40 characters. 

Administrator Assign an administrator for the plan. Typically this is the 
planning or financial manager who has full authority over all 
aspects of the plan including updates and security. 

Plan Date The Plan Date will allow Base Dates to be centrally controlled for 
a Plan without having to individually setting them on each sheet 
in a Plan. When you create a new plan, this will defaults to 
today's date. 

Plan Budget Code This field will indicate the default Budget Code to be used for a 
plan. This code will be used throughout the system for the 
budget code unless overridden with specific code.  

You will be able to select from a list of Budget Codes with in the 
company. If the General Ledger System permits, you will be able 
to enter a new budget code and appropriate description 
information and the new code will be added to the General 
Ledger System.  

This is a required field and must be filled in. 

Allow Sheet Check-
Outs to Sheet 
Managers and 
Planners 

Check this box to indicate if Check-Outs are permitted on sheets 
within the Plan to Sheet Managers and Planners.  

This option has no affect on Administrators, Plan Managers or 
Plan Controllers abilities to check-out sheets.  

This option defaults Off for new plans.  

See Check-In/Check-Out Process for more information. 

Allow Publishing Check this box to allow designated plan sheets and group data to 
be saved to the publication database. 

4.        Click Ok to save the plan modifications or click Cancel to exit without saving the changes. 

5.        If you uncheck the Publish Plan option for a plan that is associated with an existing cube, then the 
following message box displays: 

 

6.        Click Yes to remove the designated sheets and groups from the publication database), or click No to 
leave publishing turned on. 

7.        If you uncheck the Allow Sheet Check-Outs to Sheet Managers and Planners option, the following 
message box displays: 
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8.        Click Ok to Check-in all sheets within the plan that had been Checked-out, or click Cancel to cancel the 
process. 

9.        If you change the Plan Date, the following dialog box displays: 

 

10.        Optionally, select the Recalc Cell Formulas option. If this option is selected, any cell functions that are 
dependent on the base date information, such as the DAYS() or NUMPER() functions, will recalculate. 

11.        Click Ok to begin a process that will change the base date for all sheets in the plan, or click Cancel to 
cancel the process. 

Note: Changing the Plan Base Date is not as simple as just changing a date value property and saving 
it.  Changing the Plan Base Date will be done using a process.  There is a lot of data within a plan that 
needs to be adjusted when this date changes or unpredictable results may occur.  When changing the 
Plan Base Date, all sheets that are in the plan that rely upon this date will need to have all of its internal 
Group and Column dates recalculated and the data values within this sheet will need to be resaved and 
republished.  The time this process takes will be based upon the size of the Plan and the Sheets 
involved. 

Assigning Plan Security 

Plan security consists of two roles; the plan administrator and plan controller. Initially, the plan 
administrator is assigned when a plan is created. Once the plan is created, then permission to the plan may 
be granted to controllers. Only System Administrators and Plan Administrators may assign plan security. 
Refer to the security matrix that is detailed in Chapter 2 for a listing of the functions applicable to plan 
administrators and plan controllers. 

Plan Administrator 

The plan administrator may be assigned to a plan when the plan is initially created or when modifying the 
plan properties. 

1.        To assign a plan administrator to a plan, create a new plan and assign the plan administrator at that 
point, or open the Plan Properties form. 

Alternatively, highlight the plan that you wish to assign an administrator. Select Plan > Properties or click 

the Properties  icon. The Plan Properties form displays. 
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2.        Assign the plan administrator by typing a user name in the Administrator field or by selecting a user 
from the browse list. 

3.        Click Ok to save the properties. 

Plan Controller 

A plan may have many plan controllers assigned to it, however, only the plan administrator has permission 
to designate users as plan controllers. 

1.        To assign plan controllers to a plan, highlight the plan to be modified. 

2.        Select Plan > Properties, then click on the Security Tab. The security window displays. 
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3.        Highlight the user to be designated as the plan controller. 

4.        In the Security Level box, select the Controller option. 

5.        To assign multiple controllers, repeat the process. 

6.        To remove a users status as controller, highlight the user and select a security level of None. 

7.        Click Ok to save the changes. 

Republish Plan 

Occasionally you may want to republish all sheets in a plan. This is easily accomplished using the Advanced 

Tab on the Plan Properties screen. This option is not meant to be used as part of normal plan processing, 
but it is available if publishing for a plan gets messed up. This process may be needed after a data 
conversion, after reinitializing or restoring the Publication Database. 

1.        To republish a plan controllers to a plan, highlight the plan to be republished. 

2.        Select Plan > Properties, then click on the Advanced Tab.  

 

3.        Check the Republish Plan option. Click Ok and the following message box displays. 

 

4.        Click Yes to run the republication process or No to exit. 

5.        An output log documents a list of the plan sheets that were published. To cancel the process while it is 
running, click the Stop Processing button. When processing is complete, the log can be printed or saved 
to file. 

6.        Click Close to exit out of the output log. 

Publication Information 

The Publication Tab on the Plan Properties screen can be used to find information about data that is being 
published for the Plan. The list will show the names of the views along with the dimension sets included in 
each of the views. This tab will allow the users to know which views to use in order to access published data 
for reports, exports, or other purposes. 
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1.        To view Publication Information, highlight the desired plan. 

2.        Select Plan > Properties, then click on the Publication Tab.  

 

3.        Click Ok to close the screen. 

Branch Manager 

At any time, various properties for a group of plan sheets in a branch can be updated from either Plan 
Manager or Subsheet Manager. 

1.        Highlight the branch to be modified. 

2.        Select Plan > Branch Manager or click the Branch Manager  icon. The Branch Properties window 
displays. 

3.        Modify the branch properties as needed. 

 

 



Sage Budgeting and Planning User Guide 

278 

Branch Properties 

Change Status Assign a new status code to sheets in the branch. The lookup 
window can also be used to select from a list of existing 
codes. 

Change Manager Assign a new manager to the plan sheets in the branch. You 
can also use the lookup window to select from a list of 
authorized users. 

Change Sheet Locking Lock or unlock all the plan sheets in the branch. 

Set Active Revision Change the Active Revision for the branch. You can apply 
an existing Revision Code or create a new one.  If a revision 
does currently exist for a sheet in the branch, a message will 
appear indicating this and ask you if you would like to 
continue.  

Undo All Checkouts Check this box to Undo a check-out on any sheet that is 
checked out.  The user who had the sheet checked out will 
then lose their check-out statu.s 

Change Sheet Publishing Check this box if you want to change the Publishing for all 
sheets on the branch.  If checked, the you will need to 
indicate if Sheet Publishing should be turned On or Off. 
Check Sheet Published to turn on publishing or uncheck it 
to turn off publishing. 

Change Group Publishing Check this box if you want to change a setting for a Column 
Group for all sheets on the branch.  If checked, the you will 
need to select an individual group key and then select if the 
Group Publishing should be turned on or off. 

Note: The status, manager, and locking properties will be applied to ALL plan sheets within the branch. 

4.        Click Ok to save the branch modifications or click Cancel to exit without saving the changes. 

 

Modifying Hierarchy of Plan Sheets 

The hierarchical structure of a plan can be changed at any time. To restructure the subsheets, simply click 
and drag the subsheet icon to the desired node. Plan Manager and Subsheet Manager assume that you want 
to retain the hierarchical relationship, therefore if the subsheet that is moved is a branch then all of its 
subsheets are also moved, preserving those relationships. 

A subsheet can be changed to an unassigned status by either dragging its icon to the Unassigned Sheets 

branch or by highlighting it, then selecting File > Unassign. 

You can also expand or collapse the display of branches. 

•       To collapse the branch, click the minus (-) icon. 

•       To expand the branch, click the plus (+) icon. 
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Note: Each level of the Plan Manager and Subsheet Manager tree is organized in numerical and 
alphabetical order based on the sheet key, not the description. It is important to keep that in mind when 
naming sheets so that the consolidation and distribution processing occurs in the correct order. 

Refreshing the Plan Tree 

At any time, you can refresh the plan tree by selecting View > Refresh View or View > Refresh Plan Tree. 
This action updates the plan tree and displays the current tree status, including any subsheets that have 
been changed or added by other users to Plan Manager or Subsheet Manager. 

Changing Sheet Base Date 

The sheet base date for all sheets in an entire plan or a branch within a plan can be changed in Plan Manager 
or Subsheet Manager using the Change Base Date option. This option allows you to change both the Sheet 
Base Date Type and the individual Sheet Base Date for entire plan or branch. This option will only update 
current revisions. However, you can use this option to create new Revisions. 

Change Base Date 

1.        Highlight the plan root node or a branch node. 

2.        Select Plan > Change Base Date or click the Change Base Date  icon. The Change Base Date 
window displays. 
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3.        Click the Drop Down Arrow next to Base Date Type and choose the desired type. Choose Plan Base 

Date to set the sheets to the date specified in the Plan Properties. Or choose Specified Base Date if you want 
to specify the base date for the sheets. When using Specified Base Date type, click the Maintenance 

 icon to open the New Base Date window. 

 

4.        In the Current Date field, type a valid date, use the spin buttons to scroll to a valid date. 

5.        Or click the Lookup  icon to select a valid date from a calendar.. 

6.        Click Ok to set the date change or click Cancel to exit without accepting the date. 

7.        Optionally, select the Recalc Cell Formulas option. If this option is selected, any cell functions that are 
dependent on the base date information, such as the DAYS() or NUMPER() functions, will recalculate. 

8.        Select either to overwrite the current active revision or to create a new revision. If Save as new active 

revision is selected, enter a revision key. 

9.        Click Run to process the date change or Cancel to exit without changes. 

10.        An output log documents a list of the plan sheets that were affected by the base date change. To 
cancel the process while it is running, click the Stop Processing button. When processing is complete, the 
log can be printed or saved to file. 
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11.     Click Close to exit out of the output log. 

Printing Change History 

Sage Budgeting and Planning tracks a detailed history of updates made to plan sheets and sheets within the 
overall plan. These updates are recorded, in part, to ensure concurrency and accuracy of the subsheets in a 
multi-user distributed environment. This report may be viewed at any time for any sheet, multiple sheets, or 
plan. 

The system logs the date and time, the user, the plan key, the sheet key, the revision key, and a description 
of the update. The following types of updates are tracked: 

•       Original plan, sheet, and revision creation 

•       Updates to plan, sheet, and revision keys 

•       Saved changes 

The history report may be run from Plan Manager, Subsheet Manager, or the plan sheet list view. In Plan 
Manager or Subsheet Manager, you may highlight a single sheet, a branch, or the plan root. If the branch or 
plan root is selected, the history for all of the related subsheets is listed. In the plan sheet list view, you may 
select a single sheet or multiple sheets to be processed. 

1.        Highlight the desired sheet(s), branch or plan root. 

2.        Select Plan > History when running the history report from Plan Manager, or click the History 

 icon. 

3.        The Plan History report displays. 
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4.        Review the report. You can print the report or save the output for future reference. 
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Subsheet Maintenance 

Creating Plan Sheets 

New plan sheets may also be created from within Plan Manager or Subsheet Manager and will be inserted 
as a subsheet of the branch from where it is created. Note that during this process, only the plan sheet 
properties and dimensions are identified. The detail information including groups, columns, calculations, 
formatting, etc. must be added once the shell of the plan sheet is defined. 

1.        From Plan Manager or Subsheet Manager, highlight the plan sheet branch under which the new plan 
sheet will be inserted. If this is a new plan, move the cursor to the plan root or to the Unassigned Sheets 

branch. You can define the plan sheet hierarchy later, as necessary. 

2.        Select File > New > Sheet (Ctrl + N), or click the New Sheet  icon. 

3.        Complete the New Sheet options. 

 

New Plan Sheet 

Sheet Key Type up to 16 alphanumeric characters to identify the plan 
sheet. 

Description Type up to 40 characters of alphanumeric text to describe 
the plan sheet. 

Type Select the sheet type. Sheets may be defined as plan sheets, 
Excel spreadsheets, model definition sheets, or template 
definition sheets. 

Status Assign a status code to the subsheet. You can also use the 
lookup window to select from a list of existing codes. 

Manager Enter the login ID of the manager assigned to this plan 
sheet. You can also use the lookup window to select from a 
list of authorized users. 

Locked Check the box if the plan sheet is to be locked from further 
editing. 

Publish Sheet Check the box if the plan sheet is to be published. 
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Upload Company Code Assign the upload Company that will be used in the Update 
Balance process. 

4.        Click Ok to save. 

The plan sheet is assigned as a subsheet of the branch where the cursor is positioned. This process does not 
create the plan sheet detail, but merely assigns it in Plan Manager. 

Note: As this is not the most efficient way of creating multiple plan sheets, you should plan to streamline the 
process as much as possible. Options include utilizing templates, models, or the copy plan/copy partial plan 
utility. 

Assigning Subsheets as Excel Spreadsheets 

To assign an Excel spreadsheet as a subsheet, highlight the plan sheet branch in Plan Manager or Subsheet 
Manager under which the subsheet will be inserted. If this is a new plan, move the cursor to the Unassigned 

Sheets branch. 

Note: Excel spreadsheets can only be used as leaves and cannot receive consolidated values from 
subsheets. 

1.        Select File > New > Sheet (Ctrl + N), or click the New Sheet  icon. 

2.        Complete the New Sheet options. 

 

New Sheet 

Sheet Key Type up to 16 alphanumeric characters to identify the subsheet. 

Description Type up to 40 characters of alphanumeric text to describe the 
subsheet. 

Type Select Excel from the list of possible plan sheet types.  

Status Assign a status code to the subsheet. You can also use the lookup 
window to select from a list of existing codes. 

File Name Complete the path and file name or select a file using the browse 
option. 

Table Selection You may choose to select the first table found in the sheet, or you 
may restrict the spreadsheet to a predefined range name or 
worksheet/cell coordinate combination. If the file name exists, you 
can select either of these two options using the drop-down list box. 
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3.        Click Ok to create the plan sheet definition as an Excel spreadsheet. 

Editing a Subsheet 

Plan sheets may be opened for editing from Plan Manager or Subsheet Manager by double-clicking on the 
selected plan sheet key. You can also edit subsheets that are Excel spreadsheets in the same manner. Sage 
Budgeting and Planning uses the Windows File Association to launch Excel. 

Note: When you double click on a node, Plan Manager and Subsheet Manager collapses or expands the 
branch. 

Modifying Plan Sheet Properties 

Plan sheet properties can easily be modified within Plan Manager or Subsheet Manager. 

1.        Highlight the subsheet to be modified. 

2.        Select Plan > Properties or click the Properties  icon. 

3.        A prompt displays to Check Out the sheet. Click Yes. 

 

4.        Make the necessary modifications to the sheet properties. 

 

5.        Click Ok to commit any changes. 

Note: Dimensions cannot be added or removed in the Sheet Properties screen. This action can only be 
executed from an open plan sheet using Sheet > Dimensions. 

Deleting Subsheets 

Subsheets may also be deleted from Plan Manager or Subsheet Manager. 

1.        Highlight the subsheet to be deleted. 

2.        Select File > Delete, click the Delete  icon or press the Del key. 



Sage Budgeting and Planning User Guide 

286 

a.        If the subsheet is a plan sheet leaf, the following confirmation message displays: 

 

b.       If the subsheet is a plan sheet branch, the following confirmation message displays: 

 

Selecting Delete only this sheet moves the associated subsheets to the Unassigned branch. 

c.        If the subsheet is defined as an Excel spreadsheet, the system deletes only the subsheet identifier in the 
plan tree, not the actual spreadsheet file. Since Excel spreadsheets can only be subsheet leaves, only the 
individual node is deleted. The following confirmation message displays prior to deleting the subsheet: 

 

d.       If the subsheet is defined as a model, the following confirmation message displays: 

 

Any plan sheets that were generated from the model cannot be regenerated once the model definition 
has been deleted. 

e.        If the subsheet is defined as a template definition, the following confirmation message displays: 

 

Once the template definition has been deleted, the link to generated derivative sheets is broken and 
associated derivative sheets will automatically convert to regular plan sheets. 

  

Locking Subsheets 
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Subsheets may be locked from within Plan Manager, Subsheet Manager or through the Manage Sheet 
Locking menu option on the plan tree. Locking subsheets prevents any data entry to the subsheet (if it is a 
plan sheet), but allows processing updates through the following actions: 

•       Plan Calculations 

•       Cell Formulas 

•       Consolidations 

•       Distributions 

Note: A sheet that is Checked Out cannot be Locked. Conversely, Locked sheets cannot be Checked Out . 

1.        From Plan Manager or Subsheet Manager, highlight the subsheet to be locked. 

2.        Select File > Properties, or click the Properties  icon. 

3.        A prompt displays to Check Out the sheet. Click No. 

 

4.        The Sheet Properties form displays, with most items grayed out. Click the Locked checkbox. 

 

5.        Click Ok. The icon of the locked subsheet changes to the Locked Subsheet  icon in Plan Manager or 
Subsheet Manager. 

 

From the Manage Sheet Locking menu option of the Plan Tree. 
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You can lock and unlock multiple sheets using this single interface, if the include Sub-Nodes box is checked 
the action being applied to a parent node will also be applied to the all the children nodes. Selecting Ok will 
apply the new settings to the plan.. 

 

 

 

 

If a user tries to open a locked sheet, the following warning message displays: 

 

Printing Operations 

You can print one or more plan sheets or plan definitions from either Plan Manager or Subsheet Manager. In 
order to print multiple plan sheets or plan sheet definitions, you must be on a branch node when the action 
is initiated. 

1.        To print the selected plan sheet(s), select File > Print > Plan Sheet or click the Print icon and 
choose Plan Sheet.  To print the plan sheet definition(s) for the selected plan sheet(s), select File > Print > 

Definition or click the Print icon and choose Definition. 

2.        Complete the remaining options as desired. 
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3.        Click Ok to continue printing. 
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Updating Balance Tables 

Sage Budgeting and Planning can upload budget and statistical values to its Resulting Balances table. 
Budget and statistical values can optionally be exported to the balance tables of the general ledger. Budget 
and/or statistical values can be updated in three ways: during Plan Processing, from Plan Manager, or from 
an open plan sheet. Any rows marked as either Budget or Statistical in the Type column and that have a 
valid account in the Account Number column can be uploaded to the balance tables.  

The update process adjusts the budget or statistical balances to the balances maintained in the plan sheet. 
Thus, if a budget balance code previously exists, the system will replace it with the value from the plan 
sheet. In the case where multiple plan sheets are selected for the update, the plan sheet values will be 
summed and then updated in the balance table. 

In a multi-company environment, an upload company is specified on each plan sheet.  The Update Balances 
process will upload values to the balance tables for the specified company. 

Note: If values exist in the balance tables, those values will be overwritten by the new plan sheet values, not 
adjusted to a summed value. For example, if a value of 500 exists in the balance table, and the plan sheet 
value is 1000, then 1000 will be inserted into the table not 1500. 

 

Update Process 

Sage Budgeting and Planning processes the balances in several stages. 

•       The first stage determines the validity of the accounts and creates a text file in the TmpShare folder, 
located in the folder that you specified during the Sage Budgeting and Planning Network File Server 
Installation. This file contains a record for each budget value to be updated. 

•       The second stage uses this file to do a Bulk Insert into a SQL temporary table for the new budget 
records. 

•       The third stage compares the new budget records to the existing budget. 

•       The final stage replaces the records in the current budget table with the new budget values. 

Note: The update process can take a significant amount of time depending on the number of accounts and 
periods being updated. Concurrent users should not update the same balance code. Data may be lost or 
corrupted if multiple users update the same budget code concurrently or if the SQL temporary database 
(tempdb) runs out of space. 

Update Balances Procedure 

From Plan Processing 

During Plan Processing, you can set options to update balances immediately following the consolidation or 
distribution processing. Refer to the section on Plan Processing for additional information on utilizing this 
function. 

From a Plan Sheet 

1.        From an open plan sheet, select Sheet > Update Balances. The Update Balances screen displays: 
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Update Balances 

Budget Balances/ 
Statistical Balances 

Select whether to update budget balances, statistical balances, 
or both. Balances are updated for only those rows identified as 
Budget or Statistical in Type column and contain a valid 
account number in the Account Number column.  

Key/Description Enter a budget or statistical key and description. This updates 
the corresponding budget and/or statistical codes in the 
general ledger. Use the lookup window to select from a list of 
available balance codes. If the desired code does not exist, 
type a new code. For Budget Balances, the key will default to 
the Plan Budget Code from the Plan Properties screen. 

Overwrite Entire Budget Check this box to delete the balance records for all of the 
budget or statistical account values in a previously existing 
balance code. If this box is not checked, only those accounts 
that are marked in the Type column will update the balance 
table. 

Note: If you check this box, all accounts are replaced within 
the selected balance code regardless of whether they are 
specified in the plan sheet. This option should be used with 
caution. 

Group Key Select a group from a list of valid column groups. The group 
that contains the data to be updated should be selected. 

Available Columns Select the column(s) that contain the data to be updated. The 
column updates the corresponding period. If a column has a 
range of periods, Sage Budgeting and Planning updates the 
last period in the range. 

2.        Click Ok to begin the update process. 

3.        If the budget and statistical balances already exist for the key specified, you will receive a confirming 
message. Click Yes to continue the update process. 

4.        The system generates an output log. You may print or save the output log. 

From Plan Manager 

The benefit of updating balances from Plan Manager is that you may select multiple plan sheets to upload to 
the general ledger at the same time. As mentioned previously, the plan sheet values associated with the 
same account number, group key, and column key, are summed first and then the balance table is updated 
with the combined value. 

1.        In Plan Manager, highlight the node to be used as the basis for the update process. This determines 
which subsheets will be available for uploading. 
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2.        Select Management > Update Balances. 

 

3.        In the Primary Sheet field choose a plan sheet as the guide for identifying the budget and/or statistical 
code, group and columns to be updated, as well as whether the entire budget should be overwritten. 

4.        Next, the Update Balances window displays. 

 

5.        Select the update options. These options are described in complete detail in the previous section. 

6.        Click Ok to accept the selected options. 

7.        Next, select the desired sheets to be updated. You may select sheets individually, or click the Select All 

and Unselect All to quickly make your selection. The upload company is listed in the U/L Company column 
to identify the company that will receive the updated balances. 
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8.        Optionally click the Advanced tab. This allows you to delay the update processing up to 24 hours and 
55 minutes. 

 

9.        Click Run to initiate the update process. While running, a Status Bar will show the progress of the 
Update Balances Processing. The Status Bar is based on the number of sheets being processed. This may give 
odd jumps in the percentages being completed since some sheets may upload very quickly while others may 
take a long time to upload. 

 

10.     The system generates an output log. You may print or save the output log. 
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Chapter 13 - WebView 
 

 

Chapter 13 

WebView 

Sage Budgeting and Planning provides remote users with controlled access to the planning environment 
using WebView. Users can open existing plan sheets, view and edit data, and save the changes. However, 
WebView is not intended to provide full plan development and maintenance functionality. 

 WebView offers much of the core functionality as encountered in typical plan sheets: 

•       Check In and Check Out plan sheets 

•       Edit or enter cell contents and cell formulas 

•       Cut, copy, paste and fill unlocked cells 

•       Display or hide columns 

•       Add and edit cell notes 

•       Freeze columns 

•       Modify status codes 

•       Flow - consolidate plan sheets and Excel spreadsheets down one level 

•       Print plan sheets 

•       Revision control - select and activate revisions 

Note: To consolidate Excel spreadsheets, they must be stored in a location where the IIS server has access. 
They cannot be stored on the remote WebView client. Since spreadsheets are free form, there are a number 
of guidelines to keep in mind when setting up spreadsheets for processing. Review the Excel Spreadsheet 
Setup section in Chapter 12 for more information on setting up spreadsheets. 

WebView is designed to provide additional accessibility to Sage Budgeting and Planning users. Users may 
be assigned as WebView or Sage Budgeting and Planning users or both. Security assigned in Plan Manager 
and plan sheets is preserved in WebView. Therefore, WebView users may only access plan sheets for which 
security rights have been granted. Sheet protection will automatically be turned on when the sheet is 
opened in WebView, so users can change values only in non-protected cells in the authorized plan sheet. 

Note: Model and template definitions are not visible in WebView and cannot be modified using WebView. 
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Accessing WebView 

1.        Launch Microsoft Internet Explorer. 

2.        Type the web address to launch Sage Budgeting and Planning WebView. See your IIS administrator or 
your Sage Budgeting and Planning administrator for this web address. 

 

 

3.        Type the User Name, password, select a configuration, and click OK. 

 

Note: Users must be set up as a valid WebView user in Sage Budgeting and Planning before access to 
WebView is permitted.  The Admin user is not permitted to log in to WebView. 

Users will be locked out of the system after 3 invalid attempts to log in.  If this happens, then that user will 
need to be Enabled in Sage Budgeting and Planning by an Administrative User. 

Change Password 

WebView users can change their password once they have logged into WebView. 

1.        Log into WebView. 

2.        Select File > Change Password to display the Change Password screen. 

 

3.        Enter the Current Password.  Enter the new password and retype the new password.  Click Ok to 
change the password. 
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Maintaining Plan Sheets in WebView 

Opening Plan Sheets 

1.        Select a company and plan from the drop-down boxes.   

 

2.        In the Sheet List pane, click on the sheet you wish to open.  The Check Out prompt will display if you 
have editing rights. Click Yes to Check Out the sheet and open it.  Click No to open the sheet in Read-
Only mode. 

 

3.        The Sheet View displays. 

Note: The Sheet List pane will only display those plan sheets for which the user has been granted security 
rights.  

Sheet View 

Once a plan sheet is created in Sage Budgeting and Planning, it can also be accessed in WebView. All plan 
sheet characteristics created in Sage Budgeting and Planning such as dimensions, custom columns, 
formatting, security, and view options are retained in WebView. 
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Tip: Drag the Divider Bar to the left to minimize the size of the Sheet List pane, thus maximizing the Sheet 
View pane. 

 

Note: Locked sheets and cells may only be viewed and not edited within WebView. 

 

Saving Plan Sheets 

1.        Once changes have been made to a plan sheet, you may save those changes back to Sage Budgeting 

and Planning. Changes are saved when the Save  icon is clicked or by selecting File > Save.  

2.        A confirmation message will display to let you know that the sheet has been saved.  Click the Ok 
button. 

 

Check-In/Check-Out Process 

Before any sheet can be edited in any way, the sheet will need to be officially checked out by the person who 
is attempting to edit the sheet. Check-Outs are done on a sheet basis, not a revision basis. This check-out 
process does not produce a record lock on the database. The application will track if a sheet has been 
checked out and by whom. All Check-Outs remain on the sheet until it has been Officially Checked-In (or if 
an administrative function was done to undo a Check-Out).  

If the user opens up a sheet that is not checked out to them, a message box will let them know who has the 
sheet checked out.  
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They will have read-only access to the sheet and the status bar will indicate this with the words [Read 

Only]. 

Check-In/Check-Out from Sheet Maintenance 

To simplify the check-in and check-out process, WebView will assist users depending on the actions that 
they are taking.  When a user with editing rights opens an unlocked sheet, the program will check its check-
out status.  If the user has the sheet checked-out, it will just open the sheet as normal.  If the sheet is 
available to be checked-out, it will prompt the user if they wish to check-out the sheet.  If the sheet is 
checked-out by someone else, it will inform the user that the sheet is checked-out and indicate who has 
checked-out the sheet by displaying the following message: 

 

 When closing down a sheet that is checked-out by the user (by closing WebView or by opening another 
sheet), it will prompt the user if they wish to check the sheet in.  This prompt will occur after the save 

process has been completed. 

Note: A Plan Administrator or Controller can remove the Check-Out while a sheet is opened by another 
user.  Therefore, every time a sheet is saved, WebView will confirm that the user still has the sheet 
checked-out. In this event, the user will not be able to save their sheet and any changes will be lost. 

Check-Out 

1.        When you open a plan sheet that you have rights to edit, you will be prompted to Check-Out the sheet. 

 

2.        Click Yes to Check-Out the plan sheet or No to open the sheet in Read Only mode. 

3.        You can also Check-Out a plan sheet after it has been opened. Click the Check-Out  icon, or select 
File > Check Out Sheet. 

Check-In 

1.        When you close WebView or open another plan sheet, you will be prompted to Check-In the current 
sheet. 

 

2.        Click Yes to Check-In and close the plan sheet. Click No to close the sheet without checking it in. Click 
Cancel to return to editing the plan sheet. 
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3.        You can also Check-In a plan sheet while it is open. Click the Check-In  icon, or select File > Check 

In Sheet. 

 

Auto Check-In/Check-Out 

The Auto Check-In/Check-Out feature allows users to automatically check-in and check-out plan sheets 
without being prompted. The settings for the Auto Check-In/Check-Out feature are stored in a cookie, so 
these settings are machine and user dependant. 

If Auto Check-Out is turned on, the sheet will always be checked out (if able) by the user, even if they do not 
intend to make any changes. This would prevent any other user from checking out the sheet while it is being 
edited.  

If  Auto Check-In is turned on, but a plan sheet is not properly closed (power failure, application 
abnormally terminated, etc.), then the sheet will still be checked out by the user, even if the sheet is not 
open.  

When Auto Check-In is turned on, the user will not be able to hold a check-out status between editing 
sessions. They will lose their exclusive check-out whenever a sheet is closed. They would have to remember 
to turn off the Auto Check-In before saving their sheet to maintain the checked-out status.   

Auto Check-Out 

When Auto Check-Out is turned on, the user will no longer be prompted to check out plan sheets. If the 
sheet is able to be checked out for the user when opening the sheet, check-out will automatically occur.  

1.        When you open a plan sheet that you have rights to edit, you will be prompted to Check-Out the sheet. 

 

2.        A checkbox is available on the check-out prompt screen labeled Automatically check out sheets upon 

opening sheets. Checking this box will activate the Auto Sheet Check-Out. Click Yes to Check-Out the plan 
sheet. You will no longer be prompted to Check-Out a sheet in the future. 

3.        You can also turn on Auto Sheet Check-Out using a menu item in the Plan Sheet Editor. This is a 
toggled menu item allowing the option to be easily turned on or off. Select File > Auto Sheet Check Out to 
turn this option on or off. 

Auto Check-In 

When Auto Check-In is turned on, the user will no longer be prompted to check in plan sheets when the 
sheets are closed. Whenever a sheet is properly closed by the user, checked in will automatically occur.  

1.        When you close a plan sheet that you have checked out, you will be prompted to Check-In the sheet. 
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2.        A checkbox is available on the check-in prompt screen labeled Automatically check in sheets upon 

closing sheets. Checking this box will activate the Auto Sheet Check-In. Click Yes to Check-In and close the 
plan sheet. You will no longer be prompted to Check-In a sheet in the future. 

3.        You can also turn on Auto Sheet Check-In using a menu item in the Plan Sheet Editor. This is a toggled 
menu item allowing the option to be easily turned on or off. Select File > Auto Sheet Check In to turn this 
option on or off. 

 

Sheet Properties 

Plan sheet properties can be viewed from the toolbar icon or sheet menu.  Only the status 
code can be changed.  

 

 

Status Codes 

The Status box of the Plan Sheet Properties dialog box lists all available status codes. The current status of 
the plan sheet is highlighted. To change the status, select a different code from the drop-down menu. 

 

Note: WebView supports any e-mail notification that has been established for the status code within Sage 
Budgeting and Planning. 

 

Sheet Options 

Sage Budgeting and Planning provides a number of options for formatting and manipulating plan sheets. 

1.        To set specific options for a sheet, open the desired plan sheet. 

2.        Select Sheet > Sheet Options from the menu. 
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Sheet Options Plan Sheet Tab 

Frozen Columns This option allows you to freeze a specified number of visible 
columns. You can either type a value or use the spin buttons to 
adjust the value. 

Note: This option will also freeze these columns for printing. 

Display Row Numbers Check this box to display row numbers in the plan sheet. By 
turning off the display of row numbers, you can save screen 
real estate and see more of the working column area. 

Automatically 
Recalculate Cell 
Formulas 

Check this box to automatically recalculate any cell formulas 
each time a cell value is changed. If the box is not checked, 
cell formulas are not recalculated until you either press the F9 

key or select Sheet > Recalculate Cell Formulas. 

Edit Mode Permanent Check this box to allow edits to each cell in a plan sheet as the 
cursor moves into that cell. If the box is not checked, you can 
still edit a cell by pressing the F2 key or by selecting Edit > 

Cell Contents. 

Note: If this option is enabled, you will only be able to select 
and edit one cell at a time.  

Replace Text on Edit Check this box to automatically replace the existing contents 
of the cell with any new values. If the option is not checked, 
then any values typed in the cell will append to the end of the 
existing cell value. 

Tip: This box should be checked if Edit Mode Permanent is 
selected. 
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Grid Use these fields to control the display of grid lines. You can 
select whether to show vertical or horizontal grid lines, solid 
or dotted lines, and the line color. 

Locked Cell Colors Use these fields to select a foreground and background color 
for Locked Cells. These cells will display this regardless of the 
colors placed on the cell directly. 

 

View Options 

The View Options menu provides the ability to display/hide columns.  Reserved columns may be affected 
individually, as well as User Columns by Group and Valuation Type. 

 

 

Revisions 

The Sheet > Revisions List menu provides a list of all of the revisions associated with the plan sheet. The 
revision that is currently open will be highlighted.  The Revision with the designation Yes in the Active? 
column, indicates the active revision. Double clicking on a revision will open that revision for editing.  
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To make the currently open revision the Active Revision, select Sheet > Acitve Revision from the menu. 

  

New Revision 

Selecting Sheet > Revisions Properties from the menu will display the Revision Properties screen.  Type in 
a new revision designation in the Key field and click Ok.  The new revision will be created when you save 
the sheet.   

Alternatively, you can select File > Save as New Revision from the menu. This will display the Revision 
Properties screen.  Type in a new revision designation in the Key field.  The new revision will be created 
and the sheet will be saved when you click Ok. 

 

 

Printing Plan Sheets 

Plan sheets are printed as they are displayed on the screen, with cell formats and attributes. Columns that 
are frozen as defined in Sheet Options will be printed on each page.  The print options provide a large 
amount of flexibility over how to scale the printing, the page order and numbering, the plan sheet items to 
be included in the printing, and headers and footers. 

Tip: Only the plan sheet columns that are displayed will be printed. You can resize columns or use View 
Options, described earlier in this chapter, to display the intended printing result.  

1.        To print a plan sheet, you must have it displayed on the screen. Select File > Print or click the Print 

 icon. 
2.        Select the desired printing options on the Print Plan Sheet form. 

 

Print Plan Sheet 

Range Select whether to print All of the plan sheet or Selected Cells. 
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Scale There are four options available for scaling the printing.  

As Formatted: Prints sheet as formatted with no Scaling 

Best Fit: WebView follows a set of internal rules to determine how 
the plan sheet would best fit on a page 

Adjust to: Allows the user to adjust the specified size based on an 
entered percentage 

Fit To: Allows the user to enter the number of pages Wide and Tall 
they want it to print within. 

Orientation If Best Fit is selected, WebView will automatically format the 
orientation. If As Formatted is selected, specify the orientation as 
either Portrait or Landscape. This setting overrides any setting in the 
Printer Setup. 

Print Select the appropriate options to print for this plan sheet. The options 
available are: Center Vertically, Center Horizontally, include 
Gridlines, Color Printing, include Row Headings, include Column 
Heading, include Plan Sheet Border and include Row Notes. 

Page Order Designate the order in which pages should be printed. 

Tip: Use the Print option, Notes, to print the text entered into the Row Notes. Row Notes will print on a 
separate page at the end of the plan sheet pages. You can easily see what row a Note is associated with 
because it is identified with its DImension(s) and row number. 

3.        To customize and format headers and footers, click the Header and Footer tab. 

 

Header and Footer 

Text Type the custom text that you want to print. 

Variables Select from the list of custom variables to include in the 
header or footer. One or multiple variables can be included in 
a line. 

Font Name Select from a list of fonts installed on your computer. 

Font Size Select from a list of font sizes installed on your computer. 

Font Attributes Select from a list of standard attributes. 

Header and Footer Variables 
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&COMPANY& Company name 

&DATE(format)& System date in the specified format (e.g., yyyy/mm/dd or 
mm/dd/yyyy) 

&DESC& Plan sheet description 

&MANAGER& Plan sheet manager 

&PAGE& Current page number of the report. 

&PLANDATE(format)& Plan sheet base date in the specified format (e.g., 
yyyy/mm/dd or mm/dd/yy) 

&PLANKEY& Plan key 

&REVISION& Revision key 

&SHEETKEY& Sheet key 

&TIME(format)& System time in the specified format (e.g., hh:mm). 

&USER& User ID 

 

4.        To choose the printer that WebView will use for printing, click the Printer Setup button and choose the 
desired printer. 

Note: WebViewsupports printing on 8.5 x 11 paper, 11 x 17 paper or other special printer settings. To 
accomplish this, set the printer default to the desired settings, then go into WebViewand print the plan 
sheets, then set the printer default back to the normal settings. 

5.        Click Ok to save the print options and print the plan sheet.  If you click Cancel, the print options will 
not be saved. 

File Formats 

WebView Save as Excel 

You can save a plan sheet as an Excel spreadsheet. 

1.        Select File > Save as Excel. 

 

2.        Select the directory and the file name to be used. Click Save to continue or Cancel to exit without 
saving the plan sheet as a spreadsheet. 

3.       A prompt will display asking if you wish to save visible columns only. Visible columns are those that 
have not been resized to zero or hidden using View Options. 
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4.        Click Yes to save only visible columns, click No to save all columns, or click Cancel to exit without 
saving the plan sheet as a spreadsheet. 

WebView Save as HTML 

You can save a plan sheet as a read-only HTML document. 

1.        Select File > Save as HTML. 

 

2.        Select whether the Entire Sheet should be saved or just Selected Cells. 

3.        Select whether to Save Visible Cells Only. This option will only save those columns visible on the 
screen and not those that have been hidden in View Options. 

4.        Click Ok to save the sheet as an HTML page or click Cancel to cancel the action. 

 

Help 

Help is available from the main menu bar or in most dialog boxes. 
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Spreadsheet Operations in WebView 

Sheet protection will automatically be turned on when a plan sheet is opened in WebView, so users can 
enter values only in non-protected cells in the authorized plan sheet. Plan sheet cells may be populated by 
typing a specific value in the cell, by typing a formula in the cell formula bar at the top of the data grid, by 
using the Spread Values tool, by using the Fill operation, by using the Consolidate Subsheet operation or the 
Update Parent Distribution operation. 

The design of the plan sheets should take cell protection into consideration.  In the following sheet, the cells 
in the Plan columns are unlocked but have a white background color, so there is no way to visibly 
distinguish the unprotected cells.   

 

One good methodology to resolve this problem is to design the sheets so that they consistently use a specific 
background color for all unprotected cells.  WebView provides a plan sheet option that will help distinguish 
unprotected cells, in the event a consistent background color was not set for unprotected cells.  Select Sheet 

> Options from the menu bar, then checkmark the Locked Colors option. The following sheet shows the 
Locked Colors option turned on. You can now see that unprotected cells are displaying as white. 
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Entering Values into Cells 

Values can be typed into unprotected cells.  Move to  an unprotected cell and begin typing the value. When 
you've finished, you can press the Enter key to enter the typed value.  

Entering Cell Formulas 

Special budgeting-specific functions, along with the standard spreadsheet functions, are supported in 
WebView. As in Microsoft Excel, cell formulas may employ either absolute or relative cell addressing and 
are formatted similarly, for example, =SUM(D6:H6). 

Note: Any cell formulas entered into the cell formula bar will only be committed by pressing the Enter 
key. Changes will not be committed if you click off of the cell. 

Editing Cells 

WebView supports standard spreadsheet cut, copy, and paste operations. However, these operations differ 
slightly from commercial spreadsheets in that the paste area must be at least as big as the area cut or copied. 

Clearing Cell Values 

1.        Highlight the cells to be cleared. 

2.        Select Edit > Clear Value from the main menu bar. 

Tip: You can also press the Delete key or Ctrl + X to delete cell formulas and values. 

Filling Cells 

You can also copy values across plan sheet cells using the Fill operation. Highlight the cells you want to fill, 
right click and choose Fill and then choose a direction.  The cell values or formulas copy according to the fill 
action taken. 

Fill Actions 

Edit Menu  Action 

Fill Right Fills values to the right of the cell based on the cell furthest to 
the left in the selected range. 

Fill Down Fills values down based on the cell at the top of the selected 
range. 

Fill Left Fills values to the left of the cell based on the cell furthest to 
the right in the selected range. 

Fill Up Fills values up based on the cell at the bottom of the selected 
range. 

  

Column Display 

WebView supports many of the column display features observed in standard spreadsheet applications. 

•       Columns can be resized by pointing to the boundary and "dragging" it to the desired width. 

•       The option to freeze columns may be turned on or off by selecting Frozen Columns from the Sheet 

Options menu. 
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Spread Values Tool 

The spread operation in WebView is similar to the spreading technique found in the calculation engine used 
in Sage Budgeting and Planning. It allows you to quickly input and evaluate values in a plan sheet. Values 
may be spread evenly or by a percentage across selected columns, or the same value may be filled in 

selected columns. 

To use the Spread Values tool, select the row you want to affect, then select Select Edit > Spread,  click the 

Spread  icon, or select Spread Values... from the right mouse click menu. The following dialog box is 
displayed: 

 

1.        Choose the spreading approach from the Spread Options box. The default spreading option is 
Evenly. 

Spread Options 

Evenly Divides a defined amount evenly across the total number of 
affected columns. 

By Ratio Divides a designated amount across affected columns based 
upon the ratio assigned to the column. 

Fill Fills the defined amount into every affected column. 

 

Note: The default setting for Spread is Evenly. If you are editing existing data, the By Ratio option should 
be selected to ensure that the data contained in each column is accurately reflected. 

2.        Select the column Group and Valuation Type to be affected from the Group Filters box. 

3.        Use the Amount Scratch Pad to compute the value to be spread.  The total value for the selected 
group will be displayed in the Quantity box.  You may use this value, change it by entering a new 
value, or compute a new value by choosing an Operation (* / - +) and entering a Rate. 

4.        Click on Calculate Values to update the Spread Amounts per Column grid which shows the 
amounts that will be entered in each column.  Uncheck any column that you don't want affected by 
the Spread Values Tool. 

5.        Click on OK. 

6.        A confirmation will appear. Click on Yes to write the values to the sheet. 
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Note: Values entered by the spread values tool are treated as cell entries, and will be overwritten by any cell 
calculations or by consolidation and distribution from other sheets.  
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Flow 

WebView supports 1 level of consolidation of Plan Sheets and Excel spreadsheets. It also supports 
distribution from the parent sheet. For example, this allows you to create a solution where the department 
manager has a Salary Planning sheet that is a child to his Department Expense sheet. The department 
manager would open his Salary Planning sheet, enter the budgeted amounts for the employees in his 
department and save the sheet. Then he would open his Department Expense sheet and consolidate the total 
salary values from the child sheet. 

Similarly, the division manager can have a Division Totals and Targets sheet that is a parent to the 
Department Expense sheets. The division manager would open his Division Totals and Targets sheet and 
target budget amounts for each department in his division. The department manager would open his 
Department Expense sheet and update the parent distribution to pull the target values for his department 
from the parent sheet. 

Note: Webview Consolidations of Excel sheets are not supported when the IIS server is running on 
Windows 2008 or Windows Vista due to a change in the operating systems’ service security design. To 
work around this limitation, your IIS server will need to run on versions of Windows prior to 2008 and 
prior to Vista. 

 

Consolidation 

1.        To initiate the consolidation process, select Sheet > Consolidate All Subsheets. The Consolidate All 

Subsheets window displays. 

 

2.        Select which additional information you want to be consolidated with the values. 

3.        Click Ok to execute the consolidation or click Cancel to exit the flow operation. 

4.        An output log displays detailing all activity including a list of matching row IDs that were found and 
processed successfully. This log and can be printed or saved to a file. 

 

Note: When flow is executed, changes to the plan sheet are visible immediately. However, the plan 
sheet must be saved to commit the changes. 

Update Parent Distribution 

1.        To initiate the distribution process, select Sheet > Update Parent Distribution. The Update Parent 

Distribution window displays. 
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2.        Select which additional information you want to be distributed with the values. 

3.        Click Ok to execute the distribution or click Cancel to exit the flow operation. 

Note: When flow is executed, changes to the plan sheet are visible immediately. However, the plan 
sheet must be saved to commit the changes. 
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Notes 

Introduction 

Notes in WebView have the same function as notes found in Sage Budgeting and Planning. Bolded Notes 
buttons indicate rows that have notes attached to them. 

 

Creating a New Note 

Click the Notes button on the row.  The Notes screen will display, with the date and time stamp 
automatically entered.  Type the desired text and click the OK button to save the note.  Click Cancel 
to exit the note without saving. 

 

Editing or adding to an Existing Note 

1.        Click the Notes button in the plan sheet.  The note is initially in a read-only status. 

2.        Click Edit. The note becomes editable. 

3.        Type or remove any text in the note. 

4.        Click Ok to save the edits. Click Cancel to exit the note without saving any changes. 

5.        If note has been completely cleared, the Notes button will no longer be bolded. 

 

 

Note: Notes are stored and sorted in descending order from the newest note to the oldest note. 

 

  

Cell Notes 

Notes may be entered in an individual cell.  Notes are automatically stamped with the user ID, date, and 
time.  If a note is entered, a red dot will be displayed on the upper right hand corner of the cell.  Moving the 
mouse over the cell will display the note.  Note entry and editing is done in a pop-up note editor.  
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To enter a cell note, right click on a cell and select  Add/Edit Cell Notes... from the right mouse click menu.  

To delete a cell note, right click on a cell and select  Delete Cell Notes... from the right mouse click menu. 

Note: Cell notes are for display only and cannot be printed.  Consider using Row Notes instead of Cell Notes 
since they can be printed and consolidated.  

 

WebView Toolbar 
WebView Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Check-Out a plan sheet. File > Check Out Sheet  

 
Check-In a plan sheet. File > Check In Sheet  

 
Saves the current plan sheet to the 
database. 

File > Save  

 
Saves the current plan sheet as a new 
revision. 

File > Save as New 
Revision 

 

 
Prints the current plan sheet. File > Print  

 
Clears cell values only, not cell 
formulas. 

Edit > Clear > Clear Values 
Only 

 

 
Refreshes cell formulas. Sheet > Refresh Cell 

Formula 
F9 

 
Cuts selected cells. Edit > Cut Ctrl + X 

 
Copies selected cells to the clipboard. Edit > Copy Ctrl + C 

 
Pastes information from the clipboard 
into the selected cells. 

Edit > Paste Ctrl + V 

 
Launches the Sheet Options dialog 
box. 

Sheet > Sheet Options  

 
Launches the View Options dialog 
box. 

Sheet > View Options  

 
Launches the Sheet Properties dialog 
box. 

Sheet > Properties  

 
Allows the user to view and select 
Revisions of the current sheet. 

Sheet > Revision List  

 
Allows the user to create new 
Revisions of the current sheet. 

Sheet > Revision Properties  

 
Launches the Spread Values Tool. Sheet > Spread Values  
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Adds a Cell Note to the selected cell. Edit > Add/Edit Cell Notes  

 
Deletes a Cell Note in the selected cell. Edit > Delete Cell Notes  

 
Consolidates values from child plan 
sheets. 

Management > Consolidate 
Subsheets 

 

 
Updates the Parent Distribution. Pulls 
values from the Parent plan sheet into 
the currently open plan sheet. 

Management > Update 
Parent Distribution 

 

  

Uninstalling WebView from Windows Vista or Windows 2008 
When uninstalling WebView from a Windows Vista or Windows 2008 web server, a few steps need to occur 
for this to be successful. First, after "uninstall" is selected, a Files in Use screen will appear with directions to 
"...Close these applications and click Retry to continue." In the Server Manager, highlight the Sage Budgeting 
and Planning WebView service and select Stop. Then, back on the Files in Use screen, press Retry. The same 
Files in Use screen will appear again but this time, press Ignore. Finally, once the uninstall is complete, you 
must reboot your web server.  
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Chapter 14 

Publication and Analysis 

The starting point for publication and analysis is plan sheets. While plan sheets have multidimensional 
components, they do not present them in a relational or multidimensional format. Dimensions are presented 
in a flat, spreadsheet format that is ideal to a planning paradigm as it presents large volumes of data 
quickly, is ideal for data entry, and provides a familiar framework. However, data is not presented in its 
most optimal structure for analysis and manipulation. Plan sheets are used as the source for the original 
values published to the tables. 

The following elements are essential to the publication process. 

•       Dimensions assigned at sheet, column, and row levels are published to the publication database. 

•       Dimension key values for each of the above are used for the descriptions of the dimensions. 

•       Group keys are used for separation of blocks of column data. 

•       Fiscal periods are applied for period presentation. 

•       Cell values, consisting of entered data, cell formulas, or calculations, are applied to the dimensions. 

Since many columns of data may be available for publication, the data sets may be categorized by column 
groups. Thus, a set of columns that represent actual values may be differentiated from budget or plan 
columns by the use of column groups or measures. This allows you to choose which sets of data to publish 
for a meaningful analysis. You can also publish more than one group to the same table or cube for 
comparative analysis. Groups that are selected for publication are published as cube measures. 

The power of the published tables is enhanced using the Sage Budgeting and Planning calculation engine. 
Since virtually any database source can be included within a calculation, data may be passed into the 
published tables with no additional effort. This eliminates the complex setup time of a separate 
transformation process. Furthermore, since the Sage Budgeting and Planning system is aware of fiscal 
information, it is able to intelligently transform data in a fraction of the time that it would take to transform 
data using a fiscally unaware transformation process. 

Based on the publication options selected when creating plan sheets, you may save entire plans, individual 
sheets, and specific groups to the publication database. These will then be available for cube creation. 

  

Note: Any plan sheet values that you wish to view in the cube must be assigned to a group. 
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Initial Setup 

The Microsoft Analysis Server is a separate server from the SQL Server and has its own security 
requirements in addition to SQL Server and Sage Budgeting and Planning. The Analysis Server uses 
Domain Authentication for its security. Sage Budgeting and Planning uses either its own authentication or 
Domain Authentication. SQL Server uses either its own authentication or Domain Authentication. 
Depending on your specific environment, this could represent three distinct security setups. This means that 
if your Sage Budgeting and Planning User (the User ID you use to log into Sage Budgeting and Planning) 
has Administrative rights, then you have full access to cubes in terms of definition. However, as soon as you 
begin communicating with the Analysis Server, the Analysis Server will pay attention to your Domain User 
(the account you use to log into your PC) security settings. So, you will be restricted on what you can do or 
view with the cubes based on the Domain User. While these additional security requirements may seem 
challenging, you should be able to accomplish them by following the details in this chapter. 

Prior to creating and processing cubes in Sage Budgeting and Planning, it is important to verify that 
preliminary settings and configurations have been established. 

•          Make sure Microsoft Analysis Server is installed and current service packs are applied 

•          Create an Analysis database on the Analysis Server for Sage Budgeting and Planning to use when 
creating cubes 

•          On the Analysis database, set the impersonation property's security setting to "Use the service 
account" 

•          Define Sage Budgeting and Planning User permissions for each user (Edit Cubes, Edit OLAP 
Dimensions, View Cubes) 

•          Give the Sage Budgeting and Planning user security to access the Plans (Administrator, Plan 
Administrator, Plan Controller) 

•          Define the Domain User security settings: 

➢       To create, process and view cubes: the Domain User must a member of the local 
Administrator group on the Analysis server 

➢       To only view cubes: Create a Read-Only OLAP Security Role (in Sage Budgeting and 
Planning) and assign the Domain User to this role 

➢       To manage Cubes in Analysis Services: Install Analysis Services on the client PC 

If you are running OLAP Services 2000: 

• Ensure OLAP 2000 Services is installed and configured properly and the latest OLAP service packs 
have been applied 

• Create an OLAP database on your OLAP Server for Sage Budgeting and Planning to use when 
creating cubes 

• Define Sage Budgeting and Planning User permissions for each user (Edit Cubes, Edit OLAP 
Dimensions, View Cubes) 

• Give the Sage Budgeting and Planning user security to access the Plans (Administrator, Plan 
Administrator, Plan Controller) 

• Define the appropriate Domain User security settings depending on what level of security each 
user requires 

 

If you are running Analysis Services 2005: 

In earlier Sage Budgeting and Planning versions (7.46 and prior), when a cube was created and processed on 
a SQL2005 Analysis Server, Sage Budgeting and Planning created the cube using SQL2000 emulated mode; 
Sage Budgeting and Planning was not running in Native SQL2005 mode. Therefore, cubes that were created 
in prior releases will need to be saved and processed in the new, Native SQL2005 environment of Sage 
Budgeting and Planning.   

Here is a list of steps that should be completed as you upgrade: 
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1.     Create a new OLAP 2005 database on your SQL2005 Analysis Server 

• Launch SQL Server Management Studio and connect to your Analysis Server 

• Highlight your Analysis Server and expand the Databases folder 

• Right-click Databases and select New Database 

• Enter an Analysis Server Database name 

• Set the impersonation property to “Use the service account:" 

2.     Log in to Sage Budgeting and Planning as a user with Edit Cube permissions 

3.     Open each cube definition and point to the new Analysis database created in step one 

4.     Save and process each cube 

 

If you are running Analysis Services 2008: 

• Ensure Analysis Services 2008 is installed and configured properly and the latest Analysis service 
packs have been applied 

• Create an Analysis database on your Analysis Server for Sage Budgeting and Planning to use when 
creating cubes 

• Define Sage Budgeting and Planning User permissions for each user (Edit Cubes, Edit OLAP 
Dimensions, View Cubes) 

• Give the Sage Budgeting and Planning user security to access the Plans (Administrator, Plan 
Administrator, Plan Controller) 

• Define the appropriate Domain User security settings depending on what level of security each 
user requires 

 

Windows Vista Analysis Server with Sage Budgeting and Planning 

If your Analysis Server is installed on a Windows Vista machine and you are running Sage Budgeting and 
Planning on this same machine, you will need to choose Run as Administrator when launching Sage 
Budgeting and Planning to avoid an error in Cube Maintenance which occurs after entering the Analysis 
Server name. To avoid this error from occurring, highlight Sage Budgeting and Planning for launching, right 
click and choose Run as Administrator. Sage Budgeting and Planning will launch; log into Sage Budgeting 
and Planning as normal. In Cube Maintenance you can enter your Analysis Server name, tab off the field, 
and will see your databases without error. 

 

Steps to connect to OLAP server 

•          Ensure domain user is a member of the Local Administrator group on the Analysis server. 

•          Log into the machine as this domain user. 

•          Run our client setup. 

•          Log into Sage Budgeting and Planning with appropriate cube rights (see Sage Budgeting and 
Planning Security chart). 

•          User can now launch the Analyzer on an existing cube. 

•          User can create a new cube and process an existing cube. 

 

•          Install Microsoft Office Excel on machine 

•          Enable trust access to VB in Excel 

•          User can now launch the Excel Pivot Table on an existing cube. 

 

•          Install Analysis Services (client only or server install) 

•          User can now manage cubes in the Analysis server. 
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If you do not want to assign user as an OLAP Administrator, but want to give them cube 
rights 

•          Log into the machine as a user who is a member of the Local Administrator group on the Analysis 
server. 

•          Log into Sage Budgeting and Planning with appropriate cube rights (see Sage Budgeting and 
Planning Security chart). 

•          In the Cubes folder, launch Cube Security. 

•          Create a role (or use existing role) and assign domain user to this role which has appropriate 
rights to the cube. 

•          Log in to the machine as the user assigned to this role.  

•          User can now see the cube and will be limited based on the roles restrictions.  

 

OLAP Cube Roles 

Basically, if you are a cube viewer, or cube editor, you can get into the analyzer and pivot table. From that 
point on, the security is handled by the Analysis server cube security roles. So, you would probably want at 
a minimum a read role, and a read/write role to place people into. As part of the cube role security, you can 
setup roles which would obtain limited information from the cube. For example, you could limit a set of 
users to a certain department range, etc. 

There are basically two types of roles; those created in Sage Budgeting and Planning and those created 
independently. Sage Budgeting and Planning manages roles created within Sage Budgeting and Planning, 
not those created elsewhere. The roles created directly from the Analysis Manager are independent of Sage 
Budgeting and Plannings roles. 

The roles created within Sage Budgeting and Planning are stored both in Sage Budgeting and Planning and 
placed into the OLAP database. Since Sage Budgeting and Planning maintains its own copy, you can delete, 
re-create, and change these roles independently of the Analysis Manager. Those with access to the Analysis 
Server can delete/modify roles created within both the Analysis Manager and Sage Budgeting and 
Planning. 

The Roles Screen in Sage Budgeting and Planning reflects the roles from Sage Budgeting and Plannings 
perspective, not any other roles which may exist from other sources. 

  

Additional Notes and Steps 

There are two sides to OLAP Security. There is the Sage Budgeting and Planning perspective based on the 
Sage Budgeting and Planning User and the Analysis server's perspective based on the Domain User. So, for 
any action taken in Sage Budgeting and Planning, both sides exist; each with its own security and 
considerations. The two sides do not really know about the other's security setup. In other words, when you 
set up a user in Sage Budgeting and Planning (with Edit Cubes rights, for example) that is not mapped 
logically to a domain user, an Administrator, for example, has to make sure the domain user and Sage 
Budgeting and Planning user are setup so it makes sense. 

 

Action: Cube creation 

Sage Budgeting and Planning Perspective: 

•          User has appropriate rights (create cubes, plan admin, etc.) 

Analysis Server Perspective: 

•          Domain user is an Analysis Server Administrator, member of Local Administrator group on 
Analysis server 

Action: Cube processing 
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Sage Budgeting and Planning Perspective: 

•          User has rights to process cube (cube manager, plan manager, etc.) 

nalysis Server Perspective: 

•          Domain user is an OLAP Administrator, member of Local Administrator group on Analysis 
server. (They need rights to pull data from Sage Budgeting and Planning fact tables for the cube.) 

Action: Cube deletion 

Sage Budgeting and Planning Perspective: 

•          To delete Sage Budgeting and Plannings side of the cube, user has rights to delete the cube (cube 
manager, edit cubes, etc.) 

nalysis Server Perspective: 

•          To delete the Analysis server's side of the cube, domain user is an Analysis Server Administrator 
and member of Local Administrator group on Analysis server 

Action: View cube through Excel pivot table or Analyzer 

Sage Budgeting and Planning Perspective: 

•          User has rights to at least view cube. 

nalysis Server Perspective: 

•          Domain user is a member of a read or read/write role for the cube, or is an Analysis Server 
Administrator. 

Action: "Modeling" cube through Analyzer 

Sage Budgeting and Planning Perspective: 

•          User has rights to edit cube and high level plan type user. 

nalysis Server Perspective: 

•          Domain user is a member of a read/write role for the cube, or is an Analysis Server 
Administrator, and has rights to the fact table's _WB table in SQL server through a SQL login/role. 

 

Sage Budgeting and Planning Security: (Sage Budgeting and Planning Perspective) 

Sage 
Budgeting 
and Planning 
Permissions 

Create 
Cube 

Cube 
Maintenance 

Delete Cube 
Security 

Process 
Cube 

View 
Excel 
Pivot 
Table 

View 
Analyzer 

Analyzer 
Modeling 

View Cubes      X X  

Edit Cubes                X X  

View Cubes + 
Cube 
Manager 

     X X  

Edit Cubes + 
Cube 
Manager 

X X X X X X X X 

Edit Cubes + 
Plan 
Controller 

X X X X X X X X 

View Cubes + 
Plan 

     X X  
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Controller 

View Cubes + 
Plan Admin 

     X X  

Edit Cubes + 
Plan Admin 

X X X X X X X X 

Administrator X X X X X X X X 
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Defining OLAP Dimensions 

The dimensions of an OLAP cube represent distinct categories for analyzing business data. Categories such 
as time, geography, or product line breakdowns are typical OLAP dimensions. Dimensions are typically 
organized into hierarchies of information that map to columns in a relational database. Dimension 
hierarchies are grouped into levels consisting of dimension members. Each level in a dimension may be 
rolled together to form the values for the next highest level. For example, in a time dimension, months roll 
into quarters, and quarters roll into years. For a standard dimension, cities would roll into counties, which 
roll into states, which roll into territories. 

OLAP dimensions are defined from the tree-view on the desktop interface. Also, only those users that have 
been granted permission to edit OLAP dimensions, defined in User Maintenance, will have access to this 
option. 

Note: Using Analysis Server 2005/2008 requires an update to existing OLAP dimensions so they can be 
used in 2005+ cubes. Updates will occur on each cube definition's Advanced Level Properties screen 
which requires the "OLAP 2005+ Level Selection" fields (located on the bottom half of the screen) to be 
completed. See the System Management Guide's Upgrading chapter for complete details on this topic. 

Time Dimensions By Period Thru Date 

This OLAP dimension allows you to indicate when a year begins. For example, if the general ledger's fiscal 
year begins in January and you would like to contemplate the year beginning in July instead, then you can 
specify July 1 as the year begin date.  

Follow these steps to create a time dimension based on custom fiscal calendars that do not use a standard 
calendar year. 

1.        Highlight the OLAP Dimension node in the tree-view pane 

2.        Select File > New or click the New OLAP Dimension  icon. The OLAP Dimension Definition 

Wizard displays. 

 

OLAP Dimension Definition 

Name Type a name of up to 30 characters identifying the OLAP 
Dimension. 

Type Select either Time or Standard from the drop-down list. 

•          Time used to define custom fiscal calendars that do not use a 
standard calendar year. 

•          Standard used to define other dimensions such as product line 
or sales regions. 
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All Caption Indicates the name of the top level of the aggregates. By 
default, the caption is All + OLAP Dimension Name. 

Description 
(available when Advanced 
button is clicked) 

Defaults to the Dimension Name. 

Aggregation Usage 
(available when Advanced 
button is clicked) 

Select the level of the aggregate usage from the drop-down 
list. The available options are: 

•          Standard (All Levels) 

•          Top Level Only 

•          Bottom Level Only 

•          Custom 

OLAP Dimension Levels 
(available when Time is 
selected as the OLAP 
dimension type) 

Select how the dimension levels will be determined. 

•          By Period Thru Date allows you to customize the fiscal 
calendar setup by period. 

•          By Fiscal Year and Period uses the periods established in the 
general ledger to build the fiscal calendar. 

Note: The By Period Thru Date option should only be used if 
all of the fiscal years start on the same day each year and are 
one year in length. If the start dates vary, the fiscal year 
length changes, or periods roll up based on a manually 
defined hierarchy, then the By Fiscal Year and Period 
option should be used. 

Fiscal Year Start: Day of 
Month 
(available when By Period 
Thru Date is selected) 

Sage Budgeting and Planning attempts to retrieve the fiscal 
period information directly from the general ledger tables. To 
change this information, use the spin buttons to select the 
correct day of the month to start the fiscal year. 

Fiscal Year Start: Month of 
Year 
(available when By Period 
Thru Date is selected) 

Sage Budgeting and Planning attempts to retrieve the fiscal 
period information directly from the general ledger tables. To 
change this information, use the spin buttons to select the 
correct month of the year to start the fiscal year. 

3.        Click Next to continue. The OLAP Dimension Levels screen displays. Use the arrow buttons to move 
the desired Available Predefined Levels to the Selected Levels pane. These levels determine how the 
dimensions levels will logically role up into one another. For example, months roll up into quarters, which 
roll up into half years, which roll up into years. 
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4.        To create levels that are not provided, such as days, select Custom and click the Move Right  icon. 

The OLAP Dimension Level window displays. Type a Level Name of up to 30 alphanumeric characters to 
identify the custom dimension level. Use the spin buttons or type in the Approximate Number of Members. 
A low number indicates the top level of the dimension hierarchy with larger numbers indicating lower 
levels. For example, 1 would correspond to the year level, 4 for quarters, 12 for months, and so on. Click Ok 
to save the custom dimension level. 

 

Note: You cannot create valid time dimension levels that are smaller than the time element established 
as the fiscal period in the general ledger. For example, if your fiscal periods are defined as months, you 
cannot create a valid time dimension of weeks. Since weeks have not been defined, the system does not 
recognize that level of detail. 

5.        For information about the properties of the dimension levels selected, click the Advanced Level 

Properties button. The OLAP Dimension Level Properties screen displays. To view and edit the properties 
for a particular level, select the level from the Level Description pane. Once editing is complete, click Next 
to continue. 

 

OLAP Dimension Definition 

Name Defaults from the Level Description. This field may be edited. 

Description Defaults from the Level Description. This field may be 
edited. 

Member Count Indicates the order of the level in the hierarchy. A member 
count of one designates the highest level in the hierarchy. 

Type Defaults to the most logical type based on the level 
description selected. Choices include: 

•          Standard 

•          Years 

•          Half Years 

•          Quarters 

•          Months 

•          Weeks 

•          Days 
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Unique Members? Check this box if the members within the level are unique 
across the entire data set. For example, the members that 
make up Years would be 2001, 2002, 2003, 2004, which all 
have unique names.  

Order By Key? Check this box to sort the dimension levels by member key or 
member name instead of member count.  

Data Type Select the data type from the drop-down list that matches the 
data type of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Type must be specified as 
Character. 

Data Size Select the data size from the drop-down list that matches the 
data size of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Size must be specified as 16. 

Member Key The calculation used to correctly convert the time dimension 
from a standard calendar year to the designated fiscal 
calendar. 

For more information on Member Keys, see SQL Server Books 
Online. 

Member Name Performs the exact calculation used in the Member Key and 

creates the value visible to the user. 

For more information on Member Names, see SQL Server 
Books Online. 

Fact Table Fields Used to assist in defining the Member Key and Member 

Name. For example, in the Member Key and Member Name 

conversions, FieldName in the variable 
&OLAPFactTable&.FieldName would be replaced with 
&OLAPFactTable&.Accounts. 

6.        The OLAP Dimension Definition screen displays. Click Finish to save the OLAP dimension that you 
created. 

 

Time Dimensions By Fiscal Year and Period 

If your fiscal periods are an atypical size, you may choose to use this OLAP dimension to determine where 
extra weeks/periods fit into the year. For example, if your company has roughly 10, 5-week periods, you 
can decide how to roll up these periods into quarters. If you want periods 1-3 in Quarter 1 and period 4 in 
Quarter 2, there is flexibility in determining where to logically place all the periods. Furthermore, if your 
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company or school has 13 periods (instead of 12 months), you can specify which quarter the last period can 
go into (last or first quarter).  

The following wizard steps you through the process of creating this type of time dimension.  

1.        Highlight the OLAP Dimension node in the tree-view pane. 

2.        Select File > New or click the New OLAP Dimension  icon. The OLAP Dimension Definition 

Wizard displays. 

 

OLAP Dimension Definition 

Name Type a name of up to 30 characters identifying the OLAP 
Dimension. 

Type Select either Time or Standard from the drop-down list. 

•          Time used to define custom fiscal calendars that do not use a 
standard calendar year. 

•          Standard used to define other dimensions such as product line 
or sales regions. 

All Caption Indicates the name of the top level of the aggregates. By 
default, the caption is All + OLAP Dimension Name. 

Description 
(available when Advanced 
button is clicked) 

Defaults to the Dimension Name. 

Aggregation Usage 
(available when Advanced 
button is clicked) 

Select the level of the aggregate usage from the drop-down 
list. The available options are: 

•          Standard (All Levels) 

•          Top Level Only 

•          Bottom Level Only 

•          Custom 
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OLAP Dimension Levels 
(available when Time is 
selected as the OLAP 
dimension type) 

Select how the dimension levels will be determined. 

•          By Period Thru Date allows you to customize the fiscal calendar 
setup by period. 

•          By Fiscal Year and Period uses the periods established in the 
general ledger to build the fiscal calendar. 

Note: The By Period Thru Date option should only be used if 
all of the fiscal years start on the same day each year and are 
one year in length. If the start dates vary, the fiscal year length 
changes, or periods roll up based on a manually defined 
hierarchy, then the By Fiscal Year and Period option should 
be used. 

3.        Complete the necessary fields and select By Fiscal Year and Period as the OLAP Dimension Level. 

4.        Click Next to continue. The OLAP Time Dimension Levels screen displays. 

5.        Use the arrow buttons to move the desired Available Predefined Levels to the Selected Levels pane. 
These levels determine how the dimensions levels will logically role up into one another. For example, 
months roll up into quarters, which roll up into half years, which roll up into years. 

 

6.        To create levels that are not provided, such as days, select Custom. The OLAP Dimension Level 
window displays. Type a Level Name of up to 30 alphanumeric characters to identify the custom dimension 
level. Use the spin buttons or type in the Approximate Number of Members. A low number indicates the 
top level of the dimension hierarchy with larger numbers indicating lower levels. For example, 1 would 
correspond to the year level, 4 for quarters, 12 for months, and so on. Click Ok to save the custom 
dimension level. Click Next to continue. 

 

Note: You cannot create valid time dimension levels that are smaller than the time element established 
as the fiscal period in the general ledger. For example, if your fiscal periods are defined as months, you 
cannot create a valid time dimension of weeks. Since weeks have not been defined, the system does not 
recognize that level of detail. 
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7.        The Define Fiscal Year Period Mapping screen displays. Sage Budgeting and Planning will attempt to 
place the dimension levels in a logical form; however, you are given the option to move the level members 
around to create a more meaningful fiscal calendar. For example if your fiscal periods represent weeks, you 
can arrange the tree so that five weeks roll up into one month and four weeks roll up into another. Check 
the Freeze Level Naming? box to prevent the movement of members from affecting the level name. 

Note: Changes should be made to the Member Key and Member Name calculations before checking 
the Freeze Level Naming? box. Then the level members may be adjusted as needed. 

Within this screen, you may copy the fiscal year hierarchy to other fiscal years and modify the Advanced 

Level Properties as discussed earlier in this section. Click Next to continue. 

 

Note: Only one level member may be moved at a time; you cannot select and move multiple members. 
Also, you can only move the first member in a level to a level directly above it or move the last member 
in a level to a level directly below it. 

 

Note: Depending on the number of levels and members specified, this screen may take a significant 
amount of time to display. 

8.        Once you've established a hierarchy for your levels, you may copy that structure to other years by 
clicking the Copy Fiscal Year button. Highlight all of the years to copy and click Ok. 

 

9.        For information about the properties of the dimension levels selected, click the Advanced Level 

Properties button. The OLAP Dimension Layout Properties screen displays. To view and edit the 
properties for a particular level, select the level from the Level Description pane. Once editing is complete, 
click Next to continue. 
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OLAP Dimension Definition 

Name Defaults from the Level Description. This field may be edited. 

Description Defaults from the Level Description. This field may be 
edited. 

Member Count Indicates the order of the level in the hierarchy. A member 
count of one designates the highest level in the hierarchy. 

Type Defaults to the most logical type based on the level 
description selected. Choices include: 

•          Standard 

•          Years 

•          Half Years 

•          Quarters 

•          Months 

•          Weeks 

•          Days 
Unique Members? Check this box if the members within the level are unique 

across the entire data set. For example, the members that 
make up Years would be 2001, 2002, 2003, 2004, which all 
have unique names.  

Order By Key? Check this box to sort the dimension levels by member key or 
member name instead of member count.  

Data Type Select the data type from the drop-down list that matches the 
data type of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Type must be specified as 
Character. 

Data Size Select the data size from the drop-down list that matches the 
data size of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Size must be specified as 16. 

Member Key The calculation used to correctly convert the time dimension 
from a standard calendar year to the designated fiscal 
calendar. 

For more information on Member Keys, see SQL Server Books 
Online. 
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Member Name Performs the exact calculation used in the Member Key and 

creates the value visible to the user. 

For more information on Member Names, see SQL Server 
Books Online. 

Fact Table Fields Used to assist in defining the Member Key and Member 

Name. For example, in the Member Key and Member Name 

conversions, FieldName in the variable 
&OLAPFactTable&.FieldName would be replaced with 
&OLAPFactTable&.Accounts. 

10.     The OLAP Dimension Definition screen displays. Click Finish to save the OLAP dimension that you 
created. 

 

Standard Dimensions 

This is the most complicated of the OLAP dimensions because users must really understand their 
databases/fields to create the relationships needed. Standard dimensions allow you to drill down into data 
in different ways that are not normally possibly.  For example, let us say our data source, called ‘Prod’, has a 
relationship established for Area, State and Product (through one table or a join) and the table contains: 

Area     State     Product 
West     CA       A 
West     NV       A, B 
South    FL        B, C 
North   OH       B 
North   NY       C 
 
You can create levels which would drill down to display only associated values. For example, you could 
establish Level 1 = Prod.Area, Level 2 = Prod.State, Level 3 = Prod.Product. When you use this dimension 
and drill down on West, you would see only the states CA & NV. If you drill on FL, you would see only the 
products per State (B, C). You could also do this with an account number if each segment was within the 
others. For example, in account #: 1050-00-100-65 with 1050 = Base, 00 = Division, 100 = Dept, etc., you could 
drill down on all the divisions within the base, all departments within the division, etc. Using the Prod 
example, a normal dimension would allow you to see a list of all Areas but you would be unable to drill 
down at another level.  

The following wizard steps you through the process of creating this dimension. 

1.        Highlight the OLAP Dimension node in the tree-view pane. 

2.        Select File > New or click the New OLAP Dimension  icon. The OLAP Dimension Definition 

Wizard displays. 
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OLAP Dimension Definition 

Name Type a name of up to 30 characters identifying the OLAP 
Dimension. 

Type Select either Time or Standard from the drop-down list. 

•          Time used to define custom fiscal calendars that do not use a 
standard calendar year. 

•          Standard used to define other dimensions such as product line 
or sales regions. 

All Caption Indicates the name of the top level of the aggregates. By 
default, the caption is All + OLAP Dimension Name. 

Description 
(available when Advanced 
button is clicked) 

Defaults to the Dimension Name. 

Aggregation Usage 
(available when Advanced 
button is clicked) 

Select the level of the aggregate usage from the drop-down list. 
The available options are: 

•          Standard (All Levels) 

•          Top Level Only 

•          Bottom Level Only 

•          Custom 

3.        Select Standard as the OLAP Dimension type. To select an alternative Aggregation Usage type, click 
the Advanced button. 

4.        Click Next to continue. 

5.        The OLAP Time Dimension Levels screen displays. The hierarchy of the dimension levels is defined 
here. 
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6.        Select Custom from the Available Predefined Levels pane and use the right arrow button to move it to 
the Selected Levels pane. The OLAP Dimension Level screen displays. Type a Level Name of up to 30 
alphanumeric characters to identify the custom dimension level. Use the spin buttons or type in the 
Approximate Number of Members. A low number indicates the top level of the dimension hierarchy with 
larger numbers indicating lower levels. Continue this process until all of the dimension levels have been 
defined. 

 

7.        Click Next to continue. The OLAP Dimension Level Properties screen displays. To view and edit the 
properties for a particular level, select the level from the Level Description pane. Once editing is complete, 
click Next to continue. 

 

OLAP Dimension Definition 

Name Defaults from the Level Description. This field may be edited. 

Description Defaults from the Level Description. This field may be 
edited. 

Member Count Indicates the order of the level in the hierarchy. A member 
count of one designates the highest level in the hierarchy. 
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Type Defaults to the most logical type based on the level 
description selected. Choices include: 

•          Standard 

•          Years 

•          Half Years 

•          Quarters 

•          Months 

•          Weeks 

•          Days 
Unique Members? Check this box if the members within the level are unique 

across the entire data set. For example, the members that 
make up Years would be 2001, 2002, 2003, 2004, which all 
have unique names.  

Order By Key? Check this box to sort the dimension levels by member key or 
member name instead of member count.  

Data Type Select the data type from the drop-down list that matches the 
data type of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Type must be specified as 
Character. 

Data Size Select the data size from the drop-down list that matches the 
data size of the Member Key. For example, if the Member 

Key is identified as Accounts, which is defined as consisting 
of 16 characters, then the Data Size must be specified as 16. 

Member Key The calculation used to correctly convert the time dimension 
from a standard calendar year to the designated fiscal 
calendar. 

For more information on Member Keys, see SQL Server Books 
Online. 

Member Name Performs the exact calculation used in the Member Key and 

creates the value visible to the user. 

For more information on Member Names, see SQL Server 
Books Online. 

Fact Table Fields Used to assist in defining the Member Key and Member 

Name. For example, in the Member Key and Member Name 

conversions, FieldName in the variable 
&OLAPFactTable&.FieldName would be replaced with 
&OLAPFactTable&.Accounts. 

8.        The OLAP Dimension Definition screen displays. Click Finish to save the OLAP dimension that you 
created. 
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Maintaining OLAP Dimensions 

Once OLAP dimensions have been created, you may update the definition at any time. 

1.        From the tree-view pane, highlight the OLAP Dimensions node. 

2.        Highlight the OLAP dimension definition to be modified and select File > Open or click the Open 

 icon. 

3.        Modify the necessary fields. 

 

 

4.        After all of the changes have been made, click the Finish button. You will be prompted to save the 
definition. 

5.        If the OLAP dimension has been applied to any cube definitions, the following message displays: 

 

6.        Click Yes to refresh the associated cubes and apply the updated OLAP dimension. Click No or Cancel 

to cancel the action. Cubes can also be refreshed at any time within the OLAP Dimension Definition by 

selecting File > Refresh Cubes or by clicking the Refresh Cubes  icon. 
 

Note: The Refresh Cubes action applies OLAP dimension changes to the associated cube definition 
only. The cube must be reprocessed to actually reflect the changes to the cube. 

 

Note: Using Analysis Server 2005/2008 requires an update to existing OLAP dimensions so they can be 
used in 2005+ cubes. Updates will occur on each cube definition's Advanced Level Properties screen 
which requires the "OLAP 2005+ Level Selection" fields (located on the bottom half of the screen) to be 
completed. See the System Management Guide's Upgrading chapter for complete details on this topic. 
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Creating Cube Definitions 

Cube definitions are created and maintained from the Sage Budgeting and Planning desktop. The following 
is an overview of the steps required to create a cube definition. Additional information is provided in 
subsequent sections. 

1.        From the tree-view pane, highlight the Cubes node. 

2.        Select File > New (Ctrl + N) or click the New Cube  icon. 

3.        The Cube Maintenance screen displays: 

 

4.        Type a name of up to 40 alphanumeric characters identifying the cube. 

5.        Next, assign a cube Manager either by typing the appropriate user ID or by selecting one from the 
lookup list. The list of available managers is based on those users that have been given Edit Cube rights in 
User Maintenance. See the System Management Guide for additional information on setting this option. 

6.        In the Plan field, type the plan key or use the browse button to select the plan that contains the plan 
sheets to be published to the cube. Only those plans that the logged in user is the administrator or controller 
of display in the list of available. 

7.        Next, click the browse button to select the dimension-set to be published to the cube. This selection 
limits the plan sheets that will be available for publication. 

8.        Click the Plan Sheets button to choose the plan sheets to be published to the cube. 

Note: The total number of unique published groups for the sheets included in the cube must be less 
than or equal to 127. 

9.        Optionally check the Auto Publish Sheets box to republish selected plan sheets to the cube every time 
changes are made to the plan sheet. 

10.     Next, click the Dimension Attributes button to select any attributes to be published to the cube. 

11.     Select the valuation type you wish to publish to the cube. You may choose to publish Beginning 

Balance, Net Change, or Ending Balance values. 

12.     In the OLAP Settings section, type the name of the Analysis server and select the database where the 
cube definition and related cube data will be stored. 

Note: If your Analysis Server is installed on a Windows Vista machine and you are running Sage 
Budgeting and Planning on this same machine, you will need to choose Run as Administrator when 
launching Sage Budgeting and Planning to avoid an error in Cube Maintenance which occurs after 
entering the Analysis Server name. To avoid this error from occurring, highlight Sage Budgeting and 
Planning for launching, right click and choose Run as Administrator. Sage Budgeting and Planning will 
launch; log into Sage Budgeting and Planning as normal. In Cube Maintenance you can enter your 
Analysis Server name, tab off the field, and will see your databases without error. 

13.     Optionally, click the Advanced button to apply OLAP dimensions to the cube, additional storage 
options for the published cube and any aggregate storage constraints. 
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14.     Click Breakout Segments to publish dimension segments as individual cube dimensions. For example, 
if the account number is comprised of 4 segments, then each segment can be published individually and 
analyses may be performed based on a particular segment. 

Note: Selecting this option creates a new cube dimension for each segment. The key value will be 
duplicated as the dimension description. 

15.     Finally, select File > Save or click the Save  icon to save the cube definition. 

Cube Publication Options 

Plan Sheets 

Clicking the Plan Sheets button provides a list of plan sheets that match the plan key and dimension set 
specified. 

 

Sheets that are marked are those sheets that have been saved to the publication database based on the 
designated sheet and group publish options. You may change the publish options for a sheet at this point 
prior to cube processing.  

• If a sheet has been published, you may remove it from the publication table by unchecking the 
option.  

• If a sheet has not been published and you would like it to be a part of the cube, then you may add it 
to the publication table by checking the option. 

Publication options are changed and the publication tables are updated once the cube definition is saved. 

Note: Changing the publication options at this point could affect any Plan Sheet Table Lookup calculations 
that have been defined. 

Auto Publish 

By default, published tables are updated on demand, but a cube’s fact tables are not. However, you may use 
the Auto Publish option to specify that a cube’s fact tables should be updated when changes are saved 
within a plan sheet. This would then ensure that the most recent changes are always incorporated into the 
fact tables. The fact tables are the source of the OLAP cubes. So while the Auto Publish option will ensure 
that the fact tables are updated, the cube must be reprocessed to update the OLAP cube. 

Note: The drawback to automatically updating the fact tables is decreased processing speed. Depending on 
the size of the plan sheet, the save process might take substantially longer if the tables are automatically 
updated. 

 

Tip: Turning the auto publish option on is useful when querying the cube fact table. Changes to the plan 
sheet will be saved to the cube fact table automatically without necessarily affecting the processed cube. 

Dimension Attributes 
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In addition to the key plan sheet values, you may also choose to publish the dimension attributes to the 
cube. This provides an additional method for analysis. Dimensions and dimension attributes that are 
selected for publication are saved as cube dimensions. 

Note: Attribute values that are published to the cube come directly from the data source and not from the 
plan sheet. So, for example, in a compensation plan sheet, an employee’s review date is changed from 
01/15 to 01/31. The payroll database has the review date listed as 01/15, therefore, when the cube is 
processed, 01/15 will be returned because the attribute value comes from the data source, not the plan 
sheet. 

On the cube definition screen, click the Dimension Attributes button. A list of dimensions and attributes 
defined for the dimension display. You may choose various publication options for each dimension and 
attribute. 

 

Dimension Attribute Publish Options 

Dimension This column displays the dimensions that were selected for 
cube processing. To change the dimensions displayed, you 
must select a different dimension set on the cube maintenance 
screen. 

Attribute This column lists all the attributes defined for the associated 
dimension. Attributes can only be added to or removed from 
a dimension in Dimension Maintenance. 

Publish Method Use the drop-down list to select the publish method for the 
associated attribute. 

•          None – select this option to prevent the attribute from being 
published to the cube. 

•          Real/Virtual – these options publish the attribute value and 
display it in the cube. 

Member Name Use the drop-down list to select the member name displayed 
for the attribute. 

•          Masked Value + Description – this option publishes both the 
key value and the description for the attribute. For example, for 
the account number dimension, both the account number and the 
description are published (1000-000-000-00 Cash). 

•          Description – this option publishes only the attribute 
description. So in the case of the account number, only the 
description is published (Cash). 

•          Masked Value – this option publishes only the masked key 
value for the attribute. For the account number example, only the 
account number is published (1000-000-000-00). 

For additional information, refer to SQL Server Books Online. 

Advanced Options 

OLAP Dimensions 
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OLAP dimensions may be added to a cube definition at any time; however, the cube must be reprocessed to 
view the modifications. 

1.        To add or remove OLAP dimensions, click the Advanced button. The cube definition window expands 
to display advanced options including the OLAP Dimensions button. 

2.        Click the OLAP Dimensions button to assign the user-defined OLAP dimensions to the cube. 

 

3.        Click the Insert Row  icon or the Append Row  icon to add OLAP dimensions to the cube 

definition or click the Delete Row  icon to remove OLAP dimensions from the cube definition. 

4.        From the drop-down list, select the OLAP dimension you wish to publish. The available selections are 
based on previously defined OLAP dimensions. 

5.        Click Ok to save the OLAP dimensions to the cube definition. 

Note: The Date OLAP dimension is required for cube processing and cannot be deleted. 

 

Note: OLAP dimensions are company-specific. 

Cube Storage 

When creating the cube definition, one of the advanced options is to define the data storage option that best 
suits your needs. 

 

The following table describes each storage type and the advantages and disadvantages of each. 

Cube Storage Options 
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MOLAP MOLAP uses a multidimensional structure for data storage. 
Data is copied from the data source and is stored in a 
multidimensional structure. This option is the default storage 
option as it provides the best browsing performance when 
viewing and manipulating the cube. 

ROLAP ROLAP uses a relational database-type structure for data 
storage. The data is retained in the original data source. When 
the cube is queried, data is retrieved directly from the 
original source. This option is rarely implemented because a 
large quantity of storage space is required, and processing 
speed and cube-browsing performance are poor. 

HOLAP HOLAP is a hybrid of MOLAP and ROLAP. The source data is 
retained in its original location, but the aggregate data is stored 
in a specialized multidimensional cube structure. This option is 
useful if you do not have the space necessary to store copies of 
the source data and aggregate data, as is the case with 
MOLAP. 

For additional information on data storage, refer to SQL Server Books Online. 

Aggregation Design Constraints 

In addition to specifying the data storage type, Sage Budgeting and Planning provides the option to define 
constraints for the table that stores the cube aggregations. 

 

Physical size limitations may be applied by selecting the Estimated Storage Reaches option. Then, you can 
enter the maximum number of megabytes or gigabytes that the table may physically grow to. You may also 
choose to set a performance limitation by selecting the Performance Gain Reaches option and entering an 
average performance percentage. 

Note: The size and performance limitations are directly related to the disk storage space available on the 
server. Also, the default values listed are based on configuration recommendations set by Microsoft. For 
additional information on design constraints, refer to SQL Server Books Online. 



Sage Budgeting and Planning User Guide 

342 

Cube Security 

Cube security is divided into two types. The initial security applied to a cube is based on the rights a person 
has to view and/or create a cube definition. The ability to view or create cubes is defined in User 
Maintenance as described in the System Management Guide. 

Once a cube has been defined, additional security may be applied to finite sections of the cube for specific 
users and/or roles including down to the cell level. 

Cube information including any roles applied to the cube is stored within Sage Budgeting and Planning, 
which provides the ability to delete, recreate, and change the roles independent of Analysis Services. 
Therefore if a role is removed from within Analysis Services directly, it will be recreated once the cube is 
reprocessed in Sage Budgeting and Planning. All maintenance on cubes created in Sage Budgeting and 
Planning should be maintained within Sage Budgeting and Planning. 

A cube definition must be defined and saved before security may be applied to it. Security may be applied 
from within the Cube Maintenance screen by selecting Cube > Security or by clicking the Cube Security 

 icon. Cube security may also be applied to the cube from the desktop interface. Highlight the desired 

cube and select Management > Security or click the Cube Security  icon. 

 

Security can be applied to specific cubes based on the selected roles, or it can be applied to specific roles 
based on selected cubes. Then additional security may be applied at the cell level. 

Applying Security 

Assigning Roles to Cubes 

1.        Launch the OLAP Security Role feature. 

2.        In the Cube/Role Association section, click the By Cube option. 

3.        In the Select Cube box, highlight the cube you wish to apply security to. 

 

Security Options by Role 

Roles The available cube roles that have been defined are listed in 
this field. 
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Cube Access From the drop-down, select the access options: 

•          None – select this option if you do not want members of this 
role to have any access to the selected cube. 

•          Read Only – select this option to allow members of the role 
view rights only to the selected cube. 

•          Read/Write – select this option to allow members of the role 
the right to view and edit cube data for the selected cube.  

Cell Security Click this button to apply security down to the cell level of 
the selected cube. Cell security in the next section. 

Enforcement This option identifies where the authentication 
enforcement will be handled – either at the client machine 
or at the server. Authentication on the client produces 
faster results, however authentication on the server is more 
secure. For additional information, see Analysis Services 
Books Online. 

Drill Through This option allows the ability for third-party cube viewing 
tools to drill through to the source data. For additional 
information, see Analysis Services Books Online. 

4.        Assign the desired security options to the roles listed. 
5.        Click Close to apply the security options. An output log displays detailing the changes. You may print 
or save the log. 

Assigning Cubes to Roles 

1.        Launch the OLAP Security Role feature. 

2.        In the Cube/Role Association section, click the By Role option. 

3.        In the Select Role box, highlight the role you wish to apply across the defined cubes. 

 

Security Options by Cube 

Cubes The available cubes that have been defined are listed in this 
field. 

Cube Access From the drop-down, select the access options: 

•          None – select this option if you do not want members of the 
selected role to have any access to the cube. 

•          Read Only – select this option to allow members of the 
selected role view rights only to the cube. 

•          Read/Write – select this option to allow members of the 
selected role the right to view and edit cube data for the cube.  

Cell Security Click this button to apply security down to the cell level of 
the selected cube. Applying cell security is discussed later 
in this chapter. 

Enforcement This option identifies where the authentication 
enforcement will be handled – either at the client machine 
or at the server. Authentication on the client produces 
faster results, however authentication on the server is more 
secure. For additional information on security 
enforcement, see Analysis Services Books Online. 
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Drill Through This option allows the ability for third-party cube viewing 
tools to drill through to the source data. For additional 
information on drill through, see Analysis Services Books 
Online. 

4.        Assign the desired security options to the roles listed. 
5.        Click Close to apply the security options. An output log displays detailing the changes. You may print 
or save the log. 

Assigning Cell Level Security 

In addition to restricting cube access to specific roles, you may restrict roles from viewing specific measures 
and particular cells within the cube. For additional information on cell-level security, refer to Analysis 
Services Books Online. 

1.        To apply cell-level security, click the Security button for the corresponding role or cube. 

2.        The OLAP Cell Security screen displays. 

 

3.        The affected cube and role is listed in the corresponding fields at the top of the screen. 

4.        Select the Enable option to apply the security options to the cube-role combination. This option may be 
turned on or off at any time. 

5.        In the Dimensions/Attributes section, choose whether there will be access to All cells or a Range of 
cells for the dimension-attribute combination. 

6.        If Range is selected for the access level, then you can specify the range in the Member Ranges section. 
You may type a valid range or double-click on the field to select a valid parameter. To add multiple ranges, 

click the Insert Row  or Append Row  icons. Ranges may also be removed from the list by 

highlighting the row and clicking the Delete Row  icon. 

7.        You may also restrict the measures that are visible in the cube. To hide a measure, in the Measures 

section, uncheck the box next to the measure to be hidden. 

8.        Click Close to return to the OLAP Security Roles screen. 

Maintaining Cube Roles 

Create a Cube Role 

1.        To create a new cube role, open the OLAP Security Role screen. 
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2.        Click the New button. 

 

OLAP Security Roles Options 

Name Define a unique name of up to 40 characters that identifies 
the cube role. 

Description Type a description that describes the cube role. 

Enable Check this box to allow this role to be applied to cubes. This 
option can be turned on or off at any time. 

3.        Click Ok to save the cube role definition. 

Maintain a Cube Role 

1.        In the Cube/Role Association section of OLAP Security Roles, highlight the cube role to be 
maintained. 

2.        Click the Maintain button. 

3.        Modify the Name or Description or change the Enable option. 

4.        Click Ok to save any changes made to the definition. 

Delete a Cube Role 

1.        In the Cube/Role Association section of OLAP Security Roles, highlight the cube role to be deleted. 

2.        Click the Delete button. 

3.        A confirmation warning displays: 

 

4.        Click Yes to remove the cube role from Sage Budgeting and Planning and Analysis Service. Click No or 
Cancel to return to the OLAP Security Roles screen without initiating the action. 

Copy a Cube Role 

Sage Budgeting and Planning allows you to copy a cube role and it’s corresponding members to a new role 
definition. 

1.        In the Cube/Role Association section of OLAP Security Roles, highlight the cube role to be copied. 
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2.        Click the Copy button. 

3.        A new OLAP Security Role screen displays. 

 

4.        Complete the necessary fields for the copied definition. 

5.        Click Ok to save the new definition. 

Add Domain Users 

Once a role is created, you must add the users that belong to that role. Since Analysis Services uses Domain 
Authentication to validate user security, the members of the role must be identified appropriately. 

1.        In the Role Membership section of OLAP Security Roles, click the By Domain User option. 

 

2.        Next, in the New Domain User field, type a valid domain user name. 

Note: If the Analysis Server is not a part of the home domain, then you will have to add the domain 
name to the user account name when adding users to the Domain User list (e.g. Domain\User). 

3.        Click the Add button to add the user to the Domain Users list. 

4.        The users are now available to be applied to the cube role. 

Note: To remove users from the Domain User list, you must remove that user from all associated roles. 
Once the user is removed from all roles and the security screen is closed, then that account is no longer 
available in the list. 

Apply Domain Users to a Cube Role 

Users may be assigned to roles or roles may be assigned to users. The end result is the same regardless of 
the method used. 

Assigning Roles to Users 

1.        To assign roles to a user, click the By Domain User option in the Role Membership section of OLAP 

Security Roles. 

 

2.        In the Domain User list, highlight the user you wish to apply cube roles. 

3.        In the Non Member Of box, highlight the role to be applied to the user and click the right arrow 
button. Use the arrow buttons to add and remove roles. 
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4.        Click the Close button to apply the security changes. 

Assigning Users to Roles 

1.        In the Cube/Role Association section of OLAP Security Roles, click the By Role option. 

2.        Next, in the Select Role section, highlight the role you wish to add domain users to. 

3.        In the Role Membership section, click the By Role option. 

 

4.        In the Non Members box, highlight the user to be applied to the role and click the right arrow button. 
Use the arrow buttons to add and remove users. 

5.        Click the Close button to apply the security changes. 
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Cube Processing 

Once the cube definition has been defined and saved, it is ready for processing, and finally for viewing. 
During processing, Sage Budgeting and Planning republishes the selected plan sheets to the publication 
database. Then a cube fact table is created from the published tables, and finally, an OLAP cube is built from 
the data in the fact table. This ensures data integrity. 

Note: Since plan sheets are republished during cube processing, any changes made to the publication 
options of the plan sheets selected to participate in the cube could affect any previously defined Plan Sheet 
Table Lookup calculations. 

Cubes may be processed directly from within the cube definition screen. To process a cube from an open 

cube definition, select Cube > Process or click the Process Cube  icon. You may also process a cube from 
the desktop interface. Highlight the cube definition(s) to be processed and select Management > Process 

Cube or click the Process Cube  icon. An output log displays detailing the processing routine. You may 
choose to print or save the log. Once a cube has been processed, it is available for viewing through Analyzer 
or an Excel pivot table. 

Note: Only users that have edit cube rights and are defined as an Administrative user, plan administrator, 
plan controller, or cube administrator may process a cube. 
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Maintaining Cube Definitions 

Changing Definition Properties 

You can change the cube definition properties at any time, including assigning a new name, assigning a new 
plan, changing the dimension, adding or removing sheets, etc. 

1.        Highlight the cube definition to be modified. 

2.        Select File > Open or click the Open Cube  icon. 

3.        Modify any of the definition options as desired, then select File > Save (Ctrl + S) or click the Save 

 icon to save the changes. 

If plan sheets are added or removed from the cube definition, a message displays confirming that 
you wish to change the publication options. 

 

Note: Only users that have edit cube rights and are defined as an Administrative user, plan administrator 
or plan controller may change the plan assigned to an existing cube definition. 

4.        When saving the changes, a confirmation message displays: 

 

5.        Click Yes to save the changes. Click No or Cancel to return to the Cube Maintenance screen without 
affecting any changes. 

Note: Clicking Yes deletes the existing fact table data and the existing cube. Then an empty fact table 
and an empty cube definition are created. The cube must then be reprocessed to display the changes. 

Adding and Removing Plan Sheets from the Definition 

Plan sheets may be added or removed from the cube at any time. Once sheets have been added or removed, 
the cube must be reprocessed to reflect the changes. 

1.        Open the cube definition that you wish to modify. 

2.        Click on the Plan Sheets button to view the list of available plan sheets. 

3.        Check or uncheck the box next to the plan sheet to be added or removed from the cube definition. 

4.        A message displays confirming the action. 

 

5.        Click Yes to change the publication settings or click No or Cancel to return to the plan sheet listing 
without initiating any changes. 
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6.        Select File > Save (Ctrl + S) or click the Save  icon to save the changes. 

Deleting Cube Definitions 

Deleting a cube definition also removes all tables and processed cubes associated with the cube definition. 
Cubes may be deleted from the Cube Maintenance screen or from the desktop interface. 

From Cube Maintenance 

1.        From an open cube definition, select File > Delete or click the Delete  icon. 

2.        A confirmation warning displays. 

 

3.        Click Yes to delete the cube definition, any associated cube tables and any processed cubes. Click No to 
return to Cube Maintenance. 

From Desktop Interface 

1.        From the desktop interface, highlight the cube definition(s) to be deleted. 

2.        Select File > Delete or click the Delete  icon. 

3.        A confirmation warning displays. 

 

4.        Click Ok to delete the cube definition(s), any associated cube tables and any processed cubes. Click 
Cancel to return to list of cube definitions. 

Note: Only users that have edit cube rights and are defined as an Administrative user, plan 
administrator, plan controller, or cube administrator may delete a cube. 
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Analyzing Cubes with Excel Pivot Tables 

Sage Budgeting and Planning provides two ways to analyze OLAP cubes, either using Excel pivot tables or 
Analyzer. Analyzer also provides the ability to edit cubes and  “model or writeback” those changes to the 
cubes. The features and functionality of Analyzer are discussed in the subsequent section. 

By selecting Pivot Table, Sage Budgeting and Planning automatically launches Excel, connects to the 
appropriate cube and allows you to work with and save views of the cube. Additional options available 
within the pivot tables include: 

•       Auto Format Reports 

•       Charts and Graphics 

Some features normally available in Excel pivot tables are not available when pivot tables are launched from 
Sage Budgeting and Planning. However, you can use Excel outside of Sage Budgeting and Planning to view 
data from the OLAP cubes that were created in Sage Budgeting and Planning. To do this, you must define 
the data source and cube in Excel. See Excel's Help for more information on defining the data source within 
Excel. 

Note: Viewing the pivot table requires the user to have Edit or View Cube permissions. 

 

Note: In order for Excel pivot tables to work properly with Sage Budgeting and Planning, you MUST enable 
the Trust access to Visual Basic Project option in Tools > Options > Security > Macro Security > 
Trusted Sources. 

1.        Highlight the cube definition to be analyzed. 

2.        Select Management > Pivot Table or click the Pivot Table icon. 

 

3.        The pivot table is ready for viewing and manipulating. Detailed instructions for using Excel pivot table 
are found in the Excel manual. 
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Chapter 15 

Analyzer 

As mentioned in the previous chapter Sage Budgeting and Planning provides two ways to analyze OLAP 
cubes. In addition to Excel pivot tables, Sage Budgeting and Planning includes Analyzer, a data 
visualization product developed in partnership with ProClarity Corporation. 
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Understanding Multidimensional Analysis 

The Data Problem 

Many decision makers “drown in data while thirsting for information.” You probably have no lack of data: 
income statements, balance sheets, sales figures, production figures, quarterly reports, annual reports—the 
list is long. While these standard reports give you a great deal of data, they do not always provide the 
information you need about your business. 

Data + Relevance + Context = Information 

By itself, data does not provide information. To create information from data, you must first sort through 
the available data to extract the specific data points (individual facts) that are relevant to answering the 
questions you have in mind. Next you must arrange the relevant data into the desired context of 
relationships. The magnitude of a data point by itself is of little importance. What is important, however, is 
whether the magnitude of that data point is what it should be, relative to the same period last year, to its 
peers, and to the overall trend. For example, if your company had $1 million in sales this year, you will 
compare this figure to last year’s sales and the overall growth trend of the company. These kinds of 
relationships among the data reveal cause and effect patterns, trends, and exceptions that indicate how your 
business is doing and where it is going— information you can use to make decisions. 

Only after the relevant data is arranged within a context of relationships can you derive information from 
the data and make decisions based on the information. 

Getting Stuck in the Report Cycle 

Sorting though paper reports to extract the relevant data and put it into the desired context can be 
overwhelming and cumbersome. Sending report requests to your data department to arrange the specific 
data the way you want it can produce delays that make the reports obsolete. Then, viewing a custom report 
generates more questions in your mind, and these questions generate more report requests that produce 
further delays. 

The Solution 

Analyzer allows you to interact directly with the data on your server. Using familiar click and drag 
techniques and drop-down menus, you can query your database to extract the data you deem relevant and 
arrange it in the context you deem useful to create information in a matter of minutes. And the information 
can be presented as graphs or charts, so you can easily see the data relationships. 

With Analyzer, if the result of one query generates another question in your mind, you can instantly find the 
answer. By rearranging the data, choosing a different set of data, and exploring various levels of detail in the 
data, you can view successive relationships as you follow a train of thought. 
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What are OLAP and Multidimensional Analysis? 

Online Analytical Processing, or OLAP, is a way of analyzing data by interacting directly with data rather 
than by reviewing static paper reports. OLAP technology arranges raw data so that someone working at a 
computer can view the data in graphical formats that reflect a wide variety of relationships among the data. 
OLAP also makes multidimensional analysis possible. 

Multidimensional Analysis is a process of analyzing data that is organized according to the variables (such 
as region, product, time, etc.) that decision makers find most useful in evaluating their businesses. 

For example, let’s assume you have data regarding sales dollars. You also have data regarding which 
products and regions generated the sales dollars over various periods of time. The quantitative measure 

(budget dollars) contains dimensions—product, region, and time. 

When you view sales, you want to see how sales were related to the products that generated them. Perhaps 
you want to limit your product comparisons to only the top ten sellers. Then, you want to see how the sales 
per product fluctuated over time. Also, you want to see how the sales per product during a certain time 
period compared among regions. In other words, you want to see how the various dimensions of the data 
relate to one another. 

Information derived from relationships among data dimensions fosters decision-making, which is what 
multidimensional analysis is all about. 

Terms Used in Multidimensional Analysis 

Data is stored on the server’s database in a multidimensional arrangement referred to as a cube. Cubes 
contain measures and dimensions of measures. Measures are quantitative values. Some examples of measures 
are sales dollars, number of product failures, gross margin, and average inventory levels. Cubes generated 
by Sage Budgeting and Planning consist of the dimensions assigned, along with one or more groups and 
one or more measures. 

•       Dimensions (attributes or categories) are used to analyze measures. For example, you can analyze the 
measure of actual sales dollars by geographic region or product family. 

•       Dimensions are organized into a hierarchical tree. Components of the dimension are referred to as 
members or items. 

When you use Analyzer, you access a cube and choose relevant data by selecting measures and dimension 
members. You can arrange the measures and dimension members in various layouts. The arrangements 
create visual graphs and charts that illustrate relationships. You can view relationships among members 
that are lower or higher in the hierarchy by drilling down or drilling up. You can also filter and sort the data 
to narrow and order the data. Analyzer offers these and many other tools so you can choose relevant data 
and view it in pertinent relationships. Analyzer lets you create the information you need to make decisions 
about your business. 

Understanding Rows, Columns, and Background 

When you create a chart or graph in Analyzer, you select measures and dimension members to define the 
set of relevant data. You also arrange the measures and dimension members into rows, columns, or 
background to visualize comparisons. The following example view illustrates a set of relevant data and its 
arrangement. 
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Notice how the dimensions and their members specified as being Rows and Columns relate to the row and 
column labels of the chart and the grid. Notice also how the chart values correspond to the cell values of the 
grid. 

How the relevant data and its arrangement affect your charts and graphs 

The Relevant Data 

In the two views that follow, the row, column, and background dimension arrangements are the same, but 
the members included for each dimension are not. View #1 includes all members of the Product Category 
dimension; View #2 includes only the Glassware member of the Product Category dimension. 
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View 1 

 

 

View 2 

Because the relevant data for the two views is different, the values are also different, even though the 
dimension arrangement is the same. 
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The Data Arrangement 

In the two views that follow, the relevant data is the same, but the arrangements are different. Both views 
include the same members of all dimensions, but the dimensions are arranged differently among the rows, 
columns, and background. Because the relevant data for the two views is the same, the values are the same, 
even though the dimension arrangements are different. 

Different arrangements emphasize different comparisons. View #1 emphasizes a product-to-product 
comparison, while View #2 emphasizes a year-to-year comparison. 

 

Data Arrangement, View 1 
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Data Arrangement, View 2 

The Background: Invisible, Yet Relevant 

The dimension members and measures in the background, as well as those in the rows and columns, define 
the relevant data. However, the background items do not determine the visual comparisons. Graphically, 
they are invisible. Usually, you place items into the background to set them aside so that you can focus your 
analysis on the row and column items. 

Because the background dimensions do not determine the visual comparisons, you cannot drill down or 
drill up on these dimensions. When you drill down or drill up on a dimension, you access the members in a 
lower or higher hierarchy level to create further comparisons. If you want to drill down or drill up on a 
background dimension, you must move the background dimension to the row or column. Also, when a 
dimension is in the background, it cannot have multiple members selected. 
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Launching Analyzer 

Analyzer may be launched when a cube has been selected from the Sage Budgeting and Planning desktop 
interface. 

1.        Highlight the cube that you wish to analyze. 

2.        Select Management > Analyzer or click the Analyzer  icon. 

3.        You may now view and manipulate the cube data. 
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Using the Dimensions Tool 

1.        Select View > Dimensions or click the Dimensions  icon to hide or display the Dimensions 
pane. 

 

2.        Click the Dimensions drop-down to select measures or dimensions defined in the cube. You can create 
additional calculated measures as described later in this section. 

3.        You can narrow the results by selecting specific members of a dimension. To select multiple non-
consecutive members, hold down the Ctrl key while clicking. To select a range of adjacent members, click 
and drag the mouse to select the desired range. When a dimension is in the background, you may select 
only one member or all members. 

      

Note: If you select more than one member of a background dimension, only the first dimension selected 
is displayed. 
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4.        Use the layout area of the Dimensions Tool to move measures and dimensions into Rows, Columns 
and Background. 

 

Keep the following in mind as you arrange the layout: 

•       Row and column items are creating visual relationships. Background data is still relevant, but it is 
not graphically visible. 

•       You must have at least one item in each of the Rows and Columns areas. 

•       You can drill up and drill down on dimensions displayed in rows and columns. 

•       You cannot drill up or down on background dimensions. 

5.        After making selections and arranging the layout, move your cursor over to the view pane. When you 
do, the view changes to reflect your selections. To hide the Dimensions tool, click the Dimensions 

 icon or select View > Dimensions. 

Auto Apply 

By default, the Auto Apply option is turned on, which means that after making selections and arranging the 
layout, you simply have to move your cursor over to the view pane to reflect your selections.  To disable this 
option, select View > Auto Apply.  With Auto Apply disabled you will need to manually apply your 
changes to the view after making selections and arranging the layout. To apply your changes, Select View > 

Apply Now or click the Apply  icon . 
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Calculated Measures 

Calculated measures are measures that you create to calculate your data using predefined or custom-built 
formulas. You can create a variety of calculated measures, including: 

•       Growth 

•       Time series 

•       Simple relationships 

•       Custom formulas 

When you create a calculated measure, it is saved to your computer only. To create a calculated measure 
that is available to others who open the cube, contact your system administrator. 

1.        With a view displayed, select View > Dimension or click the Dimensions  icon to display the 
dimensions pane. 

2.        Click the Dimensions drop-down and select Measures. 

3.        Click the Calculated Measure  icon to open the Calculated Measure Wizard. 

4.        Choose the type of calculated measure you wish to create. 

 

5.        Click Next to make the selections that will define your calculated measure. 

•       Use memorable, unique names when naming measures. 

•       If you create a custom formula that contains errors, an error message will be generated when you use 
the measure in a view. 

•       More powerful options for creating custom queries are available from the MDX Editor located on the 
View menu. 

6.        If multiple time dimensions were published to the cube, select the time dimension to apply to the 
calculated measures. 

7.        If Growth is selected as the measure type, the following screen displays: 
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8.        If Time series is selected as the measure type, the following screen displays: 

 

9.        If Simple relationship is selected as the measure type, the following screen displays: 

 

10.     If Custom formula is selected as the measure type, the following screen displays so that you can define 
the custom formula: 

 

11.     Click Finish to view the results. 

Editing or Deleting a Calculated Measure 

1.        With a view displayed, select View > Dimension or click the Dimensions  icon to display the 
dimensions pane. 

2.        Click the Dimensions drop-down and select Measures. 

3.        From the list of measures, right-click on the calculated measure you want to edit or delete. 

4.        Click Edit or Delete. 

5.        If editing a measure, make changes in the dialog box that displays. 
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6.        Click Finish to commit the changes to the calculated measure. 

7.        If deleting a measure, the following warning message displays: 

 

8.        Click Yes to delete the selected calculated measure, or click No to cancel the action. 
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Working with Views 

You can display data views in full-screen chart format, in grid format, or in a split screen containing two 
different formats. The defaults are a Bar Chart and a Grid. 

To change the Grid view, select View > Grid and choose the Grid view option: Grid Only, Off, Bottom, 
Right. 

You can choose from several different types of business charts (for example, pie chart or line chart). To 
change the Chart type, select View > Business Charts and choose the Chart type: Area, Bar, Horizontal Bar, 
Line, Pie, Point.  

In addition to changes to the Grid view and Chart type, you can change the view by making changes to the 

Dimensions selections and layouts.  The Back and Forward  icons allow you to quickly move 
backward and forward through your changes to the views. 

Tip: To see more detail about an item in the layout area, click on the item. Member properties will be 
displayed in the Dimensions pane. 

Resetting the View to Defaults 

Sometimes you may wish to “start over” by recreating a default view that has the following specifications: 

•       All dimension hierarchies are rolled up to the highest level. 

•       All sorting and filtering is turned off. 

•       Your current view becomes the last chart type you were viewing. 

To reset the view to defaults, select View > Reset to Defaults or click the Reset  icon. 

Displaying Subtotals 

When cube data is displayed in a grid, you can display and remove multiple layers of subtotals. Subtotals 
can be calculated from both column and row data. 

1.        Display cube data in a grid. 

2.        Right-click on the grid. 

3.        Select Totals from the menu that displays. 

4.        Select what data you want to subtotal. Data can be subtotaled Across Rows, Down Columns, or Both. 

To remove subtotals from the grid, first right-click on the grid, select Totals, and then click the item that you 
want to remove. 

If subtotals are on and you drill down on an item in the grid, all subcomponents of the item you expanded 
are also subtotaled. 

Copying 

Cube data that is displayed in either chart or grid form may be copied and inserted into word processing, 
spreadsheet, or presentation applications. All charts are copied to the clipboard and pasted as bitmaps into 
the new medium. Grids that are copied and pasted into any application other than a spreadsheet are 
inserted as bitmaps. If the grid is copied into a spreadsheet, the values may be manipulated. 

1.        To copy either a grid or chart, right-click on the view. 

2.        Select Copy. 

3.        Open the new application and paste the image from the clipboard. 

Notes 
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An additional feature is the ability to add notes to views and books. All of the usual formatting such as font 
type, font size, font attribute, justification, and others may be applied to the notes. To include a note, select 

View > Notes or click the Notes  icon . Notes are saved when the Analyzer Book is saved, discussed 
later in this chapter. 

 

Exception Highlighting 

You can format grids so that certain values are highlighted. Highlighting values helps you visualize those 
that fall in or out of specified ranges. For example, you can highlight profits that fall below a specified 
amount by displaying the numbers in red. This would indicate items that are not profitable. 

1.        Display cube data in a grid, then right-click on the grid. 

2.        Select Exception Highlighting from the menu that displays. The Exception Highlighting screen 
displays: 

 

3.        Select the measure to apply the exception highlight to. 

4.        Next, select an exception operator, such as equal to, between, or less than. 

5.        Select a value or range of values for the exception. For example, if you select Between as the operator, 
you can select 0 and 5000 as the values. All values between those numbers will display exceptions. 

6.        Click Configure Highlight Format to configure the exception formatting. 

 

7.        Select the cell background color, font, font style, font color and underlining. These formats will be 
applied to all exception values. 

8.        Click Ok to return to the Exception Highlighting screen. 

9.        Click Add if you want to add more than one highlighting style. You may configure up to three 
different highlighting styles. 

10.     Click Ok to save the exception highlighting. All values in the grid that meet the exception criteria you 
defined will display as highlighted text. 

Chart Properties 

You can configure charts to display in various styles, including stacked or side-by-side. In addition, chart 
types may be specified, such as line, area, bar, or pie. You can also apply chart attributes, such as titles, call 
outs, legend positions, pointers, and axes labels to each chart. By configuring charts, you can make them 
easier to read and highlight data you want to stand out. 
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1.        Display the cube data in any chart view. 

2.        Right-click on the chart. 

3.        Select Chart Properties from the menu. The Chart Properties screen displays. 

 

4.        To edit chart configurations, chart titles, footnotes, legends, or axes, select the desired chart 
configuration component and choose the appropriate options. Tabs vary depending upon the component 
selected. 

5.        Click Ok to save the configuration options. 

MDX Editor 

Analyzer uses MDX (Multidimensional Expressions) to formulate database queries. MDX is a set of database 
functions that is used to access data in multidimensional datasets. MDX has the tools necessary to ask 
complex questions of a database and quickly return information from multidimensional datasets. You can 
create custom queries by using the MDX Editor included with Analyzer. For additional information on 
creating MDX queries, refer to Microsoft SQL Server Books Online. 

1.        To access the MDX Editor, select View > MDX Editor. The editor opens with the MDX expression for 
the current view. 

 

2.        Add meta-data and MDX functions to the MDX expression by dragging and dropping them into the 
MDX expression window. 

3.        Click Test MDX to validate your expression. If there are errors in your expression, a message box 
displays the errors. 

4.        Click Format to add line breaks and indenting to the expression. This improves the readability of the 
expression. 

5.        Click Run Query to run the MDX expression. If there are any errors in your MDX expression, a error 
message will display describing the errors. 

5.        Click Close to close the MDX Editor. 
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Note: Any MDX query typed into the MDX Editor must reference the cube displayed in Analyzer. 
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Exploring Data 

Frequently, a view that you create to answer one question will lead you to ask other questions and probe 
other data relationships. For example, suppose a view answers the question, “How did sales for the North 
America territory compare over last year?” The same view may raise another question: “The southern 
region had the most sales last year. Was this true for each quarter?” The answer to this question may make 
you wonder, “What products sold in the southern region contributed to its success in the second quarter?” 
This process of one answer (or view) leading to the next question, which leads to the next view, etc., is called 
following a train of thought. 

You could follow a train of thought using only the Dimensions tool to vary your data display. However, 
Analyzer provides several other tools that simplify following a train of thought. By using these tools, you 
can quickly rearrange (pivot) dimensions, display lower or higher levels of data hierarchy (drill down, drill 
up, expand, and collapse), and focus on select dimension members (isolate and eliminate). 

This section explains tools you will frequently use to follow a train of thought. These tools are not used in 
any particular order. As one question leads to another, you use whatever tool is appropriate to the question 
you have in mind at the time. 

Drilling Down 

Drilling down enables you to see the comparisons among lower-level members of a dimension’s hierarchy. 
Drilling down increases the amount of detail being displayed. 

For example, suppose you have a view comparing sweatshirt sales among four quarters of a year. You want 
to see comparisons among the months of one quarter. You could drill down on the quarter to view that 
quarter’s months. 

In order to drill down on a dimension, the dimension must be in either a row or a column. 

Tip: To visualize the change in your dimension selections before you drill down, display the Dimensions tool 
and click the tab for the dimension on which you will drill down. When you drill down, you will see the new 
member selections. 

Drilling Down Directly on a Chart 

1.        Move the mouse pointer over the chart. The pointer changes to a pointer with a down arrow when you 
pass over the area representing dimension members that you can drill down on. 

2.        Click on the area you want to drill down. 

3.        If a list displays, click a dimension member to drill down on. The new view reflects your selection. 

Using the Drill Down Icon from the Toolbar 

1.        From the toolbar, click the Drill Down  icon. 

2.        From the list box, select the members you want to drill down on. To drill down on more than one 
member, hold down the Ctrl key while selecting. 

3.        Click Ok. The new view reflects your selection. 

Tip: If the Drill Down icon is not present on the Toolbar, then you can easily add it.  Select View > Toolbar > 
Customize and add it to the current toolbar. 

Drilling Up 

Drilling up enables you to see the comparisons among higher-level members of a dimension’s hierarchy. 
Drilling up decreases the level of detail being displayed. 
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For example, suppose you have a view comparing sweatshirt sales among the three months of a quarter. 
You want to view the comparisons among the four quarters. You could drill up on any of the three months 
currently displayed to change the view to a quarter-by-quarter comparison. 

In order to drill up on a dimension, the dimension must be in either a row or a column. 

Tip: To visualize the change in your dimension selections before you drill up, display the Dimensions tool 
and click the tab for the dimension on which you will drill up. When you drill up, you will see the new member 
selections. 

Drilling Up Directly on a Chart 

1.        Hold down the Shift key while moving the cursor over the chart. The cursor changes to a pointer with 
an up arrow when you pass over an area representing dimension members that you can drill up on. 

2.        Continue holding down the Shift key and click on the area you want to drill up. 

3.        If a list displays, click a dimension member to drill up on. 

Using the Drill Up Icon from the Toolbar 

1.        From the toolbar, click the Drill Up  icon. 

2.        Select the member(s) you want to drill up on. To drill up on more than one member, hold down the 
Ctrl key while selecting. 

3.        Click Ok. The new view reflects your selection. 

Tip: If the Drill Up icon is not present on the Toolbar, then you can easily add it.  Select View > Toolbar > 
Customize and add it to the current toolbar. 

Expanding Dimension Members 

Expanding a dimension member allows you to drill down on one displayed member while leaving the 
remaining members at their current hierarchy levels. 

1.        Select Navigate > Expand. 

2.        Select the dimension member(s) you want to expand. To expand a single member, click the member. 
To expand multiple members, hold down the Ctrl key while you click the members you wish to expand, 
then click Ok. 

Collapsing Dimension Members 

Collapsing a dimension member does just the opposite of expanding dimensions, while leaving the 
remaining members at their current hierarchy level. 

1.        Select Navigate > Collapse. 

2.        Select the dimension member(s) you want to collapse. To collapse a single member, click the member. 
To collapse multiple members, hold down the Ctrl key while you click the members you wish to collapse, 
then click Ok. 

Isolating Dimension Members 

When you want to focus your analysis on only a few members, you can isolate them. 

1.        Select Navigate > Show Only. 

2.        Select the dimension member(s) you want to isolate. To isolate a single member, click the member. To 
isolate multiple members, hold down the Ctrl key while you click the members you wish to isolate, then 
click Ok. 
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Hiding Dimension Members 

Eliminating a dimension member from a view is useful if you are viewing a chart and one member is 
skewing the results. The following are examples: 

•       The value of one member is so much larger than the others that the graph is skewed. 

•       Members are irrelevant such as when a single member has no value. 

1.        Select Navigate > Hide. 

2.        Select the dimension member(s) you want to eliminate. To eliminate a single member, click the 
member. To eliminate multiple members, hold down the Ctrl key while you click the members you wish to 
eliminate, then click Ok. 

Using the Timeline 

To display the timeline, click the Timeline  icon or select View > Timeline. When the timeline is 
visible, you can use it to isolate a time period or to expand and collapse a time period. 

 

1.        Click on the time period displayed on the timeline. To select multiple periods, click on the Ctrl key 
while clicking. Move the mouse pointer over the view to see the result of your selections. 

2.        To expand or collapse time periods, right-click on the timeline. From the list that displays, select a time 
level. The timeline will then update. Move the mouse pointer over the view to see the results of your 
selections. 

Pivoting Dimensions 

During data analysis, you may want to change the arrangement of your data to emphasize various 
relationships. Rearranging the data is called pivoting dimensions. 

1.        From the Dimensions tool, drag dimensions into Rows, Columns, or Background sections to create 
the arrangement you want. 

2.        Move the mouse pointer into the view to see the result of the new arrangement. 

3.        You may also pivot the view by right-clicking on either the chart view or the grid view and selecting 
Pivot from the list. 
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Filtering and Sorting Data 

Filtering Data 

During an analysis, you may often prefer to work with only subsets of the data. For example, you may wish 
to include only those products that rank in the top 20% by sales dollars. 

One reason to work with a subset is that some of your dimension groups (hierarchies) may contain a very 
large number of members. For example, the clothing group of a product category dimension could contain 
over 100 members. When you want to include such a dimension in an analysis, use filtering to create a 
smaller subset to work with. Doing so will reduce the amount of time that a query (such as a drill down) 
requires to return a result, and the result will be more understandable. 

Tip: Because filtering criteria relates to rows and columns, it is easier to visualize the data being filtered if 
you select the Grid View or the Both View (grid and chart). You can display subtotals to filter by. 

1.        To turn on the filtering function, right-click anywhere within a chart or grid and select Filter or click 

the Filter  icon to open the Filter dialog box. 

 

2.        To hide columns or rows that are empty (contain no data values), select one or both of the check boxes. 

3.        In Filter 1 section of the dialog box, click Show Rows or Hide Rows. 

4.        Select a criterion from the drop-down list. 

Filtering Criteria 

None No filtering. Choose this option to turn off the filtering 
function. 

Top (Count) The rows that contain the top (count) values. 

Bottom (Count) The rows that contain the bottom (count) values. 

Top (%) The rows that comprise the top specified percentage of the 
column. 

Bottom (%) The rows that comprise the bottom specified percentage of 
the column. 

Top (Sum) The rows with the largest values that, when summed, 
comprise at least the value specified. 
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Bottom (Sum) The rows with the smallest values that, when summed, 
comprise at least the value specified. 

Above The rows that have values above the number specified. 

Below The rows that have values above the number specified. 

Between The rows that have values between the two numbers specified. 

5.        Enter the count, percentage, or amount for the criterion. 

6.        In the Based on boxes, select the filter details. 

a.        Select a column for the first field. 

b.       Select a measure for the second field. You can select any measure contained in the cube, even if it is not 
a currently displayed measure. 

7.        To define a secondary filter, complete the Filter 2 section.  Secondary filters are applied to the data that 
remains after the primary filter is applied. 

8.        Click Ok or Apply to view the result of the filtering selections. 

Filters remain in effect until you change the layout or you change the filtering specifications. To turn off the 
filtering functions, select None as the filtering criterion. 

Sorting Data 

The sort function allows you to display data sequentially in ascending or descending order. 

Tip: Because sorting criteria relates to rows and columns, it is easier to visualize the data being sorted if you 
select the grid view or both the grid and chart. 

1.        To turn on the sorting function, right-click anywhere within a chart or grid and select Sorting or click 

the Sort  icon to open the Sorting dialog box. 

 

2.        From the drop-down list, select the column by which you want to sort the rows. 

3.        Click Ascending or Descending. 

4.        Click Preserve peer groupings to restrict sorting within the groups contained in the row dimensions. If 
you do not preserve peer groups, sorting applies to all items. 

5.        Click Ok. The new view will reflect your selections. 

To turn off the sorting function, select None in the Sort rows by box. 
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Printing Data 

Once the data has been analyzed, you may decide to print a particular chart view or grid. 

1.        To print the view, select File > Print or click the Print  icon. The Print dialog box displays. 

 

2.        Select the desired options and click Print to print the selected view or click Cancel. 

Tip: If the Printer icon is not present on the Toolbar, then you can easily add it.  Select View > Toolbar > 
Customize and add it to the current toolbar. 
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Advanced Analysis 

Decomposition Tree 

The Decomposition Tree allows you to visually decompose information along any dimension and expose 
the contributing factors. Using Decomposition Trees, you can answer questions such as “Which clothing 
items are the biggest contributors to product sales?” or “What percentage of the overall Quarter 2 sales are 
represented by each territory?” 

A Decomposition Tree breaks a measure apart (decomposes it) into its subcomponents and then displays the 
subcomponents in a hierarchical tree and a Pareto chart. Decomposition Trees order data from largest to 
smallest or from smallest to largest. Decomposed data is provided both in raw numbers and in percentages 
of total. In addition, Pareto charts show which components fall above or below a particular percentage, 
enabling you to quickly identify components that contain the greatest percentage of the total. 

The Decomposition Tree Wizard guides you through the steps necessary to create a Decomposition Tree. By 
selecting values from a series of screens, you determine the starting point in the cube and the measure data 
associated with the starting cell data. 

For example, you may want to display data about sweatshirt sales. The dimensions you want to use are 
territory, product group, and year. You decide to set your starting point to clothing sales in North America 
for 2002. 

From this starting point, you decompose the data, showing the different product categories that make up 
the product line, the territories in North America that sell clothing, and the different time periods for 2002, 
for instance quarters or months. 

Note: Subcomponents with no values (empty) are not displayed; however zero-value subcomponents are 
displayed. 

 

Note: It is recommended that you close the Dimension tool before creating a Decomposition Tree view. It 
will give you more space and eliminate confusion as to which members are selected in the view. 

Decomposition Tree Wizard 

1.        Select View >Advanced Analysis Tools >Decomposition Tree or click the Decomp  icon to 
launch the Decomposition Tree Wizard. 

 

2.        Click Next to continue. 
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3.        Select the measure you want to decompose and the dimension you wish to be the starting point of the 
decomposition tree. 

4.        Click Finish to complete the Wizard. 

5.     You can now start drilling down on the dimensions to define the decomposition tree. A Pareto chart also 
displays the percentages of the totals. 

 

Working with the Decomposition Tree 

•       The current level is highlighted. The bars of the Pareto chart correspond to the current level. To 
change the current level, click a level name. 

•       To see how a percentage relates to the group and to the topmost total, point to the percentage. 

•       To expand the tree to display components of a displayed dimension (drill down), click the dimension 
member. 

•       To collapse the tree, click the dimension member you want to collapse. When you do, the levels 
below the member are cleared from the view. 

•       A stacked summary box (for example, Bottom 4) contains members that are not displayed and 
summarizes the value of those members. To display a set of members, click the summary box. 

•       Right-click in a box to start a new branch with different dimension or to begin a new tree with the 
item. 

Working with the Pareto Chart 

•       The Pareto bars represent the members contained in the current-level summary boxes. Clicking on a 
Pareto bar or hovering over the bar will display the corresponding member from a summary box. 

•       To toggle hiding/displaying the Pareto chart, click the Pareto  icon. 
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•       To toggle hiding/displaying the percent-of-total line on the Pareto chart, click the line graph 

 icon. 

•       To toggle hiding/displaying the percentage and value lines on the Pareto chart, click the values and 
percentages on the sides of the chart. 

Perspective Views 

If you want to display the relationship between two measures across selected dimensions, create a view 
using the Perspective Wizard. For example, you may want to compare variance in forecasted revenue to 
actual sales. Or, you may want to compare profitability to revenue growth. Some example analysis for 
which you may find Perspective View especially useful include sales analyses, financial analysis, and 
quadrant analysis. 

Perspective View allows you to analyze large volumes of data, because the Perspective View can effectively 
represent many more data points than can other types of charts. The Perspective Wizard creates views that 
appear similar to scatter charts but that provide richer and more detailed information. 

Note: It is recommended that you close the Dimension tool before creating a Perspective View. It will give 
you more space and eliminate confusion as to which members are selected in the view. 

1.        Select View > Advanced Analysis Tools > Perspective to launch the Perspective Wizard. 

 

2.        Click Next to continue. 

 

3.        Select the items from the dimensions you wish to analyze, for example all Product Categories for all 
Salespeople. 

4.        To select an item, double-click on the Dimension name (or highlight it and click Change Selection) to 
display the Change Selections screen. For example, Clothing is an item in the Product Category dimension, 
AS001 is an item in the Territory dimension, and 2002 is an item in the Date dimension where you wish to 
start. 
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5.        Expand the dimension, highlight the selection you want to analyze, and click Ok. The Wizard screen 
redisplays. 

 

6.        Click Next to continue. 

7.        Select measures for the X and Y-axes, in this case ACT and PLAN respectively. 

 

8.        Click Finish to display the Perspective View. 

The following illustrates an example Perspective View and some of the features that you can access from it. 

 

Working with the Perspective View 

•       To see information about what a data point represents, point to it. 

•       To change the position of the slider bar (to create a reference line), drag it with the mouse. 



Sage Budgeting and Planning User Guide 

380 

•       To change the dimensions included in the view, use the Dimensions tool or right-click on the view 
and select Perspective Wizard. 

•       Several other features are available by right-clicking anywhere in the view: 

➢       To vary the appearance of one or more data points so that each will stand out, click the Data 

Point Attributes. 
➢       To change the type of data indicated by the slider bar, click Statistical Sliders, and point to 

either Horizontal or Vertical. 
➢       To change the measures displayed on an axis, click Configure Axes. 

 

Zooming and Panning 

•       To zoom in on an area, hold down the left mouse button and drag downward and to the right 
(creating a box). 

•       To pan across quadrants, hold down the Shift key and the left mouse button, and move the mouse 
across the view. 

•       To return to a normal view after zooming in or panning, hold down the left mouse button and drag 
upward and to the left (creating a box). 
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Analyzer Books 

When working with cubes in Analyzer, you may want to save configured views, called briefing books. An 
unlimited number of views can be saved for each cube. 

Creating a New Book 

1.        To create a new briefing book, select File > New Book and a blank Briefing Book pane will appear. 

 

2.        To save the configured view in the briefing book, click the Add button. 

 

3.        In the Name field, type a descriptive name for the configured view. 

4.        Click Ok to save the view. You can save multiple configured views in the briefing book. 

 

5.        To save the new briefing book, select File > Save Book. In the File Name field, type a descriptive name 
for the briefing book and click Save. 

 

Opening an Existing Book 
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1.        To open a saved view, select File > Open Book. 

 

2.        To select the analyzer book to be opened, double-click the file name or highlight the file and click 
Open. Click Cancel to return to the current view without opening an analyzer book. 

3.        Click on any configured view in the briefing book to display that configured view. 

 

Saving the Current Book 

To save changes to the configuration of a configured view in the open book, click the Add button. 

Leave the current view in the briefing book, click the Add button to update the configured view or 
change Name to create a new configured view.  

Select File > Save Book to save the changes to the briefing book. 

Deleting a Configured View 

1.        To delete a configured view, right click on a configured view and select Delete. 

 

2.        Click Yes to delete the configured view or Cancel to exit without deleting it. 

 



 

383 

Appendix A - Desktop Interface 
 

 

Appendix A 

Sage Budgeting and Planning Desktop 
Interface 

Desktop Interface 

Upon logging into the application, you will notice that the main interface of Sage Budgeting and Planning is 
comprised of three sizeable panes: Shortcuts, Tasks and List View. 

 

The first pane, Shortcuts, allows the ability to save shortcuts to favorite Sage Budgeting and Planning 
components such as plan sheets, cubes, formulas, and dimension definitions. The second pane, Tasks, 
displays a tree structure of all of the Sage Budgeting and Planning functions. The last pane, List View, 
contains a list of items associated with each component in the Tasks pane. For example, if the Plan Sheets 
node is highlighted in the Tasks pane, then a list of all of the plan sheet definitions for the current company 
displays in the List View pane. Items in the List View pane can be sorted based on the selected column or 
dragged to the Shortcuts pane and saved as a shortcut. 

 If the item selected in the Tasks pane does not have anything to display in the Select pane, then a webpage 
will be displayed. This webpage will have links to Sage Software’s website. 
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Shortcut Pane 

Items in the list-view pane can be dragged to the shortcut pane and saved as a favorite. Then, those items 
can be quickly viewed by double-clicking on the short cut. 

Note: The contents of the shortcut pane are user specific and are based on the configurations set by the 
user account logged into the system at the time. 

Shortcut Maintenance 

Create Shortcuts 

1.        In the list-view pane, highlight the item to be saved as a shortcut. 

 

2.        Click and drag the highlighted item to the shortcut pane. 

 

3.        The shortcuts may be renamed, added to a group, and resized. 

Open Shortcuts 

1.        In the shortcut pane, click on the item you wish to view or right-click and select Open. 

 

2.        The definition is opened for viewing or modification. 
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Rename Shortcuts 

1.        In the shortcut pane, right-click on the item you wish to rename. 

2.        Select Shortcut > Rename Shortcut. 

3.        Type a meaningful name. 

4.        Press Enter to save the changes. 

Resize Shortcuts 

1.        To resize the shortcuts, right-click on the shortcut pane. 

2.        Select between large icons or small icons. 

          

Note: Icon size can vary between groups. For example, the Sage Budgeting and Planning group may have 
large icons, but the Formulas group may have small icons. 

Arrange Shortcuts 

Shortcuts may be arranged in any order that you wish. To move a shortcut, click and drag the shortcut to 
the new location. 

View Shortcut Properties 

1.        To view the shortcut properties, right-click on desired shortcut. 

2.        Select Shortcut > Properties. 

 

3.        Click Ok to exit the properties screen. 
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Other Shortcut Options 

Other plan sheet items are available from the right-click menu are Shortcut options, Print options, History, 
Revision Comparison, Generate From Model, Define Derivative Sheets, Generate From Template and 
Subsheet Manager. 

 

 

Remove Shortcuts 

1.        In the shortcut pane, right-click on the item you wish to remove from the shortcut pane. 

2.        Select Shortcut > Remove Shortcut. 

3.        A warning displays, confirming that you wish to remove the shortcut. 

 

4.        Click Yes to remove the shortcut or click No to cancel the action. 

Shortcut Group Maintenance 

Create Groups 

1.        To create a group, right-click on the shortcut pane. 

2.        Select Add New Group. 

3.        Type the name of the new group and press Enter. 

Rename Groups 

1.        To rename a group, right-click on the group to be renamed. 

2.        Select Rename Group. 

3.        Type a new name for the group and press Enter. 

Remove Groups 

1.        To remove a group, click on the group name you wish to remove. 

2.        Right-click on the shortcut pane and select Remove Group. 

3.        A warning displays, confirming that you wish to delete the group. 

 

4.     Click Yes to remove the group and all of the shortcuts in that group, or click No to cancel the action. 

Add Items to a Group 

1.        To add a shortcut to a group, expand the group to receive the shortcut. 



Sage Budgeting and Planning User Guide 

388 

2.     Either create the shortcut directly into the expanded group by highlighting the item in the list-pane and 
dragging it to the group, or drag a shortcut from an existing group to the new group. 

Remove Items from a Group 

1.        To remove a single item from a group, right-click the shortcut and select Shortcut > Remove Shortcut. 
A warning displays, confirming that you wish to remove the shortcut. 

2.     To remove all shortcuts from a group, right-click on the shortcut pane and select Remove All Items. A 
warning displays, confirming that you wish to remove all shortcuts from the group. 

3.     Click Yes to remove the shortcut(s) or click No to cancel the action. 

Set Default 

The Set Default option sets the selected group and the associated shortcuts to display on login. All other 
groups are minimized at the bottom of the pane and must be expanded to view the associated shortcuts. 

To set a group to be the display default, right-click on the group name and select Set Default. 
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List Pane 

The information displayed in the list pane may be arranged to suit your needs. Column headings may be 
moved to display essential information first. Additionally, rows may be sorted based on the column selected 
for the sort order. 

Note: To restore the list pane to its original state, select View > Reset to Default View from the main menu. 

Arrange Column Headings 

1.        To move a column heading, hover the mouse over the column heading until it changes to a black 
arrow. 

 

2.        Click and drag the column to the desired location. 

 

Sort Listings 

The listings may be sorted in ascending or descending order. Click on the column heading to change the sort 
order.  An icon will appear in the column header to indicate the sort order.  Ascending order will display 

the Ascending Sort  icon and descending sort order will display the Descending Sort  icon. 
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Appendix B 

Toolbar Actions 

List Pane Icons 

Icon Description 

 Plan 

 Plan Root 

 Unassigned Root 

 Plan Sheet 

 Locked Plan Sheet 

 Checked-Out Sheet - by current user 

 Checked-Out Sheet - by another user 

 Excel Sheet 

 Model Definition 

 Model Sheet 

 Template Definition 

 Derivative Sheet 

 Plan Formula 

 Global Formula 

 Sheet Formula 

 
Dimension 

 Tiered Dimension 

 Cubes 

 OLAP Dimension 

 User 

 Status Code 
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Sage Budgeting and Planning Desktop Plans Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new plan. File > New > Plan  

 
Creates a new plan sheet as a 
subsheet of a selected plan sheet. 

File > New > New Sheet Ctrl + N 

 
Check-Out a plan sheet. File > Check Out Sheet  

 
Check-In a plan sheet. File > Check In Sheet  

 
Undo Check-Out, effectively checks-
in all plan sheets in the Plan or 
selected branch. 

File > Undo Check Out 
Sheet 

 

 
Opens a selected plan sheet. File > Open Sheet Ctrl + O 

 
Deletes the selected plan or plan 
sheet. 

File > Delete  

 
Opens the Plan Processing form. Management > Plan 

Processing 
 

 
Change Plan Base Date. Plan > Change Base Date  

 
Copies the selected plan sheet or 
branch to another existing plan or 
copies the entire plan to a new plan. 

Plan > Copy Plan  

 
Prints the selected plan sheet or the 
definition of the selected plan sheet. 

File > Print > Plan Sheet  

File > Print > Definition 

 

 
Displays the Plan Manager tree with 
the plan and the plan sheets in the 
hierarchical structure. 

View > Tree View  

 
Displays a list of plan sheets for the 
selected plan. 

View > List View  

 
Processes a history report of the 
selected plan sheet or all the plan 
sheets in the selected plan. 

Plan > History  

 
Displays the properties of the selected 
plan sheet or plan. 

 Plan > Properties  

 
Opens the Revision Comparison form. Plan > Revision 

Comparison 
 

 
Opens the Branch Manager form. Plan > Branch Manager  
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Regenerates the selected plan sheet 
based on the model used to initially 
create the plan sheet. 

Management > Generate 
From Model 

 

 
Opens the Template Source Definition 
form and allows the derivative sheets 
to be added, removed, or updated for 
generation. 

Management > Define 
Template Values 

 

 
Generates or regenerates derivative 
sheets based on the selected template 
definition. 

Management > Generate 
From Template 

 

 
Displays Subsheet Manager. Management > Subsheets  

 

Sage Budgeting and Planning Desktop Plan Sheets Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Check-Out a plan sheet. File > Check Out Sheet  

 
Check-In a plan sheet. File > Check In Sheet  

 
Undo Check-Out, effectively checks-
in all plan sheets in the Plan or 
selected branch. 

File > Undo Check Out 
Sheet 

 

 
Opens the selected plan sheet. File > Open Ctrl + O 

 
Deletes the selected plan sheet. File > Delete  

 
Prints the selected plan sheet or the 
definition of the selected plan sheet. 

File > Print > Plan Sheet  

 File > Print > Definition 

 

 
Processes a history report of the 
selected plan sheet or all the plan 
sheets in the selected plan. 

Plan > History  

 
Displays the properties of the selected 
plan sheet or plan. 

Plan > Properties  

 
Opens the Revision Comparison form. Plan > Revision 

Comparison 
 

 
Regenerates the selected plan sheet 
based on the model used to initially 
create the plan sheet. 

Management > Generate 
From Model 

 

 
Opens the Template Source Definition 
form and allows the derivative sheets 
to be added, removed, or updated for 
generation. 

Management > Define 
Template Values 
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Generates or regenerates derivative 
sheets based on the selected template 
definition. 

Management > Generate 
From Template 

 

 
Displays Subsheet Manager. Management > Subsheets  

 

Sage Budgeting and Planning Desktop Plan Formulas Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the Plan Formula 
Maintenance form to create a new 
formula definition. 

File > New Ctrl + N 

 
Opens the definition for the selected 
plan formula. 

File > Open Ctrl + O 

 
Deletes the definition(s) of the selected 
plan formula(s). 

File > Delete  

 
Prints the definition(s) of the selected 
plan formula(s). 

File > Print Definition  

 

Sage Budgeting and Planning Desktop Global Formulas Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the Global Formula 
Maintenance form to create a new 
formula definition. 

File > New Ctrl + N 

 
Opens the definition for the selected 
global formula. 

File > Open Ctrl + O 

 
Deletes the definition(s) of the selected 
global formula(s). 

File > Delete  

 
Prints the definition(s) of the selected 
global formula(s). 

File > Print Definition  

 

Sage Budgeting and Planning Desktop Sheet Formulas Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Opens the definition for the selected 
sheet formula. 

File > Open Ctrl + O 

 
Deletes the definition(s) of the selected 
sheet formula(s). 

File > Delete  

 
Prints the definition(s) of the selected 
sheet formula(s). 

File > Print Definition  
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Sage Budgeting and Planning Desktop Dimensions Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new dimension. File > New  

 
Creates a new tiered dimension. File > New Tier  

 
Opens the definition for the selected 
dimension. 

File > Open  

 
Deletes the definition(s) of the selected 
global formula(s). 

File > Delete  

 

Sage Budgeting and Planning Desktop Cubes Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new OLAP cube definition. File > New Ctrl + N 

 
Opens the selected OLAP cube 
definition. 

File > Open Ctrl + O 

 
Deletes the selected OLAP cube 
dimension. 

File > Delete  

 
Opens the OLAP Security Roles form 
to apply security to the processed cube. 

Management > Security  

 
Processes the OLAP cube and readies 
it for analysis using Analyzer or Excel 
pivot tables. 

Management > Process 
Cube 

 

 
Opens the generated OLAP cube for 
viewing in Analyzer. 

Management > Analyzer  

 
Opens the generated OLAP cube for 
viewing in an Excel pivot table. 

Management > Pivot Table  

 

Sage Budgeting and Planning Desktop OLAP Dimensions Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new OLAP dimension. File > New  

 
Opens the selected OLAP dimension 
definition. 

File > Open  

 
Deletes the selected OLAP dimension 
definition. 

File > Delete  
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Sage Budgeting and Planning Desktop User Maintenance Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the User Maintenance form to 
create a new user. 

File > New Ctrl + N 

 
Opens the User Maintenance form for 
the selected users. 

File > Open Ctrl + O 

 
Deletes the selected user(s). File > Delete  

 

Sage Budgeting and Planning Desktop Status Codes Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the New Status Code form to 
create a new status code. 

File > New Ctrl + N 

 
Opens the Status Code Maintenance 
form for the selected status code. 

File > Open Ctrl + O 

 
Deletes the selected status code(s). File > Delete  

 

Sage Budgeting and Planning Desktop Accounts and Account Dimensions Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the New Account form to 
create a new account number. 

File > New Ctrl + N 

 
Opens the Account Maintenance form 
for the selected account number. 

File > Open Ctrl + O 

 
Deletes the selected account number(s). File > Delete  

 

Sage Budgeting and Planning Desktop Balances Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Launches the New Balance form to 
create a new balance information. 

File > New Ctrl + N 

 
Opens the Balance Maintenance form 
for the selected balance information. 

File > Open Ctrl + O 

 
Deletes the selected balance 
information. 

File > Delete  

 

Sage Budgeting and Planning Desktop Resulting Balances Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Opens the Resulting Balance 
Maintenance form for the selected 

File > Open Ctrl + O 
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resulting balance information. 

 
Deletes the selected resulting balance 
information. 

File > Delete  

 

Plan Sheet Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Check-Out the current plan sheet. File > Check Out Sheet  

 
Check-In the current plan sheet. File > Check In Sheet  

 
Open another plan sheet. Displays a list 
of plan sheets to select from. 

File > Open Ctrl + O 

 
Saves the current plan sheet to the 
database. 

File > Save Ctrl + S 

 
Deletes the current plan sheet. from the 
database. 

File > Delete  

 
Inserts a row into the plan sheet above 
the highlighted rows. 

Rows > Row Control > 
Insert (Plan Sheets) 

 

 
Appends a row to the end of the plan 
sheet. 

Rows > Row Control > 
Append  

 

 
Deletes all highlighted rows. Rows > Row Control > 

Delete  
 

 
Inserts a column to the left of the 
highlighted column. 

Columns > Column Control 
> Insert  

 

 
Appends a column to the end. Columns > Column Control 

> Append > Column  
 

 
Append a Custom Column. Columns > Column Control 

> Append > Custom Column 
 

 
Opens the Copy Column window. Columns > Column Control 

> Copy 
 

 
Deletes all highlighted columns. Columns > Column Control 

> Delete 
 

 
Opens the Column Maintenance form. Columns > Maintenance  

 
Moves the highlighted column to the 
left. 

Columns > Column Control 
> Move Left 

 

 
Moves the highlighted column to the 
right. 

Columns > Column Control 
> Move Right 

 

 
Displays the Column Manager 
window. 

Columns > Column 
Manager 
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Displays the Group Manager window. Columns > Group Manager  

 
Displays the Custom Column Manager 
window. 

Columns > Custom Column 
Manager 

 

 
Copies the plan calculations for the 
highlighted plan sheet rows. 

Rows > Calculations > Copy  

 
Pastes the plan calculations into the 
highlighted plan sheet rows. 

Rows > Calculations > Paste  

 
Refreshes the plan calculation results 
for the highlighted plan sheet cells. 

Rows > Calculations > 
Refresh Range 

Ctrl + F9 

 
Opens the Revision Control window. Sheet > Revision Control  

 
Displays Subsheet Manager. Management > Subsheets  

 
Displays the plan sheet security form. Management > Security  

 
Opens the Cell Format window. Edit > Cell Formats Ctrl + F2 

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 
Inserts a page break above a 
highlighted row or to the left of a 
highlighted column. 

Edit > Page Break  

 
Turn on or off display of page breaks. Sheet > Sheet Options > 

Page Breaks 
 

 

 

 

Model Definition Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Saves the model to the database. File > Save Ctrl + S 

 
Deletes the current model from the 
database. 

File > Delete  

 
Inserts a row for a model source sheet 
above the highlighted rows. 

Rows > Insert  

 
Appends a row for a model source 
sheet to the end of the table. 

Rows >  Append   

 
Deletes all highlighted rows. Rows >  Delete   

 
Inserts a comparison column to the left 
of the highlighted column. 

Columns > Insert   
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Appends a comparison column to the 
end. 

Columns >  Append    

 
Deletes all highlighted columns. Columns >  Delete  

 
Displays column properties. Columns > Properties  

 
Opens the Cell Format window. Edit > Cell Formats  

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 
Define Sheets to Generate. Launches 
the Model Source Values screen. 

Model > Go to Dimension 
Values 

 

 
Selects all sheets to generate. Model > Select All Ctrl + A 

 
Unselects all sheets to generate. Model > Unselect All  

 
Generates the plan sheet(s) from a 
Model. 

File > Generate From Model  

 
Launches the Automatic Sheet 
Definition window. 

Model > Automatic Sheet 
Definition 

 

 

Template Define Derivative Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Saves the derivative definition to the 
database. 

File > Save Ctrl + S 

 
Inserts a row for a template source 
sheet above the highlighted rows. 

Rows > Insert  

 
Appends a row for a model source 
sheet to the end of the table. 

Rows >  Append   

 
Deletes all highlighted rows. Rows  > Delete   

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 
Generates the plan sheet(s) from a 
Model. 

File > Generate From Model  

 
Launches the Automatic Sheet 
Definition window. 

Model > Automatic Sheet 
Definition 

 

 

Template Generation Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Selects all sheets to generate. Model > Select All Ctrl + A 
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Unselects all sheets to generate. Model > Unselect All  

 

Global Formula Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new global formula. File > New Ctrl + N 

 
Displays a list of global formulas to 
select from. 

File > Open Ctrl + O 

 
Saves the current global formula to the 
database. 

File > Save Ctrl + S 

 
Deletes the current global formula from 
the database. 

File > Delete  

 
Inserts a row into the formula above 
the highlighted rows. 

Edit > Insert Rows  

 
Appends a row to the end of the 
formula. 

Edit > Append Row  

 
Deletes all highlighted rows. Edit > Delete Row   

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 

Plan Formula Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new plan formula. File > New Ctrl + N 

 
Displays a list of plan formulas to select 
from. 

File > Open Ctrl + O 

 
Saves the current plan formula to the 
database. 

File > Save Ctrl + S 

 
Deletes the current plan formula from 
the database. 

File > Delete  

 
Inserts a row into the formula above 
the highlighted rows. 

Edit > Insert Rows  

 
Appends a row to the end of the 
formula. 

Edit > Append Row  

 
Deletes all highlighted rows. Edit > Delete Row   

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 
Allows formulas to be saved as global View > Global Formulas  
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formulas. 

 
Allows formulas to be saved as plan 
formulas. 

View > Plan Formulas  

 

Sheet Formula Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new sheet formula. File > New Ctrl + N 

 
Displays a list of sheet formulas to 
select from. 

File > Open Ctrl + O 

 
Saves the current sheet formula to the 
database. 

File > Save Ctrl + S 

 
Deletes the current sheet formula from 
the database. 

File > Delete  

 
Inserts a row into the formula above 
the highlighted rows. 

Edit > Insert Rows  

 
Appends a row to the end of the 
formula. 

Edit > Append Row  

 
Deletes all highlighted rows. Edit > Delete Row   

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 
Allows formulas to be saved as global 
formulas. 

View > Global Formulas  

 
Allows formulas to be saved as plan 
formulas. 

View > Plan Formulas  

 
Allows formulas to be saved as sheet 
formulas. 

View > Sheet Formulas  

 

Dimension Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new dimension. File > New Ctrl + N 

 
Saves the current dimension to the 
database. 

File > Save Ctrl + S 

 
Deletes the current dimension from the 
database. 

File > Delete  

 
Inserts a row into the formula above 
the highlighted rows. 

Edit > Insert Rows  
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Appends a row to the end of the 
formula. 

Edit > Append Row  

 
Deletes all highlighted rows. Edit > Delete Row   

 
Test the SQL query syntax to ensure 
that the correct dimension values are 
being returned. 

File > Test SQL  

 
Launches the Edit Column form to 
allow advanced queries, text, and 
variables to be added to the column. 

Edit > Edit Column  

 

Tiered Dimension Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new tiered dimension. File > New Ctrl + N 

 
Saves the current tiered dimension to 
the database. 

File > Save Ctrl + S 

 
Deletes the current tiered dimension 
from the database. 

File > Delete  

 
Inserts a row into the formula above 
the highlighted rows. 

Edit > Insert Rows  

 
Appends a row to the end of the 
formula. 

Edit > Append Row  

 
Deletes all highlighted rows. Edit > Delete Row   

 
Displays the field lookup window. Edit > Lookup Window Ctrl + L 

 

Cube Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new OLAP cube definition. File > New Ctrl + N 

 
Saves the current OLAP cube 
definition. 

File > Save Ctrl + S 

 
Deletes the selected OLAP cube 
dimension. 

File > Delete  

 
Opens the OLAP Security Roles form to 
apply security to the processed cube. 

Cube > Security  

 
Processes the OLAP cube and readies it 
for analysis using Analyzer or Excel 
pivot tables. 

Cube > Process  
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OLAP Dimension Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Creates a new OLAP dimension 
definition. 

File > New Ctrl + N 

 
Deletes the current OLAP dimension 
definition. 

File > Delete  

 
Refresh cubes. Applies any changes 
made to the current OLAP dimension 
to all associated cube definitions. 

File > Refresh Cubes  

 

WebView Toolbar Icons and Actions 

Icon Action Menu Equivalent Shortcut 

 
Check-Out a plan sheet. File > Check Out Sheet  

 
Check-In a plan sheet. File > Check In Sheet  

 
Saves the current plan sheet to the 
database. 

File > Save  

 
Saves the current plan sheet as a new 
revision. 

File > Save as New 
Revision 

 

 
Prints the current plan sheet. File > Print  

 
Clears cell values only, not cell 
formulas. 

Edit > Clear > Clear Values 
Only 

 

 
Refreshes cell formulas. Sheet > Refresh Cell 

Formula 
F9 

 
Cuts selected cells. Edit > Cut Ctrl + X 

 
Copies selected cells to the clipboard. Edit > Copy Ctrl + C 

 
Pastes information from the clipboard 
into the selected cells. 

Edit > Paste Ctrl + V 

 
Launches the Sheet Options dialog 
box. 

Sheet > Sheet Options  

 
Launches the View Options dialog 
box. 

Sheet > View Options  

 
Launches the Sheet Properties dialog 
box. 

Sheet > Properties  

 
Allows the user to view and select 
Revisions of the current sheet. 

Sheet > Revision List  

 
Allows the user to create new Sheet > Revision List  
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Revisions of the current sheet. 

 
Launches the Spread Values Tool. Sheet > Spread Values  

 
Adds a Cell Note to the selected cell. Edit > Add/Edit Cell Notes  

 
Deletes a Cell Note in the selected cell. Edit > Delete Cell Notes  

 
Consolidates values from child plan 
sheets. 

Management > Consolidate 
Subsheets 

 

 
Updates the Parent Distribution.  Pulls 
values from the Parent plan sheet into 
the currently open plan sheet. 

Management > Update 
Parent Distribution 
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Appendix C 

Function Detailed Listing 

Following are the detail descriptions and examples for Sage Budgeting and Planning cell functions. A 
sample plan sheet is displayed below showing the rows, columns and values used to produce the results 
shown in the example cell functions.  All examples that use Account Numbers are shown using Row 3 
which has an Account Number of 6100-100-200-00.  The plan sheet has a base date of January 1, 2007. 

 

Note: The results can vary on the screen according to the decimal precision of the cell format. 

 

Function 

 

Description Example 

ABS(number) Absolute value of a number ABS(P8) = 10,000 

ACCT() Returns the Account Number for 
the row without any formatting 
characters. 

ACCT() = "610010020000" 

ACCTSEG(SEGNO) Returns the indicated account 
segment. 

ACCTSEG(1) = "6100" 

ADD(number1, number2) Adds number1 to number2 ADD(P3,R4)= 116,000 

AMASK(mask) Returns the Account Number 
after it has been passed through 
the indicated mask without any 
formatting characters 

AMASK("4200???99900") = 
"420010099900" 
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AND(bool1, bool2, &) Logical AND boolean function AND(P3=U6) = 1 (True) 

AVERAGE(value1  

[, value2 [,.]]) 

Finds the average of a list of 1 to 
32 values. Each value may be a 
number, cell reference, or a cell 
range. Empty cells within range 
are not included.  

AVERAGE(P3:W3) = 145,000 

BASEDATE() Returns the Sheet Base Date. BASEDATE() = 01/01/2007 

CEILING(number, factor) Rounds number up to the number 
that is a multiple of factor. 

CEILING(R5,1000) = 21,000 

CHAR(value) 

 

Returns the character specified by 
a number. 

CHAR(66) = "B" 

CHOOSE(index, value1  

[,value2 [, ...]]) 

Returns the appropriate value 
based on the index. You can have 
up to 30 values from which to 
choose. 

CHOOSE (2,R3,U8,W3) = -46,000  

CLEAN(text)  

 

Removes all nonprintable 
characters from text. 

CLEAN(CONCATENATE(O4, 

CHAR(7),O8)) = "ABCD" 

CODE(text)  

 

Numeric code representing the 
first character in a text string 

CODE(O6) = 66 

COLUMN([cell]) Returns the column number of the 
current column. 

cell (optional): Cell reference to 
return column number for. 

Note: Sage Budgeting and 
Planning column numbering 
includes reserved columns and 
dimensions. 

COLUMN(P3) = 16 

COLUMNS([cellrange]) Returns the number of columns 
included in a cell range. If the 
cellrange is omitted, the current 
column will be assumed and 1 
will be returned. 

COLUMNS(P3:W3) = 8 

CONCATENATE(text1, 

 text2 [,&]) 

Combines multiple text strings or 
numbers into one text string. 

CONCATENATE 
(O4,O8)  = "ABCD" 

COUNT(value1 [, value2 [, .]]) Counts the number of nonempty 
values of a list of 1 to 32 values. 
Each value may be a number, cell 
reference, or a cell range. Empty 
cells in a range are not counted. 

COUNT(P3:P8) = 4 

DATE(Year, Month, Day) Returns the serial value for a 
particular date. 

DATE(2007,4,21) = April 21, 2007 
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DATEDIFF(interval, date1,  

date2[, firstdayofweek[, 
firstweekofyear]]) 

Returns a number representing 
the number of intervals between 
two dates.  Interval is a string 
representing the desired interval.  

Days = d, Weeks = w 

Months = m, Years = yyyy 

DateDiff("d",perbegin(),perend())  = 
30 

DATEVALUE(datestring) Returns the date value of a string.   DATEVALUE("April 21, 2007") = 
39193 

DAY(date) Returns the day number of the 
month (integer 1 to 31) 

DAY(PEREND()) = 31 

 

DAYS([fromperiod [,thruperiod 
[,excludesaturdays [, 
excludesundays]]]]) 

Calculates the number of days in 
an individual or a range of 
periods. This form of the function 
is intended for backward 
compatibility with previous 
versions of Sage Budgeting and 
Planning. See the new DAYS() 
function option following. 

fromperiod (optional): From period 
for the period range. If field is 
omitted, the period number of the 
current column is used. 

thruperiod (optional): Thru period 
for the period range. If field is 
omitted, the Thru period will be 
the same as the From period. 

excludesaturdays (optional): 
Indicates whether to exclude 
counting Saturdays. If this option 
is zero, Saturdays will be 
included. If this option is one, 
Saturdays will be excluded. If the 
option is omitted, Saturdays will 
be included. 

excludesundays (optional): 
Indicates whether to exclude 
counting Sundays. If this option is 
zero, Sundays will be included. If 
this option is one, Sundays will be 
excluded. If the option is omitted, 
Sundays will be included 

Note: Specify the period number 
itself, rather than using a cell 
reference. 

Note: If you specify one 
parameter, you will need to 
specify all parameters to the left. 
See Using Commas in a List of 

Arguments earlier in this chapter. 

DAYS(7) = 31 
DAYS(7,9) = 92 
DAYS(7,9,1,1) = 65 
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DAYS(fromyearoffset, 
fromperiodtype, fromperiod, 
thruyearoffset, thruperiodtype, 
thruperiod [, excludesaturdays [, 
excludesundays]]) 

Calculates the number of days in a 
range of periods. This form of the 
function offers more flexibility in 
specifying the From and Thru 
periods. Years other than the 
From and Thru date years can be 
specified, and periods can be 
specified using absolute or 
relative periods. 

Fromyearoffset An offset from the 
column begin year. 

Fromperiodtype Indicates whether the 
fromperiod parameter contains an 
absolute or a relative period number. 
If zero, fromperiod is interpreted as an 
absolute period number in the column 
begin year. If non-zero, fromperiod is 
interpreted as an offset from the 
column begin period. 

fromperiod If fromperiodtype is zero, this 
is an absolute period number in the 
column begin year. If fromperiodtype is 
non-zero, this is an offset from the 
column begin period. 

thruyearoffset An offset from the 
column end year. 

thruperiodtype Indicates whether the 
thruperiod parameter contains an 
absolute or a relative period number. 
If zero, thruperiod is interpreted as an 
absolute period number in the column 
end year. If non-zero, thruperiod is 
interpreted as an offset from the 
column end period. 

thruperiod If thruperiodtype is zero, this 
is an absolute period number in the 
column end year. If thruperiodtype is 
non-zero, this is an offset from the 
column end period. 

Excludesaturdays Indicates if Saturdays 
should be excluded from the 
Calculation. If this option is zero or 
omitted, Saturdays will be included. 

Excludesundays Indicates if Sundays 
should be excluded from the 
Calculation. If this option is zero or 
omitted, Sundays will be included.  

DAYS(0,1,-1,0,1,-1) = 31 

In column Q it returns 31 because 
January is one period offset from 
February. 
 
DAYS(0,0,1,0,0,4) = 120 

In any column returns 120 days, the 
absolute number of days in periods 
1 to 4. 
 
DAYS(0,0,1,0,0,4,1,1) = 86 

In any column returns 86 days, the 
absolute number of days in periods 
1 to 4 excluding Saturdays and 
Sundays. 
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DB(cost, salvage, life, period [,  

month]) 

Depreciation (fixed-declining 
balance method  

cost: Initial Cost of Asset 

salvage: Value of Asset at end of 
useful life 

life: Length of useful life of the 
asset 

period: Period for which the asset 
depreciation is calculated 

month:  Optional. Number of 
months in the first year. If month 
is omitted, it is assumed to be 12 

Note: Period should correspond 
to the life. Thus, if you use 60 
months for life, then period 2 
would be the second month. 

DB(Q6,P10,P9,2,7) = 18,750 

DDB(cost, salvage, life, period) Double Declining Balance 
Depreciation (See above fixed-
declining balance for expressions) 

DDB(Q6,P10,P9,2) = 10,800 

DIMENSION (code[,format[,  

masked]])  

 

Returns the specified dimension 
code displayed optionally with 
the format mask.  

Dimension("Accounts") = 

"610010020000" 

DIMENSIONSEG (code,segno)  

 

Returns the specified dimension 
code segment displayed 
optionally with the format mask.  

Dimensionseg("Accounts",1) =  

"6100" 

EVEN(value) Rounds the specified value up to 
the nearest even integer 

Even(P9) = 6 

EXACT(text1, text2)  EXACT(text1, text2) - Returns 1 
(True) if two strings are the same; 
otherwise, 0 (False) 

EXACT(O4,O5) = 0 

EXP(power) Returns e raised the given power. 
The constant e equals 
2.71828182845904, the base of the 
natural logarithm.  

EXP(2) = 7.38905610 

FACCT() Returns a String data type of the 
Formatted Account Number for 
the row with formatting 
characters.  If no Account Number 
exists on the row, it will return an 
empty string. 

FACCT() = "6100-100-200-00" 
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FAMASK(mask) Returns a String data type of the 
Account number with formatting 
characters after it has been passed 
through the indicated format 
mask.  You should not place any 
formatting characters in the mask 
of this function.  If no Account 
Number exists on the row, it will 
return an empty string. 

FAMASK("4200???99900") =  

"4200-100-999-00" 

FALSE( ) Returns the value 0 (False). The 
function does not accept 
arguments. 

FALSE( ) = 0 

FIND(Find_text, Within_text  

[, Start_num]) 

Finds one text value within 
another. Returns the text values 
position in the text you searched.  

Find_text: Text you are trying to 
find. 

Within_text: Text through which 
you are searching. 

Start_num: (Optional) The 
character at which to start the 
search. If you omit Start_num, it is 
assumed to be 1. 

FIND(O6,O4) = 2 

FLOOR(number, factor) Rounds number down to the 
number that is a multiple of 
factor. This is similar to ceiling, 
but rounded down instead of up. 

FLOOR(R5,1000) = 20,000 

FV(rate, nper, pmt  

[, pv [, due]]) 

Future Value of an annuity 

rate: Interest rate per period 

nper: Total number of payment 
periods 

pmt: Payment to be made each 
period - payment should be 
displayed as a negative for a 
decrease in cash flow or use 
NEG() function 

pv (optional) Present Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

FV(P11/NUMPER(1), 

P13*NUMPER(1), NEG(P14)) = 

204845 

HOUR(time) Returns the hour that corresponds 
to the provided time. Specify the 
time argument as a serial value or 
time value. 

HOUR(TIME(16,48,10)) = 16 
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IF(expression, truevalue,  

falsevalue) 

If the expression evaluates to true, 
the truevalue is returned else the 
falsevalue is returned 

IF(Q8<0,Q7,Q8) = 20,000 

INT(number) Integer value of number INT(3.4567) = 3 

IPMT(rate, per, nper, pv 

 [, fv [, due]]) 

Interest Payment of an annuity 
result displayed as a negative cash 
flow 

rate : Interest Rate per Period 

per : Payment Period 

nper : Total Number of Payments 
in the annuity 

pv : Present Value 

fv (optional): Future Value. If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

IPMT(P12,2,P13,Q7) = -920 

IRR(values [, guess]) Returns the internal rate of return 
for a series of periodic cash flows. 

Values : A range of values 
containing the cash flows. The 
flows should contain at least one 
negative value (payment) and one 
positive value (receipt). 

Guess (optional): A value that you 
guess will be returned by this 
function. If guess is omitted 0.1 
will be assumed. 

Note: This function works by 
repeated iterations to find the 
appropriate percentage rate. It 
will start with guess and iterate 
up to 20 times to find a percentage 
within 0.00001 percent accuracy. 

IRR(P8:W8) = 1.0374 

ISBLANK(cell) Returns 1 if cell is blank, 0 if cell is 
not blank. 

ISBLANK(P7) = 1 

ISEMPTY(cell) Returns 1 if cell is empty, 0 if cell is 
not empty. 

ISEMPTY(P7) = 1 

ISEVEN(cell) Returns 1 if cell is even, 0 if cell is 
not even. 

ISEVEN(P13) = 1 

ISNONTEXT(cell) Returns 1 if cell is nontext, 0 if cell 
is text. 

ISNONTEXT(P13) = 1 
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ISNUMBER (cell) Returns 1 if cell is a number, 0 if 
cell is not a number. 

ISNUMBER(P13) = 1 

ISODD(cell) Returns 1 if cell is odd, 0 if cell is 
even. 

ISODD(P9) = 1 

ISREF(cell) Returns 1 if cell is a cell reference, 
0 if cell is not a cell reference. 

ISREF(P9) = 1 

ISREF(555) = 0 

ISTEXT(cell) Returns 1 if cell is text, 0 if cell is 
nontext. 

ISTEXT(P9) = 0 

LEFT(MyText, Num_chars) Returns the first (or leftmost) 
characters from a text value. 

LEFT(O4, 2) = "AB" 

LEN(value) Returns the number of characters 
in a text string. 

LEN(O4) = 3 

LN(value) Returns the natural log of the 
value provided. Natural 
logarithms are based on the 
constant e. 

LN(7.38905610) = 2 

LOWER(value) Converts text to lowercase letters. LOWER(O4) = "abc" 

MAX(value1[, value2[, &]]) Returns the maximum value from 
the listed values. Value can be a 
range of cells. 

MAX(Q6,Q7) = 45,000 

MID(Text, Start_num,  

Num_chars) 

Returns the requested number of 
characters from a text string 
starting at the position you 
specify. 

MID(O4,2,1) = "B" 

MIN(value1[, value2[, .]]) Returns the minimum value from 
the listed values. Value can be a 
range of cells. 

MIN(Q6,Q7)= 20,000 

MINUTE(time) Returns the minute corresponding 
to the provided time value. 

Specify the time argument as a 
serial value or time value. 

MINUTE(TIME(16,48,10)) = 48 

MIRR(values, financerate, 
reinvestrate) 

Returns the modified internal rate 
of return for a series of periodic 
cash flows. 

values : A range of values 
containing the cash flows. The 
flows should contain at least one 
negative value (payment) and one 
positive value (receipt). 

financerate : Interest rate paid as 
the cost of financing. 

Reinvestrate : Interest rate received 
on gains from cash investment.  

Note: This function will only work 
in a Numeric Custom Column. 

MIRR(P8:W8,P12,P11) = 0.19572 
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MOD(numerator, denominator) The remainder when the 
numerator is divided by the 
denominator. 

Note: If x or y are decimals, the 
remainder will return as a decimal, 
not as an integer. 

MOD(R3,R5) = 14,400 

MONTH(date)  Returns the month corresponding 
to the specified date value.  

MONTH(DATEVALUE("April 21, 
2007")) = 4 

NEG(value) Changes the sign of value. NEG(P8) = 10,000 

NOT(value) If value is 0 then 1 is returned 
otherwise 0 is returned. 

NOT(P10) = 1 

NOW( ) Returns the serial value of the 
current date and time. 

NOW() = 38861 

The date value for todays date 

NPER(rate, pmt, pv 

[, fv [, due]]) 

Number of periods for an annuity. 

rate : Interest rate per period 

pmt : Payment to be made each 
period 

pv : Present Value 

fv (optional) Future Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

NPER(P12/NUMPER(1),NEG(P14),Q7) 
= 20.93 

NPV(rate, value1  

[, value2, [.]]) 

Returns the net present value of 
an investment based on a series of 
periodic cash flows. 

rate : Discount rate over the length 
of the period expressed as a 
decimal. 

values : A list of cash flows. Values 
can be numbers, cell references, or 
a range of values. Values must 
consist of at least one negative 
number (payment) and one 
positive number (receipt). 

NPV(P11/NUMPER(1),P8:W8) = 
73,962 



Sage Budgeting and Planning User Guide 

414 

NUMPER([yeartype]) Returns the number of periods in 
the year specified by yeartype. 

yeartype (optional) A numeric 
parameter indicating the year for 
which the count of periods should 
be returned. If this option is left 
blank, it is assumed to be 4. 

1 - Return the number of periods 
in the current fiscal year. 

2 - Return the number of periods 
in the sheet base date year. 

3 - Return the number of periods 
in the group date year. If the 
column is not a member of a 
group, the number of periods in 
the sheet base date year is 
returned. 

4 - Return the number of periods 
in the column from date year. 

5 - Return the number of periods 
in the column Thru date year. 

6 - Return the number of periods 
between the column From and 
Thru dates. 

NUMPER(1) = 12 
NUMPER(6) = 1 

ODD(value) Rounds the specified value up to 
the nearest odd integer. 

ODD(P11) = 1 

OR(bool1, bool2, &) OR boolean function. Returns 1 
(True) if any argument is True; 
returns 0 (False) if all arguments 
are False. 

OR(ISBLANK(P5),ISBLANK(P6)) = 1 

PERBEGIN( ) Returns a date data type for the 
Begin Date of the Column.  If the 
column has no Begin Date, it will 
return an error. 

PERBEGIN( ) = 39,083 

Date value corresponding to  

January 1, 2007 

PEREND( ) Returns a date data type for the 
End Date of the Column.  If the 
column has no End Date, it will 
return an error. 

PERBEGIN( ) = 39,113 

Date value corresponding to  

January 31, 2007 
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PERNUM([datetype], 

[coldatetype]) 

 

 

 

This function has multiple uses.  
Usage 1:  Returns the period 
number of the date specified by 
datetype. 

datetype (optional): A numeric 
parameter indicating the date for 
which a period number should be 
returned. If this option is left 
blank, it is assumed to be 4. 

1 - Returns the current fiscal 
period from the GL. 

2 - Returns the period number 
of the sheet base date. 

3 - Returns the period number 
of the group date. If the 
column is not part of a group, 
then the period number of the 
sheet base date is returned. 

4 - Returns the period number 
of the current columns From 
Date or Thru Date. 

coldatetype (optional): Only valid 
when datetype is 4.  A numeric 
parameter indicating which 
column date to return. If this 
option is left blank, it is assumed 
to be 1. 

1 - Returns the period number 
of the column From Date. 

2 - Returns the period number 
of the column Thru Date. 

PERNUM() = 1 

PERNUM(2) = 1 

PERNUM(1) = 5 

 

 

PERNUM([cellreference], 

[coldatetype]) 

 

Usage 2:  Returns the period 
number of the column date 
specified by the cellreference. 
 Cellreference must reference a 
user-defined column 

coldatetype (optional): A numeric 
parameter indicating which 
column date to return. If this 
option is left blank, it is assumed 
to be 1. 

1 - Returns the period number 
of the column From Date. 

2 - Return the period number 
of the column Thru Date. 

PERNUM(R3) = 3 

PERNUM(S3,2) = 4 
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PERNUM([datevalue]) Usage 3:  Returns the period 
number of the date specified by 
datevalue , or zero if the date value 
is invalid. 

datevalue: A date value or a  
reference to a cell with a date 
value. 

PERNUM(DATEVALUE("April 21, 
2007")) = 4  

PMT(rate, nper, pv  

[, fv [, due]]) 

Returns the payment of an 
annuity. Payment will be 
expressed as a negative number 
representing a decrease in cash 
flow. 

rate : Interest rate per period 

nper : Total Number of Payment 
Periods 

pv : Present Value 

fv (optional) Future Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

PMT(P12/NUMPER(1), 

P13*NUMPER(1),Q7) = -212.13 

PPMT(rate, per, nper [, pv [, fv, 
due]]) 

Returns the principal payment of 
an annuity. Payment will be 
expressed as a negative number 
representing a decrease in cash 
flow. 

rate : Interest rate per period 

per : Payment Period 

nper : Total Number of Payment 
Periods 

pv : Present Value 

fv (optional) Future Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

PPMT(P12/NUMPER(1),1, 

P13*NUMPER(1),Q7) = -128.80 

PLANKEY() Returns the Key for the current 
plan. 

PLANKEY() = "PlanKey" 

PROPER(text) Capitalizes the first letter in each 
word of a text string. 

PROPER(O3) = "Abc" 
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PV(rate, nper, pmt [, fv [, due]]) Present Value of an annuity 

rate : Interest rate per period 

nper : Total number of payment 
periods 

pmt : Payment to be made each 
period 

fv (optional) Future Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

PV(P12/NUMPER(1), 

P13*NUMPER(1),NEG(P14)) =  

94,281.35 

RATE(nper, pmt, pv [, fv [, due 
[, guess]]]) 

Returns the interest rate per 
period of an annuity 

nper : Total Number of Payment 
Periods 

pmt : Payment to be made each 
period - this should be expressed 
as a negative for cash flow or use 
NEG () function. 

pv : Present Value 

fv (optional) Future Value: If this 
option is left blank, 0 will be 
assumed. 

due (optional): 0 if payments are 
due at end of payment periods, 1 
if payments are due at the 
beginning of the payment periods. 
If this option is left blank, 0 will be 
assumed. 

guess (optional): Value you guess 
will be returned. If guess is not 
provided, a value of 0.1 will be 
used. 

Note: This function works by 
repeated iterations to find the 
appropriate percentage rate. It 
will start with guess and iterate 
up to 20 times to find a percentage 
within 0.00001 percent accuracy. 

RATE(P13*NUMPER(1), 

NEG(P14),U6) = 0.0031 

REPLACE(Old_text, Start_char, 
Num_chars, New_text) 

Replaces part of a text string with 
a different text string. 

 REPLACE(O4, 2, 1, "DE") = "ADEC"  

REPT(Text, Number) Repeats text a specified number of 
times. 

REPT("AB", 2) = "ABAB" 
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REVISIONKEY() Returns the Current Revision Key 
as a string. 

REVISIONKEY()="Current" 

RIGHT(Text, Num_chars) Returns the rightmost characters 
from a text value. 

 RIGHT(O4, 2) = "BC" 

ROUND(number, places) Rounds number to decimal places. ROUND(P12/12,3) = 0.004 

ROUNDDOWN(number, places) Rounds number down to decimal 
places. 

ROUNDDOWN(1.777,2) = 1.770 

ROUNDNEAREST(number, 
factor) 

Rounds number to the nearest 
multiple of factor. 

ROUNDNEAREST(P3,1000) = 23,000 

ROUNDUP(number, places) Rounds number up to places 
decimal places. 

ROUNDUP(P12/12,3)= 0.005 

ROW([cell]) Returns the row number of the 
current row. 

cell (optional): Cell reference to 
return column number for. 

ROW(P4) = 4 

ROWS([cellrange]) Returns the number of rows 
included in a cell range. If the 
cellrange is omitted, the current 
row will be assumed and 1 will be 
returned. 

ROWS(P4:P10) = 7 

SALARYRATE(baserate, 
ratedate, hiredate, 
evaluationdate, increasepercent) 

Returns the salary on the 
evaluation date based upon an 
annual increase of the increase 
percent due on the hire date each 
year. Base rate is the current salary 
and rate date is a date when the 
base rate was in effect.  

SALARYRATE(45000, 

DateValue("1/1/2007"), 

DateValue("6/15/2001"), 

DateValue("5/31/2007"), 

0.045)/12 = 3,750 
  

SALARYRATE(45000, 

DateValue("1/1/2007"), 

DateValue("6/15/2001"), 

DateValue("6/30/2007"), 

0.045)/12 = 3,919 

SECOND(time) Returns the seconds 
corresponding to the provided 
time value. Specify the time 
argument as a serial value or time 
value. 

SECOND(TIME(16,48,10)) = 10 

SHEETKEY() Returns the Current Sheet Key as 
a string. 

SHEETKEY()="Summary" 

SIGN(value) Returns the sign of the value 
supplied. For positive numbers, 1 
is returned. Negative numbers 
return -1 and zero will return 0. 

SIGN(U8) = -1 
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SLN(cost, salvage, life) Computes the straight-line 
depreciation 

cost : Initial Cost of the asset 

salvage : Value of asset at the end 
of its useful life. 

life : Length of useful life of the 
asset 

SLN(Q6,P10,P9) = 9,000 

SUBSTITUTE(Text , Old_text, 
New_text[, Instance]) 

 

Substitutes a new string for 
specified characters in an existing 
string. 

Text: The string or a reference to a 
cell containing the string in which 
you want to replace characters. 

Old_text: String to be replaced. 

New_text: New string to use 
instead of existing string. 

Instance: (Optional) Specifies 
which occurrence of the existing 
string to replace. 

SUBSTITUTE(O4,"AB","C") = "CC" 

 

SUM(value1[, value2 [, .]]) Sums cells or blocks of cells. SUM(P8:W8) = 77,000 

SYD(cost, salvage, life, period) Computes the sum-of-the-years-
digits depreciation 

cost : Initial Cost of the asset 

salvage : Value of asset at the end 
of its useful life. 

life : Length of useful life of the 
asset 

period : Period for which the 
depreciation is calculated. 

SYD(Q6,P10,P9,2) = 12,000 

TEXT(value, format_text) Converts a value to text in a 
specific format. 

TEXT(P5,"0,000.00") = "13,000.00" 

TIME(hour, minute, second) Returns the serial value for a 
specified time. 

TIME(16,48,10) = 0.70011574 

TODAY() Returns the serial value of the 
current date. 

TODAY() = 38,861 

TRIM(text) Removes extra spaces from a 
string and leaves single spaces 
between words. 

TRIM("  ABC  DEF   ") = "ABC DEF" 

TRUE( ) Returns the value 1 (True). The 
function does not accept 
arguments. 

TRUE( ) = 1 
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TRUNC(number, places) 

OR 

TRUNCATE(number, places) 

Truncates a number to the 
indicated number of places. 

TRUNC(P12/12,5) = 0.00416 

UPPER(text) Converts text to uppercase. UPPER(O3) = "ABC" 

URL(text 1[,text 2]) Creates a hypertext link in an 
exported HTML file. Use text1 to 
specify a URL address in a 
hypertext link in the exported 
HTML table. Use the optional 
text2 argument if you want to 
display the link as a descriptive 
name. 

URL("http://www.microsoft.com", 

"Microsoft") 

The browser will display the link as: 
Microsoft 

VALUE(numberstring ) Returns a numeric data type 
containing a numeric value of a 
string.  If it is unable to convert 
the string to a valid number, the 
function will return zero. 

VALUE("1234.0") = 1,234 

WEEKDAY(date[, type]) Returns the day of the week for a 
specified date. Specify the date as 
a serial value. 

date: The date as a serial value. 

type: (Optional) Number that 
represents the numbering scheme 
for the returned day value 
(defaults to 1 if omitted).  

If type=1, then numbers 1 
(Sunday) through 7 (Saturday) are 
returned.  

If type=2, then numbers 1 
(Monday) through 7 (Sunday) are 
returned.  

If type=3, then numbers 0 
(Monday) through 6 (Sunday) are 
returned. 

WEEKDAY(DateValue("1/1/2007")) = 
2   

(equivalent to Monday) 

YEAR(date) Returns the year corresponding 
to the specified date value. 
Specify the date argument as a 
serial value. 

Note: This function will only 
work in a Numeric Custom 
Column. 

YEAR(DateValue("1/1/2007")) = 2007 
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Appendix D 

Basic SQL Components 

Basic Query 

The simplest possible SQL query is: 

SELECT fieldname FROM tablename 

This query returns the selected field from the desired database table. Most Sage Budgeting and Planning 
SQL queries will use aggregate functions and filters (discussed below) to retrieve the appropriate final 
result. 

Table Aliases 

Table names can be assigned aliases. You would typically use table aliases where you need to select fields 
from the same table twice. An example would be: 

SELECT A.fieldname FROM tablename A, tablename B 

The alias will distinguish between the above two tables. You can also use the AS word to connect the table 
to the alias. Later, you will join common fields from the two tables to obtain the desired result set (discussed 
below). 

Note: The examples show generic SQL query syntax.  Refer to the documentation for your data source 
provider as the specific syntax will vary from provider to provider. 
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Filtering the Query Results 

Where Clause 

You use the WHERE clause to restrict selection of rows to those matching your criteria. The WHERE clause 
evaluates each row in the set of input records and decides whether or not the expression contained in the 
WHERE clause evaluates to TRUE. If it does, the record is selected. If not, the record is omitted from the 
result set. 

While it is beyond the scope of this section to give a complete tutorial on SQL, the following representative 
examples point some of the unique features of the Jet version of SQL. 

Selecting Matching Values 

SELECT SUM(Amounts) FROM Products 

WHERE Products.CategoryID=2; 

For each row in Products where the CategoryID column is equal to the literal value 2, the row is selected. If 
you were comparing the column to a string value, you would need to enclose the value in single quotes (e.g. 
CategoryID = ’Active’) 

Selecting Using Partial String Matching 

SELECT SUM(Amounts) FROM Products 

WHERE Products.ProductName LIKE 'CH*'; 

Microsoft Jet uses different partial match characters with the LIKE operator than most SQL dialects. The 
asterisk (*) character matches zero or more characters and is equivalent to the percent (%) character in ANSI 
SQL. The other Microsoft Jet partial match characters are the question mark (?), which matches any 
character in a single column, and the number sign (#) which matches any digit in a single column. 

Selecting Boolean Values 

SELECT SUM(Amounts) FROM Products 

WHERE Products.Discontinued=TRUE; 

The constant value TRUE is equal to -1; FALSE is equal to 0. You can substitute YES for TRUE and NO for 
FALSE in the text of your SQL statement. 

Selecting Using BETWEEN…AND Operator 

SELECT SUM(Amounts) FROM Products 

WHERE Products.Titles BETWEEN 'ABC' AND 'DEF'; 

The BETWEEN operator determines that the value of the expression lies between the two values specified. 

Selecting Using the IN Clause and a Value List 

SELECT COUNT(OrderNo) FROM Orders 

WHERE Orders.ShipCity IN ('London','Madrid','Rome'); 

This SQL command selects a single value in the underlying table against a list of literal values. The IN clause 
can be combined with NOT: 

… WHERE Orders.ShipCity NOT IN ('New York'); 

Combining More Than One Expression 

SELECT COUNT(OrderNo) FROM Orders 

WHERE Orders.ShipCity='Detroit' AND Orders.ShipVia='U'; 
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A WHERE clause can consist of more than one procedure that combines various AND OR clauses. The truth 
of the entire WHERE clause is evaluated using standard rules of Boolean logic. You can use parentheses 
with the procedure to ensure the order of evaluation. 

Selecting Using Nested Subqueries 

SELECT SUM(Orders.Amounts) FROM Orders 

WHERE Orders.CustomerID IN (SELECT CustomerID FROM Customers 

WHERE City='London'); 

This example matches each CustomerID value in Orders against a list that is created by selecting the 
CustomerIDs of all Customers whose City is London. Although this is a standard SQL query, it could also 
be executed more efficiently by directly joining the Orders table to the Customers table. 

Selecting Using Correlated Subqueries 

SELECT SUM(Orders.Amounts)  

FROM Orders AS A 

WHERE A.Amounts>= 

(SELECT AVG(Orders.Amounts) 

FROM Orders 

WHERE Orders.State='CA'); 

A correlated subquery is evaluated once for each row processed by the outer query. In this example, the 
Order Amounts of each input row in the Orders table (given alias of A) is compared to the results of an 
inner query. The inner query uses the value in the outer State field as a selection criterion. Because the State 
field in the outer Orders table can change for each row processes, the inner subquery must be re-executed 
for each row of the outer table that is processed. 
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Aggregate Functions 

Aggregate functions are used in a SELECT clause on groups of records to return a single value that applies 
to a group of records. For example, the AVG aggregate function can return the average of all the values in a 
specific field of a record set. The following table lists the aggregate functions. 

Aggregate Function Description 

AVG Obtain the average values in a specific field 

COUNT Return the number of records in the selection 

SUM Return the sum of all the values in a specific field 

MAX Return the highest value in a specified field 

MIN Return the smallest value in a specified field 
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Joining Tables 

The real power of a relational database is evident when you combine results from one table with those from 
another. SQL syntax is flexible in the type and format of the statements used to create the relational join. In 
addition to joins in which the linking criteria is specified in the WHERE clause, SQL syntax can use the JOIN 
clause to specify inner, left, and right outer joins, as well as non-equi joins, in which the linking criterion is 
not a match in values between two tables, but a generic conditional expression that evaluates to TRUE. 

Joins Specified in the WHERE Clause 

With SQL syntax, you can create relational joins by specifying the linking condition in the WHERE clause: 

SELECT COUNT(Products.ProductID)  

FROM Products, Categories 

WHERE Products.CategoryID = Categories.CategoryID; 

This query selects the count of all products where the Category ID matches the Category ID in the 
Categories table. 

INNER JOIN 

SELECT COUNT(Product.ProductID) 

FROM Products  

INNER JOIN Categories ON Categories.CategoryID = 

Products.CategoryID; 

Essentially this the same query as the one above but documents the implicit inner join from the WHERE 
clause. Multiple, complex INNER JOINS can be established. 

LEFT and RIGHT OUTER JOINS 

The INNER JOIN clause only retrieves rows in which there is a match in both tables. In some cases, you 
might want to retrieve the values from one table even when there are no matching values in the other joined 
table. For example, you might have to accept a batch of Orders records in which the ProductID is unknown 
for one reason or another. You want to create a join from Orders to Products, but you don’t want to exclude 
Orders from the result set simply because there is no corresponding Product record. 

When you specify a left or right outer join, SQL retrieves all rows from one table even though there are no 
matches in the other table. 

SELECT SUM(Amounts) FROM Orders 

RIGHT OUTER JOIN Products ON Orders.ProductID = 

Products.ProductID; 

Note the word OUTER is optional in SQL syntax, as a left or right join implies an outer join. In this example, 
all rows from Orders are retrieved even if the ProductID column in Orders does not find any matches in the 
Products table. 

Whether the join is considered to be a left or a right join is determined from the point of view of the tables 
listed in the join clause. There is no effect on efficiency, or in the actual rows returned. 

Self Joins 

It’s possible to create a join between a table and a second instance of the same table. A common example is 
in an Employees table, where the ReportsTo field contains the EmployeeID values found in the Employees 
table itself. 

The following example joins the Employees table to itself. The ReportsTo field in the first instance of the 
Employees table is linked to the EmployeeID field in the second instance. The second instance of the 
Employees table is given the alias “Supervisor”: 
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SELECT COUNT(Employees.EmployeeID) 

FROM Employees 

INNER JOIN Employees AS Supervisors ON 

Employees.ReportsTo=Supervisors.EmployeeID; 
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Other Key SQL Functions 
Keyword Meaning/Usage Example 

DATEADD (interval, number, 
date) 

Adds or subtracts a specified time 
interval from a date. Valid intervals are: 

yyyy - Year 
q - Quarter 
m-Month 
y-Day of year 
d-Day 
w-Weekday 
ww-Week 
h-Hour 
n-Minute 
s-Second 

DATEADD(“m”,1,01/31/96) 
returns 02/29/96 because it 
adds one month to the date.  

DATESERIAL(year,month,day) Returns a Date for a specified year, 
month, and day. For the year argument, 
values between 0 and 99, inclusive, are 
interpreted as the years 1900-1999. For 
all other year arguments, use a complete 
four-digit year (for example, 1800). You 
can also specify relative dates for each 
argument using any numeric expression 
that represents some number of days, 
months, or years before or after a certain 
date. 

DATESERIAL(96,01,31) 
returns a date of 
01/31/1996. 
 
The following example uses 
numeric expressions instead 
of absolute date numbers. 
Here the DateSerial function 
returns a date that is the day 
before the first day (1 - 1) of 
two months before August 
(8 - 2) of 10 years before 1990 
(1990 - 10); in other words, 
May 31, 1980. 

DATESERIAL(1990 - 10, 8 - 
2, 1 – 1) 

DISTINCT Omits records that contain duplicate 
data in the selected fields.  

SELECT DISTINCT 
LastName FROM 
Employees; 

DISTINCTROW Omits data based on entire duplicate 
records, not just duplicate fields. 

SELECT DISTINCTROW 
CompanyName FROM 
Customers INNER JOIN 
Orders ON 
Customers.CustomerID = 
Orders.CustomerID 

FIRST,LAST Returns a field value from the first or 
last record in the result set returned by a 
query. 

SELECT FIRST(BirthDate) 
FROM Employees 

GROUP BY Combines records with identical values 
in the specified field list into a single 
record. A summary value is created for 
each record if you include a SQL 
aggregate function, such as SUM or 
COUNT in the SELECT statement. 
GROUP BY is seldom used with Sage 
Budgeting and Planning since the first 
value is returned in the query. 

SELECT field FROM table 
WHERE criteria 
GROUP BY groupfieldlist 
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HAVING Specifies which grouped are records are 
displayed in a SELECT statement with a 
GROUP BY clause. After GROUP BY 
combines records, HAVING displays 
any records grouped by the GROUP BY 
clause that satisfies the conditions of the 
HAVING clause. 

SELECT field FROM table 
WHERE criteria 
GROUP BY groupfieldlist 
HAVING groupcriteria 

MID(field,position, length) Returns a portion of a field string - 
similar to SUBSTRING 

MID(‘mmdd’,1,2) returns 
‘mm’ 

ORDER BY Displays the data in a specific sort order. 
ASC sorts data in ascending order. 
DESC sorts the data in descending 
order. Since Sage Budgeting and 
Planning returns the first value, ORDER 
BY is seldom used. 

SELECT LastName, 
FirstName FROM 
Employees 
ORDER BY LastName ASC 

TOP Returns a certain number of records that 
fall at the top or the bottom of the range 
specified by an ORDER BY clause. 

SELECT TOP 25 LastName 
FROM Students WHERE 
GraduationYear = 1994 
ORDER BY 
GradePointAverage DESC 

TOP n PERCENT Returns a certain percentage of 
records that fall at the top or bottom 
of a range specified by an ORDER BY 
clause. 

SELECT TOP 10 PERCENT 
LastName FROM Students 
WHERE 
GraduationYear=1994 
ORDER BY 
GradePointAverage ASC; 

 

Note: The examples show generic SQL query syntax.  Refer to the documentation for your data source 
provider as the specific syntax will vary from provider to provider. 
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Appendix E 

Manipulating Fiscal Periods in SQL Queries 

The following are several examples of how to manipulate periods in Sage Budgeting and Planning SQL 
Queries. You can use these queries as part of the WHERE clause in SQL statements to manipulate the 
accounting periods. 

Systems with SQL Date Formats 

You can use the DATEADD SQL function. The syntax for this function is 
DATEADD("interval",number,beginningdate). Optional intervals are as follows: 

•       yyyy - year 

•       q - quarter 

•       m - month 

•       d - day 

•       w - weekday 

 
Example: 

To go back exactly one year: 
DATEADD("yyyy",-1,&PEREND&) 

To go back exactly two months: 
DATEADD("m", -2,&PEREND&) 

To go back one year and two months: 
DATEADD("m",-2,DATEADD("yyyy",-1,&PEREND&)) 

 

Note: This query works with calendar month ends only. If you have varying fiscal periods, it will not work 
properly. 

Note: The examples show generic SQL query syntax.  Refer to the documentation for your data source 
provider as the specific syntax will vary from provider to provider. 
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Systems with Julian Date Formats 

You can use regular math functions for simple queries. 

 
Example: 

To go back one year: 
(&PEREND(Julian)&-365) 

 

Note: This query would work well for calendar months but would need to be adjusted for leap years. It would 
not support varying fiscal periods. 
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Using the mbvwPeriods View 

You can also use the Sage Budgeting and Planning mbvwPeriods View. The columns in this view are: 

•       YearNumber 

•       PeriodNumber 

•       YearStartDate 

•       YearEndDate 

•       PeriodStartDate 

•       PeriodEndDate 

The column YearNumber corresponds to the current fiscal year, based on the current processing period. You 
do not actually type in the year number but a value to indicate the relative positioning of the year. For 
example, YearNumber 0 is the current active year. YearNumber -1 is last year and so forth. 

For example, the following query computes units shipped for each column: 

 
Example: 

SELECT SUM( qty_shipped* unit_price) 

FROM artrxcdt, artrx, mbvwPeriods 

WHERE artrx.trx_ctrl_num = artrxcdt.trx_ctrl_num 

AND artrxcdt.date_applied BETWEEN PeriodStartDate 

AND PeriodEndDate 

 

Note: The YearNumber is 0 is based on the current active year. Even if you were budgeting a future year, 
you would still leave the YearNumber as 0. 

Wrapping Fiscal Years 

The above examples will not wrap fiscal years. To wrap fiscal years, use the following example: 

 
Example: 

Wrap fiscal years: 
SELECT PeriodStartDate 

FROM mbvwPeriods 

WHERE YearNumber= 

    CASE(&PERNO&-1) 

       WHEN 0 THEN -1 

       ELSE 0 

    END 

AND PeriodNumber= 

    CASE(&PERNO&-1) 

       WHEN 0 THEN 12 

       ELSE (&PERNO&-1) 

    END 

If the fiscal year has more than 12 fiscal periods, then substitute the number of fiscal periods for the 12 in the 
above example. 

 

Note: The above example will only process on Microsoft SQL Server. 
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Glossary of Terms 

Account Format The pattern of positions and separators for account numbers, 
for example, 0000-000-000-00.  

Account Segment A portion of the account typically representing a reporting 
designation such as a department or location. 

Accounts A from and thru value that determines a group of account 
balances. Account ranges are based on values of each 
segment in the range, not the account number as a whole.  

Administrator A user that controls all facets of Sage Budgeting and 
Planning.  

Balance Code The specific code to be used if a balance type is specified as 
budget or statistical. When used in a formula, it can also refer 
to the plan sheet group. 

Balance Type Indicates the kind of account balance to use. Balance types are 
actual, budget, or statistical. When used in a formula, it can 
also refer to the plan sheet group. 

Balance Valuation The portion of the account balance that is to be calculated 
such as net change, beginning, ending, or average daily. 

Cell Formats Display characteristics assigned to one or more cells in a plan 
sheet. Display characteristics include numeric formatting, 
alignment, font control, borders, and background colors. 

Cell Formula A spreadsheet formula attached to a plan sheet cell to 
compute a desired result.  

Column Key A unique identification assigned to a plan sheet column.   

Controller A user-status assigned to a plan that controls all facets of a 
plan or plan sheet from Plan Manager, except the assignment 
of additional controllers. 

Cube A multidimensional arrangement of data with pre-calculated 
aggregates (or totals). 

Data Source A unique name given to an ODBC configuration for the 
specified database. This name is established by the ODBC 

Configuration Utility. 
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Database A collection of information, data tables, and other objects that 
are organized and presented to serve a specific purpose, such 
as facilitation of searching, sorting, and recombination of 
data. 

Delimited File A file of values that are variable in length separated by a 
known character. 

Dimension The various elements that define how an organization plans 
and operates. 

Exporting A way of exchanging information between working budgets 
and commercial file formats, such as spreadsheets and 
delimited files.  

Field A single item of information contained in a row or a record. 
The logical equivalent of a column. 

Filter A value containing filter characters (?) to indicate the field 

value will be replaced with a new value. The resulting value 
will be substituted from a specific source such as plan sheet 
accounts.  

Flow A row-level assignment to a subsheet through the row ID. 

Formulas Mathematical expressions used to calculate budgets. 
Formulas can use a combination of constants, operands, 
accounts, and database query results.  

Home Currency The main currency used in your accounts.  

Importing A way of exchanging information to a working budget from 
commercial file formats such as spreadsheets and delimited 
files.  

Lookup Window A window that allows you to select valid values for a field. 
Lookup windows in Sage Budgeting and Planning allow you 
to lookup database values or dates. 

Manager A user-status assigned to a plan sheet that controls all facets 
including the assignment of additional user security. 

Measure A quantitative value that is analyzed, for example, sales 
units, costs, etc. 

Member An item in a dimension representing one or more occurrences 
of data. 

Model The function used to generate a series of plan sheets using a 
defined set of assumptions. 

Multidimensional 
Expressions (MDX) 

Syntax used for querying multidimensional data. 

Natural Currency The native currency of the original transaction. Natural 
currencies are translated into home currencies based on 
conversion exchange rates. 

Object Linked and 
Embedded Database 
(OLE-DB) 

A set of interfaces that provides applications with uniform 
access to data stored in diverse information sources. 
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ODBC Driver A dynamic-link library (DLL) that allows an ODBC-enabled 
applications to access to a data source. Each database using 
ODBC for access requires an ODBC driver. 

One-time Calculation A plan calculation that is processed against selected cells and 
not saved for future use. 

Online Analytical 
Processing (OLAP) 

A technology that uses multidimensional structures to 
provide rapid access to data for analysis. 

Open Database 
Connectivity (ODBC) 

A database-neutral connectivity-programming interface for 
applications. ODBC is designed to allow any application 
vendor to write a driver that supports the programming 
interface. 

Parent Row ID A unique identification to a row that is used for consolidation 
or distribution updates from or to parent plan sheets. These 
updates only take effect if the parent plan sheet has granted 
access to the subsheet and the parent row ID matches the row 
ID of the parent plan sheet. 

Plan Admin A user-status assigned to a plan that controls all facets of a 
plan or plan sheet from Plan Manager, including the 
assignment of controllers. 

Plan Calculation A predefined calculation definition applied to one or more 
plan sheet rows. Plan calculations can consist of fixed 
amounts, source calculations or formulas. 

Plan Sheet A spreadsheet grid used to develop a working budget or 
analysis.  

Planner A user-status assigned to a plan sheet that allows full editing 
privileges but not the assignment of additional security. 

Query A request of information from a database. A query contains 
all of the information to determine where the information is 
to come from, the criteria for information to be returned, and 
the fields to be returned. 

Record A group of related fields (columns) of information treated as 
a unit. The logical equivalent of a row. 

Reviewer A user-status assigned to a plan sheet that allows read-only 
access to a plan sheet. 

Row In a table, a set of related fields of information (columns) that 
are treated as a unit and that describe a specific entity. The 
logical equivalent of a record. 

Row ID A unique identification to a row that is used to create 
consolidation or distribution updates to subsheets in a parent 
plan sheet. The row ID must match the parent row ID of the 
subsheet. 

Structured Query 
Language (SQL) 

A widely used database language used for accessing data in, 
querying, updating, and managing relational database 
systems. 



Sage Budgeting and Planning User Guide 

436 

SQL Variables Special Sage Budgeting and Planning codes that are pre-
processed before running a SQL query.  

Status A user-definable code indicating the current status of a 
subsheet. 

Subsheet A term used to define any subsidiary components of a parent 
plan sheet. This includes both plan sheets and Excel 
spreadsheets. 

Table A collection of rows (or records) that have associated 
columns (or fields). It is the logical equivalent of a database 
file. 

Tiered Dimension Individual dimensions that are joined together in a 
hierarchical structure. 

Toolbar A row of icons displayed on many maintenance forms to 
streamline data entry and manipulation. Clicking an icon 
duplicates a specific menu selection. 

User ID A name known to a database and assigned to a login ID for the 
purpose of allowing a user to have access to that database.  
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