HTTP 404 after new Sage CRM Install
Description
User trying to open CRM login screen after a new CRM installation and receive HTTP 404 file or directory not found.
Cause
Please make sure to follow the Sage CRM installation and upgrade guide.
Resolution
This is a brief list of IIS configuration on a windows 2008 R2/2012 server.
Make sure Server has .NET Framework installed, if not, then
- Select Start, Administrative Tools, Server Manager
- From the Features Summary panel, select the Add Features option.
- Select the .NET Framework 3.5.1 Features option.
- Click Install.
Ensure that IIS is installed as a Server Role.
To check IIS is installed as a Server Role:
- Select Start, All Programs, Administrative Tools, Server Manager. Roles.
- Select Add Roles.The Add Roles Wizard is displayed.
- Click Next.
- Select Web Server (IIS).
Then, in the Role Services section of the Add Roles Wizard, make sure that the following role services are selected for your install:
Under Application Development, enable
- ASP .NET
- ASP (set Enable Parent Paths to True)
- ISAPI Extensions
- ISAPI Filters
Security, Windows Authentication (if Auto Logon is required)
Management Tools, IIS Management Console and IIS Management Compatibility
If using the Extensibility Module with IIS 7.0, check that IIS, Web Service Applications, Active Server Pages is not set to Prohibited.
When working with IIS 7.0 or above please check that the Enabled Parent Paths option is enabled.
CRM Installations on a 64-Bit Server:
CRM is a 32 bit application which can run on a 64-bit server. If installing on Windows 2008R2 x64 or on Windows 2012 x64, you need to do the following after the install for all application pools under the DefaultWebSite.
To enable 32 bit ISAPI.dll to run on IIS x64:
- Click the Application Pools node.
- Select the AppPool item you want to change.
- Select Advanced Settings from the Actions panel.
- On the Advanced Settings dialog box, set Enable 32-bit Applications to True.
- Click OK.