Sage 100 Blank, White Screen Appears When Starting

Description

  • Blank, white screen appears when starting Sage 100 Advanced or Premium
  • Blank white Sage 100 ERP screen appears with Help when launching Sage 100 ERP Advanced. Error: “Sage 100 ERP has stopped working” appears at the Server
  • Nothing happens or something flashes when starting Sage 100 Advanced or Premium

Backup Warning

Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions.

Network Warning

This solution requires advanced knowledge of your network. Contact your system administrator for assistance. Modifying Windows security incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows security. Always create a backup of your data before proceeding with advanced solutions.

Cause

Possible causes:

  • Stranded Pvxwin32.exe session on the server
  • Damaged system files
  • Blocked port
  • Insufficient permissions

Resolution

Note:  For Sage 100 ERP Advanced and Premium, must stop the Sage 100 ERP Application Server desktop or Application Server Service and all users must exit the program while performing the following:

  • A Pvxwin32 process may be stranded on the Sage 100 ERP server
    1. At the server, stop the application server or service.
    2. Open Task Manager, Processes
    3. Select option to Show processes from all users
    4. Sort column by Image Name and locate Pvxwin32.exe task
    5. End all Pvxwin32.exe process
      • Note: An alternative is to have all users to log out of Sage 100 ERP (and for the Advanced or Premium editions, stop the Sage 100 ERP Service or Application), and then reboot the server.
  • If Terminal Server / Citrix (TS/Citrix) is used, the TS/Citrix session may have timed out or disconnected while Sage 100 ERP was still open.
    • At the Sage 100 ERP server, end the Pvxwin32.exe task
  • System files may be damaged
    1. Have all users log out of Sage 100 ERP (and for the Advanced or Premium editions, stop the Sage 100 ERP Service or Application)
    2. In Windows Explorer, go to the \MAS90\MAS_System folder where Sage 100 ERP is installed
    3. Rename the following files:
      • SY_Console.m4t
      • SY_Workstation.m4t
    4. For Sage 100 ERP Advanced or Premium editions only:
      1. Go to the \MAS90\Home\Lib\_Appserv folder also rename the following files:
        • Locate.pvk
        • Sessions.pvk
      2. Restart the Application Server Configuration and have someone log in. This will automatically generate theSessions.pvk and Locate.pvk
      3. If Sage 100 ERP Advanced or Premium is normally run as a Service:
        1. Stop the Application
        2. Exit Application Server Configuration
        3. Start the Service
  • The port number used might not be active.
    1. Open command prompt, run the following command
      • Netstat -a |More (“|” before “More” is the Pipe sign)
      • Verify the port used  is listed as listening
    2. The port number might be used by another program.  Change the port
      1. Open Application Server Configuration. at the server
      2. Select Server  tab
      3. Change the Socket number and click Apply.  Make note of the current port number before changing in case this does not resolve the issue.
      4. At the workstations, change the port number with either of the following methods:
        • Uninstall and reinstall Workstation Setup and enter the new port number when prompted
        • Modify the Icon properties and the Sota.ini file
          1. Right click and select Properties on the Sage 100 ERP workstation client icon
          2. Change the port in the Target  and click Apply.  It should be listed after the Server Name or IP address.
            (ex. ..\MAS90\Home\pvxwin32.exe ../launcher/sota.ini *Client -ARG “ServerName” “10000” “Sage 100 ERP”)
          3. Click Open File Location.  This will open Windows Explorer in the  Home folder where the client installation is located.
          4. Go back one folder to locate the Launcher folder
          5. Open Sota.ini
          6. Locate [Servers] section which is near the bottom
          7. Change the port which is listed just after the Server Name or IP Address.  Save file and close.
            (ex 1=ServerName;10000;APS=SAGE;APPLICATION=Sage 100 ERP;Path=)
      5. Restart the Application Server service or application and test for error.
  • Close Session errors on Sage 100 ERP Server
    1. Log into Sage 100 ERP server with Windows account running Sage 100 ERP Application service
    2. Close all Sage 100 ERP Error windows

Note:  If the port number is changed and the Application Server is being run as a Service.  The Service must uninstalled and reinstalled to use the new port.

  • Firewall might be blocking access to the program.
    • Check firewall settings on the server and at the workstations.
    • Security settings may be too high or may not be allowing bidirectional communication
    • Windows 7, Server 2008,  and later operating systems may require Firewall Inbound and Outbound rules created.
  • An open file might be blocking access.
    • Close open files using Server Manager
      1. Right Click Computer, select Manage
      2. Open Roles, File Services, Share and Storage Management
      3. Under Actions select Manage Open Files
      4. Select only files that are open in the MAS90 folder
    • Reboot Server to close open files if unable to locate file causing issue 

Support

If necessary, seek the assistance of Acute Data Systems to help provide assistance with this process.